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OpenRoads Survey: 
Horizontal Geometry 

 

Alignment Design Files 

For ODOT projects, each geometric alignment is typically stored in its own Geometry Basemap (BK) design 

file. These files are stored in the 400-Engineering\Roadway\Basemaps folder. 

This multi-file approach, also referred to as a “federated” approach, allows multiple users on a project to 

create and edit horizontal and vertical geometry simultaneously. 

Alignment design files are created using the OHDOT Create Design Files application. The application is 

accessed from the Ohio DOT WorkFlow by selecting the OHDOT Create Design Files icon. 

The create design files application has been enhanced to utilize 

multiple filter fields to find the basemap or sheet files you are 

looking to create. 

For the Geometry Basemap (BK) design file we can utilize a 

Roadway and a Basemap Filter to narrow down our file types 

within the application. 
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Civil Formatting 

Before getting started with the OpenRoads geometry tools, it is a good idea to review the design file 
settings to ensure they are set correctly for ODOT projects. Take the following steps to review the Civil 
Formatting settings: 
 

• Select the Files tab to access the backstage area. 
 

• Select Settings > File > Design File Settings to access the dialog shown below 

 
Choose the Civil Formatting option to review the current settings. Settings specific to ODOT are detailed 
below. These setting are set in the ODOT seed files. See the online help for additional information. 
 

Station Settings 
Make sure the Equation option is set to By Index for compatibility with the GEOPAK GPK file. 
 
 
Radius Settings 
The Radius Settings should be set as shown at right 
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Profile Settings 
The Profile Settings should be set as shown at right 
 
 

 
 
 
 
 

User Preferences 

The ORD User Preferences include several options for the civil products. These parameters are accessed by 
selecting File > Settings > User > Preferences as shown below. These options have been configured as 
necessary in the OHDOT workspace. See the Bentley online help for information not covered in this 
document. 
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View Options Civil - Manipulator Settings 
When OpenRoads geometry elements are placed in the design file, the elements are “ruled” graphics that 

behave according the geometric rules that define how the element was placed. These rules can be edited 

based on the element type. The line below was drawn using the Line Between Points command and 

contains three rules: The start point, the direction, and the length. 

 

The rules are revealed when the 

element is selected using the Element 

Selection tool as shown at left. The 

rules can be selected and edited as 

described on the followin pages. 

 

 

The display of the manipulators and text can be adjusted as part of the User Prefernces by select the 

Manupulator Settings group as shown below. These parameters allow the user to control the settings and 

symbology of the civil geometry manipulators and associated text. 
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Civil Geometry Manpulation and Modification 

Civil Geometry elements drawn using the OpenRoads tools are “ruled” graphics that behave according to 
the geometric rules that define how the element was placed. 
 
For example, a simple line drawn using the Line Between Points command has two rules: Length and 
Direction. 
 

 
 

The rules can be reviewed in the Properties dialog. An example for a line element is shown below. 
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MicroStation’s Manipulate commands (Copy, Move, Scale, Rotate, etc.) cannot be used on ruled geometry. 
The rule must be removed to use these commands. To remove a rule, select the line and choose the Rules 
menu as shown below. 

 
The following options are provided: 
 

Lock – Deactivate Rule 
Remove Rule 
Unlock – Activate Referencing Rules 
Lock – Deactivate Referencing Rules 
Remove Rule 
 

Element Manipulators 
OpenRoads Geometry elements have Manipulators that are displayed in MicroStation when an element is 
selected. These manipulators can be used to edit the selected element graphically or by entering a value. 
 
For example, a simple two-point line has several manipulators as shown below. 

 
Clicking on the direction or the length manipulator will open an editor to change the display as shown 
below. 
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Clicking on one of the key point manipulators will display direction arrows to edit the line, as shown on the 
example below. 

 
 
Tip: The size and color of the Manipulator Text can be adjusted in the User Preferences. From the 
MicroStation menu, select Workspace > Preferences and then choose the View-Options - Civil item on 
the left side of the dialog. The Manipulator Size or the Manipulator Font Scale parameters can be used to 
adjust the text size. 
 

Design Intent 
As geometric elements are drawn in MicroStation using the OpenRoads Horizontal Geometry tools, the 
software retains information about not only what element was drawn, but how it was drawn. This is 
referred to as the Design Intent. 
 
In the example below, the horizontal line was drawn first. The second line was drawn using the 
MicroStation Perpendicular snap to draw the line at a perpendicular form the horizontal line to a specific 
ending point. 
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If the horizontal line is modified by changing the direction of the line, the design intent for the 
perpendicular line is preserved. The Perpendicular rule, and the ending location are preserved. The result 
is shown below. 
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Alignment Feature Definitions 

Alignment elements are assigned a Feature Definition, which controls the symbology of the element 

(level, color, line style, and line weight) as well as the annotation properties of the element. The OHDOT 

Standards include feature definitions for alignments, which can be reviewed from the Project Explorer 

dialog, as shown below. 

 

Note that the alignment feature definition 

controls the symbology and annotation settings 

for both the horizontal geometry and the 

proposed vertical alignment. 
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Alignment Annotation 

When geometric alignments are placed in the file, the annotation is not automatically generated by the 

software. The user must identify the alignments that are to be annotated either individually, by selecting 

the specific alignments, or by annotating all of the alignments contained in the active model, or all models 

in the active file. 

Annotation commands are selected from the OpenRoads Modeling WorkFlow, or in the Survey Workflow, 

in the Drawing Production tab, as shown below. 

 

Element Annotation 
Individual elements are annotated by selecting the Element Annotation command from the Drawing 

Production tab. Two commands are available as shown below. 

 

Annotate Element 
The Annotate Element command is used to annotate one of more selected elements. The command 

prompts to select the OpenRoads element to be annotated. Multiple elements can be selected. Reset (right-

click) to complete the selection process and initiate the annotation placement. 

An example of annotation at the beginning of an alignment is shown below. 
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Remove Element Annotations 
The Remove Element Annotations command is used to remove the annotation from selected elements. 

When prompted, select the elements to remove the annotation. Reset (right-click) to end the selection 

process and initiate the removal process. 

 

Model Annotation 
The Model Annotation command us used to annotate all of the elements in the active model, or all models, 

by selecting a specfic Annotation Group. Two options are available as shown below. 

 

Annotate Model 
Select this command to annotate all the elements in a model, or in all models, by selecting a specific 

Annotation Group. 

When the command is selected, the user is prompted as shown below. Issue a data point (left mouse-click) 

to initiate the process. 

 

Remove Model Annotations 
Select this command to remove all annotations from the active model or all models in the active file. 

  



 
Ohio Department of Transportation 
Office of CADD and Mapping Services 

May, 2019 

 

OpenRoads Survey: Horizontal Geometry 510-12 

 

Alignment Annotation Levels 
Stationing is defined by the Feature Definition assigned to the alignment element. Annotation is frequently 

drawn at different intervals depending on the type of sheet that is displaying the alignment information 

(20-scale plan vs. a 500-scale schematic sheet). There is no way to assign an element template to an 

alignment in one file with one set of annotation values appropriate for the 20-scale plan, and a different 

element template in another file with a different set of annotation values appropriate for a 500-scale 

schematic plan. To facilitate different station and tic intervals, it is necessary to define the text for multiple 

scales in the Feature Definition that is assigned to the element. 

Three groups of levels and element templates are provided to facilitate alignment annotations with 100’, 

500’, and 100’ spacing for the major station labels. 

In the example below, stations and curve data for a sprial elemet are visible. The levels for the stations at 

100’ interval are turned on, while the levels for the 500’ and 1000’ stationing interval are turned off. The 

Annotation Scale value is set to 1:20. 

 

In the example below, the Annotation Scale value is set to 1:100 with the levels for 500’ station intervals 

toggled on. 
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Note: The levels are named according to the station label intervals (100’, 500’, and 1000’), not the 

annotation scale value. For example, the GE_P_100_Stations and GE_P_100_Curve_Data levels are 

appropriate for multiple annotation scale values (1:10, 1:20, 1:50). 

Also note that the spiral and curve data cannot be configured as a combined curve set with OpenRoads 

Designer Update 3. This is planned for a future update and will be adjusted in the OHDOT standards after it 

has been implemented. 
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Exercise 1: Creating Design Files 

For this exercise we will create 4 Alignment (BK) files, one for each of the four centerlines. 

ODOT projects that have been created outside of the ProjectWise environment using the OHDOT template 

contain the file 400-Engineering\Startup.dgn. This file is used as the launching point for opening ORD to 

create new DGN files for the WorkSet. The Startup.dgn file can be ignored once the initial design files for the 

project are created. 

Inside the ProjectWise environment, the Startup DGN file is not used. One of the seed files is used as the 

initial launching point to create new design files for the WorkSet. 

Take the following steps to open 106471_DesignSeed2d.dgn and create a new FB design file for the 
project. 

• Open ProjectWise Explorer 

 
 

• Browse to the folder shown below, using your home District and your user name. 

 
• Right-Click on the file 106471_DesignSeed2d.dgn and choose the Open With… option to open the 

file with OpenRoads Designer CONNECT Edition. Toggle the Always use the program option ON 
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• Select OK to open the file. 

 

• Select the Ohio DOT workflow from the top left of the ORD interface. 

 

• From the Apps tab, select the OHDOT Create Design Files icon 

 

The application dialog will appear as shown below: 
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• Select the Roadway Geometry Basemap (BK) file using the checkbox and change the number of files 

to create to 4. 

o Fill in the comments section accordingly for each centerline and fieldbook 

▪ 106471_BK001.dgn → Centerline I-71 

▪ 106471_BK002.dgn → Baseline Ramp 3 

▪ 106471_BK003.dgn → Centerline Gemini Place 

▪ 106471_BK004.dgn → Centerline Polaris Parkway 

 

• Click the Create Files button in the lower right-hand corner. Four design files are created. 

 

• When complete, exit OpenRoads Designer and check the file back into ProjectWise. 
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Exercise 2: Creating the Centerline of 71 

When generating horizontal geometry there are sever methods that can be utilized. This exercise will use 

the OpenRoads Geometry commands to generate a portion of the IR-71 centerline. 

• Open the 106471_BK001.dgn (for the creation of the centerline of 71) through the ProjectWise 

Explorer client. (BK files are in the 400 Engineering\Roadway\Basemaps folder) 

 

• Reference in the 106471_FB001.dgn using the attach tools command from the Home→ Primary 

tool set. This file contains the monumentation as surveyed. 

 

 
• Select the Line Between Points command as shown below. 

 

Use this command to place the first tangent line of IR-71 from the southern-most monument point, 

number SV1 as shown on below. 
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To place the Line Between Points, define the starting point using the MicroStation Key-point 

Snap to snap to the center of the surveyed point SV1. Use the following values: 

Distance:   9449.64 

Direction:   N3:31:16E 

Feature Definition: Alignment > GE_X_Alignment 

Name:   CLX_71 

 

This defines the first tangent line for the centerline of IR-71. 

• Select the Simple Arc From Element command to place the horizontal curve at the end of the 

tangent line. 
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Place a 0°28’ arc by using the following parameters: 

Trim/Extend:  None 

Radius:   d0:28 

Arc Length:  7085.71’ 

Feature Definition: Alignments > GE_X_Alignment 

Name:   CLX_I71 

 

Notice that the Radius value can be keyed in using a lower case “d” to designate the value in degrees as 

shown above. The value is converted to the radius as shown below. 

 

At this point, two separate pieces of geometry have been created. These elements can now be combined 

into a single alignment using the Complex Geometry command. 

• Select the Complex Geometry command as shown below. 
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Create the complex element using the settings below. 

Method:  Automatic 

Maximum Gap:  0.033 

Feature Definition: Alignments > GE_X_Alignment 

Name:   CLX_I71 

When prompted to select the first element, be sure to identify the element by selecting the element 

as shown below to store the complex element in the appropriate direction. 

 

The elements are joined together as a single complex element. 
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Transform 
Now that the geometry is placed the centerline will need to be rotated into place using the Transform tool 

under the Common Tools grouping (from the Survey Workflow→ Geometry tab) 

 

• Once selected the Transform Elements tool dialog will open 

 

The Transform Elements command can be used for translating, rotating and scaling elements. For this 

example, we will rotate the centerline of IR 71. 

• Enable the Rotate command and unselect the other transform options as shown above 

o Use Cursor Point and About: Fixed Point options 

• To the right of the About: Fixed Point select the Select point to scale or rotate about icon 

• Snap to the “fixed” end of CLX_IR71 at point SV1. The coordinates are populated in the dialog as 

shown above 

• Select the CLX_IR71 element which will be transformed by snapping to the end of the alignment (at 

the northern end) 

• Snap to the center of SV2 and left click to accept the rotation as shown below 
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The centerline line element is rotated to meet the control point. 
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Stationing 
Now that the centerline is now in its proper location, the stationing can be to be applied 

• Under the Survey workflow → Geometry tab → Horizontal group select under the modify 

command Start Station 

 
o Following the heads-up prompt locate the element to station (CLX_IR71) 

o Enter the start distance as 0.00’ 

o Enter the begin stationing for CLX_IR71 as 191+71.05 and left click to accept 

 

Notice the stationing is not visible upon completion but is 

ruled to the geometry. To check, select the element and look at 

the beginning to see the station. This is one place the stationing 

can be adjusted as well. 

  

 

To display the stationing and annotations the element must be annotated. There are 2 methods for 

achieving this: 

Annotate Element 

This function is used to annotate the selected element or elements 

 

Annotate Model 

This function will annotate every element in the model that has a feature definition assigned with 

an annotation definition defined 

This exercise will introduce element annotation. 

• The tool can be found under the Survey workflow→ Drawing Production tab → in the 

annotations group. The dropdown will allow for annotations to be removed (same functionality as 

the annotations command). 

 

• Using the heads-up prompt data point to select the element that needs annotated (CLX_IR71). 

*Note different annotations are plotted during this function. Please select the proper spacing for the 

project using the Level Display dialog (Survey workflow → Home tab → Primary group). 
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In the example below, the Annotation Scale value is set to 1:500. 

 

• Close 106471_BK001.dgn. 
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Exercise 3: Creating the Centerline for Ramp 3 

Ramp three consists of two curves and a spiral as shown below. 

 

Take the following steps to define the geometry for Ramp 3: 

• Open the 106471_BK002.dgn (for the creation of Ramp 3) through the ProjectWise Explorer client. (BK 

files are in the 400-Engineering\Roadway\Basemaps\ folder) 

 

• Reference in the 106471_BK001.dgn using the attach tools command from the Home→ Primary tool set 

(also located in other workflows). 
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Before entering the baseline for Ramp 3, we will store a point at the station and offset location where the ramp 

begins relative to the centerline of IR 71. 

• Open the Civil Accudraw dialog if it is not already open by selecting the command from the Survey 

WorkFlow → Geometry tab 

 

• Toggle on the Station-Offset ordinate 

 

After Civil AccuDraw is turned on the next step is to select the Point tool in the Geometry tab. 

 

Once the point tool has been selected this icon and dialog box will appear. 
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• The Feature Definition defines the symbology for the point. For this exercise choose the CALCPT feature 

definition as shown above. 

 

• Use Civil AccuDraw to identify the station and offset location for the CALCPT. 

o Press the Tab button to change the keyboard focus to the Offset field 

o With focus in the Offset field, type in the “origin” shortcut with the letter “o”. This must be done 

in the offset tab since stations can have letters in the name.  

o You are prompted to select the centerline to use as the station and offset reference. Select the 

CLX_IR71 element. 
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• Enter the following values: 

o  Station: 254+61.93 

o Offset: -222.47 for offset.   

 

*Note The offset is negative since it is to the left of the CL-71.  A point will be placed at that location. 

 

Ramp 3 starts on a curve. In order to enter the curve using the Simple Arc From Element tool, a reference line 

must first be placed at the correct bearing for the arc. 

• Use the Line Between Points command to place a line at the CALCPT location using the values shown below. 

Tip: Use the Origin snap to ensure that you are placing the line by snapping to the center of the 

calculated point. 

 

• Select the Survey > Geometry > Arcs > Arc From Element > Simple Arc From Element command to place an 

arc as shown below: 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services 

May, 2019 

 

OpenRoads Survey: Horizontal Geometry 510-29 

 

 
• Select the Survey > Geometry > Arcs > Arc From Element > Simple Arc From Element command to place the 

second arc as shown below: 
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• Select the Survey > Geometry Spirals > Spiral From Element command to place the spiral as shown below: 

 
• After entering the elements for the ramp, delete the scratch line that was used to define the entrance 

bearing for the first curve. 

 

• Select the Survey > Geometry > Complex Geometry command to create a complex element for the ramp. 

The ramp will be stored in the opposite direction than it was initially defined as shown below. 
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• Define the stationing be selecting the Survey > Geometry > Modify > Start Station command as shown 

below: 

 
• Annotate the alignment using the Survey > Drawing Production > Annotations > Element Annotation 

command. The stationing and curve data are annotated like the example below. 
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Exercise 4: Importing the LandXML File for Gemini Place 

As shown in exercise 4, it is best practice to export alignments to an XML file once finalized in ORD. This 

allows for the surveyor to retain a record of the alignment for posterity purposes. This also allows for the 

centerline to be imported into other programs or for use in future projects. 

• To begin the exercise, open the file 106471_BK003.dgn (created previously) 

• Reference the Centerline of 71 

o Under the Home tab→ Primary group → select the attach tools command 

▪ 400-Engineering\Roadway\Basemaps\106471_BK001.dgn 

• Select the Import Geometry tool from the Survey workflow → Home tab → Model 

Import/Export 

• Once selected the Import Geometry dialog will prompt the user to select the geometry to be 

imported. 

 

• Browse to the LandXML file located in the 300-Survey\SurveyData\FieldData\Reports\ folder 

• Select Open 
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• The contents of the file will appear in a new dialog box 

o The XML file containing the geometry for Gemini Place does not contain a vertical profile or 

any additional alignments. 

• Select the CLX_Gemini and click Import 

o Be sure the Create Civil Rules is checked on. 

• The alignment can now be annotated 

o The tool can be found under the Survey workflow→ Drawing Production tab → in the 

annotations group. The dropdown will allow for annotations to be removed (same 

functionality as the annotations command). 

▪ Using the heads-up prompt, data point to select the element that needs annotated 

(CLX_Gemini). 

*Note different annotations are plotted during this function. Please select the proper 

spacing for the project using the Level Display dialog (Survey workflow → Home 

tab → Primary group). 
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Exercise 5: Importing Polaris Parkway from a GEOPAK GPK File 

Openroads Designer also allows for the importing of legacy GPK alignment data. This will allow surveyors 

to update existing data to an open source format while keeping the civil rules associated with the file. 

*Note: It is still best practice to export GPK alignments to a LandXML format once imported into ORD. 

• For this exercise open the 106471_BK004.dgn created previously 

• Reference the Centerline of 71 

o Under the Home tab→ Primary group → select the Attach Tools command 

▪ 400-Engineering\Roadway\Basemaps\106471_BK001.dgn 

• Select the Import Geometry tool from the Survey workflow → Home tab → Model Import/Export 

• Once selected the Import Geometry dialog will prompt the user to select the geometry to be imported. 
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• Browse to the GPK file located in the 300-Survey\SurveyData\FieldData\Reports\ folder 

• Select Open 

 

• The contents of the file will appear in a new dialog box 

o This GPK does not have a vertical profile but it does contain points. In order to load only the 

alignment data, browse the tree to select the alignment as shown above. 

• Select the EX_CLPOLARIS and click Import 

o Be sure the Create Civil Rules is checked on. 

*Notice the alignment does not contain a feature definition (one will need to be added) 

• Adding a feature definition 

o Select the Set Feature Definition tool from the Survey workflow → Geometry tab → General 

Tools group → Standards dropdown. 

o The Set Feature Definition dialog will open 

 

▪ Select the feature definition from the dropdown (GE_X_Alignment) 

▪ Name the alignment accordingly (CLX_Polaris) 
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o Using the heads-up display, select the alignment element to assign the feature definition 

▪ Reset (Right click) to Complete 

The Alignment can now be annotated 

• The tool can be found under the Survey workflow→ Drawing Production tab → in the Annotations 

group. The dropdown will allow for annotations to be removed (same functionality as the annotations 

command). 

o Using the heads-up prompt, data point to select the element that needs annotated (CLX_Polaris). 

*Note different annotations are plotted during this function. Please select the proper spacing for 

the project using the Level Display dialog (Survey workflow → Home tab → Primary group). 

• Close and check in the DGN file to complete the exercise 
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OpenRoads Software Version 

This document was prepared using following software: 

OpenRoads Designer CONNECT Edition 2019 Release 1 – Update 7 – Version 10.07.00.56 

 

Contacts 

For any questions, suggestions, or problems with this document please contact the ODOT Office of CADD 

and Mapping Services by use of the following form on the ODOT website: 

https://odot.formstack.com/forms/cadd_servicerequest 

 

 

https://odot.formstack.com/forms/cadd_servicerequest

