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1 Introduction 

Course Prerequisites 
This training course is intended to familiarize ODOT personnel involved in the production of highway 
construction plans using MicroStation and GEOPAK CADD Software with updates made to the ODOT 
CADD Standards for MicroStation V8i (SELECTseries 3) and PowerGEOPAK V8i (SELECTseries 4). 
 
This training course is intended for ODOT personnel currently using MicroStation in a plan production 
capacity. This course does not cover MicroStation operation. It is assumed the user is familiar with the 
following CADD related functions: 
 

 Proficient with basic Windows 7 operations 
 Accessing MicroStation and opening Design Files 
 Familiarity with ODOT’s legacy  V8iSTD CADD Standards 
 MicroStation basics, including the following: 

o Creating Files 
o Seed Files 
o Cells 
o Editing Text 
o Plotting 
o Reference Attachments 
o Models 
o Annotation Scale 
o Etc… 

 

CPD Credit 
No CPD credits will be issued for this class. 

Course Outline 
The following topics are covered in the class: 
 

 ODOTcadd Standards for MicroSTation (SELECTseries 3) and PowerGEOPAK (SELECTseries 4) 
 Creating new Projects using ODOTcadd_CreateNewProjects.exe 
 Standard Project Folder Structure 
 Standard Design File Names 
 ODOT_Sheets.mvba 
 MicroStation Tags 
 ODOT_Files.mvba 
 ODOT_SheetManager.mvba 
 ODOT_XSSheetManager.mvba 
 ODOT_SheetCrossRefs.mvba 
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ODOT CADD Standards and Support 
ODOT CADD Standards for MicroStation and GEOPAK are maintained and distributed by the ODOT Office 

of CADD and Mapping Services. 

http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Pages/default.aspx 

The ODOT CADD Engineering Standards manual is available in Adobe Acrobat PDF format on the ODOT 

Website: 

http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Standards/Pages/Manuals.aspx 

ODOT’s Design Resource Reference Center is a centralized online reference center to help locate online 

or printed material. Additionally, several mailing lists are available to keep you informed about updates 

to ODOT standards. Visit the Design Resource Reference Center at the following URL: 

http://www.dot.state.oh.us/drrc/Pages/default.aspx 

Support for Bentley OpenRoads Survey is the responsibility of the Office of CADD and Mapping Services. 

Support questions can be sent to the CADD Support staff using the following form: 

http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Support/Pages/ServiceRequest.aspx 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Pages/default.aspx
http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Standards/Pages/Manuals.aspx
http://www.dot.state.oh.us/drrc/Pages/default.aspx
http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Support/Pages/ServiceRequest.aspx
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Exercise 1 – Install the Training Files 
The training files for this course are typically installed to the following folder: 

C:\ODOT_Training\CADDStdsTraining 

 
If the files are not already installed, or if you would like to install a fresh set of the training files, the 
following ODOT program is used to install the training dataset: 
 

I:\ODOTcadd\Standards\ODOT\Training\ODOTcadd_ConfigureTraining.exe 

 
The dialog shown below is opened when the program is accessed: 

 
 Choose the option for the ODOTcadd Standards Training class as shown above to install the 

training files for the course. 
 

 Select the Install Training Files button. 
 
 
This training course will use a customized workspace environment to access MicroStation and 
PowerGEOPAK for the lab exercises. The custom environment differs from the normal everyday work 
environment in the following ways: 
 

 For the training class, users will open PowerGEOAPK using the desktop shortcut contained in the 
\ODOT_Training\CADDStdsTraining folder as shown on the following page. 
 
Note: This shortcut is used only for the training class. In a typical work environment the user 
will open MicroStation or PowerGEOPAK by use of desktop shortcuts. 
 

 The configuration files for the training environment are contained in the ODOT_Training folder. 
This allows users to install the training files on their local computers without interfering with the 
normal working MicroStation configuration. 
 

 The training environment reads the ODOTcadd Standards from i:\ODOTcadd\Standards. The 
CADD Standards themselves are not contained in the ODOT_Training folders. 
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To open MicroStation for this training course, use the MicroStation shortcut contained in the 
\ODOT_Training\CADDStdsTraining folder as shown below. 

 

Troubleshooting the Training Data Installation 

The training configuration is driven by the shortcuts shown above. For a typical ODOT 
installation, the provided shortcut should work to access the training data with the correct 
configuration. The following assumptions are made: 
 

 MicroStation/PowerGEOPAK are installed in the default location. 

 The training files are installed to the C:\ODOT_Training folder 
 
If this is not the case, it is necessary to edit the Target of the shortcut for the correct path to 
MicroStation as well as the path to the primary configuration file: 

\ODOT_Training\CADDstdsTraining\ODOTcaddStdsTraining.cfg 

 
Additionally, the path for the file mslocal.cfg will need to be edited in ODOTcaddStrsTraining.cfg 
file if MicroStation (SELECTseries 3) has been installed to a different location. 
 
See your CADD manager if the training shortcuts do not open MicroStation properly. 
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2 “ODOTcadd” Standards Overview 

January 2015 ODOTcadd Standards Release 
The January 2015 update to ODOT’s CADD Standards represents a significant change for users of ODOT’s 
CADD Standards. This release was the last official update to the V8istd CADD Standards and also 
included the first official release of the “ODOTcadd” Standards. 
 
The new ODOTcadd Standards are intended for use with new projects started with MicroStation and 
GEOPAK/PowerGEOPAK (SELECTseries 3) or higher, and are located in the following folder: 

I:\ODOTcadd\Standards 

 
The standards are maintained and distributed by the CADD Services group within the Office of CADD and 
Mapping services. Requests for enhancements and questions about these standards should be directed 
to the CADD Services group using the following form: 
 
http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Support/Pages/ServiceRequest.aspx 

 
 

ODOT CADD Engineering Standards Manual 
The ODOT CADD Engineering Standards Manual for ODOTcadd is in the process of being updated to 
reflect changes made to ODOT’s CADD Standards with the ODOTcadd release. The draft version of the 
manual for the ODOTcadd Standards can be found on the ODOT Website in the following location: 
 
 http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Standards/Pages/Manuals.aspx 
 

This training guide makes reference to several sections of the CADD Manual. In all cases, the CADD 
Manual supersedes the information presented in this training guide. It is the responsibility of the 
designer to familiarize themselves with the content of the manual. 
 
 

ODOTcadd Compatibility with Current Projects 
The ODOTcadd Standards were specifically developed for MicroStation and GEOPAK (SELECTseries 3) 
and beyond. These CADD Standards can be used with SELECTseries 2 software; however, there are some 
significant changes to the ODOTcadd Standards that are not compatible with projects currently under 
development using the legacy V8istd CADD Standards. 
  

 All of the plan sheet borders contained in ODOT_Sheets.cel have been changed to use 
MicroStation Tag elements in place of Data Entry Regions. This was done to provide future 
compatibility with ProjectWise. The Data Entry Regions have been removed from the title block 
portion of all of the cells. The new cells are not compatible with the old sheet numbering and 
cross referencing applications. New MicroStation Visual Basic Applications have been developed 
to use the Tag elements for sheet numbering and cross referencing. 
 

http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Support/Pages/ServiceRequest.aspx
http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Standards/Pages/Manuals.aspx
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 The project folder structure has been modified. New applications have been developed for 
project creation and design file creation. 
 

 Standard design file names have been modified to insert an underscore character between the 
PID number and the two character file type code. 
 

 The two character file type code has been changed for bridge design file names for consistency.  
 
Due to these incompatibilities, it is recommended that users complete existing projects using the 
CADD Standards defined in V8istd.  
 
 

ODOT Project Configuration and Directory Structure 
The ODOT CADD Engineering Standards Manual for ODOTcadd, Section 302 defines the required 
directory structure to be used on all ODOT projects. The folder structure has been updated for the 
ODOTcadd Standards with input from all 12 Districts. The folder structure is to be used for all new 
projects started with MicroStation and GEOPAK/PowerGEOPAK SS3 or SS4 using the ODOTcadd 
Standards. 
 
See Chapter 4 for more information on the new folder structure and an ODOT program used to create 
new projects. 
 

 

ODOT Design File Names 
The ODOT CADD Engineering Standards Manual for ODOTcadd, Section 304 File Naming Conventions, 
defines the standard MicroStation design file names to be used on all ODOT projects. 
 
The file names have changed slightly from previously published CADD Standards. An underscore 
character has been inserted between the PID number and the two character file type code. 
 
ODOT provides a Visual Basic application to assist with the creation of MicroStation design files using the 
ODOT file naming convention. The program can be accessed from the MicroStation pull-down menu by 
selecting ODOT > File Management > New Design File. 
 
See Chapter 5 for more information. 
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ODOT Seed Files and Geographic Coordinate Systems (GCS) 
A seed file is an empty MicroStation design file that is used as a template for the creation of new design 
files. Seed files can be been configured specifically to meet a particular need. When new design files are 
created, the seed file specified by the user is copied and renamed to create the new file. ODOT provides 
several seed files for use with MicroStation and GEOPAK. The seed files are located in the following 
folder: 
 

I:\ODOTcadd\Standards\seed\ 

 
One of the parameters that can be defined in a seed file is the Geographic Coordinate System which 
allows users to specify the position of the design contents on the earth´s surface. Once that position is 
established, the design can be easily coordinated with other data for which the geographic location is 
known. A library of predefined Geographic Coordinate Systems, or GCS for short, is available in 
MicroStation. 
 
The use of Geographic Coordinate Systems and ODOT’s Seed files is document in Chapter 5. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



October, 2015 Project Management with the ODOTcadd Standards   

 

Page 8 Chapter 2 – ODOTcadd Standards 

 

Windows Start Menu Commands 
With the distribution of new computers to ODOT personnel in August of 2015, a new “ODOTcadd” 
program group has been added to the ODOT menu The Windows Start Menu. Select All Programs > 
ODOTcadd as shown below. 

 
Program shortcuts to open MicroStation and PowerGEOPAK with the ODOT CADD Standards are 
provided along with links to commonly used documents and tools. The content of this menu will be 
referenced through this guide. 
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3 New Project Creation 

ODOT Standard Project Directory Structure 
The ODOT CADD Engineering Standards Manual for ODOTcadd, Section 302 defines the required 
directory structure to be used on all ODOT projects. The folder structure has been updated for the 
ODOTcadd Standards with input from all 12 Districts. 
 

 The standards folder structure is to be used for all new projects started with MicroStation V8i 
(SELECTseries 3) and GEOPAK/PowerGEOPAK V8i (SELECTseries 3) or later using the ODOTcadd 
Standards. 

 
An example of the folder structure is shown below. 
 

 

The ProjectData Folder 

New projects that are started with the ODOTcadd Standards will be stored in the ProjectData 
folder. This is being done to separate projects created with the legacy V8istd CADD Standards 
from the new projects using the ODOTcadd Standards. 

 

The County Folder 

Some Districts prefer to store the project PID folder (detailed below) by county. For these 
Districts, a County folder is permitted as shown in the example above. Use of the County folder 
is optional. 
 
Use of a County folder is a site specific standard and should be consistent for all projects created 
at that specific site. 
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The PID Number Folder 

The parent folder for all ODOT projects is the PID Number folder. 
 
PID Number folders may be stored in a 3-Character County folder as specified above, or stored 
directly under the ProjectData folder. 
 
The intent is that all data pertinent to a specific project for all phases of the project 
development is stored under the PID number folder. 
 
The name of the PID Number folder can be appended with an optional 15-character description. 
The description is separated from the PID number by an underscore and is intended to be used 
for the primary County-Route-Section designation for the project. Example: 
 

11111_ALL-111-12.34 
 
Descriptions are limited to alphanumeric, dash, underscore, and decimal point characters. 
 

Primary Sub-Folders 

Beneath the PID Number folder, the following subfolders are defined to house all information 
that is generated throughout the lifecycle of a project: 
 

 Construction 
 Design 
 Environmental 
 ProjAdmin 
 RealEstate 

 

The Design Folder 

The Design folder is used to house planning and design information for the development of a 
project. This folder is where the MicroStation and GEOPAK related data is stored and will be the 
primary focus of this training course. 
 
The Design folder is split into several Discipline specific folders as needed for the project. An 
example of the folder structure for a typical ODOT project is shown below. 

 
Optional sub-folders can be added as necessary for projects involving multiple design teams. See 
the ODOT CADD Engineering Standards Manual for ODOTcadd, Section 302 for more 
information. 
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Project Configuration Files 
With the ODOTcadd Standards, ODOT will transition to the use of MicroStation Project Configuration 
(.pcf) files. 
 
PCF files are used to define project specific variables uniquely for each project. When MicroStation is 
opened using the appropriate desktop shortcut, the PCF file is selected from the File Open dialog as 
shown below. 

 
When the Project file is selected, MicroStation will default to the \Design folder for the project as shown 
above. 
 
It is important to select the PCF file every time a file from a new project is accessed in order to set the 
configuration properly for the project. 
 
When MicroStation is opened, the Project will default to the last PCF file that was accessed. For this 
reason, it is necessary to open MicroStation to select the PCF file before selecting the design file that 
you wish to open. Double-clicking on the file name in Windows Explorer will not ensure that the correct 
PCF file is active when the file is opened. 
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ODOTcadd_CreateNewProject.exe 
ODOT provides a Visual Basic program to create the project configuration file and directory structure for 
an ODOT project. The program provides the following functionality: 
 

 Create the Folder Structure for a new project 
 Create a MicroStation PCF file for a new project 
 Add discipline specific Design sub-folders to an existing project 

 
The program can be accessed within MicroStation by selecting ODOT > Project Management > Create 
New Project from the MicroStation pull-down menu, or from the following location: 

I:\ODOTcadd\Standards\ODOT\ProjectTools\ODOTcadd_CreateNewProject.exe 

 
The program can also be accessed from the Windows Start menu by selecting All Programs > ODOTcadd 
> Utilities > ODOTcadd_CreateNewProject.exe. 
 
This is a stand-alone Visual Basic program that does not require MicroStation. When the program is 
accessed, the dialog shown below is opened. 
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Project Creation Frequently Asked Questions 
 
Who should create new projects? The CADD Manager, the Project Manager, Planning, the Surveyor? 
 

 Each ODOT District Office should establish a procedure for the creation of new projects to 
ensure consistency. This will typically be the CADD Manager. 

 
What if we need to start a project before the PID number has been assigned? 
 

 Crete the project using a PID number of 00000 with a description to uniquely identify the 
primary County-Route-Section for the project.  Example: 00000_ALL-111-12.34 

 
How do we change the PID number for a project? 
 

 ODOT provides a program, ODOTcadd_ChangePID.exe that can be used to change the PID 
number for a project. See Chapter 9 of this training guide for more information. 
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Exercise 3 – ODOTcadd_CreateNewProject.exe 
In this exercise we will use the ODOTcadd_CreateNewProject.exe program to create two test projects. 
We’ll also add discipline specific design folders to a project after it has been created. 
 

 Run the ODOTcadd_CreateNewProject.exe application from the following folder: 

I:\ODOTcadd\Standards\ODOT\ProjectTools\ODOTcadd_CreateNewProject.exe 

 
 Create a new project using the settings shown below: 

 
This project represents a smaller project where all of the design information will be stored in the 
Roadway folder. Survey data will be stored in the Survey folder. Multiple Discipline specific 
folders are not used but can be added later if necessary using the Add Folders to Existing 
Projects option by choosing Operation > Add Folders to Existing Project. 
 

 Take a few minutes to review the project folder. Take a look at the following folders to review 
the files that were created with the project: 
 
C:\ODOT_Training\CADDStdsTraining\ProjectData\ALL\111111_EXAMPLE1\Design\GEOPAK\ 
C:\ODOT_Training\CADDStdsTraining\ProjectData\ALL\111111_EXAMPLE1\Design\Standards\Seed\ 
C:\ODOT_Training\CADDStdsTraining\ProjectData\ALL\111111_EXAMPLE1\Design\Survey\RawData\ 
C:\ODOT_Training\CADDStdsTraining \ProjectData\ALL\111111_EXAMPLE1\Design\Survey\GCS\ 

 
 Open the PCF file for the project with Notepad to review the contents 

 
C:\ODOT_Training\CADDStdsTraining\ProjectPCF\ALL_111111_EXAMPLE1.PCF 
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 Create a second project using the settings shown below: 

 
This example represents a larger project with multiple design teams. The data for each design 
team is stored in a separate \Design\Discipline specific folder. 
 
A \design\Structures folder is added to contain the structure information for a bridge and a wall. 
 

 Take a few minutes to review the project folder for this example. Take a look at the following 
folders and their sub-folders: 
 
 C:\ODOT_Training\CADDStdsTraining\ProjectData\DEF\111112_EXAMPLE2\Design 

 
C:\ODOT_Training\CADDStdsTraining\ProjectData\DEF\111112_EXAMPLE2\Design\Structures 
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4 Accessing MicroStation 

Start Menu Shortcuts 
With the ODOTcadd Standards, ODOT users will open MicroStation or PowerGEOPAK by use of Start 
Menu shortcuts as shown below. 

 
Notice that these shortcuts are configured to open either MicroStation or PowerGEOPAK with either the 
legacy V8istd CADD Standards or the new ODOTcadd Standards. 
 

 Be sure to use the appropriate shortcut to open either MicroStation or PowerGEOPAK with the 
proper CADD standards configuration to access the legacy V8istd CADD Standards or the new 
ODOTcadd Standards. 
 

 Existing projects started with the V8istd CADD Standards should be completed using these 
standards. 
 

 New projects should be started with the ODOTcadd Standards. 
 
For the purpose of this training class, be sure to use the shortcut in the CADDStdsTraining folder: 

C:\ODOT_Training\CADDStdsTraining\ODOTcadd MicroStation SS3 
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Which should I use? MicroStation or PowerGEOPAK? 
PowerGEOPAK is new to ODOT users. There is no functional difference between an installation of 
MicroStation with the GEOPAK suite, or PowerGEOPAK. The difference is that PowerGEOPAK is installed 
as a single program and has a lower license fee than a MicroStation/GEOPAK Suite installation. 
 
ODOT is billed based on daily software usage. Please make every effort to use only one product, 
MicroStation or PowerGEOPAK in a given day. If you anticipate that you will need GEOPAK functions at 
some point through the day, use the PowerGEOPAK Shortcut for the entire day. If you do not anticipate 
using GEOPAK functions, use the MicroStation shortcut. Using a MicroStation license costs the State, 
and therefore you, a taxpayer, less than using a PowerGEOPAK license. 
 
Be sure to access MicroStation or PowerGEOPAK using the appropriate desktop shortcut for the CADD 
standards that you wish to access. 
 
 

Double-Clicking a File in Windows Explorer 
With the ODOTcadd installation of MicroStation and PowerGEOPAK it is no longer possible to open 
MicroStation by double-clicking on the design file name in Windows Explorer. When a file is opened by 
double-clicking the file name, it is opened with Bentley Navigator in a read-only mode. 
 
Bentley Navigator is a free utility that can be used for read-only viewing and plotting design files. ODOT 
is not charged a license fee for the use of Bentley Navigator. 
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Accessing MicroStation or PowerGEOPAK with V8istd 
Older projects that were started using the legacy V8istd CADD standards should be completed using the 
older standards. When MicroStation is accessed using one of the ODOTV8istd shortcuts, the User and 
Project should be set as shown below. 

 

Accessing MicroStation or PowerGEOPAK with ODOTcadd 
Projects started using the ODOTcadd standards are accessed by selecting one of the ODOTcadd desktop 
shortcuts. The User is set to ODOTcadd and the Project is selected from the drop-down list. 
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Accessing MicroStation or PowerGEOPAK with the Bentley Interface 
For users taking a training course through Bentley Learn, it is now possible to access MicroStation using 
the default interface by opening MicroStation or PowerGEOPAK from the Windows Start Menu. From 
the Start Menu, choose All Programs > Bentley and then choose either MicroStation or PowerGEOPAK. 
In the example below, the User and Project are set appropriately for a GEOPAK class through Bentley 
Learn. 
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Exercise 4 – Opening MicroStation with a Start Menu Shortcut 
For the purposes of the training class, MicroStation will be opened using the shortcut contained in the 
\ODOT_Training\CADDStdsTraining folder as shown below. 

 
 Open MicroStation using the ODOTcadd MicroStation SS3 shortcut. The User should default to 

ODOTcadd. 
 

 Select the project ALL_111111_EXAMPLE1 from the Project menu. The File Open dialog defaults 
to the \Design folder for the selected project. 
 

 Open the following design file: 

\Design\Standards\Seed\111111_Seed2d,dgn 

 
You will notice that the MicroStation configuration looks a little different when using the 
ODOTcadd Standards. We’ll discuss this on the following page. 
 
Note: 
The ODOTcadd_CreateNewProject.exe application that was used to create this project creates 
three design files for a new project: two seed files and the survey basemap. All other files will be 
created using the ODOT_CreateFiles.mvba application covered in the next chapter. 
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MicroStation Configuration for ODOTcadd 
MicroStation tools are typically accessed from the Task Navigation menu with the ODOTcadd Standards 
configuration. By default, the Task Navigation menu is docked to the left of the screen, along with the 
Project Explorer and the Element Information dialog, as shown below. 

 
Each menu expands when the cursor is passed over one of these tabs. These icons can be 
docked/undocked by selecting push-pin icon. 
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The Project Explorer menu is also docked and unpinned on the left side of the interface. Project Explorer 
is used extensively with the GEOPAK/OpenRoads tools. For now, we’ll discuss only one aspect of the 
Project Explorer dialog. 
 
When the dialog is expanded, it appears as shown below. 

 
The Links tab contains a drop-down menu to select various options. All of the options will not be 
explained in detail at this time. The ODOT CADD Services options provides links to various ODOT 
resources as shown above. The Bentley Online link provides access to various Bentley materials as 
shown below: 
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Project Explorer is also used to display the content of the current project. In the example below, the 
Project option is selected with the Sheets item expanded. 

 
Each design file in the project is examined to display the name of any Sheet Models found. Files can be 
opened by double-clicking on the sheet icon next to the file name. 
 
 
NOTE! 
The Task Navigation menu, Project Explorer, and Element Information dialogs are used extensively 
with GEOPAK and OpenRoads tools. It is recommended that users take the time to familiarize 
themselves with these menus as they will become increasingly important in the coming months. Take 
the time to get accustomed to this interface instead of customizing the interface so that it looks like it 
did in (SELECTseries) 2. 
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Function Key Menus 

The ODOTcadd configuration will look for a user defined function key menu in the following location: 
 

$(ODOT_USER)fkeys/USER_fkeys.mnu 
 

Note: ODOT_USER is defined when the initial configuration is set up for the computer. By default, this 
variable is set to W:\ODOTcadd_User. 
 
The function key menu must be named as shown above. If the file is found, the function key menu is 
loaded when MicroStation or PowerGEOPAK is opened. 
 
If a user defined function key menu is not found, the following function key menu is opened: 
 

…\ODOTcadd\Standards\gui\ODOT_fkeys.mnu 
 
This menu is a copy of the MicroStation default menu with a few changes specifically configured for 
OpenRoads users. The following function key assignments have been added: 
 
Function Key Command Description 
Alt+F1 vba run OneView Close all view windows except for view 1 

Alt+F2 vba run TwoView3D Turn on View 1 and View 2. View 2 displays the 3D Model 

Alt+F3 vba run ToggleViewConstructions Toggle on/off Construction Elements 

Alt+F4 vba run FourView Turn on view windows 1-4 

Alt+F5 vba run SetActiveModelToDrawLast Set the active model last in the Reference Update list 

Alt+F6 vba run analyzeTerrainModelPoint Analyze selected linear features, similar to DTM tools 

Alt+F7 vba run ExaggerateZForAttachment View exaggerated terrain surfaces 
Alt+F8 Vba run DeleteUnusedFonts Deletes any unused fonts in the file and compresses. 

Alt+F9 Vba run Toggle Toggles on/off the view window background color to white 

Alt+F10 Choose none Clear the current command and any selected elements 

Alt+F11 Corridor TemplateLibraryOpen Open the Create Templates dialog 

 
The VBA commands defined in the function key menu are contained in the following file, which was 
taken from the Bentley Civil Imperial workspace: 
 

…\ODOTcadd\Standards\vba\Viewset.mvba 
 
This vba application is loaded by default when using the ODOTcadd configuration. 
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The ODOT Pull-Down Menu 

The content of the ODOT pull-down menu has been restructured to organize the applications in more 
logical groupings. Take a few minutes to familiarize yourself with the reorganized menu. 

 
 

The menu is context sensitive. Commands that require a Sheet 
model, such as placing sheet cells, are not available if the current 
model is a Design or Drawing model. 
 
Tools that use GEOPAK functions are only available if GEOPAK or 
PowerGEOPAK is active. 
 
For more information on the available applications, see the help 
documents for each application. 
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5 MicroStation Design Files 

This chapter discusses several enhancements to the way ODOT uses MicroStation design files with the 
ODOTcadd Standards. The following items are covered: 
 

 Changes to ODOT’s Design File names 
 The use of Basemap and sheet Design files 
 Using Models 
 Annotation Scale 
 Geographic Coordinate Systems 
 ODOT_Files.mvba 

 

Standard Design File Names 
The ODOT CADD Engineering Standards Manual for ODOTcadd, Section 304 File Naming Conventions, 
defines the standard MicroStation design file names to be used on all ODOT projects. 
 
The file names have changed slightly from previously published CADD Standards. An underscore 
character has been inserted between the PID number and the two character file type code. 
 

Example file name: 111111_BE001.dgn 
 

 The standard design file names are to be used on all ODOT projects. 
 

Basemap and Sheet Design Files 
For ODOT purposes, a MicroStation design file is typically used as either a Basemap design file, or a 
Sheet design file. 
 

 Basemap design files are used to draw plan, profile, and cross section information for your 
project in real world dimensions. 
 

 The basemap drawings are then referenced into Sheet design files to assemble the plan sheets 
for the project. 

 
In either case, the only real difference between a Basemap and a Sheet design file is the Model that is 
used to contain the information. 
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\Design\Discipline Basemaps and Sheets Sub-Folders 
ODOT’s Standard folder structure defines separate sub-folders for Basemap and Sheet design files. For 
example, the \Design\Roadway folder contains the sub-folders shown below. 
 

 
 The Basemaps folder is used for Basemap design files 

 
 The Sheets folder is used for Sheet design files. 

 
 Each \Design\Discipline folder will contain the sub-folders shown above. For example, if a 

\Design\Drainage folder is used on the project, the \Drainage folder will contain the sub-folders 
shown above. 

 
Basemap and Sheet design files are separated into separate folders for easier access when attaching 
reference files. For example, if the Right-of-Way designer wishes to reference the drainage basemap in 
his sheets he only needs to search the \Drainage\Basemaps folder for the drainage basemap rather than 
sort through all the sheet files since they are contained in the \Drainage\Sheets folder. 
 
Several basemap design files may be used depending on the project complexity. The ODOT CADD 
Standards allow for multiple basemap design files for each unique discipline (drainage, lighting, mot, 
roadway, signals, etc…). 
 
For smaller projects, it is permissible to combine the design information into fewer basemap files; 
however it is not desirable to place all the information in one design file. As a minimum, the following 
four basemap design files are required: 
 

Existing Ground Survey 
Geometry (when using OpenRoads Geometry tools) 
Proposed Design 
Right-of-Way 

 
The use of additional basemaps for larger projects is optional. 
 
 
 
 
 
 



 Project Management with the ODOTcadd Standards October, 2015 

 

Chapter 5 – MicroStation Design File Creation Page 29 

 

Models 
A MicroStation design file is composed of one or more drawing areas called a Model. When users draw 
or place elements with MicroStation tools, the elements are added to the active Model. 
 

 Design files can contain multiple models.  Think of each model as a separate design within a 
design file. 
 

 A Model can be either 2D or 3D. The same design file can contain both 2D and 3D models. 
 

 3D models can be referenced to 2D models, and vice-versa. 
 

 Each Model is a completely independent drawing area and has its own set of eight views, 
reference attachments, etc.; however, all models within the same DGN use the same Color 
Table and Background Colors.  

 
MicroStation provides three types of models: 
 

 Design – This model type is used for creating design geometry that can be either 2D or 3D. 
 

 Drawing – This model type serves as a “container” for centralizing annotations that need to be 
shared across multiple sheets. A drawing model is always a 2D model. ODOT does not currently 
use the Drawing model. 
 

 Sheet – The Sheet model is used to assemble the plan sheets for the project. 
 
In summary, the models are used as follows: 
 

 Basemap design files are used to draw the plan view graphics for the entire project in real world 
dimensions. The Design Model is used for this information. 
 

 Sheet design files are used to assemble the plan sheets for a project. The plan sheet information 
is drawn in a Sheet Model. 

 
 

The Models Dialog 
The Models dialog is used to manage and switch between models in the current MicroStation design file.  
 

 Select the Models icon in the Primary Tools box as shown below: 

 
 

 Select File > Models from the MicroStation pull down bar. 
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When a new MicroStation design file is created using one of the ODOT seed files, there are two models 
available in the file for your use as shown above. 
 
When you open the Models dialog box for the first time the default model is listed as the active model.  
The default model has the name “Design” with the description “Master Model” as shown above. 
 
To work with another model in the design file, you must activate it. Double-clicking a Model within the 
dialog box makes the model active.  Alternatively, you can use the View Groups window to rapidly 
switch between models visited in the current design session as shown below. 

 
 
The name of the active model is also displayed in the View window title bar as shown below. 
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Model Properties 
You can select or edit Properties of a model in the open DGN file.  From the Models dialog, select Edit 
Model Properties as shown below. 

 
The model properties are different depending on what type of model it is, Design or Sheet. 

 
 
 
 
 
 
 
 
The following parameters are common to both Design and Sheet models: 
 

Type - sets the model's type (Design, Drawing, or Sheet) and dimensionality (2D or 3D). 
 
Name – is a text field to enter a name for the model. 
 
Description – is a text field to enter a description of the model. 
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Ref Logical - sets the Reference Logical name for the model.  The logical name identifies the 
model when it is attached to another model as a reference. 
 
Annotation Scale - sets the scale for text, dimensions and cells in the model.  You can select 
from the list of common scales used for ODOT plan sheets. 
 
Line Style Scale - Lets you set the scale for custom line styles. This can be set to match the 
Annotation Scale value by selecting the Annotation Scale option, or can be set to a different 
value using the Global Annotation Scale option with a keyed-in value. For most ODOT work, the 
Annotation Scale option is used.  
 
Update Fields Automatically - If set on, fields are automatically updated when a file is opened. 

 
Cell Properties - Any model from any design file can be placed as a cell using these options. 
 

Can be placed as a cell – if toggled on, it is possible to place the model as a cell. 
 
Cell Type - sets the cell type (Graphic or Point).  This option menu is enabled only if “Can 
be placed as a cell” is toggled on. 
 
Can be placed as an annotation cell – if toggled on, (Can be placed as a cell enabled 
only) If on, it is possible to place the model as an annotation cell.  When placed as an 
annotation cell, the current annotation scale is applied to the cell. 

 
The following parameters are relevant to Sheet models only: 
 

Sheet Properties 
Sheet Name – Lets you assign a name to the sheet model. The name assigned here can 
be assigned to the bookmarks in a multi-page PDF file. See Chapter 11 for more 
information. 
 
Sheet Number – Lets you assign a sheet number to sheet models.  This makes it easy to 
control the order of sheet models for presentation, printing, cataloging in a project, or 
generating PDFs. 
 
Display Sheet Boundary – If toggled on, a sheet element will display in the new sheet 
model.  This option must be toggled on in order to use the Sheet Name and Sheet 
Number for multi-page PDF plotting. 
 
Border Attachment - When you associate a border attachment to a sheet model, any 
changes to the annotation scale for the sheet, automatically are propagated to the 
border attachment. The Border Attachment option is normally set to None for ODOT 
projects. 

Size - sets the sheet size. 
Origin - sets the origin of the sheet. 
Rotation - sets the rotation angle of the sheet, measured in degrees counter-
clockwise from the x-axis (horizontal). 



 Project Management with the ODOTcadd Standards October, 2015 

 

Chapter 5 – MicroStation Design File Creation Page 33 

 

ODOT’s use of Models 
When creating a new DGN file using ODOT’s Seed files the default Design Model and a Sheet Model are 
already created for use. 
 
Select the Design or Sheet model to work in depending on your workflow described below. 

Design Model 

The default design model named “Design” is to be used for creating all design geometry.  The 
Description was left as “Master Model” but if necessary the description can be changed by the 
user. 
 

 The Master Model cannot be deleted. 
 

 All basemap information is drawn in the default “Design” Model using real world 
dimensions at a 1:1 scale. 

 
 All Line Styles and Cells shall be placed in the basemap design model at a scale of one (1) 

and then scaled using the Annotation Scale setting. 

Sheet Model 

The sheet model named “Sheet” is to be used to assemble plan sheets for plotting the design 
geometry.  A Description can be added if needed. 
 
Based on the type of sheet to be built (title sheet, schematic sheet, etc.), a sheet border cell is 
placed in the “Sheet” model from the ODOT_Sheets.cel cell library.  Final design graphics 
contained in the “Design” model must then be attached (referenced) to the “Sheet” model and 
annotations are added as needed.  The “Sheet” model then contains a graphic representation of 
the final plan sheet, and is ready to be plotted. 
 
The benefit of attaching the “Design” model as references to the “Sheet” model is that any 
changes made to the “Design” model is then reflected immediately in each “Sheet” model. 

  
 For Roadway projects and for the Bridge site plan, when attaching basemap Design 

Models to the Sheet Model the user shall not scale, move, or rotate the basemap 
reference attachment.  Basemap Design Models shall be attached using the 
MicroStation Coincident-World setting.  If a rotated plot view is required, the user shall 
rotate the Sheet Model view only for proper plot orientation.  The sheet border cells 
shall be placed in the rotated view.  All reference file clipping shall be done in the 
rotated view.  See Section 303 References in the CADD Engineering Manual. 

 
 ODOT’s CADD Engineering Standards Manual Section 303.4 Sheet Design Files states the 

following: 
 

 Each sheet of the plan shall be contained in its own separate design file when 
submitted to the Department. 
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 When sheet design files are submitted to the Department, no other graphics are 
permitted in the Sheet model other than the graphics representing the final 
plotted sheet.  All extra graphics used to generate the sheet, or old versions of 
the sheet, should be deleted or moved to a design model.  No extra reference 
attachments that are not a part of the final sheet are permitted to be attached 
to the Sheet model. 

 

 It is highly recommended to place all drawing and sheet annotations only in the 
Sheet model.  Using this approach will enable you to reuse designs in other DGN 
files while avoiding conflicts in annotation.  Some exceptions would be 
annotation that is placed in the Design model by PowerGEOPAK when designing 
the geometry like stationing and curve data. 

 

Model Annotation Scale 
The Model Annotation Scale sets the proper scale for all Annotations placed in a Design or Sheet model.  
Any Text, Dimensions and Cells that are placed in the model are referred to as Annotations in 
MicroStation. 
 
The Annotation Scale value can be set in the Model Properties dialog, or by use of the Drawing Scale 
dialog. To access the Drawing Scale dialog shown below, select Settings > Drawing Scale. 

 
By default, the dialog has several items displayed that are not 
normally changed during the design process. These options can 
be turned off by right-clicking on the face of the dialog and 
toggling off the options that you do not wish to display. 
 
 
 
 

 
 
The following items are typically toggled off: 

 Working Units 

 Sub-Units 

 ACS 

 ACS Scale 
 
With these options toggled off, the dialog appears as shown below and can be easily docked for quick 
access: 
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The Annotation Scale parameter is really just a multiplier that is applied to the base size of an element 
when the element is placed. This allows elements to be displayed correctly at a variety of plotting scales. 
 
The Model Annotation Scale should be set prior to placing any annotations (Text, Dimensions, Cells, or 
custom line styles) in the current model. 
 
For example, with the Drawing Scale set to a value of Engr 1:20, text is placed with the following 
parameters: 

 
 
The text Height and Width is set to the default size 
for a 1:1 representation (0.14) as shown at left.  
 
Annotation Scale Lock located in the tool settings 
window that must be ON to use the model 
annotation scale as shown at left. 
 
 
 

When the text is placed in the file, it is placed at the height and width defined for the element (0.14). 
The initial size is then multiplied by the current Annotation Scale value to determine the displayed size 
of the text element (0.14 X 20 = 2.8 Master Units). Changing the current Annotation Scale value will 
change the display size of the text element appropriately. 
 

 All ODOT’s Text and Dimension Styles and Cells were created at a 1:1 scale so they are displayed 
properly to the appropriate sheet scale. 
 

 If the Model Annotation Scale Lock is off, any annotation placed in the model will not be scaled 
automatically. 

 
Some of the ODOT cells have been defined using the actual dimensions of the item that they represent 
and cannot be scaled with the annotation scale setting. For example, pavement markings are placed at 
their real world size and are not scaled using the Annotation Scale parameter. The cell definition itself 
defines whether an individual cell is placed using the annotation scale parameter. 
 

In the example at left, the cell PMLFT is 
placed at its actual size and is not scaled by 
the annotation scale parameter even 
though the annotation scale lock is toggled 
on. 
 
Cells that are defined using their real world 
dimensions are referred to as Physical cells 
 

Cells that represent the location of an item, but not the actual size (such as a mailbox or telephone pole) 
are referred to as Cosmetic cells and are scaled by the annotation scale parameter. 
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ODOT uses the Model Annotation Scale primarily for creating Sheet models for plotting a set of plans.  
When creating the Sheet models ODOT’s drawing border is scaled to fit the design since all geometry is 
drawn and referenced at a 1:1 scale.  With this method, where the drawing border is scaled up (or 
down) to cover the required area in the design, the display of text, dimensioning and cells must be 
scaled the same amount by use of the Annotation Scale parameter.  This is to ensure that when the 
scaled print is created, text, dimensioning and cell elements are at the correct physical and cosmetic 
size. 
 

Model Line Style Scale 
Just like text, cells, and dimensions, ODOT’s custom line styles are placed in the design file using a base 
scale value appropriate for a 1:1 scale drawing which is then multiplied by the Annotation Scale for the 
intended plotting scale. 
 
When curvilinear elements are drawn using a custom line style, the scale value set in the Line Styles 
dialog is used to determine the initial placement size of the custom line style. Select Element > Line 
Styles > Custom to access the dialog shown below. 

 
 
The Scale Factor item is used to set the initial 
placement value. If this item is toggled off, as 
shown at left, a value of 1 is assumed. 
 
 
 
 
 
 
 
 
 
 

 All ODOT’s Custom Line Styles were created at a 1:1 scale so they are scaled to the appropriate 
sheet scale. 

 
Similar to ODOT’s cell, some of the custom line style definitions are defined as Physical line styles 
representing real world dimensions and are not scaled when placed, while others are Cosmetic 
representations of elements used to designate the location of the feature, but not the size. The 
definition of the custom line style itself defines whether an individual line style is a cosmetic or physical 
element. 
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Using Multiple Sheet Models 
The ODOT CADD Engineering Standards Manual for ODOTcadd, Section 303.2 contains information on 
the use of multiple models for ODOT projects. 
 
In general, it is not permissible to use multiple models in a Basemap design file other than the models 
that are automatically generated by the use of Bentley’s OpenRoads Corridor Modeling tools. For 
example, it is not permissible to create a Basemap design file with one model containing the proposed 
plan view information and another model containing the proposed landscaping information. If the 
landscaping information is needed in a separate model it should be housed in a separate design file as 
defined in the ODOT CADD Standards. 
 
It is permissible to use multiple sheet models in a Sheet design file, within the guidelines established in 
the ODOT CADD Engineering Standards Manual for ODOTcadd, Section 303.2. To summarize 
 

 ODOT allows only one plan sheet per model in a sheet design file. 
 Plan sheets of a like type can be separated into separate design files, or alternately separate 

models within one design file. 
 Multiple sheet models may be used within a sheet design file for multiple sheets of the same 

type. For example, it is not permissible to create a model for the General Notes and another 
model for the Typical Sections within the same design file. 
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Exercise 5A – Models and Annotation Scale 
 
In this exercise we will explore how the annotation scale is set in the survey basemap and how it can be 
controlled by the reference file attachments independently from the value set in the survey file. 
 

 Open MicroStation using the desktop shortcut for the ODOTcadd Standards in the 
CADDStdsTraining folder: 

C:\ODOT_Training\CADDStdsTraining\ODOTv8istd MicroStation SS3 

 
 On the MicroStation File Open dialog, change the Project to GRE-00000 

 
 Open the Survey Basemap \Design\Survey\Basemaps\00000_BE001.dgn 

 
There are a few things to note about this file: 
 

o This file was generated using the OpenRoads Survey tools and is a 3D file. 
o The Terrain Model is part of the design file, not a separate GEOPAK TIN file 
o The design file graphics are tied to the terrain model. Editing the design file graphics 

edits the terrain. Therefore, designers are not permitted to edit the Survey file. 
o The survey data is not stored in a separate GEOPAK GPK file 

 
The graphics contained in a Survey basemap generated with the OpenRoads Survey tools are all 
Annotation Scale aware. Changing the annotation scale value will change the display size of 
cells, text and the custom line styles in the file. 
 

 Change the current annotation scale value to ENGR 1:50. Note the changes to the design file 
graphics. 
 

 After changing the annotation scale, choose File > Save Settings to save this change. 
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 Open the Roadway Basemap: \Design\Roadway\Basemaps\00000_BP001.dgn 

 
 Review the attached references. Notice that the survey basemaps is already attached as a 

reference file. In the References dialog, right-click on the survey basemap and choose the 
Settings option. The Attachment Settings dialog shown below is opened. 

 
The Global LineStyle Scale option is used to control how linestyles are displayed for the selected 
reference attachment. In the example above, the reference attachment was set to Master when 
the file was initially attached. This setting allows the active (master) design file to control the 
annotation scale appearance of the reference attachment. Choose the Cancel button to close 
the dialog without making any changes. 
 

 Change the Annotation Scale setting to ENGR 1:10 in the active file. The display of the text, 
cells, and custom line styles is changed independently of the setting defined in the original 
Survey basemap. 
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Next we’ll place the cells, text, and lines using a custom line style to illustrate how the annotation scale 
is applied to each. 
 

 Change the active level to SC_Scratch1 
 

 Select the Place Text command to place some text in the design file similar to the example 
below. Be sure the text size is set to the default value (Height and Width = 0.14) for the Slanted-
Normal LS=50 text style. Also make sure the Annotation Scale Lock is toggled on.

 
 Next we’ll place a few cells in the file. Place the following cells making sure the Annotation Scale 

Lock is toggled on. 
o AC 
o BBQ 
o PMLT 

 
 Lastly we’ll draw a couple lines in the file using a custom line style. Set the active level to the 

levels below and draw a line on each level. 
o RD_X_Fence 
o PM_X_Lane_Line 

 
 After the graphics have been drawn, change the annotation scale value to ENGR 1:1. Notice that 

the display of each element is scaled about its individual origin point. 
 
The PMLT cell and the custom line style for the line drawn on the PM_X_Lane_Line level are not 
scaled as the cell and linestyle definition for each is defined as a “Physical” representation of 
each, representing their real world sizes. 
 

 Now change the annotation scale setting to ENGR 1:200. Depending on the distance between 
the elements you have drawn several of them may overlap. The display of each element is scale 
about its origin and may not yield the results that you desire. 
 

 Change the annotation scale setting back to ENGR 1:20 at the completion of this exercise. 
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Creating Design Files 
A lot of thought must go into the creation of new design files for your project as summarized below: 
 

 The correct Seed File is used for the new design file (2D, 3D) using the appropriate Geographic 
Coordinate System 

 Files stored in the appropriate \Design\Discipline\Basemaps or \Sheets folder 
 File named according to the ODOT CADD Standards: 

o PID Number 
o Two Character Type code 
o Three Digit number 

 Appropriate Model used for Basemaps (the Design model) or Sheets (the Sheet model) 
 Annotation Scale set appropriately for the content 
 Windows Title and Comments properties 

 
ODOT provides a Visual Basic application to assist with the creation of MicroStation design files using the 
ODOT file naming convention and assigning the various parameters detailed above. The program can be 
accessed from the MicroStation pull-down menu by selecting ODOT > File Management > New Design 
File. 

 
Information about the program can be accessed by selecting the Help icon in the upper right corner of 
the dialog. Before creating design files, we’ll discuss each of the items in the bullet list above throughout 
this chapter. 
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Seed Files 
A seed file is an empty MicroStation design file that is used as a template for the creation of new design 
files. Seed files can be been configured specifically to meet a particular need. When new design files are 
created, the seed file specified by the user is copied and renamed to create the new file. ODOT provides 
several seed files for use with new projects started using the ODOTcadd Standards. The ODOT seed files 
are located in the following folder: 

I:\ODOTcadd\Standards\seed\ 

 
Standards seed files are provided for 2D and 3D uses, as well as seed files that have been defined with a 
specific Geographic Coordinate System (GCS) defining commonly used coordinate systems for Ohio. 
Additionally, a custom GCS can be defined for projects that are mapped using ground coordinates. 
 
Projects started with the ODOTcadd Standards will typically use a project specific seed file that has been 
defined with the correct GCS information for the project. Project specific seed files will be stored in the 
following location for each project: 

…\Design\Standards\Seed 

 
Important! 
Care should be taken to select the appropriate seed file when creating new design files. 
 

Geographic Coordinate Systems 
MicroStation V8i contains Geo-Coordination features which allow users to specify the position of the 
design contents on the earth´s surface. Once that position is established, the design can be easily 
coordinated with other data for which the geographic location is known. A library of predefined 
Geographic Coordinate Systems, or GCS for short, is available in MicroStation. 
 
The GCS tools available in Bentley Map allow users to define custom GCS definitions that are used to 
facilitate Grid-to-Ground conversion of the project data. This allows users to work in ground coordinates 
and distances while maintaining the ability to seamlessly integrate the project data with other Geo-
referenced systems such as Google Earth, Bing Maps, Aerial mapping and imagery, and GIS systems. 
 
The ODOTcadd Standards provide users with the tools to define the appropriate Geographic Coordinate 
System (GCS) on a project started with MicroStation and GEOPAK/PowerGEOPAK (SELECTseries 4). At 
this time, the use of a GCS is recommended, but it is not required. 
 
The GCS for a project can be defined on the appropriate State Plane North or South Zone or defined 
using a custom CGS to define a ground coordinate system. Whether a project is defined using grid 
coordinates or ground coordinates is up to the individual District/designer and should be coordinated 
with the District survey personnel before the project is started. 
 
Detailed information about defining the GCS is available in ODOT’s GEOPAK Survey with OpenRoads 
Technology training guide. This guide will discuss how to select the GCS once it has been defined by the 
Survey personnel. 
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Selecting the GCS 

The GCS can be selected by choosing Tools > Geographic > Select Geographic Coordinate 
System from the MicroStation pull-down menu. The Geographic Coordinate System dialog 
shown below is opened. 

 
To choose a GCS from the library, select the second icon, From Library. The Select Geographic 
Coordinate System dialog shown below is opened. 

 
The ODOT workspace defines the State Plane coordinate systems typically used on ODOT 
projects in the ODOT folder as shown above. Choose the appropriate GCS from the list. Other 
coordinate system definitions can be found in the Library folder. 
 
If a project specific GCS has been defined, it can be found in a project specific folder within the 
Select Geographic Coordinate System dialog. In the example above, the folder 11111_Custom 
contains the project specific GCS definition. 

 
It is very important that all users of the project data use the same GCS for all files created for the 
project. With this in mind, we have asked ODOT’s Surveyors to create project specific seed files when 
applicable. 
 
When it doubt, talk to the Survey personnel to make sure you are using the correct GCS information. 
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Project specific Seed Files 
If a custom GCS is to be used on a project, we are asking ODOT’s Survey Personnel to define project 
specific seed files with the GCS predefined. These project specific seed files should be used for every file 
created on the project to ensure that the design files have the correct GCS defined. Project specific seed 
files can be found in the \Design\Standards\Seed folder for the project and are named using the PID 
number. An example is shown below. 
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Exercise 5B – ODOT_Files.mvba 
In this exercise we’ll create new design files for both projects that were created in the previous exercise. 
 

 Open MicroStation using the desktop shortcut for the ODOTcadd Standards in the 
CADDStdsTraining folder: 

C:\ODOT_Training\CADDStdsTraining\ODOTcadd MicroStation SS3 

 
 On the MicroStation File Open dialog, change the Project to ALL_11111_EXAMPLE1 

 
 Open one of the seed files that was created with the project. 

 
 From the MicroStation pull-down menu, select ODOT > File Management > Create Design Files  

 
 Create the Basemap design files listed below for the project assigning the Default Comment to 

an appropriate value (“S.R. 123 Relocation” for example). Also be sure to set the Annotation 
Scale parameter appropriately for each file type 
 

Basemap Design Files 

 Drainage 

 Geometry 

 Profiles 

 Proposed Roadway 

GEOPAK Specific Basemap Files 

 Clipping Borders 

 Profile Motif File 

 Pattern Lines 

 Plan Motif File 

 Cross Section Cells (Roadway) 
 
Note the file names and the folders where the files are created. For this project, all of the files 
default to the \Design\roadway\basemaps folder since discipline specific sub-folders were not 
created. 
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 Toggle the Category to Roadway Sheets to create the files listed below. 
 

 Title Sheet 

 Schematic Plan 

 Typical Sections 

 General Notes 

 General Summary 

 Sub-Summary 

 Cross Sections 
 

 Select the Models option to create multiple models for a few of the file types, where 
appropriate. 
 

o For which Sheet Types would you typically NOT want to create multiple models? 
 

 Be sure to set the Annotation Scale and the Cell parameters appropriately for each file type.  
 

o What Scale should you use for the Schematic Plan? 
o What Scale Should you use for the Cross Sections? 
o Some Sheet Types do not default to place a sheet border. Why? 

 
 Change the Comments property as desired. 

 
 Select the Create Files item to create the files. Note the file names and the folder where the files 

are created. 
 
Next we’ll create some drainage sheets for the example project. This project does not include 
separate discipline specific folders, therefore drainage sheets will be added to the 
\Design\Roadway\Sheets folder. 

 
 Toggle the Category to Roadway Sheets to create the files listed below. Create multiple models, 

assign sheet cells, comments, and the Annotation Scale as desired. 
 

 Schematic 

 Notes 

 Sub-Summary 

 Quantity Table 
 

 Open the Title Sheet design file to verify the contents. The file should default to the sheet model 
as the active model with the title sheet cell placed in the file. 
 

 Open one of the design files that you created with multiple models (the Typical Sections for 
example). The file contains multiple models, each containing a sheet border cell. 
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Next we’ll create design files for the second example project. This one uses a larger folder structure with 
multiple design specific discipline basemaps. 
 

 Completely exit MicroStation by selecting File > Exit from the MicroStation menu. 
 
Note: It is required that you completely exit MicroStation when changing projects in order to 
clear all project specific configuration variables from memory. 
 

 Open MicroStation using the shortcut for the ODOTcadd Standards in the CADDStdsTraining 
folder: 

C:\ODOT_Training\CADDStdsTraining\ODOTcadd MicroStation SS3 

 
 On the MicroStation File Open dialog, change the Project to DEF_111112_EXAMPLE2 

 
 Open the 2d seed file that was created with the project. 

 
 Create several basemap design files of your choice for the project. For a few of the basemap 

types, create multiple files using the Files option. 
 
Take a look at the folders where the files will be created. File types that have a discipline specific 
folder will be created in the \Design\discipline\basemaps folder. File types that do not have 
a specific discipline folder will be created in the \Design\roadway\basemaps folder. 
 
Notice that the name of the basemap design files you created by specifying more than one file 
are incremented. 
 

 Create several sheet design files for several disciplines of your choice for the project setting the 
Comments, Scale, and Cell as necessary for each file type. Create multiple files, or multiple 
models as desired for appropriate file types. 
 
Which file types might it be appropriate to create multiple models? Why? 
 
Which file types would not be appropriate to create multiple files or multiple models? Why? 
 

 On the Create Files dialog, use the Browse button for the Parent Folder to select the 
\Design\Structures\DEF112_1234C folder. Create basemap and sheet design files for the 
bridge setting the Comments, Scale, and Cell as necessary for each file type. 
 

 On the Create Files dialog, use the Browse button for the parent folder to select the 
\Design\Structures\Wall_001 folder. Create basemap and sheet design files for the wall 
setting the Comments, Scale, and Cell as necessary for each file type. 
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Windows File Properties 
The Windows file properties Title and Comments may be used by ODOT personnel to add additional 
information about the design file contents that can be displayed in Windows Explorer and also in the 
MicroStation File Open dialog. The use of these properties is optional. 
 
The file properties are assigned when a design file is created using the ODOT_Files.mvba application and 
can also be assigned manually in MicroStation. 
 
To edit the file properties in MicroStation, select File > Properties to access the Properties dialog shown 
below. Select the Summary tab to review or edit the Title and Comments properties. 

 
The Title property is typically used to 
define the file type. 
 
The Comments property is typically 
used to define the file contents.  
 
 
 
 
 
 
 
 
 
 

 

Displaying the Title and Comments Properties in Windows 

The Title and Comments properties can be displayed in Windows Explorer by taking the 
following steps: 
 

 Set the Windows Explorer View Display to Details by using the Change your view option 
located in the upper right corner of the Windows Explorer dialog. 
 

 Right-Click on the column headers to reveal the menu 
shown at right which allows you to toggle on/off the 
columns that are displayed in the Details view. Toggle on 
Title and Comments. Use the More… option to toggle on 
the Comments column. 
 

 The order of the columns can easily be rearranged by 
dragging the column header to the left or right. An 
example is shown on the following page. 
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After the window has been customized, the settings can be assigned to all of the folders by 
taking the following steps: 
 

 From the Organize menu, 
located at the left of the 
Windows Explorer dialog, select 
Folder and search options to 
access the Folder Options dialog 
shown at right. 
 

 Choose the Apply to Folders 
option 
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Displaying the Title and Comments Properties in MicroStation 

The Title and Comments properties can also be displayed in the MicroStation File Open dialog 
boxes. Take the following steps to configure MicroStation to display the file properties. 
 

 Use the View Menu icon in the MicroStation File Open dialog to set the display mode to 
Details. 
 

 Right-Click on one of the column headers to toggle on the Title and Comments options. 
Use the More… option if the Title and Comments options are not available. 

 
After setting the options, the MicroStation File Open dialog will appear similar to the 
example shown below. 
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6 Sheet Cells and Tags 

Sheet Border Cells 
MicroStation Cells are used to define the ODOT standard Sheet Border cells. These cells are contained in 
the following cell library: 
 

…\ODOTcadd\Standards\cell\ODOT_Sheet.cel 

 
The sheet border cells have been updated to provide some new functionality for the ODOTcadd 
Standards as well as to provide future compatibility with Bentley’s ProjectWise software. The changes to 
the sheet border cells are summarized below: 
 

 Data Entry Regions for the title block information have been replaced with MicroStation Tag 
elements 

 Active points are placed at the text insertion points for the various title block attributes. These 
active points are tagged with the sheet parameters. 

 Every item in the sheet titles has been tagged for access programmatically 
 Sheet cells that are commonly edited are now split into two cells; one contain the sheet border 

and a second containing the sheet interior 
 
These changes provide significant improvements to the way ODOT manages the sheet title information; 
however, these improvements come at a cost: It is no longer possible to drop a sheet border cell. If a 
sheet border cell is dropped, the tags assigned to the sheet are lost. 
 

MicroStation Tags 
Most ODOT users are unfamiliar with MicroStation Tag elements. This section will present some general 
information about tags and how they are defined and assigned. For additional information, see the 
MicroStation online help. 

Tagged Elements 

Specific data can be associated with an element as a Tag. The value of the tag can be displayed 
in MicroStation as a text element. If the element is deleted, the tag is deleted as well. 

Tag Sets 

Before you can attach a tag to an element, you must define a Tag Set. A tag set definition 
specifies the unique tag name, display attributes, data type, and default value for each tag in the 
set. 
 
You do not have to create a Tag Set in order to use the Tags that have been assigned to the 
ODOT Sheet Border cells. When an ODOT Sheet Border cell is placed in a MicroStation model, 
the tags assigned to the cell are added to a Tag Set in the active design file. For example, the 
tags defined in the cell TITLE1 are added to the design file when the TITLE1 cell is placed in the 
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file. The Tag Sets can be reviewed in MicroStation by selecting Element > Tags > Define. An 
example is shown below. 

 
Each ODOT tag is named using the prefix “ODOT_” followed by a descriptive name. For example, 
the Tag Set ODOT_CRS is used to define the County-Route-Section text in the title block of the 
sheet border cell. 

 

Assigning Tag Values 
Initially, the tags defined on an ODOT sheet border cell are assigned a default value as shown in the 
example below. 
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The tags for the sheet numbers have a default value of 0 assigned with the exception of the Title sheet 
which has a default value of 1. 
 
Values can be assigned to tags in the ODOT cells by using the Tags toolbox or the Edit Text command. 
The Tags toolbox is accessed in the Tasks window as shown below. 

 
 
Use the second icon to edit the value of a tag. 
 
In the ODOT sheet border cells, the tags have been 
assigned to the point elements at the text insertion 
location. An example editing the tag value for the 
ODOT_CRS tag is shown below. 

 
After the tag Value has been assigned, the text for the 
tag is displayed in MicroStation similar to the example 
shown below. 
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Displaying Tags 
The display of tags is controlled by MicroStation’s View Attributes. If you are not seeing the value of 
your tags displayed, make sure the Tags item is toggled on in the View Attributes dialog as shown below. 

 
 
The View Attributes dialog is accessed by 
selecting Settings > View Attributes. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 Project Management with the ODOTcadd Standards October, 2015 

 

Chapter 6 – Sheet Cells and Tags Page 55 

 

Exercise 6 –Editing Tags 
In this exercise we’ll take a look at placing sheet cells and editing tags manually. 
 

 Open MicroStation using the shortcut for the training class. 
 

 From the MicroStation File Open dialog, choose the ALL_11111_EXAMPLE1 Project that was 
created in Exercise 3. 
 

 Open the following design file: 

\Roadway\Sheets\111111_GT001.dgn 

 
 Use the Edit Tags command of the Edit Text command to assign values to the various items in 

the sheet title block. 
 

 Notice that the Title Sheet border is a separate cell from the interior contents. The interior can 
be dropped for editing as required. 

 
Tags can also be edited using the Edit Text command. 

 Open the General Notes file from the following location: 

\Roadway\Sheets\111111_GN001.dgn 

 
 Use the Edit Text command to edit the values of the Tags. 

 
Note that you do not need to drop the status of the sheet border to edit the Tag values. 
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7 Sheet Manager 

With ODOT’s V8istd CADD Standards, the CADD Services Group within ODOT Central Office has provided 
a variety of applications intended to assist users with the task of managing some of the parameters 
within the sheet border cell title block such as the County-Route-Section or the sheet numbers. These 
applications have been used by some of ODOT’s District offices while other Offices have developed their 
own solution. 
 
As we move forward with MicroStation PowerGEOPAK (SELECTseries 4), the CADD Services group has 
developed a new Sheet Manager application intended to replace previous solutions for not only the 
sheet numbering, but as a tool to manage all of the various sheet border title block attributes. 
 

ODOT_SheetManager.mvba 
The Sheet Manager can be accessed by selecting ODOT > Sheet Management > Sheet Manager from 
the MicroStation pull down menu. In the example below, a sheet design file has been selected with the 
sheet attributes displayed to the right. 

 
This application is used to review and edit the value of the MicroStation tag elements in the sheet 
title block for a selected design file. Select the Help icon for complete documentation. 
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ODOT_XSSheetManager.mvba 
Cross section sheets have specific requirements that can be initially edited using the 
ODOT_XSSheetManager.mvba tool. This application is accessed by selecting ODOT > Sheet 
Management > XS Sheet Manager from the MicroStation pull-down menu. 

 
Select the Help icon for complete documentation. 
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Exercise 7A – ODOT_SheetManager.mvba 
In this exercise, we’ll take a look at the various modes of operation for the ODOT_SheetManager 
application.  

Part 1 – Single File Mode 

 Open MicroStation using the desktop shortcut for the ODOTcadd Standards in the 
CADDStdsTraining folder. 
 

 On the MicroStation File Open dialog, change the Project to DEF_11112_EXAMPLE2 
 

 Open the title sheet design file for the project. 
 

 Open the Sheet Manager application by selecting ODOT > Sheet Management > Sheet 
Manager from the MicroStation pull-down menu. 
 
Each \Design\discipline\sheets folder found in the project is listed in the Discipline list 
regardless of whether the folder contains any design files. Take a look at each available 
Discipline to review the sheet design files that are available in the project. 
 

 Set the Mode to the Single File option. 
 

 Toggle the Discipline option to Roadway. Select the Roadway Title Sheet from the file list. 
The parameters for the cell TITLE1 are listed in the dialog. 
 
The name of the cell found in the file is listed below the Files list as well as the number of 
sheet models found in the file. There should only be one sheet model in a Title Sheet design 
file. 
 
Define the following values for the Title Sheet: 

 Sheet Total:    150 

 County-Route-Section:  DEF-555-12.34 

 PID Number:   11112 

 Federal Project Number:  123456789 

 Railroad Involvement:  NONE 

 Const. Project Number:  123456 
 
Select the Write button to apply the values. The Sheet Cell in the file is updated with the 
new values. 
 

 You do not need to be in the file to edit the parameters. Select another file from the list, the 
General Notes file for example. Assign the parameters for the sheet and use the Write 
button to write the values to the file. 

 
 Did you create more than one Model for the General Notes file, or one of the other files? 

Choose a file from the list that has more than one model. The Sheet Model list will default 
to the first sheet model found in the file. Assign parameters to the cell in each sheet in the 
models by changing the Sheet Model item. 
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Part 2 – Multi-File Mode 

Multi-File mode is used to edit common parameters, such as the Sheet Total, for multiple files. 
 
 Change the Model to Multi-Files. The dialog is limited to only parameters that are common 

to multiple sheet types. 
 

 Select one of more Files to edit. 
 

 Assign values for the following parameters: 

 Sheet Total:   150 

 County-Route-Section: DEF-555-12.34 

 Calculated:   AAA 

 Checked:   BBB 
 
After writing the parameters to the selected files, toggle back to Single File mode to review 
the values. 
 

 Change the Discipline to assign parameters to some of the other sheet types. 
 
 

Part 3 – Excel Output Mode 

The Excel Output modes are used to read the Sheet attributes and write the values to an Excel 
file. The Excel file can be edited and saved, and then re-read to update the sheet files to match 
the parameters as defined in the Excel file. 
 
There are two Excel output modes: Excel Output, which will output information for the selected 
Discipline only, and Excel Output All which will output information for all the sheets in the 
entire project. 
 
 Toggle the Discipline to Roadway. 

 
 Set the Mode to Excel Output. 

 
 Choose the Write Excel File option to write the parameters for the Roadway Sheets to Excel. 

 
 Save the Excel file to the following location: 

 
\Design\Roadway\EngData\SheetManager_Roadway.slxs 
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Part 4 – Excel Input Mode 

The Excel Input mode is used to read the contents of an Excel file generated by the Excel Output 
mode and update the sheets to match the parameters defined within the Excel file. 
 
 Open the Excel file generated in the previous step. 

 
 Assign values for the sheet parameters that do not already have a value assigned. Save the 

changes. 
 

 Change the ODOT_SheetManager mode to Excel Input. 
 

 Use the Browse button to select the Excel file 
 

 Choose the Read File button to read the Excel file and update the sheets. 
 

 Use the Single File mode to review the files after the Excel file has processed. 
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Exercise 7B – ODOT_XSSheetManager.mvba 
In this exercise we’ll use the ODOT_XSSheetMananger application to annotate the cross section sheet 
borders. 
 

 Open MicroStation using the desktop shortcut for the ODOTcadd Standards in the 
CADDStdsTraining folder. 
 

 On the MicroStation File Open dialog, change the Project to GRE_00000_GRE-72-13.67 
 
 Open the cross section sheet design file for the project. 

 
The cross section sheets in this file were generated with PowerGEOPAK using the One Sheet 
Per Model option. Each cross section sheet is contained in a separate sheet model. This is 
the recommended practice for projects using the ODOTcadd Standards. 
 

 Open the ODOT_XSSheetManager.mvba application by selecting ODOT > Sheet 
Management > XS Sheet Manager from the MicroStation pull-down menu. 
 

 Process the cross section sheets using the the settings shown below. After the process is 
complete, open a few of the sheet models to verify the results. 

 
 Open the Sheet Manager tool to review the cross section sheet design file. Select each 

model in the file to verify the results. 
 

 Save settings in the cross section sheet file and exit MicroStation. 
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8 Sheet Cross References 

ODOT_SheetCrossRefs.mvba 
ODOT provides an updated sheet cross referencing application with the ODOTcadd Standards. The 
updated tool reads the Tag elements defined in the sheet border cell to get the sheet number as well as 
the subset number. The cross references can be assigned to either the sheet number or the subset 
number. 
 
The new application is not compatible with cross references previously assigned using ODOT’s V8istd 
cross referencing applications or the older ODOT cells using data entry regions. 
 
The application is accessed by selecting ODOT > Sheet Management > Cross References. 

 
Complete documentation for the application is available by selecting the Help icon. 
 
A training video is also available for this application online: 
 

https://www.youtube.com/watch?v=XdSXe6DyOdg 

 
 
 
 
 
 
 
 
 
 
 
 
 

https://www.youtube.com/watch?v=XdSXe6DyOdg
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Exercise 8 – Sheet Cross References 
In this exercise we’ll use the ODOT_SheetCrossRefs.mvba application to assign sheet attributes to the 
plan sheets in a sample project. 
 

 Open MicroStation using the shortcut for the training class. 
 

 From the MicroStation File Open dialog, choose the GRE_00000_GRE-72-13.67 Project. 
 

 Open the following design file: 

\Roadway\Sheets\00000_GP002.dgn 

 
 The upper left of the sheet contains a table for two cross references. Use the 

ODOT_SheetCrossRefs application to assign cross references to the data fields in the table. 
o Assign the CL References & Benchmarks cross reference to the design file containing the 

Schematic Plan sheet. 
o Assign the Culvert Details cross reference to the design file containing the Culvert Detail 

sheet 
 

 Open the following design file: 

\Roadway\Sheets\00000_GP003.dgn 

 
 Edit the cross reference for the cross sections. 

o The data entry regions for the cross reference are actually underscore characters. Use 
the Convert to DER function to convert the underscore characters to a data entry 
region. 

o Assign the cross reference to the XS design file. Which sheet model in the cross section 
design file contains the cross section sheet with the drive detail? 

 
 Cross references are not limited to single data entry regions. Use the MicroStation Place Text 

command to place the following text string: 
 

See Sheets __ and __ for details. 
 

 Assign cross references to the two data entry regions in the text string you have placed using the 
design files of your choice. 
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9 Change PID Number 

ODOTcadd_ChangePID.exe 
Occasionally work is started on a project before a PID number has been assigned. In this case, the 
recommended practice is to use the ODOTcadd_CreateNewProject.exe application to create the project 
directory using a PID number of “00000” and a supplemental description consisting of the primary 
County-Route-Section designation. Example: 00000_AAA-123-12.34 
 
When the project is assigned a PID number there are several things that need to be updated. ODOT 
provides an application to assist the user with the task of changing the PID number for a project. The 
application is found in the following location: 

\ODOTcadd\Standards\ODOT\Utilities\ODOTcadd_ChangePID.exe 

 
When the application is opened, the dialog shown below appears. 

 
Caution! 
Care should be taken before running this application. There is no Undo once the process has 
been initiated. 

 
The application preforms the following functions: 
 

 Renames the Project Configuration File (PCF File) using the new PID Number 

 Edits the PCF File to replace any occurrences of the old PID number with the new PID number 

 Renames the primary PID folder for the project with the new PID number 

 Searches all sub-directories of the PID folder for any file with the PID number in the name and 
renames the file using the new PID number. 

 Opens every MicroStation DGN file to correct missing reference file attachments as a result of 
the PID number changes made to the design file names. 
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Exercise 9A – ODOTcadd_ChangePID.exe 
In this exercise we’ll change the PID number for a small sample project that has just a few files. 
 

 We’ll use the ODOT_ChangePID application to change the PID number for the following project: 

\ODOT_Training\CADDStdsTraining\ProjectData\GRE\00000_GRE-72-13.67 

 
The New PID number for the project is 78086. 

 
 If the selected PCF file has an optional description after the PID Number (_GRE-72.13.67 in the 

example above) the can be removed by checking on the Remove Description option. 
 

 Select the Change PID option to initiate the process. 
 

 After the process is complete, take a few minutes to review the folders and files contained in 
the sample project to ensure that the files have been renamed with the new PID number 
 
For this example, the following sub-folders contain design files: 

\Design\Roadway\Basemaps 

\Design\Roadway\Sheets 

\Design\RW\Basemaps 

\Design\RW\Sheets 

\Design\Standards\Seed 

\Design\Survey\Basemaps 
 

 Open the PCF file with Notepad to review the contents.  

\ODOT_Training\CADDStdsTraining\ProjectPCF\GRE_78086.pcf 
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Exercise 9B - PID numbers and Geographic Coordinate Systems 
For plans that will be prepared using ground coordinates, the ODOT training guide for GEOPAK Survey 
with OpenRoads Technology recommends the use of custom Geographic Coordinate Systems (GCS) for 
Grid-to-Ground transformations. Custom GCS definitions are stored in a DTY file uniquely for each 
project. The recommended procedure for ODOT’s Surveyors is to name the custom GCS with the County 
name and the PID number. 
 
When the ODOTcadd_ChangePID.exe application is processed, the name of the DTY file is updated to 
reflect the new PID number. The project PCF file is also updated to specify the new name for the DTY 
file. MicroStation files that use the custom DTY file will default to the new file name; however, the name 
of the Coordinate System is not changed internal to the DTY file definition. It is necessary to manually 
edit the name of the coordinate system to use the new PID number. 
 
Note: This is not necessary if the project is to be developed using Grid Coordinates and one of the 
standard Ohio North or South Zone coordinate definitions. This is only necessary for projects where a 
custom GCS is used to define the ground coordinate system and the name of the custom GCS includes 
the PID number. 
 

 Let’s review the GCS settings for one of the design files on the GRE-72 project that we used in 
Exercise 9A to change the PID number. The DTY file is stored in the following folder: 

\ODOT_Training\CADDStdsTraining\ProjectData\GRE\78086\Design\Survey\GCS\780

86_Custom.dty 

 
Verify that the DTY file has been renamed successfully for the project. 

 
 Open the PCF file for the project with Notepad to verify that the definition for the custom DTY 

file has been updated to reflect the new PID number. The PCF file is located in the following 
folder: 

\ODOT_Training\CADDStdsTraining\ProjectPCF\GRE_78086.pcf 

 
Close Notepad after you have verified the DTY file name. 
 

 Open MicroStation using the ODOTcadd PowerGEOPAK SS4 shortcut located in the 
\ODOT_Training\CADDStdsTraining folder. 
 

 From the MicroStation File Open dialog, select the Project GRE_78086 and then open the 
following design file: 

\Design\Standards\Seed\78086_Seed2d.dgn 

 
The GCS is uniquely assigned to each Model in the design file and can be reviewed by selecting 
Tools > Geographic > Select Geographic Coordinate System to access the dialog shown on the 
following page. 
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In the example above, the Name of the Coordinate System definition within the DTY file is still 
GRE-00000-OH83-SF even though the DTY file name was changed to 78068_Custom.dty. 
 
The GCS definition cannot be edited unless Bentley Map is activated. Take the following steps to 
activate Map and edit the GCS name: 
 

 From the MicroStation pull-down menu, select Applications > Map > Activate Map. If the option 
for Map is not available, either you did not open MicroStation using the appropriate shortcut to 
gain access to a PowerGEOPAK license, or Map has already been activated. 

 
 After activating Map, choose Tools > Geographic > Select Geographic Coordinate System to 

access the Geographic Coordinate System dialog shown above. 
 

 Choose the second icon, From Library, to access the Select Geographic Coordinate System dialog 
shown below.

 
 Right-click on the custom GCS definition and choose Edit Coordinate System Properties as 

shown above. The Edit Geographic Coordinate System dialog is opened. 
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 Edit the Name of the Coordinate System to reflect the new PID number as shown in the example 
below. 
 
Important! Be sure not to change any other values in the Coordinate System definition. 

 
 Select OK to complete the edit, and then select OK on the Select Geographic Coordinate System 

dialog to make the GCS definition active. You should now see the renamed GCS listed in the 
Geographic Coordinate System dialog as shown below. 

 
The GCS definition has now been updated with the correct PID number, however this change is 
not automatically propagated to the other Models in the active design file, or to any of the other 
design files in the project. 
 

 It is necessary to reselect the GCS in every Model in every design file on the project. This can be 
facilitated using the ODOT_AssignGCS.mvba application. The application is accessed by 
selecting ODOT > Project Management > Assign GCS from the MicroStation pull-down menu. 
The dialog shown on the following page is opened. 
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The application will default to the Project Folder defined by the MicroStation configuration 
variable _USTN_PROJECTDATA. This variable is normally defined in the .pcf file for an ODOT 
project. 
 
The application will display the GCS Name for the CGS that is defined in the active model of the 
current design file. 
 

 Make sure the GCS Name is the name that you wish to propagate to all of the design files for the 
project. 
 

 Select the Assign GSC to All Files button to initiate the process. The program will search every 
sub-directory from the Project Folder path looking for MicroStation files and will open every 
model in every file to assign the GCS that you have specified. 
 
WARNING! 
Running this application is going to touch every design file in the project. Make sure you want to 
do this before running this process. 

 
 After the process is complete, open a few of the design files to verify that the GCS has been re-

assigned to all of the models in each file. 
 

 Exit MicroStation. 
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10 ODOTcadd MicroStation Utilities 

ODOTcadd_ClientConfigurationTool.exe 
Information for the ODOTcadd configuration for a typical ODOT installation of MicroStation V8i 
(SELECTseries 3) with PowerGEOPAK V8i (SELECTseries 4) can be found in the following document: 

\ODOTcadd\Standards\ReadME-ODOTcadd.pdf 

 
The ODOTcadd_ClientConfigurationTool.exe application, shown below, is intended to be run by the 
user after the system administrator has installed MicroStation and PowerGEOPAK on your computer. 
 
The program is used to properly set up the client configuration on the local computer. The application is 
available from the ODOTcadd program group in the Windows Start Menu or can be accessed from the 
following location: 

\ODOTcadd\Standards\ODOT\Utilities\ODOTcadd_ClientConfigurationTool.exe 

 
Use of this program is optional. Administrators can have the users set up the MicroStation configuration 
manually following the guidelines established in the \ODOTcadd\Standards\ODOTcadd-ReadMe.pdf 
document mentioned on the previous page. 

 
When initiated, the program will search for the default folders based on the installed software found on 
the local computer. 
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The folders for the User Preference files can be changed as necessary. For a typical ODOT installation, 
the folders shown above should be used. If the folder(s) have not been previously created, the program 
will show a blank entry for the applicable User Preferences field. The Browse icons include the option to 
create a new folder if these folders have not been previously created. 
 
Once the folders have been defined, select the Configure Client for ODOT Configuration button to 
launch the process. The following functions are performed: 
 

 The program will clean out the contents of the folders specified for the User Preferences and 
reconfigure the folders with the necessary sub-folders for use with the ODOTcadd Standards as 
well as the ODOTstd\V8i Standards. 
 
Note: This action completely removes all files in the specified User Preference folders. If the 
User Preference folders contain any customized files that you wish to retain, such as a 
MicroStation Function Key Menu or a Button Menu, be sure to make a copy of these files before 
initiating the process. 
 

 The contents of the C:\Temp folder will be completely removed and reinitialized with the proper 
sub-folders for a typical ODOTcadd installation. 
 

 The appropriate desktop shortcuts are copied from the ODOTcadd\Standards\config\shortcuts 
folder to the user’s Desktop for access to MicroStation and/or PowerGEOPAK with either the 
legacy V8iSTD CADD Standards or the ODOTcadd Standards. 
 

 The program will write a redirect file named z_ODOT_refirect.cfg for the ODOTcadd 
configuration and place it in the following location: 

C:\ProgramData\Bentley\MicroStation V8i (SELECTseries)\WorkSpace\Standards 

 
The redirect file is used in conjunction with the desktop shortcuts to access MicroStation with 
either the legacy V8istd CADD Standards or the ODOTcadd Standards. 
 
An example of the redirect file that was generated by the program is shown on the following 
page. 
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#---------------------------------------------------------------------- 
# Ohio DOT Site Configuration Redirect 
# 
# Written by the ODOTcadd_ClientConfigurationTool. 
# Date: 2/12/2015 2:00:44 PM 
# 
#---------------------------------------------------------------------- 
 
%if defined(ODOTcadd) 
 
 #ODOT System 
 ODOT_ROOT =  I:/ODOTcadd/     #ODOT data Root. 
 ODOT_STD =  I:/ODOTcadd/Standards/ #ODOT Standards folder path. 
 ODOT_LOCAL =  I:/ODOTcadd/Local/ #ODOT per site custom (in-house use) 
 ODOT_USER =  W:/ODOTUser_ODOTcadd/  #User data folder. Users preference files reside here. 
 ODOT_PROJECT =  I:/ProjectPCF/ #ODOT (*.pcf) folder path. 
 ODOT_TEMP =  C:/Temp/  #ODOT Temp folder for temp resources 
 
 %lock ODOT_ROOT 
 %lock ODOT_STD 
 %lock ODOT_LOCAL 
 %lock ODOT_USER 
 %lock ODOT_PROJECT 
 %lock ODOT_TEMP 
 
 #ODOT Site Configs 
 %if exists ($(ODOT_STD)config\Standards\*.cfg) 
   %include $(ODOT_STD)config\Standards\*.cfg 
 %endif 
 
%elif defined(ODOTv8istd) 
 
 ODOTSTD : I:\ODOTstd 
 V8iSTD : $(ODOTSTD)\V8istd 
 HOMEV8i : w:/ODOTUser_V8iSTD/ 
 V8iSTD_PROJDIR : $(ODOTSTD)/Projects/ 
 
 %if exists ( $(V8iSTD_PROJDIR)*.pcf) 
   _USTN_PROJECT = $(V8iSTD_PROJDIR) 
 %endif 
 
 %if exists ($(HOMEV8i)*.ucf) 
   _USTN_USER = $(HOMEV8i) 
   _USTN_HOMEPREFS = $(HOMEV8i) 
   MS_USERPREF             : $(_USTN_PREFNAMEBASE).upf 
   MS_DOCKINGPREF          : $(_USTN_PREFNAMEBASE).docking.xml 
   MS_TASKDIALOGPREF       : $(_USTN_PREFNAMEBASE).TaskNavigation.xml 
   MS_GROUPPANELPREF       : $(_USTN_PREFNAMEBASE).GroupPanels.xml 
 %endif 
 
%endif 
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ODOTcadd_MicroStationUtilities.exe 
The ODOTcadd Standards include a new Visual Basic program that can be used to perform some 
common maintenance tasks. The application is available from the ODOTcadd program group in the 
Windows Start Menu or can be accessed from the following location: 

\ODOTcadd\Standards\ODOT\Utilities\ODOTcadd_MicroStationUtilities.exe 

 
When accessed, the program will search for the default User Preferences Folders based on the software 
installed on the computer. The Browse buttons can be used to select the appropriate folders. 
 
The application has the following four functions: 

Kill MicroStation 

Occasionally MicroStation or PowerGEOPAK will abort and close. In the case of a software crash, 
there is often an open software process still running for MicroStation or GEOAPK that should be 
ended. The Kill MicroStation function will end any running MicroStation or GEOAPK process. 

Clean C:\Temp 

ODOT uses the C:\Temp folder for temporary CADD files. Occasionally cleaning this folder is a 
good practice and is necessary when a new software version has been installed. Choosing the 
Clean C:\Temp option will delete all of the files in the C:\Temp folder and reset the folder back 
to the original state with the necessary sub-folders for a typical ODOT installation. 

Delete RSC Files 

GEOPAK uses resource files (.rsc) to store dialog box settings. Occasionally one or more of these 
resource files can become corrupt causing all sorts of problems. The Delete RSC Files function is 
used to delete all of the GEOPAK .rsc files found in the C:\Temp folder and the C:\Temp\rsc 
folder. It is good practice to delete the RSC files any time a new version of GEOPAK is installed. 

Reset Preferences 

It is occasionally necessary to reset the MicroStation User Preference File (.upf). Choose the 
Reset Preference option to reset the user preference back to their default state. This should 
always be done after installing a new version of MicroStation.
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11 PDF Printing with Print Organizer 

Printing Multi-Page PDF Files Process Overview 
ODOT is transitioning towards the use of multi-page PDF files for plan submissions instead of TIFF 
images. PDF printing is facilitated using the MicroStation Print Organizer. 
 
The Print Organizer is a MicroStation utility for printing and reprinting a set of design files, models, or 
Project Explorer links. The files that are to be printed are saved as a print set file (.pset).  
 
The steps to create and print a multi-page PDF are summarized below: 
 

 Select File > Print Organizer from the MicroStation pull-down menu to launce the application. 
 

 The Print Organizer dialog will default to the last print driver that was used when the application 
was opened. If this is the first time you open the dialog, you will be prompted to select a print 
driver as shown below.

 
ODOTcadd.pltcfg 
Select this print driver to plot full size or quarter size plan sheets. 
 
ODOTcadd_PDF.pltcfg 
Select this print driver to create a multi-page PDF file 
 
ODOTcadd_PDF_Levels.pltcfg 
Use this print driver to create a multi-page PDF with levels. Note: The resulting PDF file 
size can be quite large when using this option. 
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ODOTcaddL.pltcfg 
This print drive is used to plot letter size (8.5” x 11”) plan sheets. 

 
If the print driver has been previously selected, the current print driver is listed at the bottom of 
the dialog as shown below. You can click on the name of the print driver to select a different 
driver. 

 
 Open the PSET file for the project. 

 
When a project is created using the ODOTcadd_CreateNewProject.exe utility, a .pset file is 
created for the project in the location shown below. The file is named using the PID number for 
the project. 

...\Design\standards\pltdrv\#####.pset 

 
The PSET file is prepopulated with folders to organize the design files that will make up the print 
set as shown below. 
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 Add the design files for the project to the Print Organizer. This can be accomplished using the 
Add files to Set icon, or by dragging and dropping files from Windows Explorer into the 
appropriate folder. 
 

 As files are added to the print set, the name of the design file is used as the Name for the sheet 
in the print set. In the example below a General Notes design file was added to the print set that 
contained 2 sheet models. 

 
Note: Design Models are not included 
in the print set. 

 The ODOT configuration allows for the 
Sheet Name as defined in the Model 
Properties dialog to be used as the 
Name in the PSET file. 
 
The Sheet Name and the Sheet Number 
properties are automatically assigned to 
the Model Properties when the 
ODOT_SheetManager.mvba application 
is used. 
 
The Display Sheet Boundary option 
must be toggled on in order for the Print 
Organizer to recognize the Sheet Name 
property. 
 
Note: The Sheet Number field is limited 
to numeric values only. Alphabetic 
characters are not supported. 
 
 
 
 
 
 
 

 To define the print set Name using the model Sheet Name property, take the following steps: 
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o Select the file or folder in the Print 

Organizer dialog that you wish to 
update using the model’s Sheet 
Name property. To update all the 
files in the print set, select the top 
level PID Number folder. 
 

o From the Print Organizer dialog, 
select Edit > Rename by 
Expression to access the Rename 
Print Definitions by Expression 
dialog. 
 

o Change the Expression Name 
value to ODOT_SheetName. Choose 
the OK button to apply the model’s Sheet Name property to the selected file(s) in the print 
organizer. 
 
 
 

 Choose the Print icon to create a PDF file from the print set. 

 
 

Print Range 
The Print Range can be set to All or Selection. All will print the entire contents of the print set. 
Selection will print only the selected items. 
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Destination 
The Destination field is used to define the location where the PDF file is created. The 
MicroStation variable MS_PLTFILES is used to define the default location. This variable has been 
defined in the Project Configuration File (.pcf) for ODOT projects to save the PDF files in the 
following folder for the project: 

\ProjectAdmin\PlanPackage 

 
 The completed PDF is organized by the order of the folders and files listed in the Print Organizer 

dialog. Bookmarks for each sheet in the plan set are created within the PDF file as shown in the 
example below. 

 

 
 

 After the PDF file has been generated, be sure to save the PSET file settings. Choose File > Save 
from the Print Organizer dialog to save the PSET file. 
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Updating a Print Set 
A previously saved PSET file can be opened and reused to generate a new set of prints, or a new PDF file 
as needed. 
 
The PSET file contains a “snapshot” of the design files at the time the print set was created. The PSET file 
is not dynamically linked to the design files and must be updated if any changes have been made to the 
design files since the time the PSET file was created. 
 
Take the following steps to update the print set: 
 

 Start Print Organizer by selecting File > Print Organizer from the MicroStation pull-down menu. 
 

 Open the PSET file. 
 

 From the Print Organizer dialog, select the top level folder (typically the PID Number). The sub-
folders contained in the PSET are listed on the right side of the dialog. Select the sub-folder(s) 
that you wish to update. In the example below, the PSET definition for files listed in the 
Plan/Profiles folder will be updated. 

 
 From the Print Organizer dialog, select Edit > Properties to access the Modify Properties dialog 

shown on the following page. 
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 Toggle on the Update from design file option on the Advanced tab. 
 

 Choose OK to initiate the process. The PSET is updated by reading the selected files.

 
 

 After the PSET has been updated, proceed to print the files or create a new PDF as necessary. 
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Exercise 11 – Creating a Multi-Page PDF with Print Organizer 
In this exercise we will create a multi-page PDF file for the sample project. 
 
Note: The project and design file names may have been changed from what is shown below if you have 
run the ODOTcadd_ChangePID.exe application as detailed in Chapter 9. 
 

 Open MicroStation using the shortcut for the training class. 
 

 From the MicroStation File Open dialog, choose the GRE_00000_GRE-72-13.67 Project. 
 

 Open the following design file: 

\Roadway\Sheets\00000_GT001.dgn 

 
 From MicroStation, start the Print Organizer by selecting File > Print Organizer. 

 
 Select the ODOTcadd_PDF.pltcfg print driver 

 
 A PSET file is included with the dataset. From the Print Organizer dialog open the PSET file: 

\Design\Standards\pltdrv\00000.pset 

 
 Using this chapter as a guide, populate the PSET dialog with the design files for the project. 

Make sure to import the design files into the proper sub-folders within the Print Organizer 
dialog. 
 

 After importing the design files, use the Rename by Expression option to set the name of the 
files within Print Organizer using the Model’s Sheet Name property. 
 

 Create the PDF file. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 


