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1 Introduction 

1.1 Course Prerequisites 
This training course is intended for ODOT personnel directly involved in the production of roadway 
construction plans. The course serves as an overview of the OpenRoads tools for Corridor Modeling 
available in GEOPAK/PowerGEOPAK V8i (SELECTseries 4) tools and should not be considered a 
comprehensive reference guide. For additional information regarding specific software functions not 
covered in this manual, please refer to Bentley’s online help information. 
 
It is required that students meet the following prerequisites: 
 

 Familiarity with ODOT’s design policies, procedures, and CADD Standards 
 Plan preparation experience 
 A working knowledge of Windows 7 
 A working knowledge of MicroStation V8i 
 A working knowledge of GEOPAK Road 

 
This course builds upon the concepts and processes detailed in the following ODOT training guides: 
 

 GEOPAK V8i SELECTseries 1, Road 1 
 GEOPAK V8i SELECTseries 1, Road 2 
 Project Management with the ODOTcadd Standards 

 
It is assumed that class participants have completed these courses. 
 

1.2 Course Outline 
The following topics are covered in the class: 
 

 ODOT Project Configuration Standards 
 ODOT CADD Standards for Survey and Design 
 Using OpenRoads Survey Data 
 Annotation Scale 
 Working with 3D MicroStation Files 
 Geographic Coordinate Systems 
 Civil AccuDraw 
 Horizontal Geometry 
 Vertical Geometry 
 Plan Graphics 

 
 

 Templates 
 Corridor Modeling 
 Superelevation 
 3D Geometry 
 Intersection Design 
 Civil Cells 
 Cross Section Sheets 
 Cross Section Annotation 
 Component Quantities 
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1.3 Course Schedule 

 

Start Time: 8:30 AM 
End Time: 3:00 PM 

 

Breaks: 15 Minutes per half day 

 
Lunch: 30 Minutes 

 

Web Browsing: Please limit web browsing to break times and lunch. 

 

Email: Please limit email usage to break times and lunch. 

 

Cell Phones: Please set cell phones to vibrate and take calls only at break times and lunch 
unless absolutely necessary. Please refrain from texting during the class 

 

1.4 CPD Credit 
Participants in the class are eligible for CPD credit*.  A certificate for CPD credit is available upon request 
from the instructor at the completion of this course. 
 
*Please note that final determination on what qualifies for CPD credit ultimately lies between the license holder and the State 
Board for Professional Engineers and Surveyors. 
 

1.5 ODOT CADD Standards and Support 
ODOT CADD Standards for MicroStation, GEOPAK, and OpenRoads are maintained and distributed by 
the ODOT Office of CADD and Mapping Services. 
 

http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Pages/default.aspx 

The ODOT CADD Engineering Standards Manual is available in Adobe Acrobat PDF format on the ODOT 
Website: 
 

http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Standards/Pages/Manuals.aspx 

ODOT’s Design Resource Reference Center is a centralized online reference center to help locate online 
or printed material. Additionally, several mailing lists are available to keep you informed about updates 
to ODOT standards. Visit the Design Resource Reference Center at the following URL: 
 

http://www.dot.state.oh.us/drrc/Pages/default.aspx 

Support for Bentley Software is the responsibility of the Office of CADD and Mapping Services. Support 
questions can be sent to the CADD Support staff using the following form: 
 

http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Support/Pages/ServiceRequest.aspx 

http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Pages/default.aspx
http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Standards/Pages/Manuals.aspx
http://www.dot.state.oh.us/drrc/Pages/default.aspx
http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Support/Pages/ServiceRequest.aspx
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1.6 ODOTcadd Standards 
The ODOTcadd Standards for MicroStation V8i (SELECTseries 3) and GEOPAK V8i (SELECTseries 4) are 
located in the following folder: 

I:\ODOTcadd\Standards 
 
For users external to ODOT, these CADD Standards can be downloaded from the ODOT website: 
 

http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Standards/Pages/Files.aspx 

 
The standards are maintained and distributed by the CADD Services group within the Office of CADD and 
Mapping services. Requests for enhancements and questions about these standards should be directed 
to the CADD Services group using the following form: 
 
http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Support/Pages/ServiceRequest.aspx 

 
The ODOT CADD Standards for MicroStation V8i (SELECTseries 3) and GEOPAK V8i (SELECTseries 4) are 
not intended to be used with older versions of MicroStation and GEOPAK software. 
 

1.7 Companion Training Guides 
This training guide is specific to the GEOPAK and OpenRoads tools used for Corridor Modeling. Topics 
related to project configuration and plan production using the legacy GEOPAK Road commands are not 
covered in this training guide. ODOT provides two other training guides, listed below, that are 
complimentary to this training guide. 
 
It is assumed that the student is familiar with the content each of these training guides. 

Project Management with the ODOTcadd Standards 

ODOT provides a separate training guide for the ODOTcadd Standards that covers several project 
management tasks, including the following topics: 
 

 Standard Directory Structure 
 Standard Design File Names 
 New Project Creation 
 File Creation 
 Design Files, Models, and Annotation Scale 
 Sheet Cells and Tags 
 Sheet Management and Cross References 
 PDF Printing 

 
Many of these topics are relevant to this course, however we will not cover these topics in this training 
guide. See the Project Management with the ODOTcadd Standards training guide, located in the 
ODOTcadd folder, for more information on these topics: 

I:\ODOTcadd\Stadards\ODOT\Traning\Guides\ODOT_ODOTcaddTrainingGuide.pdf 
 
 

http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Standards/Pages/Files.aspx
http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Support/Pages/ServiceRequest.aspx
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ODOT GEOPAK Road 1 and Road 2 Training Guides 

The OpenRoads tools included with GEOPAK v8i (SELECTseries) 4 are primarily aimed at creating a 3D 
model of the project. Plan production tasks are still accomplished using the legacy GEOPAK Road tools. 
The ODOT GEOPAK Road 1 and Road 2 training guides are still relevant for plan production processes.  
 
Any references to a project folder structure and file names detailed in the Road 1 and Road 2 training 
guides are superseded by the ODOTcadd Standards as detailed in the CADD Engineering Standards for 
ODOTcadd manual and the Project Management with the ODOTcadd Standards training guide. 
 
ODOT’s GEOAPK Road 1 and Road 2 training guides can be found in the following location: 
 

I:\ODOTcadd\Stadards\ODOT\Traning\Guides\ODOT_GEOPAK_V8i_Road1.pdf 
I:\ODOTcadd\Stadards\ODOT\Traning\Guides\ODOT_GEOPAK_V8i_Road2.pdf 

 

1.8 Bentley Online Training Resources 
The ODOTcadd configuration contains links to Bentley Online training resources. 
 
In the MicroStation Project Explorer dialog, select the Links group. From the drop-down list, choose 
Bentley Online. 

 
Of particular note is the OpenRoads Video Clips. Tech Notes & FAQs link. Be sure to take a look at the 
information available at this link by double-clicking the item in the Project Explorer dialog. 
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2 OpenRoads Overview 

2.1 What is OpenRoads? 
You may have heard of Bentley’s “OpenRoads” technology and the SELECTSeries 4 release of 
MicroStation and Bentley Civil products. But exactly what is OpenRoads? 
 
OpenRoads is not a software product that can be purchased and installed separately. OpenRoads is a 
technology that is included with the installation of Bentley’s InRoads, GEOPAK, and MXROAD software. 
 
OpenRoads is described as follows on the Bentley Website: 
 

“OpenRoads technology represents the continued evolution of merging functionality for 
Bentley’s road design, drainage analysis and design, data input and reduction, and bridge 
modeling products. This shared technology is embedded in InRoads, GEOPAK, MXROAD, and 
PowerCivil. It expands these products to include information-rich 3D modeling integrated with 
CAD, mapping, GIS, and business tools like PDFs, i-models, and hypermodels.” 
 
“OpenRoads technology provides the common workflow, data structure, and modeling tools that 
civil engineering organizations need to meet today’s information modeling and accelerated 
project delivery requirements.” 

 
But what does this mean for ODOT’s GEOPAK Road and GEOPAK Survey users? It means that a new 
generation of Bentley Civil tolls is upon us that will eventually supersede Bentley’s current civil products 
InRoads, GEOPAK and MXROAD. 
 
 

2.2 How does OpenRoads differ from GEOPAK Road/Survey? 
There are several key differences between the OpenRoads technology and GEOPAK Road/Survey. Some 
of the major differences are summarized below. 
 

 Unlike GEOPAK, all OpenRoads data is stored directly in MicroStation 
o The GPK file is no longer necessary to store survey points, survey chains, or geometric 

alignments and profiles; however, a GPK file is still necessary for some plan production 
processes. 

o All ground survey data processed using OpenRoads Technology is stored in a 3D 
MicroStation design file.  

o GEOPAK TIN models are no longer used. Terrain models are stored directly in 
MicroStation in the same design file as the survey information. 
 

 3D MicroStation Design Models are used for OpenRoads survey processing 
o The design files you receive from ODOT’s Surveyors will be 3D files. 
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 All graphics generated using OpenRoads technology tools use MicroStation’s Annotation Scale 
functionality 

o Note: With the current implementation of the software, some of the graphics will still be 
annotated using the GEOPAK Design and Computation Manager. As with previous 
releases of GEOPAK, these graphics do not honor the Annotation Scale setting. 

 
 The ODOT implementation of OpenRoads uses a new MicroStation User Configuration file 

(ODOTcadd) and project specific Project Configuration Files (PCF). 
o Users must use the MicroStation Manager dialog to open design files in order to select 

the correct UCF and PCF files before opening the design file. 
o It is no longer acceptable to open MicroStation files by double-clicking on the file name 

in Windows Explorer. 
 

 All ODOT projects will use the ODOT standard directory structure and file naming convention. 
See the ODOT CADD Engineering Standards Manual (ODOTcadd) for details. 
 

 Default project settings for OpenRoads are stored in DGN Libraries that are included in the 
ODOT workspace configuration. 
 

 Geographic Coordinate Systems (GCS) will be used to establish the coordinate system for the 
project data. This allows easy translation between grid and ground coordinates and other Geo-
referenced systems such as Google Earth, Bing Maps, Aerial Mapping, and GIS systems. 
 

 The user interface has changed. OpenRoads tools are built into the MicroStation Task 
Navigation menu and the Tools pull-down menu. OpenRoads tools are not accessed through the 
Applications > GEOPAK pull-down menu 
 

 Feature definitions are defined in MicroStation DGN Libraries. The GEOPAK D&C Manager 
database (.ddb) is no longer used for most OpenRoads functions; however it is still used for 
stationing alignments. 
 

 OpenRoads tools fully support MicroStation’s Undo functionality. 
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2.3 3D Modeling vs Plan Production 
The OpenRoads technology is designed specifically to help users produce a 3D model of the proposed 
design. To date, the available OpenRoads technology tools have been developed primarily for this 
purpose. Plan production tools, such as labeling, plan and profile sheet clipping, etc… are not currently 
supported using OpenRoads specific tools. For most plan production functions, the legacy GEOPAK tools 
are still used. This guide will focus specifically on the use of the OpenRoads technology to generate a 3D 
model. The legacy plan production tools are not covered by this manual. See the ODOT GEOPAK Road 1 
and ODOT GEOPAK Road 2 training guides for information on the legacy GEOPAK software functions. 
 
Many design functions can be completed with ether the legacy GEOPAK tools, or the OpenRoads 
Technology tools. Import and export functions within the OpenRoads toolset allow users to move 
to/from the use of the OpenRoads Technology and the legacy GEOPAK tools. The table below 
summarizes a few of the major work processes and the relationship between the legacy GEOPAK tools 
and the Open Roads technology. 
 
 
 
 
 
 
 
 
Survey mapping from GEOPAK Survey can be used with OpenRoads. The TIN file from GEOPAK Survey 
must be imported to an OpenRoads Terrain Model. 
 
Survey mapping generated using the OpenRoads Technology can be used by the legacy GEOPAK Tools, 
however the OpenRoads Terrain Model must be exported as a GEOPAK TIN. OpenRoads Survey points 
and linear features are contained in the DGN file and are not stored in a GEOPAK GPK file; however, 
survey points and linear features can be selectively exported to a GPK file as needed. 
 
 
 
 
 
 
 
 
OpenRoads alignments are stored in a DGN file. The geometric data can be exported to a GEOPAK GPK 
file as necessary. 
 
GEOPAK Alignments and profiles stored in the GPK file can be imported as OpenRoads geometry. 
 
Many legacy coordinate geometry functions are not supported directly by OpenRoads tools. OpenRoads 
geometry is typically exported to the GPK file as a part of the workflow process. 
 
 
 

Survey Mapping 

and Terrain 

OpenRoads 
GEOPAK 

Horizontal and 

Vertical Geometry 

OpenRoads 
GEOPAK 
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All plan view labeling is done using the legacy GEOPAK tools, including centerline stationing. The 
Stationing can be automated, however it is still a function of the GEOPAK Design and Computation 
Manager. 
 
 
 
 
 
 
 
 
OpenRoads vertical geometry is stored with the horizontal alignment in the DGN file, but the vertical 
geometry is not drawn in the design file in the traditional manner. For plan and profile sheet generation, 
both the horizontal and vertical geometry must be exported to a GPK file and plotted using the GEOPAK 
Design and Computation Manager.  
 
 
 
 
 
 
 
 
Superelevation definitions for OpenRoads are computed using the legacy GEOPAK SEP file and are 
stored in the DGN file using control lines for each lane of pavement. A GEOPAK Shape Input File can be 
read into OpenRoads; however, OpenRoads superelevation definitions cannot be exported for use with 
the legacy GEOPAK tools. 
 
 
 
 
 
 
 
 
OpenRoads cross sections are a byproduct of the 3D model. All OpenRoads commands are utilized with 
the intent to generate the 3D model. Cross sections generated by OpenRoads can be placed with a 
GEOPAK Control Cell for use with legacy GEOPAK Cross Section functions. 
 
Cross section sheets can be generated using OpenRoads tools, or the legacy GEOPAK cross section sheet 
tool. For ODOT purposes, the legacy tools provide better options. 

Plan and Profile 

Labeling 

GEOPAK 

Plan and Profile 

Sheets 

GEOPAK 

Superelevation 

OpenRoads 
GEOPAK 

Cross Sections 

OpenRoads 
GEOPAK 
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2.4 OpenRoads Online Help 
To access the OpenRoads help information, select Civil Tools > OpenRoads Help > OpenRoads Help 
from the MicroStation Tasks menu as shown below. 

 
 
The Civil Tools V8i SELECTseries 4 dialog shown below is 
opened. 
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2.5 The ODOT Workspace 
A Workspace is a custom MicroStation environment or configuration. By selecting a workspace, you are 
customizing MicroStation and the Civil products for a specific discipline, project, or task. The workspace 
contains pointers to the CADD standards, DGN libraries, cell libraries, seed files, symbology resources, 
etc. necessary for the project. 
 
ODOT’s Standard configuration provides two workspaces for MicroStation and GEOPAK projects. These 
workspaces are selected by choosing the appropriate item from the Windows Start Menu as shown 
below. 

 
The workspaces are configured to access 
MicroStation/PowerGEOPAK with either the legacy V8istd 
CADD Standards or the new ODOTcadd Standards. 
 
Care must be taken to select the appropriate item for the 
project that you intend to open to ensure that the correct 
CADD standards are accessed. 
 
When the ODOTcadd PowerGEOPAK SS4 item is selected, the 
MicroStation File Open dialog shown below is opened. 
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User Configuration 
The User option is used to select the MicroStation user configuration file (.ucf).  When MicroStation is 
opened the User option will default to ODOTcadd as shown above.  
 
Project Configuration 
With MicroStation and PowerGEOPAK V8i (SELECTseries 4), ODOT will transition to using a MicroStation 
project configuration (.pcf) file for each project that has been assigned a PID number. The PCF file is 
used to define project specific MicroStation variables. The Project menu will contain a list of the 
available projects. When a project is selected from the list, the File Open dialog will default to the root 
folder that has been defined for the project. 
 
Important! 
Many users are in the habit of opening MicroStation files by double-clicking the file name in Windows 
Explorer. When a MicroStation file is opened in this fashion, the User and Project configuration files that 
were active the last time MicroStation was opened will be used. In order to ensure that the correct 
configuration files are selected for OpenRoads projects, users should get in the habit of opening 
MicroStation from the program shortcut in order to select the appropriate User and Project 
configuration files before prior to opening MicroStation design files. 
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Exercise 1 - Training File Installation 
The training files for this class can be installed from the ODOT CADD Standards folder by use of a custom 

application. 

 From the Windows Start Menu, select All Programs > ODOTcadd > Utilities > 
ODOTcadd_ConfigureTraining to install the training files. 
 
You can also run the program from the following location: 
 
I:\ODOTcadd\Standards\ODOT\Training\ODOTcadd_ConfigureTraining.exe 

The application will prompt you to close MicroStation if it is running. Select OK to proceed. 

 
The program must access the ODOTcadd Standards in order to install the training files. The 

program will search for the ODOTcadd folder in the following location: 

I:\ODOTcadd 
 

 If the program cannot find the ODOTcadd folder in the location specified above, the Browse for 
Folder dialog is opened and you must choose the ODOTcadd folder. 
 
After the ODOTcadd folder has been successfully identified, the dialog shown below is opened. 

 

 Choose the OpenRoads Design option. 
 

 Specify the Installation Folder for the training data installation. Use the default location for the 
training file installation. 
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If you elect to change the installation folder, the selected folder will automatically be appended 
with the “\ODOT_Training” folder name. For example, selecting the path W:\myFiles will result 
in an installation folder of W:\myFiles\ODOT_Training. 

 
 Select the Install Training Files button to begin the installation process. 

 
If a previous installation of the training files exists on the computer, you will be prompted to 
remove the old files. 

 
In addition to copying the necessary training files for the selected class from the CADD Standards to the 
selected folder, the program will create a shortcut that must be used to launch MicroStation with the 
proper workspace configuration for the training material. 
 
If the training files are installed to the default location, C:\ODOT_Training, the shortcut shown below is 
located in the following folder:  C:\ODOT_Training\OpenRoadsDesign 

 
 
Important! 
This shortcut should be used for training only. When working on ODOT projects, be sure to open 
MicroStation from the Windows Start Menu to access the normal ODOT working environment. 
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Double-click the training shortcut to launch MicroStation for the training environment. The File Open 

dialog is opened as shown below.

 

User Configuration 
The User option is used to select the MicroStation user configuration file (.ucf).  When MicroStation is 
opened using the training shortcut, the User option will default to ODOTcadd as shown above.  
 
Project Configuration 
The training data for this class uses MicroStation project configuration files (.pcf) to open the dataset for 
various exercises. These PCF files are located in the following folder for the training class: 
 

C:\ODOT_Training\OpenRoadsDesign\ProjectPCF 
 
The PCF files define project specific MicroStation configuration variables. The dataset for the training 
has several PCF files that are selected from the File Open dialog before accessing the project data, as 
shown on the following page. 
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When a Project is selected from the list, the File Open dialog will automatically change to the parent 
folder for the selected project. 
 
Take the following steps to open the dataset for our sample project: 
 

 Select the Project configuration file 12345-HORIZ_GEOMETRY as shown above. The File Open 
dialog will automatically change to the Design folder for the project. 
 

 Open the following design file: 
 

\Survey\Basemaps\12345_BE001.dgn 
 
When a file is opened, the interface should appear similar to the example shown on the following page. 
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The Task Navigation, Project Explorer, and Element Information dialogs are docked and “unpinned” at 
the left of the screen. Floating the cursor over each of these tabs will expand the dialogs for use. The 
dialogs can be “pinned” in place using the push-pin icon at the upper right corner of each dialog. In the 
example below, the Task Navigation menu is pinned in place. 
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2.6 Task Navigation 
By default, the Task Navigation menu is docked to the left of the screen as shown in the example on the 
previous page. This menu is used to select OpenRoads by selecting Civil Tools from the Tasks menu. 

 
 If the Task Navigation menu is not shown, it can be configured by selecting Workspace > 

Preferences to access the Preferences dialog shown below. Set the Task Navigation > 
Presentation option to Dialog. 

 
 The Task Navigation menu can be opened by selecting  Tools > Tasks. 

 
 
 
 
 
 
 
 
 
 



March 30, 2017 GEOPAK OpenRoads Technology for Civil Design  

 

Page 18 Chapter 2 – OpenRoads Overview 

 

2.7 Project Explorer 
The Project Explorer dialog is used extensively with OpenRoads. By default this dialog is docked on the 
left side of the screen as shown previously. 
 

 If the Project Explorer dialog is not shown, the dialog can be opened by selecting File > 
Project Explorer from the MicroStation pull-down menu. 

 
The Project Explorer dialog contains several tabs which can be toggled on or off in the project explorer 
settings. To review the settings, select Settings > Project Explorer from the MicroStation pull-down 
menu to open the Project Explorer Settings dialog shown below to the right. 
 
Recommended settings: 
 

Browsers 
Set all of the available options to True. 
 
Dialog Properties 
Set the Browse Layout option to Group Panel . 

 
 
 
 
 
 
 
 
 
 
 
Once configured, the Project Explorer dialog should 
contain all the the Group Panels shown in the example 
shown at right. 
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2.8 MicroStation Design File Settings 
The design file itself also has several settings used by the OpenRoads software. To access these settings 
select Settings > Design File and then click the Civil Formatting item from the list on the left of the 
dialog. 

 
These settings are initially defined in the ODOT Seed files and have been configured appropriately for 

ODOT projects. However, you may wish to change the following settings on a file-by-file basis. 

Coordinate Settings 
 The Format can be set to X, Y or N, E as desired. 

 
 The Precision setting is used to control the display and precision of coordinates within 

the various civil and survey dialogs. 
 
Station Settings 
Controls the format, delimiter and precision of the station values to be used and displayed in the 
various civil dialogs. In addition, there are two options to control how equations are represented 
within the station values. 
 

 By Name - This is the standard InRoads presentation (A100+00, B105+00, etc.) 
 

 By Index - This is the standard GEOPAK presentation (100+00 R 1, 105+00 R 2, etc.) 
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2.9 MicroStation User Preferences 
The MicroStation User Preferences includes several options for OpenRoads. These parameters are 
accessed by selecting the View Options – Civil item on the Preferences dialog as shown below. 

 
Most of these settings are related to OpenRoads Survey and are not documented here. 
 
The Toggle Commands group is used to set the default on/off settings for the OpenRoads Feature 
Definition Toggle Bar. 
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2.10 Project Explorer > Civil Standards 
The OpenRoads technology uses MicroStation DGN Libraries extensively to define various standards 
used by both OpenRoads Civil and Survey tools. These DGN libraries are defined by the ODOT 
workspace. 
 
When a new MicroStation design file is created, these standards are referenced by the configuration 
and can be reviewed from the Civil Standards tab of the Project Explorer dialog. 

 
The Civil Standards tree contains two main branches; one for the active design file, and one for 
Libraries, as shown above. 
 
When a new file is created, the standards are initially defined only in the Libraries branch. These are the 
default standards that are defined for ODOT projects. 
 
As a particular standard is accessed, the standard is copied to the active file where they can be reviewed 
and modified if necessary. This is done so that the design file can be easily shared with other users 
independent of the configuration. 
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Civil Standards > Feature Definitions 

Feature definitions are used to control symbology, annotation, and various other properties that are 
applied to geometric elements and terrain models. 
 
The feature definitions are used by the software for the following: 
 

 Define what the geometric information actually represents such as curb, centerline, edge of 
pavement, a mailbox, etc. 
 

 Control symbology in various views, including capability to define differing symbology in plan, 
profile, and 3D spaces. 
 

 Define terrain modeling attributes (spot, break line, void, etc.) for each surveyed point or linear 
feature. 
 

 Define the display characteristics of terrain models. 
 
Feature definitions are defined in MicroStation DGN Libraries (.dgnlib). Several DGN libraries are 
configured according to ODOT CADD Standards for use with Bentley’s OpenRoads Technology as shown 
in the Project Explorer dialog below. 

 
The Feature Definitions branch of the Civil Standards tab lists the feature libraries that have been 
configured for the ODOT workspace. Three types of features can be defined: 
 

 Linear 
 Point 
 Surface 
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Linear and Point feature definitions are used to define a wide variety of parameters for each specific 
feature. A specific feature can be configured to read settings from a GEOPAK DDB file, a GEOPAK SMD 
file, or a MicroStation Element template. In each case, the following settings are defined for each 
feature: 
 

 Symbology settings for various contexts (plan, profile, cross section, 3D)  

 Whether a specific feature is defined for Survey use 

 Whether a specific feature is configured to automatically process a 3D model 
 
Surface features are used to define terrain model display parameters for the terrain model itself as well 
as any profiles that are extracted from the terrain model. 
 
The use of features will be discussed in greater detail throughout this training guide. 
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3 Using OpenRoads Survey Data 

3.1 OpenRoads Survey Data format 
Survey mapping processed with the OpenRoads Survey tools are written to a MicroStation design file 
similar to data that has been processed using the legacy GEOPAK Survey tools. However, there are 
several key differences: 
 

 Survey data is  processed in MicroStation using a Survey “Field Book” design file 
o The field book design file is contained in the project’s \Design\Survey\RawData folder 
o This file is named with a “FB” file type code; example: 12345_FB001.dgn 
o The field book design file is normally accessed by only the surveyors 
o When the survey processing is complete, the data is exported to a Survey basemap in 

the project’s \Design\Survey\Basemaps folder. This file is named with the “BE” two 
character file type code. The BE file is normally used by design personnel 

o Survey processing “rules” are stripped from the survey basemap BE design file when the 
data is exported to the BE file. The BE file contains simple MicroStation graphics and the 
terrain model 

o If additional survey information is needed, the new information will be processed in the 
field book FB design file. A new survey basemap BE file will be generated for the survey 
mapping and terrain. Previous edits to the survey basemap BE design file will be lost 

 
 Survey Data is typically mapped to a 3D Model 

o Designers will typically work in 2D models 
o MicroStation allows 3D models to be referenced to 2D models, and vice-versa 

 
 The Survey points and linear features are stored directly in the Survey field book design file 

o Survey information is not written to a separate GEOPAK COGO Database (.gpk file) 
o Selected data can be exported to a GPK if needed 

 
 The Terrain Model is contained in the DGN file 

o Survey points and linear features in the FB design file are dynamically linked to the 
terrain model. Changes to the survey points and linear features are immediately 
reflected in the terrain model 

o The terrain model is included in the survey basemap BE design file when the survey data 
is exported from the field book design file 

o The terrain model contained in the basemap BE file is not dynamically linked to the 
survey points and linear features 

o The terrain model can also be exported to a GEOPAK TIN file if needed 
o Terrain display is handled using OpenRoads Feature Definitions and MicroStation 

Element Templates 
 

 A MicroStation Geographic Coordinate System (GCS) may be applied to the data if desired. 
o The GCS is used to identify the location of the data on the Earth’s surface 
o The use of GCS is optional at this time 
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3.2 Data Integrity 
Protecting the integrity of the survey information has always been a concern for ODOT’s Survey 
personnel. The accuracy of the Survey information is the responsibility of the surveyor and therefore the 
original survey information should not be edited by design personnel. Under no circumstances should 
design personnel edit the survey data contained in the Survey field book FB design file. If changes need 
to be made to the survey files, these changes should be coordinated with the originator of the survey 
data. 
 

3.3 Survey Basemaps 
The Survey basemap is stored in the \Design\survey\basemaps folder within the project directory 
structure. The survey information for the training datasets is located in the following design file: 
 

.. \Design\survey\basemaps\12345_BE01.dgn 

 
To gain access to the survey mapping and the terrain model, designers should use MicroStation 
References to attach the survey basemap. No graphics are to be drawn in the survey basemap by design 
personnel. 

Point Features 

When survey data is processed, each field shot is stored as a Point Feature in a Field Book within the 
survey field book FB design file. For example, the field code “PP” is used to designate a power pole. 
When the survey data is processed, the power pole code is plotted in MicroStation using an ODOT 
standard cell element as shown below: 

 
Notice that text elements for the point name (SV1051), elevation (1004.6770), and field code name (PP) 

are plotted along with the power pole symbol. Each of these text elements are placed on their own level 

and can be toggled on/off as desired. 

Each survey point must have a unique point name. Point names are assigned in the field by the surveyor 
as the data is collected. 
 
Floating your cursor over the point symbol or the text associated with a point in the Field Book design 
file will open a pop-up menu with information about the point as shown in the example above. 
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When the survey information is exported to the survey basemap BE design file, all of the survey 
processing rules are removed from the survey points and linear features. Floating the cursor over a 
survey point will display only the information for a simple MicroStation graphic as shown in the example 
below. 

 
The point name is included in the design file export, as shown above, however the survey points are not 
included in a GEOPAK GPK file. 
 

Linear Features 

A series of points representing curvilinear features can be connected together as a Linear Feature as 
shown in the example below. 

 
Floating your cursor over the linear feature in the field book FB design file will open a pop-up menu with 
information about the feature line as shown in the example above. 
 
Similar to point features, the survey attributes for linear features are removed from the design file when 
the survey data is exported from the survey field book FB design file to the survey basemap BE design 
file. 
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Field Attributes 

Many of the ODOT field codes allow for the use of attributes to store additional information with a 
specific survey shot. For example, the feature code “PP”, used to specify a Power Pole, has the following 
attributes: 
 

Material 
Owner 
Pole# 

 
The attributes are plotted in the file similar to the example shown below. 

 
See the ODOT Code list for a summary of feature codes and the associated attributes. 
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3.4 MicroStation Levels for Survey Data 
ODOT’s CADD Standards include several levels specific to survey information. These levels are grouped 
in the level library using the prefix “SV”. 
 
The levels can be turned on/off using the MicroStation Level Display dialog. The Level Display dialog can 
be opened by selecting Settings > Levels > Display from the MicroStation pull-down menu, or from the 
Level Display icon in the Primary Tools. 
 
The Level Display dialog includes the ability to filter the dialog to only show specific levels. By selecting 
the Survey filter, the dialog will show only the survey levels. 

 
The survey levels include several levels specific to survey data that has been mapped using OpenRoads 
Survey. Each survey point displays text on the following levels: 
 

 SV_X_Text_Comment 
 SV_X_Text_Description 
 SV_X_Text_Elevation 
 SV_X_Text_Name 

 
These levels can be toggled on or off as desired using the Level Display dialog. 
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If the survey information was generated using raw observation data, the software also draws 
Observation Lines and Setup Lines. An example of the observation lines is shown below. 

 
 

 Observation Lines are drawn on the level SV_Observation 
 

 Setup Lines are drawn on the level SV_Setup 
 
These lines can be turned on/off using the MicroStation Level Display dialog. Depending on how the 
data was processed or exported from the field book FB design file to the survey basemap BE design file, 
these lines may not be present in the survey basemap BE design file. 
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3.5 Geographic Coordinate Systems 
A MicroStation Geographic Coordinate System (GCS) is used to define the position of the survey and 
design information on the Earth’s surface. Once that position is established, the design can be easily 
coordinated with other data for which the geographic location is known such as Google Earth, Bing 
Maps, Geo-Referenced Imagery, or GIS systems. 
 
Whether the survey data originates from ground survey or aerial mapping, the data is typically mapped 
on the appropriate State Plane Zone in the design file.  
 
A library of predefined GCS is available in MicroStation. Optionally, a custom GCS can be defined to 
reposition the data using ground coordinates, if required. 
 
The process to create a custom GCS for Grid-to-Ground conversions is the responsibility of ODOT’s 
Survey personnel and is not covered in this manual. This manual will cover the basics to review the GCS 
and create new design files using the same GCS that has been defied by the Survey personnel. 
 

ODOT Seed Files and Geographic Coordinate Systems 

A seed file is an empty MicroStation design file that has been configured specifically to meet a particular 
need. When new design files are created, the seed file specified by the user is copied and renamed to 
create the new file. ODOT provides several seed files for use with OpenRoads. The seed files are located 
in the following folder: 

I:\ODOTcadd\Standards\seed\ 
 
Seed files are provided without a GCS definition as well as seed files with the Ohio North and South Zone 
coordinate systems defined, as shown below. 
 

 
 
 
When a new project is created using the ODOT_CreateNewProject.exe application, 2D and 3D seed files 
are copied from the I:\ODOTcadd\Standards\Seed folder to the project’s \Design\standards\seed 
folder for the project. The seed files copied into the project folder can then be modified by the Survey 
Personnel to define a custom GCS definition that is used to facilitate Grid-to-Ground projection. 
 
The GCS tools available in Bentley Map allow ODOT’s Survey personnel to define a custom GCS 
definition that can be used to facilitate Grid-to-Ground conversion of the project data. This allows users 
to work in ground coordinates and distances while maintaining the ability to seamlessly integrate the 
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project data with other Geo-referenced systems such as Google Earth, Bing Maps, Aerial mapping and 
imagery, and GIS systems. 
 

Project Specific Seed Files 

When the survey data for the project is initially processed, it is the responsibility of the Surveyor to 
define the appropriate GCS for the project data. As the designer for the project, it is your responsibility 
to ensure that all new design files created for the project use the same GCS as defined by the Surveyor. 
 
ODOT’s Surveyors have been asked to define the GCS in project specific seed files. When creating new 
design files for a project, the designer should always use the seed files that are contained in the projects 
\Design\standards\seed folder. 
 
If the project mapping comes from Aerial mapping, the designer must review the Aerial Mapping design 
file’s GCS to ensure that new files are created using the appropriate GCS. 
 

Reviewing/Selecting the GCS Definition 

The GCS can be reviewed or selected by choosing Tools > Geographic > Select Geographic Coordinate 
System from the MicroStation pull-down menu. The Geographic Coordinate System dialog shown below 
is opened. 

 
To choose a GCS from the library, select the second icon, From Library. The Select Geographic 
Coordinate System dialog shown below is opened. 
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The ODOT workspace defines the State Plane coordinate systems typically used on ODOT projects in the 
ODOT folder as shown above. Choose the appropriate GCS from the list. A different GCS can be selected 
by browsing the Library folder. The GCS definitions for Ohio shown below are available by selecting 
Library > Projected (northing, easting) > North America > United States of America > Ohio. 

 
 
When a GCS is initially selected, you are simply telling MicroStation where the data resides. It is 
important to note that choosing a GCS when one has not been previously defined does not re-project 
existing data in the design file to the selected GCS. The data is only re-projected when changing from 
one GCS to another. 
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Longitude and Latitude Coordinates 

When a geographic coordinate system is assigned to a model, it appears in the Auxiliary Coordinates 
dialog (Tools > Coordinate Systems > ACS > Auxiliary Coordinates). When it is made the active auxiliary 
coordinate system, data can be entered in longitude, latitude format, and coordinate readout can be set 
to show longitude and latitude. 
 

 Select Tools > Coordinate Systems > ACS > Auxiliary Coordinates to open the Auxiliary 
Coordinates dialog shown below. 

 
 Right-click on the coordinate system in the list and choose either the Set Active View or Set all 

Views option. 
 

 To get a longitude, latitude coordinate readout, turn on Running Coordinates by right-clicking 
the status bar (located to the lower left of the MicroStation window as shown below). 
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 Next, click on the coordinates (located at the bottom of the MicroStation window, towards the 
right side) and select ACS Position. 

 
As the cursor is moved in the MicroStation window, the running coordinates will display in longitude and 
latitude format as shown in the example below: 

 
The mode, precision, and format of the longitude and latitude values are controlled in the Design File 
Setting dialog under Angle Readout and Working Units. 
 
Click on the coordinates display and select Position to change the readout back to X, Y, Z coordinates. 
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3.6 Referencing Design Files with a GCS Defined 
When attaching the survey design file, if the active model and the reference model have the same GCS 
defined, choose the Coincident - World option to align the referenced the active model as shown below.

 
If the referenced model has a different coordinate system than the active model, choose the Geographic 
– Reprojected option to reproject the referenced model to the coordinate system that is defined in the 
active model. 
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3.7 Working with OpenRoads Terrain Models 
Terrain models generated by OpenRoads Survey are stored in the same MicroStation design file that 
contains the survey data as a Terrain Model element type. 
 
The terrain model can be accessed by design personnel by attaching the survey basemap BE design file 
as a reference to the active model. 
 
In the example below, the active file is 12345_KD001.dgn. The terrain model is contained in the file 
12345_BE001.dgn which has been attached as a reference file. 
 
The terrain model is part of the Civil Model and can be reviewed from the Project Explorer dialog under 
the Civil Model tab by expanding the Terrain Model item as shown below. 

 
Right-clicking on the name of the terrain model will reveal the menu of commands shown above. The 
most commonly used commands are available by selecting the terrain model boundary as shown on the 
following page. 
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Properties 
When the Properties icon is selected, the menu shown below is opened. 
 

 
Since the design file containing the terrain 
model has been attached as a reference, the 
following parameters cannot be changed: 
 

Edge Method 
Length 
Feature Name 
Feature Definition 

 
Changing the Override Symbology value to 
Yes will to allow changing the on/off display 
status for the remaining parameters. 
 
 

 
Typically, it is a better option to use the MicroStation Level Display dialog to turn on/off terrain 
features rather than using the Override Symbology option shown above. 
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Set as Active Terrain Model 
Choose the Set As Active Terrain Model icon to set the terrain model as the active terrain 
model. When profiles are extracted for an OpenRoads alignment, the active terrain model is 
used to extract the existing ground profile. The active terrain model is also used to define the 
existing ground in corridor modeling. 

 
 

Export 
Terrain models can be exported to the following formats: 
 

MX 
InRoads DTM 
GEOPAK TIN 
Land XML 
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Terrain Model Feature Definitions 

Terrain model display is controlled by the use of a Feature Definition. The feature definition can be 
selected by choosing the terrain model and opening the Properties dialog as shown below. 

 
Note: The feature is assigned to the terrain model in the basemap survey BE design file and cannot be 
changed when the terrain model is attached as a reference. To change the terrain model Feature 
Definition, first open the survey basemap BE design file. 
 
A library of feature definitions are available in the ODOTcadd Standards. The features for Terrain Model 
display are contained in the following MicroStation DGN library: 
 

\ODOTcadd\Standards\dgnlib\ODOT_Features_Design.dgnlib 
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The available terrain features can be reviewed in the MicroStation Project Explorer dialog by selecting 
the Civil Standards tab and expanding the Libraries item as shown below. 

 
Expanding the Terrain Models category will reveal several surface features that have been configured 
for your use as shown on the following page. 
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Feature definitions are available for both existing and proposed terrain models. Each feature definition 
uses a MicroStation Element Template to define the display parameters for the terrain model. 
 
The terrain model feature definition also controls how existing ground profiles and cross sections are 
displayed, again, by the use of MicroStation Element Templates. 
 
Right-click on a terrain feature definition and select Properties to review information about the selected 
feature definition. The properties for the X_Contours 02’ Major feature definition is shown on the 
following page. 
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The Name Prefix is used as the 
prefix for the name of exported 
terrain models. 
 
The Surface Defaults option 
defines how the terrain model is 
included in earthworks quantity 
computations. 
 
The Profile option is used to 
define how profiles extracted 
from the terrain model are 
displayed. This can be defined by 
a Native Style, which refers to a 
GEOPAK Design and 
Computation Manager item, or 
by an Element Template. 
 
 

The 3D item defines the element template that is used for the terrain model display (triangles, contours, 
spots, break lines, void areas, etc) as well as the symbology for existing ground cross sections extracted 
from the terrain model. 
 
Note: The boundary of the terrain model is displayed using the same setting that is used to display cross 
sections extracted from the terrain model. This is normal. 
 

Terrain Model Features and Contour Display 

Several features definitions in the ODOTcadd Standards have been configured to display major and 
minor contour lines at various intervals. The Feature Definition can be changed in the survey basemap 
BE design file. 
 
Elevation labels that are displayed using an OpenRoads feature definition are dynamically displayed 
based on the active model’s Annotation scale setting and the zoom extents. Therefore, the location of 
the elevation labels will shift when the MicroStation Zoom controls are used to adjust the view display. 
This will yield unpredictable results on printed plan sheets with the contours displayed. 
 
For plan drawings where contours are displayed, it may be better to export the OpenRoads Terrain 
Model to a GEOPAK TIN file, and then use the TIN file to display static graphics using the legacy GEOPAK 
DTM Tools to load the contours. 
 
To export a GEOPAK TIN from the OpenRoads Terrain Model: 
 

 Select the Terrain Model boundary and choose the Export GEOPAK TIN option from the pop-up 
menu as shown below.  
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 Save the GEOPAK TIN file in the \Design\Geopak\ folder. Be sure to name the TIN file 

appropriately according to the ODOT CADD Standards. 
 
Note: The exported TIN file is not associated with the OpenRoads terrain model contained in the 
MicroStation design file. A new GEOPAK TIN model must be exported if changes are made to the 
OpenRoads terrain model. 
 

 Select Applications > GEOPAK > Road > DTM Tools to access the tool palette shown below. 

 
 Choose the Load DTM Features icon as shown above. The Load DTM Features dialog is opened 

as shown below. 
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 The Load DTM Features dialog is used to load various digital terrain model features, such as the 
triangles, boundary (TIN Hull), contour lines, etc… Preference Files are used to set the 
symbology for these features. To choose a preference file, select File > Open from the Load DTM 
Features dialog. Several preference files have been configured for your use in the ODOT CADD 
Standards as shown below. Choose the appropriate preference file, existing or proposed, for the 
intended plotting scale. Note: The text placed for the contour line labels using the Load DTM 
Features dialog is a static text size and does not respond to Annotation Scale changes. 

 
 Turn on the contour feature by double-clicking the word Contours. The dialog should appear 

similar to the example shown below.  
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There are several parameters in the Load DTM Features dialog. See the GEOPAK online help for 
complete details. 
 
Choose the Load Extent option to load contours for the entire DTM file. 
 
When the Display Only option is toggled on, the contours are displayed on-screen but are not 
written to the file. Toggle this option off to write the contours to the file. 
 
Toggle on the Graphic Group option to place the contour lines and labels in a MicroStation 
graphic group. 
 
The Minor and Major Intervals are used to set the increment values for the contour lines. Major 
and Minor contours have different symbology settings as defined by the preference file. 
 
Contours can be placed for a Range of elevations, defined by the Minimum Z and Maximum Z 
parameters. Choose the Read option to set the minimum and maximum values by reading the 
vertical extents of the TIN file. 
 
The symbology for the Major Lines, Major Label, Minor Lines, and Minor Label can be set by 
clicking on each item. These values have been set according to ODOT standards when choosing 
one of the ODOT preference files as detailed in the preceding page. 
 
Choose the Load option to write the contours to the active model. 
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3.8 Importing GEOPAK TIN files for OpenRoads Use 
The data for projects that have been mapped using the legacy GEOPAK Survey tools will normally 
include a GEOPAK Triangle Model in the GEOPAK TIN format. This file can be imported as an OpenRoads 
Terrain Model for use with the OpenRoads technology. 
 
We do not recommend importing legacy GEOPAK TIN models into the Survey Basemap. TIN files should 
be imported into the Digital Terrain Model Features basemap type. This file has a “KD” two character file 
type code and can be created using the ODOT_Files.mvba application as shown below. 
 
The ODOT_Files.mvba application is used to create new design files. The program, shown below, is 
accessed by selecting ODOT > File Management > Create Design Files from the MicroStation pull-down 
menu. 
 
Note: Be sure to use the 3D Seed file when creating the KD file. 

 
To import the TIN file, from the Task list choose Civil Tools > Terrain Model > Create From File. 

 
Change the Files of Type option to GEOAPK TIN 
(*.tin). Browse for the TIN file that you wish to 
import. The Import Terrain Models(s) dialog is 
opened. 
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Review the available parameters using the OpenRoads Help. Choose Import to initiate the process. 
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4 Working with 3D Files 

In addition to using a 3D MicroStation model for the Survey information, OpenRoads also uses 3D 
models for the 3D Corridor Model that is generated for your design. Many ODOT CADD users have never 
worked in 3D before. This intent of this chapter is to cover some introductory basics of working with 3D 
files and not to provide a comprehensive guide. Further information can be found in the MicroStation 
online help documentation. Additionally, ODOT employees have access to the Bentley Learn server and 
can sign up for online MicroStation 3D training. See your CADD Manager for more information about 
Bentley Learn. 
 

4.1 The Design Cube 
3D DGN files consist of a design cube in which you work. The design 
cube represents a 3D DGN file's total volume, in which points are 
defined with x-, y-, and z-values, or coordinates. Points can be 
placed anywhere within the design cube, and are not restricted to a 
single plane as is the case when you work in a 2D DGN file. 
 
Design cube coordinates are expressed in the form (x, y, z). The 

global origin in the 3D seed files provided with MicroStation is 

located at the exact center of the design cube and assigned the 

coordinates (0, 0, 0). Any point above the global origin has a 

positive z-value and any point below it has a negative z-value. 

 
 
The view volume (sometimes called the display volume) is the volume of the design cube that is 
displayed in a 3D view. In most cases, only a part of the design cube is displayed in a view. 
 

 
 

 “A” denotes the window area (hatched). 
“D” denotes the Display Depth, bounded by the front “F” and back “B” clipping planes. 

The large cube shows the design cube, part of which is displayed in each view. 
 
Any elements or parts of elements, not contained in the view volume are not displayed in the view. 
Unless a clip volume has been applied to a view, the view volume is bounded by the window area, and 
its display depth. 
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4.2 Active Depth 
The Active Depth in a view defines the position of a plane, parallel to the screen, on which data points 
are placed. 

 
 

 
The active depth is denoted by “AZ.” 

“x,” “y,” and “z” denote the View axes. 
“F” and “B” denote the front and back clipping planes, respectively. 

 
 
 
 
 

 
You set the active depth graphically with the Set Active Depth view control. 

 
1. Select the Set Active Depth view control. 
2. Select the view in which you want to set the active depth. 
3. Enter a data point at the desired location. 

 
You can also set the active depth for a specific view window using a key-in command. 
 

1. Key in ACTIVE ZDEPTH ABSOLUTE <depth>. 
or Key in AZ= <depth>. 

2. Select the view(s). 
 
You can also query a view window for the current active depth value with the Show Active Depth 
command. 

 
1. Select the Show Active Depth view control. 
2. Select the view. The view's active depth setting is shown in the status bar. 
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4.3 Viewing a 3D Model 
A 3D view can display part of the design cube from any point, looking in any direction. 
 

 As in 2D, elements to the left, right, above, or below, can be excluded from a view by zooming in 
or windowing so that the elements are outside the view's area. 

 
 3D views also have depth. You can exclude the display of elements located in front of, or behind, 

a required object by changing the view's display depth, or by applying a clip volume.  See the 
MicroStation online help for information on changing the display depth or applying a clip 
volume. 
 
Note: In the ODOT seed files for OpenRoads, the view attribute for the Clip Volume has been 
turned off for all views. 

 

Display Styles 

The Display Styles dialog is used to select from a list of predefined render overrides that can be assigned 
to a view. 
 
In the view control bar, select the Choose View Display Style icon. A list of available styles is presented 
as well as the option to Open Display Style Dialog. 

 
By default, the display style is set to Wireframe when using the ODOT seed files.  
 
Select the Open Display Style Dialog option to access the Display Styles dialog shown on the following 
page. 
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The predefined list of display styles can be selected and edited using this dialog. When a style is selected 
the preview pane, located at the bottom right of the dialog, shows an example of how the display will 
appear using the selected style. In the example above, the Illustration style is selected. 
 
See the MicroStation online help for more information about editing and defining display styles. 
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Rotating Views in 3D 

The Rotate View control is used in 3D files to rotate a view to a custom orientation or one of the 
standard views (Top, Front, Right, etc.) as shown below. 

 
When rotating views in 3D, an important point to consider is the axis about which you want the view to 
rotate. By default, the pivot point is the center of the view, at the active depth. If the active depth is far 
behind the elements in the view, then you can quickly rotate the geometry out of sight. You can, 
however, move the pivot point to another location prior to rotating the view as follows:  
 

1. Select the Rotate View view control. 
2. Set Method to Dynamic. A plus sign (+) appears at the center of the view. 
3. Click on the plus sign at the center of the view. 
4. Enter a data point to reposition the pivot point. 

 
 

Clip Volumes 

Clip Volumes can be used to limit the display of the survey data to a specific portion of the model 
without being hindered by elements outside the area of interest. When a clip volume is applied to a 
view, only elements located within the clip volume are displayed, or can be snapped to, in that view. 
Each view may have a different clip volume displayed. 
 
Once a clip volume has been defined, operations such as view rotation, fence processing, and rendering 
honor the clip volumes. Elements that are not displayed within the defined volume are ignored. 
 
The Clip Volume tools can be accessed from the View window as shown on the following page. 
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See the Bentley Online Help for complete documentation of these commands. An example using the 
Apply Clip Volume by Two Points command is documented below. 
 
In the example below, the Apply or Modify Clip Volume command has been selected. The Clip By 2 
Points command is used to define a rectangular region in the top view to be used to define the clip 
volume. 
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Once the rectangular region has been defined, the display of the graphics is clipped as shown below. 

 
 
If desired, the clipped area can be rotated and rendered as shown below. 
 

 
The display of the rectangle representing the clipping limits can be toggled on or off using the Show or 
Hide Active Clip Volume command. 
 
The Clear Active Clip Volume command is used to remove the clipping mask from the selected view. 
 
Clipping elements can be manipulated/modified with the standard MicroStation tools. 
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5 Horizontal Geometry 

5.1 Basemap Design File Requirements 
ODOT’s CADD Standards detail the use of basemap design files to draw plan, profile, and cross section 
information for your project in real world dimensions. These drawings are then referenced into sheet 
design files to produce the plan sheets for the project. 
 
Several basemap files may be used depending on the project complexity. The ODOT CADD Standards 
allow for multiple basemap design files for each unique discipline (drainage, lighting, mot, roadway, 
signals, etc…). For smaller projects, it is permissible to combine the design information into fewer 
basemap files; however it is not desirable to place all the information in one design file. As a minimum, 
the following basemap design files are required: 
 

 Existing Ground Survey 
 Geometry 
 Proposed Design 
 Right-of-Way 
 3D Modeling 

 
The use of additional discipline specific basemaps for larger projects is optional. See the ODOT CADD 
Engineering Standards Manual (ODOTcadd), Section 300 File Management for more details. 
 

The Geometry Basemap 

OpenRoads Horizontal alignments are stored directly in a MicroStation design file. A GEOPAK GPK file is 
not required when using the OpenRoads geometry tools; however, the GPK file is still required for many 
of the legacy GEOPAK functions that are used for plan production. 
 
ODOT’s CADD Standards designate a specific basemap design file for storing OpenRoads geometry. It is 
not permissible to store the OpenRoads geometry information in the same design file as the plan view 
graphics or the survey basemap. Geometry basemaps are located in the \Design\Geopak\Basemaps 
folder for the project. 
 
The file is named as follows: 
 

nnnnnn_BK###.dgn 
 
where: 

 nnnnnn = the 5 or 6 digit PID number for the project 
### = a three digit number for the file (001. 002, 003, etc…) 

Example: 
 12345_BK001.dgn 
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Using Multiple “Federated” Basemaps 

Multiple horizontal alignments may be stored in one geometry basemap design file, however on 
projects with more than one alignment it is recommended to store each alignment in a separate design 
file. This “federated” approach will allow multiple designers to work on different alignments 
simultaneously. 
 
It is up to the individual designer/design team to make a decision on whether to use one or more 
geometry basemaps depending on the magnitude of the individual project. 
 
If multiple geometry basemaps are used, the “000” geometry basemap file, nnnnnn_BK00.dgn, is used 
as the federated basemap “collector” design file. This file is an empty design file with a reference 
attachment for each geometry basemap. This allows users of the project to easily access all of the 
geometry for the project by attaching the 000 file as a reference with a nest depth value of 1. 
 
The October, 2016 update to the ODOTcadd Standards included a change to the ODOT_Files.mvba 
application to facilitate creating the “000” files when new design files are created. A Federate Basemaps 
option has been added as shown below: 

 
When the Federated Basemap option is used, the ODOT_Files.mvba application will create the “000” 
file for a given file type, if it does not already exist. As each new design file is created, the file is 
automatically add a reference attachment to the “000” file for that file type. 
 
As graphic elements are drawn in each basemap design file, these graphics are displayed in the “000” 
file, or any other file that references the basemap, according to the setting of the configuration variable 
MS_REF_NEWLEVELDISPLAY. This variable is defined as follows in ODOT_Site.cfg: 
 

MS_REF_NEWLEVELDISPLAY = 0 
 

As new elements are drawn in the various federated basemaps, the graphics are not dynamically 
displayed in the “000” file (or in any other file that may reference these graphics) with the variable 
defined as shown above. Users must open the MiroStation Level Display dialog to turn on/off levels for 
each reference attachment, as desired. 
 
In some cases, this behavior is desirable as it prevents new and potentially unwanted information from 
being automatically displayed on any plan sheets that reference one or more of the federated 
basemaps. Other users may find this behavior frustrating as new graphics must be manually turned on 
for each reference attachment. 
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The default variable definition can be overwritten when a reference file is attached by setting the New 
Level Display parameter to a value of Always. When files are created using the ODOT_Files.mvba 
application, the references are attached to the “000” collector file with the New Level Display option set 
to Always as shown below. 

 
Some users may prefer a dynamic display of the graphics for all reference attachments in all design files 
as the project is developed. The configuration variable can be defined on a per-project basis in the 
project’s PCF file. Set the variable as follows in the PCF File for the project: 
 

MS_REF_NEWLEVELDISPLAY = 1 
 
The variable could also be redefined in ODOT_Site.cfg, keeping in mind that it will default back to the 
value defined by ODOT if an update to the site configuration file is issued with the ODOTcadd Standards 
quarterly update. 
 
When a federated workflow is used with multiple geometry basemaps, the MicroStation Comments 
property can be used to identify the name of the alignment contained within the geometry basemap 
file. The Title and Comments properties can be displayed in Windows Explorer, as well as the 
MicroStation File Open dialog as shown in the example below. 
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See the Project Management with the ODOTcadd Standards guide for more information on the use of 
the Title and Comments properties. 
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Exercise 5A – Geometry Basemaps 
In this exercise we will create multiple design files to house our geometry for the project. 
 

 To get started, open MicroStation using the shortcut that has been specifically configured for 
the training course located in the following folder: 

C:\ODOT_Training\OpenRoadsDesign\ 
 

The MicroStation File Open dialog is displayed. 

 
 The User should default to ODOTcadd as shown above 

 
 Select the 12345_HORIZ_GEOMETRY project. 

 
The sample project already includes a geometry basemap, 12345_BK001.dgn, containing the 
existing centerline information. 
 

 Open the following design file from the project’s folder: 
..\Design\Geopak\Basemaps\12345_BK001.dgn 

 
Depending on the project and the District office, you may or may not receive a basemap with 
the existing centerline information. For this example, all of the existing alignments are stored in 
this file. 
 
The existing alignments have been visualized with an OpenRoads Feature Definition for an 
existing centerline and are not considered plan production graphics. 
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The ODOT_Files.mvba application is used to create new design files for the project. Take the following 
steps to create three new geometry basemaps for the project: 
 

 From the MicroStation pull-down menu, select ODOT > File Management > Create Design Files 
to open the ODOT_Files.mvba Visual Basic Application shown below. 

 
 Verify that the correct Seed File for the project is selected. 2D files are used for most 

OpenRoads design files 
 

 Toggle the Federate Basemaps option on. This will create a “000” file for each basemap type 
created. In the example above, the file 12345_BK000.dgn will be created. 
 

 Toggle on the Geometry basemap option to create the file 12345_BK002.dgn. This file will be 
used to store the proposed centerline of State Route 185. 
 

 Set the Comments for the first file as “S.R. 185”. 
 

 Set the Scale value to 20. This is used to set the Annotation Scale setting in the newly created 
design file 
 

 Choose the Create Files option. The first geometry basemap, named 12345_BK002.dgn is 
created in the \Design\geopak\basemaps folder. 
 

 Create two more geometry basemaps by assigning the Comments for each file as follows: 



 GEOPAK OpenRoads Technology for Civil Design March 30, 2017 

 

Chapter 5 – Civil Geometry Page 63 

 

 

File Name Comments 

12345_BK003.dgn Proposed St. Peter Road 

12345_BK004.dgn Proposed Jameson Road 

 
The Title and Comments fields can be displayed in the Windows Explorer and in the MicroStation File 
Open dialogs. Take the following steps to enable the display of these fields: 
 

 Exit MicroStation 
 

 Open Windows Explorer and set the View Option to Details as shown below. 

 
 Right-click on the Name column header and turn on the Title field 

 
 Choose the More… option and toggle on the Comments field 

 
 After toggling on the fields, you can arrange the fields in the order that you wish be dragging the 

column header to the desired location. Move the Title and Comments fields to the right of the 
Name field. The Windows Explorer dialog should appear similar to the example below. 
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 Next we’ll apply these changes to all folders on the computer. From the Windows Explorer 

dialog, select Organize > Folder and Search Options to open the Folder Options dialog shown 
below. 

 
 From the View tab, choose the Apply to Folders option. Confirm the change when prompted 

 
 Choose OK to close the dialog.  
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5.2 Civil Formatting 
Before getting started with the OpenRoads Geometry tools, it is a good idea to review the design file 
settings to ensure they are set correctly for ODOT projects. From the MicroStation pull-down menu, 
select Settings > Design File to access the Design File Settings dialog shown below. 

 
Choose the Civil Formatting option to review the current settings. Settings specific to ODOT are detailed 
below. These setting are set in the ODOT seed files. See the online help for additional information. 
 

Station Settings 
Make sure the Equation option is set to By Index for compatibility with the GEOPAK GPK file. 
 
 
Radius Settings 
The Radius Settings should be set as shown at right 
 
 
 
 
 
Profile Settings 
The Profile Settings should be set as shown at right 
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5.3 Design Standards 
A Design Standard can be assigned to a geometric alignment to preform alignment checks and set 
required degrees of curvature when laying out your geometric alignments. Design Standards work at 
two levels: 
 

 Provide values for the element creation tools (for example: radius values and transition lengths) 
 Check the design of complex elements (for example: check for kinks in an alignment) 

 
When a design standards is violated, feedback is provided in two ways: 
 

 An icon is displayed on the graphics of the element that has the problem 
 The Civil Message Center reports details on the error 

 
The use of design standards is optional. 
 
Design Standards are defined in a MicroStation DGN 
Library and can be reviewed by the Project Explorer 
dialog as shown at right. 
 
The Civil Standards group can be used to review the 
Design Standards that have been configured in the 
ODOTcadd workspace. The Horizontal group contains 
the design standards for various ODOT design 
standards as shown at right. 
 
The application of Design Standards is covered later in 
this chapter. 
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5.4 Civil Geometry Manipulation and Modification 
Civil Geometry elements drawn using the OpenRoads tools are “ruled” graphics that behave according 
to the geometric rules that define how the element was placed. 
 
For example, a simple line drawn using the Line Between Points command has two rules: Length and 
Direction. 

 
The rules can be reviewed in the Element Information dialog. An example for a line element is shown 
below. 
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MicroStation’s Manipulate commands (Copy, Move, Scale, Rotate, etc.) cannot be used on ruled 
geometry. The rule must be removed in order to use these commands. To remove a rule, select the line 
and choose the Rules menu as shown below. 

 
 
The following options are provided: 
 

Lock – Deactivate Rule 
Remove Rule 
Unlock – Activate Referencing Rues 
Lock – Deactivate Referencing Rues 
Remove Rule 
 

Element Manipulators 

OpenRoads Geometry elements have Manipulators that are displayed in MicroStation when an element 
is selected. These manipulators can be used to edit the selected element graphically or by entering a 
value. 
 
For example, a simple two-point line has several manipulators as shown below. 

 
Clicking on the direction or the length manipulator will open an editor to change the display as shown 
below. 
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Clicking on one of the keypoint manipulators will display direction arrows to edit the line, as shown on 
the example below. 

  
 
Tip: The size and color of the Manipulator Text can be adjusted in the User Preferences. From the 
MicroStation menu, select Workspace > Preferences and then choose the View-Options - Civil item on 
the left side of the dialog. The Manipulator Size or the Manipulator Font Scale parameters can be used 
to adjust the text size. 
 

Design Intent 

As geometric elements are drawn in MicroStation using the OpenRoads Horizontal Geometry tools, the 
software retains information about not only what element was drawn, but how it was drawn. This is 
referred to as the Design Intent. 
 
In the example below, the horizontal line was drawn first. The second line was drawn using the 
MicroStation Perpendicular snap to draw the line at a perpendicular form the horizontal line to a specific 
ending point. 
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If the horizontal line is modified by changing the direction of the line, the design intent for the 
perpendicular line is preserved. The Perpendicular rule, and the ending location are preserved. The 
result is shown below. 
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5.5 OpenRoads Geometry Commands 
OpenRoads Geometry commands are contained in two task lists as summarized below. 
 

General Geometry 

 
The General Geometry commands are accessed from 
the Task Navigation dialog by selecting Civil Tools > 
General Geometry. 
 
This toolset is split into four separate groups as 
summarized below. 
 
See the online help for more information. 
 
 
 
 
 
 

 
 

Geometry Toggles 

 
Design Standards Toolbar 
Opens the Design Standards Toolbar, shown below, which allows selecting the active 
design standard as well as setting the design standard for a specific element. 
  

 
 
 
 
 
 
Set Design Standard 
Used to assign a design standard to an element that previously had none. The 
active design standard is assigned to the selected element(s). 

 
Toggle Active Design Standard 
When toggled on and placing a “civil” element, that element is assigned with 
the active design standard when drawn to the model. When toggled on certain 
tool parameters will be set automatically to meet the active design standard. 
 

Set Design Standard 

Vertical Design Standard List 

Horizontal Design Standard List 
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This tool is also found in the Design Standards Toolbar, See description above. 
 
Features Definition Toggle Bar 
Opens the Features Definition Toggle Bar shown below. 

 
 Use Active Feature Definition 
Forces the active OpenRoads tool to use the feature definition defined here. 
 
Feature Definition List 
 Drop-down list to choose the active feature definition 
 
Match Feature Definition 
Will set the Feature Definition List to the feature definition that is assigned to 
the selected element. 
 
 Create 3D Automatically 
Click the Create 3D Automatically icon to generate 3D model elements for the 
created elements. The 3D element is computed by best fit of the default terrain 
model. But, if the element being created is adjacent to other geometry 
elements which have a defined design profile, then a quick profile transition is 
computed to define the 3D element. 
 
 Use Feature Definition Template 
Click the Use Feature Definition Template icon apply a roadway template to the 
created element automatically. The feature definition must have a template 
assigned in its properties. 
 
 Chain Commands 
If the tool chaining is toggled on, then many tools can automatically determine 
base elements to use during calculations. For example, Arc Between Elements 
will choose the two most recent elements and set them for base elements to 
construct its fillet. 
 
 Rule Deactivation 
If toggled on, then tools create elements with rules disabled. 
 

 
Set Feature Definition 
Used to assign a feature definition to a civil geometry element, or change the feature 
definition on an element. 
 
Match Feature Definition 
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This tool is also found in the Features Definition Toggle Bar, See description above. 
 
Civil Message Center 
Opens the Civil Message Center dialog which is used to review errors in the design 
standards that have been placed in the file. 
 
Set Element Information 
This command can be used to add a note to an element that is displayed in the Element 
Information dialog. 
 
 

Geometry Import/Export 

 
Import Geometry 
Import geometry elements that are stored in the COGO databases 
 
Export to Native 
Used to export selected civil geometry elements into one of the following COGO 
databases: MX FIL files, InRoads ALG files, or GEOPAK GPK files. 
 
Create Civil Rule Feature 
Assign Civil Geometry rules to elements created by tools other than civil geometry 
commands. 
 
 

Geometry Civil Toggles 

 
Activate Civil AccuDraw Toolbar 
Activates or deactivates Civil AccuDraw. 
 
Remove Rules 
Removes rules on selected elements. 
 
Deactivate Reference Rules 
Deactivates reference rules on selected elements. Reference rules are elements upon 
which the chosen element is dependent. For example, a curve between elements 
depends on the two other elements that define it. This command allows deactivating 
the rules for those other elements. 

 
 

Geometry Design Elements 
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Set Active Profile 
Used to define which profile element is used to define the 3D model for a corridor 
 
Set Active Terrain Model 
Used to designate the active terrain model. The active terrain model is used when a 
profile is generated and also used as the default target for corridor modeling. 
 
Select by Graphical Filter 
Places all elements matching the Graphical Filter into a MicroStation selection set. 
 

Horizontal Geometry 

 
The Horizontal Geometry commands are accessed from the Task Navigation dialog by selecting Civil 
Tools > Horizontal Geometry. 

 
This toolset is split into several separate groups as 
summarized below. 
 
See the online help for more information. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 

Horizontal Geometry Point 
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Point 
Constructs a civil point element. 
 
Equal Spaced Points 
Inserts a specified number of points, points at a defined interval, or a combination of 
both into the View. 

 
 
Horizontal Geometry Line 

 
Line Between Points 
Creates a line between two user defined points. 
 
Simple Line to Element 
Constructs a line at a skew to a reference element. Note other line to element tools can 
be accessed via this button with a long left click. 
 
Simple Line from Element 
Constructs a line at a skew from a base element. Note other line from element tools can 
be accessed via this button with a long left click. 
 
Line Between Arcs 
Constructs a line between two previously placed arcs. 
 
Chamfer Between Elements 
Planes a corner, example, it alters an existing intersection by inserting a line between 
the elements. 

 
 
 
 
 
 
 
 
 
 
Horizontal Geometry Arc 
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Circle 
Draws a circle. 
 
Arc Between Points 
Creates an arc between points. 
 
Simple Arc to Element 
Constructs an arc based on a selected base element which controls tangency at one end. 
Note other Arc to Element tools can be accessed via this button with a long left click. 
 
Simple Arc From Element 
Constructs an arc based on a selected base element that controls tangency at one end. 
The construct may also include an optional spiral transition or arc transition (2 center 
curve). Note other Arc from Element tools can be accessed via this button with a long 
left click. 
 
Simple Arc Between Elements 
Constructs an arc between two previously placed elements. This tool has the ability to 
optionally apply a back and/or forward transition and/or taper between the elements 
and the constructed arc. Note other Arc Between Element tools can be accessed via this 
button with a long left click. 
 
Arc Between Arcs 
Constructs an arc between two previously placed arcs. This tool has the ability to 
optionally apply both a back and/or forward transition between the base arcs and the 
constructed arc. 
 
Complex Transition Between Any Element and Arc 
Constructs an arc between two previously placed elements. This tool has the ability to 
optionally apply a Back Spiral and/or Ahead Transition between the elements and the 
constructed arc. 

 
Horizontal Geometry Spiral 

 
Spiral From Element 
Constructs a spiral from a previously placed element, using this base element to 
determine tangency at one end. 
 
 



 GEOPAK OpenRoads Technology for Civil Design March 30, 2017 

 

Chapter 5 – Civil Geometry Page 77 

 

Spiral Between Elements 
Constructs a spiral (or spirals) between two base elements that determine tangency. 
 

Horizontal Geometry Complex 

 
Complex By elements 
Constructs a complex element of previously placed elements by joining them in 
sequence. 
 
Complex by PI 
Creates a linear element with curves based on user input of PI (point of intersection) 
locations. The curves can include transitions or set the radius to zero for no curves at 
the PI. 
 
Complex Redefine 
Replicates an element at a specified distance from the original. 
 
Insert Horizontal Fillet 
Inserts a curve into a previously created element. 
 
Append Element 
Constructs a complex element by appending additional elements in a previously 
established complex element. 
 
Define Horizontal By Best Fit 
Constructs an element that best fits a course defined by a selected linear object. 
 
Simple Offset Entire Element 
Constructs linear elements based on various methods of offsets from a base element. 
The base element may be a line, arc, spiral, or complex. Note other offset tools can be 
accessed via this button with a long left click. 
 
Reverse Curve by Angle 
Constructs reverse curves between previously drawn elements. Note other Reverse 
Curve tools can be accessed via this button with a long left click. 
 
Create Geometry by Template 
Used to access the Pick Template dialog then insert the chosen template into the 
drawing relative to a reference element. Any point in the template, whose feature 
definition is set to create geometry, will produce offset element constructions at the 
template defined offset. 
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Horizontal Geometry Modify 

 
Start Station 
Assigns stationing to an element. 
 
Add Station Equation 
Defines a station equation at a designated location on an element. 
 
Create Civil Rule Feature 
Assigns Civil Geometry rules to elements created by tools other than civil geometry 
commands. 
 
Copy Element 
The Copy Element tool creates a new instance of visible geometry only. 
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5.6 Civil AccuDraw 
Placing elements in a 2D model is like manual drafting — all elements appear on the same plane, the 
sheet of paper.  
 
In 3D, you place elements in space — horizontally (for example, a floor), vertically (for example, a wall), 
or at any other angle or direction (for example, a sloping roof).  
 
By default, data points in a 3D model are placed at the view's Active Depth. Where you snap a tentative 
point or place a data point in a blank part of a view, it will be located at the active depth. You can, 
however, snap a tentative point to an existing element at any depth in a view. When you accept such 
tentative points, the data point is placed at the level of the snap point. 
 
Civil AccuDraw and its drawing plane let you place elements away from the active depth. Often this 
improves productivity, since you need not constantly change the active depth. 
 
Select Tools > Civil AccuDraw > Activate Toolbar from the MicroStation pull-down menu to open the 
Civil AccuDraw dialog shown below. The first icon is used to turn Civil AccuDraw on or off. 

 
Civil AccuDraw performs many of the same functions as MicroStation AccuDraw but has greatly 
expanded capabilities for the civil designer. 
 

Note: Simultaneous use of Civil AccuDraw and MicroStation AccuDraw will cause errors. Close 

MicroStation AccuDraw when using Civil AccuDraw. 

This guide will cover only a few of functions available when using Civil AccuDraw. For more information, 
see the GEOPAK online help by selecting Applications > GEOPAK > Road > Help. From the Civil Help 
dialog, select Civil Tools > Civil AccuDraw. 
 
The coordinates of the current cursor position are displayed by default in a floating dialog as shown 
below. You can switch between the floating or fixed dialogs using the up and down arrow keys. The 
contents of the dialog will depend upon the current ordinate system selected. 

 
The Tab key is used to move through the key-in fields 
in the dialog. 
 
Values entered in the floating dialog are locked when 
the Enter key is pushed. 
 
To unlock a value, tab to the field and push the End 
key. 
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Shortcuts: Civil Accudraw Settings 
Civil AccuDraw shortcuts and settings are accessed by selecting and holding down the left mouse button 
on the second icon as shown below.  

 
 
These shortcuts are described in the online 
help by selecting Applications > GEOPAK > 
Road > Help. 
 
From the Civil Help dialog, select Civil Tools > 
Civil AccuDraw > Civil AccuDraw > AccuDraw 
Tool Access > Shortcuts. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
A single-click on the second icon will open the Civil AccuDraw Settings dialog shown below. 

 
 
These settings are described in the online help by 
selecting Applications > GEOPAK > Road > Help. 
 
From the Civil Help dialog, select Civil Tools > Civil 
AccuDraw > Civil AccuDraw > Settings. 
 
 
 
 
 
 
 
 
 
 
 

 
Civil AccuDraw Compass 
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When the Always Show Compass setting is toggled on, a compass is displayed at AccuDraw’s origin 
point when Civil AccuDraw is active. 

 
 
The compass is always circular and is marked by a number of tics. The default 

is 4 compass points which can be changed in the settings. 

The north arrow on the compass will always point to north as defined in 
Settings > Design File > Angle Readout. 

 
 

If the Civil AccuDraw Settings dialog (shown on the previous page) has the Context Sensitive option 
turned on (default), then the compass auto-rotates in a similar fashion to MicroStation AccuDraw: 

 
Note that rather than direction being shown, the label and value are now an Angle. This is because the 
context is based on the direction of the preceding line segment rather than an absolute direction. 
 
The compass can be rotated with the V, B, T, RQ, RE shortcuts.  
 

V rotates the drawing plane to align with the view axes. 
T rotates the drawing plane to align with the axes in a standard Top view. 
RQ is used to quickly and temporarily rotate the drawing plane. 
RE rotates the drawing plane to match the orientation of a selected element. 

 
Use the T (Top) shortcut or the corresponding drop-down to return to a pure direction. 

 

 
Distance-Direction 
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The Distance-Direction ordinate is used to enter points in polar coordinates as shown below. 

 
Angle Syntax 
The input for angle and direction fields follows the MicroStation Settings > Angle Readout settings. 
 
Valid forms for the various settings are as follows: 
 

DD.DDDD, Radians or Grads - Use the customary decimal input. 
 
DD MM SS or DD MM - The following delimiters are supported between degrees, minutes and 
seconds: 
 

Colon - For example DD:MM:SS 
 
^ (caret) to designate degrees, minute (’) and second (”) - For example DD^MM’SS” 

 
The following are not supported in the current version: 
 

A space between degrees, minutes and seconds because space launches the Civil 
AccuDraw popup menu 
 
Use of d, m and s to designate degrees, minutes and seconds. 

 
 
 
 
 
 
 
XY 
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Rectangular coordinates can be entered by use of the XY ordinate as shown below. 

 
Station-Offset 
The Station-Offset ordinate is used with a reference element to enter information as a station and 
offset relative to a selected element. 

 
The reference element can be a MicroStation element or a Civil Geometry element. If a MicroStation 
element is selected, the beginning of the element is assumed to be station 0+00. If a civil element is 
selected with stationing defined, the station value of the selected element is used. 
 
To select the reference element, with the Station-Offset ordinate active use the O shortcut to select the 
reference element. Once selected, data can be entered using station and offset values relative to the 
reference element as shown in the example above. 
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5.7 OpenRoads Feature Definitions 
As you draw information using the OpenRoads horizontal geometry tools, the plan view representation 
of the item is drawn using the active MicroStation settings. OpenRoads Features are used to define not 
only the plan view representation of an object, but also how the object will appear in other contexts 
such as the profile, cross sections, and 3D. 
 
What is a Feature? 
Simply stated, a feature is anything in your design that represents a real-world object such as: 

 Curb and Gutter 

 Pavement 

 Catch basins, Manholes, Inlets 

 Walls 

 Ditches 

 Cut and Fill Slopes 

 Etc. 
 
Feature Definitions are normally created in advance for your use in order to standardize the design. 
Three types of Feature Definitions are supported by the software: 
 

Point Features 

 Control Points 

 Catch Basins 

 R/W Marker 

 Etc. 
 

Linear Features 

 Curb and Gutter 

 Walls 

 Ditches 

 Etc. 
 

Surface Features 

 Existing Ground 

 Aggregate Base 

 Asphalt Pavement 

 Etc. 
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Features are defined in MicroStation DGN Libraries. The ODOTcadd Configuration defines which feature 
libraries are available for ODOT use. The libraries can be reviewed using the in the Civil Standards tab of 
the Project Explorer dialog as shown below. 

 
The Features are organized by categories. Expanding a category will reveal the features available in the 
category. Right-click on a Featre to review the properties as shown below. 
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Depending on the type of feature definition, there are various properties defined for the item. Some 
examples are shown below. 
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5.8 Working with GPK Files 
Legacy GEOPAK Road commands use the GEOPAK Coordinate Geometry (COGO) Database to store all of 
the geometric alignment information (both Horizontal and Vertical) for the project. The COGO database 
has a .gpk file extension. 
 
Horizontal and vertical alignment information generated using the OpenRoads Geometry tools is stored 
directly in the active MicroStation model. The GPK file is not required for OpenRoads commands; 
however OpenRoads horizontal and vertical alignment information must be exported to the GPK file for 
use with the legacy GEOPAK commands. 
 
There are two ways to export OpenRoads geometry to the GEOPAK GPK file: 
 

 Manually export selected OpenRoads geometry alignments using the Export to Native 
command. 
 

 Automatically export OpenRoads geometry as the alignments are created by use of specific 
feature definitions that have been configured to auto-export the alignment. 

 
In either case, the GPK file must be created before exporting the geometric information. The export 
process does not create a GPK file. 
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Exercise 5B –GPK Files 
OpenRoads alignment information is stored in MicroStation design files, however, it is still necessary to 
create a GEOPAK Coordinate Geometry Database that will also contain the horizontal and vertical 
alignments. 
 
The location of the GEOPAK COGO database is defined by the Working Directory parameter in the 
GEOPAK User Preferences dialog. Creating a GPK file is as simple as defining the Working Directory, and 
entering a Job Number for the GPK file when the COGO command is accessed. 
 
Note: For most projects it is desirable to create a GEOAK Project and use the GEOPAK Project Manager 
to facilitate the plan production process. The procedure to create a GEOPAK Project is detailed in 
ODOT’s GEOPAK Road 1 Training Guide. 
 

http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Standards/Documents/St

artmenu/GEOPAK_V8i_Road1.pdf 

 
The training data already contains a GPK file that was created by the Survey personnel.  This file contains 
the existing alignment information. For the purpose of OpenRoads training, we will define the Working 
Directory and review the process to create a GPK file for cases where one has not been provided by the 
Survey personnel. 
 

 Open MicroStation using the shortcut provided for the training class. 
C:\ODOT_Training\OpenRoadsDesign\ 

 
 In the MicroStation File Open dialog, set the User and Project as follows: 

User:  ODOTcadd 
Project:  12345_HORIZ_GEOMETRY 
 

 Open the following design file for the training project: 
\Design\Geopak\Basemaps\12345_BK002.dgn 

 
 Set the GEOPAK Working Directory by selecting Applications > GEOPAK > Road > User 

Preferences. Define the Working Directory as the \Design\Geopak folder for the project. 

 

http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Standards/Documents/Startmenu/GEOPAK_V8i_Road1.pdf
http://www.dot.state.oh.us/Divisions/Engineering/CaddMapping/CADD_Services/Standards/Documents/Startmenu/GEOPAK_V8i_Road1.pdf


 GEOPAK OpenRoads Technology for Civil Design March 30, 2017 

 

Chapter 5 – Civil Geometry Page 89 

 

 Check the Show this dialog at startup option to automatically open the User Preferences dialog 
every time GEOPAK is activated. This is useful to verify that GEOPAK is pointed to the correct 
folder location for the project that you are currently working on. 
 

 Select OK to confirm the dialog settings. 
 
After configuring the User Preferences, we can now open the GEOPAK Coordinate Geometry dialog to 
gain access to the GEOPAK GPK file. 
 

 From the MicroStation pull-down menu, select Applications > GEOPAK > Road > Geometry > 
Coordinate Geometry to access the dialog shown below. 

 
The dialog has the following options: 
 

Project Name 
This optional field is used to set a description that is displayed at the top of any COGO 
input and output files. 
 
Job 
This is used to designate the GPK file name. The Job Number entered here can be 
alphanumeric, three characters maximum, with no spaces or special characters. The 
resulting GPK file is named as follows: Job###.gpk 

   
To the right if the Job field is a selection button that can be used to browse the current 
Working Directory to select any previously created GPK files. 
 
Operator Code 
The Operator Code is used to identify each individual user of the COGO database by 
their initials. The field has a maximum of two alphanumeric characters. COGO input and 
output files are stored using the Operator Code as part of the resulting file name. 
 
Subject 
This optional field is used to enter a description. 
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 Enter 000 for the Job Number 
 

 Enter your initials for the Operator Code.  
 

 Select the OK button. You are prompted to create the GPK file as shown below. 

 
 Select Yes to create the GPK file. The Coordinate Geometry dialog shown below is opened. 

 
The file is created in the folder specified by the GEOPAK Working Directory parameter and is 
named as follows: job000.gpk 
 
NOTE! 
We will not use this GPK file for the training class. This file was created simply to illustrate the 
GPK file creation process without creating a GEOPAK Project. As stated previously, users will 
normally create a GEOPAK Project as detailed in ODOT’s GEOPAK Road 1 training guide.  
 
Tip: 
ODOT recommends setting the visualization mode to Disable Visualization when working with 
the OpenRoads tools. 

 
 Close the COGO dialog. It is not necessary to keep the COGO dialog open when exporting 

OpenRoads geometry to the GEOPAK GPK file. All that is necessary is the Working Directory is 
defined with the path to the folder where the GPK file is located, and the GPK file has been 
previously created. 
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5.9 Exporting OpenRoads Geometry to the GPK 
OpenRoads geometry can be manually exported using the Export to Native command, or automatically 
exported by using a Feature Definition that has been configured with the Auto Export and Auto 
Annotation options toggled on. Each option is discussed below. 

Export to Native 

The Export to Native command is located in the General Geometry task group as shown below. 
 

 
When the command is selected, you are prompted to 
select the OpenRoads geometry elements that you would 
like to export. After selecting the element(s), right-click 
(reset click) to complete the process. 
 
 

 
 

Exporting via the Feature Definition 

The ODOTcadd configuration contains several feature definitions that are used for geometric 
alignments. These features are defined in the DGN Library ODOT_Features_Design.dgnlib. 
 
The features can be reviewed in the Project Explorer 
dialog in the Civil Standards group as shown at right. 
Unique features are defined for various types of 
geometric data as shown at right. 
 
These features, contained in the Geometry & 
Stations category, define two key parameters that 
are used for storing the geometric data in the GPK 
file and also for annotating the geometry: Auto 
Export, and Auto Annotate. 
 

Auto Export 
The Auto Export parameter is enabled for 
every feature in the Geometry & Stations 
category except the Scratch Alignment 
feature. 
 
With this parameter enabled, OpenRoads 
graphics drawn using one of these feature 
definitions will be automatically exported to 
the GPK file when the element is initially 
drawn or subsequently edited. 
 
Auto Export will update the GPK definition for the alignment for every action that is done to the 
alignment graphics, including deleting the graphics. 
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Auto Annotate 
The legacy GEOPAK Design and Computation Manager Database is used to annotate stations 
and curve data along your OpenRoads geometric alignments. 
 
Each Feature Definition in the Geometry & Stations category has been defined to correspond to 
a companion item in ODOT’s legacy GEOPAK Design and Computation Manager Database, 
ODOT.ddb. 
 
When the geometry is exported to the GPK, the Auto Annotate parameter will trigger the 
station annotation function using the corresponding item in ODOT.ddb. 
 
These feature definitions have been specifically configured for working with OpenRoads 
alignments in the Geometry basemap BK design file. These features annotate only the station 
and keypoint information and are not intended to be used for plan production purposes in the 
roadway basemap BP design file. Curve data is not annotated when using these features. 
 
The current annotation scale value is used to determine the text size for the annotation. The 
following annotation scale values are supported: 
 

Engr: 1:10 
Engr: 1:20 
Engr: 1:50 
Engr: 1:100 
Engr: 1:200 
Engr: 1:500 

 
The Auto Annotate parameter is enabled for every feature in the Geometry & Stations category 
except the Scratch Alignment and CL_P_Driveway features. 

Using Feature Definitions to Draw OpenRoads Geometry 

As we have discovered, Feature Definitions control the 
appearance of our OpenRoads alignments in various 
contexts (plan, profile, 3D, cross sections).  
 
Feature Definitions can be applied as the graphics are 
drawn, or defined later. For example, the Horizontal 
Geometry command, Line Between Points can be 
defined with the parameters shown at right. One of 
these parementers is the Feature Definition, which is 
selected from the drop down list. 
 
The Use Active Feature Definition option can be used if 
you have previously defined a feature as the active 
feature by use of the Features Definition Toggle Bar (see 
page 70). 
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After a feature has been selected, the Name field will be populated 
with a prefix to use for naming the geometric alignment. The prefix is 
defined in the selected feature. For example, choosing the feature 
definition CL_P_Construction will default to a Name value of CLP_ as 
shown at right. 
 
See the ODOT CADD Engineering Standards Manual (ODOTcadd), 
Section 300, for more information on naming standards for geometric alignments. 
 

Using the “Scratch Alignment” Feature Definition 

We recommend designing your alignments with a temporary feature assigned so the individual 
components of the geometric alignment (lines, arcs, spirals) are not automatically exported to the GPK 
file until you have completed the design of your alignment. 
 
You can choose the Feature Definition as each element is placed, as shown on the previous page, or you 
can set the Active Feature as detailed below: 
 

 Open the Feature Definition Toggle Bar from the Horizontal Geometry task group as shown 
below. 

 
 Choose the feature definition Geometry & Stations > Scratch Alignment to use while working 

on alignments. This will draw the geometry on the level SC_Scratch1 and will not automatically 
export the individual elements (lines, arcs, spirals) to the GPK as they are drawn. 
 

 
 

 Toggle on the Use Active Feature Definition option as shown above. This will automatically 
assign the selected feature as the active feature as you use various OpenRoads Geometry 
commands. 
 

 Once the alignment has been completely defined, assign the appropriate feature to export and 
annotation the alignment when you store the graphics as a complex alignment. See the example 
on the following page. 

 
 



March 30, 2017 GEOPAK OpenRoads Technology for Civil Design  

 

Page 94 Chapter 5 – Civil Geometry 

 

In the example below, two lines were drawn using the Line Between Points command. The central curve 
was created using the Simple Arc command. 
 
The Complex By Elements command is used to create the alignment that will be exported to the GPK file 
and annotated. 

 

 
 
After the complex element has been created, the Auto Export function that has 
been defined for the Feature Definition will now automatically store the alignment 
in the GPK. You are prompted to select the GPK file to store the alignment as 
shown at right. 
 
The graphics are updated using the Active Feature as shown on the following page. 
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In this example, the MicroStation Annotation Scale was set to Engr 1:20 and the feature Geometry & 
Stations > CL_P_Construction was used. The graphics are placed on the level shown below for each 
feature definition. 
 

Feature Name MicroStation Level 

CL_P_Construction CL_P_Construction 

CL_P_Driveway GE_P_Driveway_CL 

CL_P_MOT CL_P_MOT 

CL_P_RW CL_P_RW 

CL_X_Construction CL_X_Construction 

CL_X_MOT CL_X_MOT 

CL_X_RW CL_X_RW 

CL_X_Survey CL_X_Survey 

Scratch Alignment SC_Scratch1 

 
Notes: 
 

 Use the Scratch Alignment feature when you are working on an alignment. Don’t assign one of 
the other features until you create the complex element. 
 

 The driveway Feature Definition does not place any stationing in the design file. 
 

 These items should be thought of as equivalent to COGO Visualization graphics when using the 
legacy GEOPAK COO tools. The graphics and stations drawn when using these feature definitions 
are not intended for plan production. 
 

 For plan production purposes, use the GEOPAK D&C Manager to plot the centerline and station 
information in the appropriate basemap design file. 
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5.10 Stations and Station Equations 

Start Station 

When OpenRoads alignments are stored, the software assumes a beginning station value of 0+00. This 
station can be redefined by use of the Start Station command. 

 
 
The command has two parameters: 
 
Start Distance 
The distance along the alignment to assign the Start 
Station. The beginning station is computed based on the 
Start Distance and the Start Station value. 
 
Start Station 
The station value to be assigned at the Start Distance 
location. 
 
 

 
 

When you assign the Start Station value to the alignment, if the feature definition that is assigned to the 
selected element has been defined with Auto Export and Auto Annotate set to True, the alignment is 
automatically updated in the GPK file and the graphics are updated to reflect the new station value. 
 
Tip: Make sure MicroStation’s current Annotation Scale setting is set to one of the supported, as 
defined on page 89, in order for the Auto Annotate function to properly update the graphics and display 
the alignment stationing. 
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Add Station Equation 

The Add Station Equation command, located to the right of the Start Station command adds 
parameters for the Ahead Station and Back Station. 

 
 
When the command is selected, the user is prompted to 
select the alignment to assign the station equation. 
 
After the alignment has been selected, the location of 
the equation can be identified graphically, or by keying 
in the Back Station value as shown below. 
 
 
 
 
 
 
 

 
 

 
When the equation is applied, if the feature definition that is assigned to the selected element has been 
defined with Auto Export and Auto Annotate set to True, the alignment is automatically updated in the 
GPK file and the graphics are updated to reflect the new station equation. 
 
Station equations are defined using the “Region” concept in the same manner as GEOPAK COGO chains. 
See ODOT’s GEOPAK Road 1 Training Guide for more information on station equations. 
 
 
 
 
 
 
 



March 30, 2017 GEOPAK OpenRoads Technology for Civil Design  

 

Page 98 Chapter 5 – Civil Geometry 

 

5.11 Design Standards 
Design Standards are used to monitor various alignment parameters on OpenRoads geometry elements. 
The standards are stored in the DGN Library ODOT_DesignStandards.dgnlib. 
 
The design standards can be used for two purposes: 
 

 Provide default values for element creation tools such as radius of a curve for a selected ODOT 
standard 
 

 Check and report on the compliance of a geometric element with the design standard that has 
been assigned to the element 
 

When a design standard is violated, the user is notified in two ways: 
 

 An icon is displayed on the graphics to indicate that there is a problem 
 

 The Civil Message Center reports any errors 
 
The Design Standards Toolbar allows you to select and apply a design standard. On the Task menu, 
select Tasks > Civil Tools > General Geometry > Design Standards Toolbar. 

 
The toolbar contains a drop-down list to select the design standards and the design speed. The Vertical 
design standard is automatically set when the Horizontal design standards is selected. 
 
There are two icons located to the left of the drop-down menus. The first, Set Design Standard, is used 
to apply the current design standard to selected geometric elements. The second, Toggle Active Design 
Standard, is used to set the selected design standards active for relevant commands. 
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The values defined for a design standard can be 
reviewed in the Project Explorer dialog by right-
clicking on the Design Standard and choosing the 
Properties option. 
 
The properties for the selected design standard are 
shown below. 
 
Transition lengths for acceptable radius values are 
defined in a table. Selecting the Table option in the 
properties list will allow you to review the values 
that have been defined for a specific design 
standard. 
 
For each radius entry, the appropriate transition 
(spiral) length is shown.  
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To Apply a Design Standard 

Let’s take a look at an example applying a design standard when using the Simple Arc command to place 
a curve between two tangent lines. 
 

 The Design Standards Toolbar is set to the ODOT standard 202-8E, 2-Lane Undivided with a 
design speed of 55 MPH 
 

 The Toggle Active Design Standard icon is checked on 
 

 Using the Simple Arc command, the Radius value defaults to the value defined in the selected 
design standard, 954.9279 
 

 The design standard defines a minimum transition length of 205 for the default radius. Spirals 
will be placed even though the Simple Arc command was initially selected. 

 
Design Standards can also be applied to an element after it has been created by using the Set Design 
Standard icon on the Design Standards Toolbar. 
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To Review a Design Standard Violation 

In the event that a design standard is violated, the software will display an icon on the element with the 
violation similar to the example below. Floating the cursor over the icon will display the error message. 

 
Errors can also be reviewed in the Civil Message Center by selecting Tasks > Civil Tools > General 
Geometry > Civil Message Center. Toggle on the Error option to view any errors. 

 
You can zoom to the error by right-clicking on the error and choosing the Zoom To option. 
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Exercise 5C – Proposed State Route 185 
State Route 185 is the main alignment for our project. In this exercise we’ll lay out a new proposed 
alignment for State Route 185. 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 In the MicroStation File Open dialog, set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_HORIZ_GEOMETRY 

 
 Open the geometry basemap for State Route 185: 

 
..\Design\Geopak\Basemaps\12345_BK002.dgn 

 
 Attach the survey information as a reference file. The survey information is located in the 

following design file: 
 

..\Design\Survey\Basemaps\12345_BE001.dgn 
 
When attaching the reference file, which Orientation option should be used? Coincident – 
World, or Geographic – Reprojected?  
 
Should Live Nesting be used? 
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The sample project contains three roads as shown below. 

 
 Turn on/off levels for the survey information as necessary. Start by turning off the levels shown 

below, and any other levels that you may not want to see while working on the geometry for 
the project. 
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 Select the terrain model graphics from the reference attachment and set it as the Active Terrain 
(select the terrain boundary and then hover the mouse over the boundary to get the pop-up 
toolbar seen below, a long right click on the boundary will bring up a context menu where the 
Set of Active Terrain Model button can be found as well). 

 
 From the Civil Tools > General Geometry task list, choose the Features Definition Toggle Bar 

icon. Set the active feature to Geometry and Stations > Scratch Alignment. Toggle on the Use 
Active Feature Definition icon. 

 
 From the Task list, choose the Civil Tools > Horizontal Geometry > Line Between Points 

command. 
 
Start by placing a line from the RSPK feature located at the intersection of St. Peter Road and 
S.R. 185. This is point SV901 in the Survey file. Use the MicroStation Origin Snap to ensure you 
are starting the first point of the line by snapping to the center of the RRSKP cell. 
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 Define the second point of the line with a Distance of 1556.74 and a Line Direction of 
N00^40’43”E as shown below. 
 
Tip: Degrees, minutes, and seconds are entered using the colon character as a separator. 
Example: n00:40:43e 

 
 
 

 Use the Line Between Points command to store the following lines.  
 
         Starting from the RRSPK feature, SV901. 

Distance:  1595.31 
Line Direction: s01:13:48"w 
 

         Starting from the end of the previous line. 
Distance:  1838.00 
Direction:  s63:50:18e 
 

         Starting from the end of the previous line. 
Distance:  650.00 
Direction:  s03:35:00w 
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 Next we’ll use the Design Standards Toolbar to place a spiral-curve-spiral set. From the 
MicroStation Task list, choose the Civil Tools > General Geometry > Design Standards Toolbar 
icon. 
 

 Toggle on the second icon, Toggle Active Design Standard, and select the item shown below. 
 

 
 

 From the Task list, choose the Civil Tools > Horizontal Geometry > Spiral-Arc-Spiral command 
(this is a sub-command of the Simple Arc command and is accessed by holding down a data-
point on the Simple Arc command).  
 
When using a Design Standard, the software will set the length of the spirals and the degree of 
curvature is set to the default values defined by the selected design standard.  
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 Use the Trim/Extend Both option to complete the process 

 
 

 Place the second spiral-curve-spiral using the following values: 
Radius:    d7:45 
Back Transition Length:  250 
Ahead Transition Length: 250 

 
Tip: The degree of curve can be set by keying in the degree value in the Radius field prefixed 
with a lower case “d”. Degrees, minutes, and seconds are separated by the colon character. 

 
 Use the Trim/Extend Both option to complete the process 
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The second spiral-curve-spiral combination does not meet the currently 
selected 55 MPH Design Standard. A red X is displayed on the curve as 
shown at right. Design errors can be reviewed in the Civil Message Center 
dialog. 

 
 
 
 
 
 

In the default ODOT configuration, the Civil Message Center is docked and unpinned below the 
MicroStation view window. 
 
Floating your cursor over the tab will open the dialog as shown below. 

 
Information about the error is displayed similar to the example above. 
 
No action is required to remedy the error in order to continue designing the corridor model. This 
is strictly informational and can be ignored if the data is correct. 
 
If the Civil Message Center dialog has been closed, it can be opened from the General Geometry 
task group as shown below. 
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Next we will create a complex chain from the individual elements that have been placed for the 
proposed centerline of S.R. 185. 
 
We will assign a feature definition for the complex element that will automatically export the centerline 
element to the active GEOPAK Coordinate Geometry Database (GPK file). Before creating the complex 
chain, make sure the GEOPAK Working Directory is defined to specify the location of the GPK file and 
that the GPK file exists. 
 

 Open the GEOPAK User Preferences dialog by selecting GEOPAK > Road > User Preferences 
 

 Verify that the Working Directory is set appropriately for the active project. For this training 
class, the Working directory should be set as follows: 
 
C:\ODOT_Training\OpenRoadsDesign\ProjectData\12345_HORIZ_GEOMETRY\Design\Geopak 

 
 Close the User Preferences dialog when complete 

 
After verifying the Working Directory is set correctly for the project, take the following steps to create 
the complex element:  
 

 Set the MicroStation Annotation Scale value to Engr 1:20 (from the MicroStation pull-down 
menu select Settings > Drawing Scale). Remember that the various centerline feature 
definitions are configured to support only specific annotation scale values as previously 
described. 

 
 From the Task list, choose the Civil Tools > Horizontal 

Geometry > Complex By Elements icon  
 

 Set the Feature Definition to the Geometry and Stations > 
CL_P_Construction as shown at right. 
 

 Key in the Name for the centerline element. Remember 
that a chain element will be stored in the GPK file; 
therefore the name must follow GEOPAK COGO element 
name restrictions. See the ODOT CADD Engineering 
Standards Manual (ODOTcadd) Section 300 for more 
information on naming COGO elements. 
 

 Using the Automatic Method, choose the first element to define the complex element. Note 
that the direction of the element is significant. When you move the cursor over the first 
element, an arrow is displayed indicating the direction the complex element will be defined. 
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 Select and accept the first element. The entire complex chain is 
highlighted. The Job Number dialog is opened displaying a list of all the 
GPK files found in the current GEOPAK Working Directory. Choose the 
job185.gpk file to store the complex element in the GPK. 
 

 The complex element is created and stored in the GPK using the Name 
you have specified. If a chain exists in the GPK with the same name, it is 
overwritten. The COGO Redefine option is ignored. 
 

 The Auto Annotate function defined by the feature definition will ensure 
that the stationing is displayed in the design file. If the stationing is not 
displayed, either the chain was not successfully stored in the GPK file, or 
the current MicroStation Annotation Scale setting does not match one of the 
scales that the Feature Definition that was configured for. 

 
The chain is stored with a default beginning station value of 0+00. Use the Start Station tool to define 
the beginning station for the newly created alignment as detailed below. 
 

 From the Task list, choose Civil Tools > Horizontal Geometry > Start Station. 
 
The Start Distance parameter defines the location along the selected alignment where the Start 
Station value is applied. The Start Distance should be 0 and the Start Station is 385+00.00 
 
When the Start Station value is assigned, the stationing is automatically updated in the design 
file, as well as in the GPK file. This automatic update to the COGO Chain in the GPK file only 
happens if the Feature Definition of the selected alignment has the Auto Export parameter set 
to a value of True. 
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The parameters for each alignment can be reviewed using the Project Explorer dialog’s Civil Model 
group. 

 
Various parameters can be reviewed and/or 
edited in Project Explorer by right-clicking on an 
item and selecting Properties. 
 
For example, the Assigned Station value can be 
reviewed and edited in the Element Information 
dialog as shown below. 
 
 
 
 

 

 
 
When a federated approach is used to create separate design files for each alignment, the graphics may 
not automatically display in the “000” basemap (see Using Multiple “Federated” Basemaps). 
 

 Open the file 12345_BK000.dgn 
 Verify that the file containing the S.R. 185 centerline, 12345_BK002.dgn, is attached as a 

reference 
 If the graphics for the S.R. 185 centerline are not displayed, use MicroStation’s Level Display 

dialog to turn on/off the desired levels for each reference attachment 
 Save settings and close the 000 file when complete 
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Exercise 5D – St. Peter Road Improvements 
St. Peter Road is located roughly in the center of the project. This is a simple centerline consisting of only 
one tangent line. Take the following steps to define the centerline for St. Peter Road: 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the MicroStation User and Project as follows: 
User:  ODOTcadd 
Project:  12345_HORIZ_GEOMETRY 

 
 Open the design file that will be used for the St. Peter Road alignment: 

..\Design\Geopak\Basemaps\12345_BK003.dgn 
 

 Attach the alignment information for CLP_S185 as a reference file. Use a Nest Depth of 1. 
..\Design\Geopak\Basemaps\12345_BK000.dgn 

 
 Attach the survey information as a reference file. 

..\Design\Survey\Basemaps\12345_BE001.dgn 
 

 In the Features Definition Toggle Bar, set the Active Feature to Geometry and Stations > 
Scratch Alignment and toggle on the Use Active Feature option 

 
  Use the Line Between Points command to store a line with the following parameters: 

 
Start Point: 

Snap to the center of the RSPK feature at Station 400+56.74 on CLP_S185 
 
End point: 

Distance:  500’ 
Bearing: N84^09’20”E 

 
 

Even though this centerline consists of a single element, we still have to make it a complex element to 
store it as a chain in the GPK file. 

 
  Use the Complex By Elements command to define a chain named CLP_STPETER.  

 
 Set the model Annotation Scale value to 1:20 

 
 In the Features Definition Toggle Bar, set the Active Feature to Geometry and Stations > 

CL_P_Construction and toggle on the Use Active Feature option 
 

 Be sure to define the complex element for the centerline of St. Peter Road with the direction 
going towards the centerline of S.R. 185 as shown below.  
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 When prompted, store the alignment in job185.gpk 

 
  Use the Start Station command to redefine the Start Station as 15+00 with a Start Distance of 0. 

 

 
 

 From the MicroStation menu, choose File > Save Settings when complete 
 
When a federated approach is used to create separate design files for each alignment, the graphics may 
not automatically display in the “000” basemap (see Using Multiple “Federated” Basemaps). 
 

 Open the file 12345_BK000.dgn 
 Verify that the file containing the St. Peter Road centerline, 12345_BK003.dgn ,is attached as a 

reference 
 If the graphics for the St. Peter Road centerline are not displayed, use MicroStation’s Level 

Display dialog to turn on/off the desired levels for each reference attachment 
 Save settings and close the 000 file when complete 
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5.12 Importing OpenRoads Geometry from a GEOPAK GPK file 
Geometry that has been previously defined in a GEOPAK Coordinate Geometry database can be easily 
imported from the GPK file into the design file as an OpenRoads Civil Geometry element. This includes 
both horizontal and vertical geometry; however, vertical geometry cannot be imported without a 
corresponding horizontal alignment. 
 
To import geometry from a GPK file, choose the Import Geometry command from the Tasks menu’s 
General Geometry group as shown below. 

 
The Import Geometry dialog is opened as shown 
below. Select the GPK file that you wish to use to 
import the geometry. 
 
 
 
 

 
 

 
After selecting the GPK file, another Import Geometry dialog is opened as shown on the following page. 
This dialog allows users to specifically choose which alignments and profiles to import as civil geometry 
alignments. 
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When importing profiles, be sure to choose only the proposed profile. There is no need to import 
existing profiles as the OpenRoads software will automatically create an existing profile from the active 
terrain model. 
 
Toggle on the Create Civil Rules option to create ruled geometry. 
 
Choose Import to initiate the process. 
 
The geometry is imported using the feature definition defined in the GPK file. If no feature definition is 
defined, the resulting geometry in the dgn file will not have a feature definition assigned. 
 
Note: The feature definition can be changed to an ODOT definition after the geometry has been 
imported. Remember that choosing a feature definition with the Auto Export option set to a value of 
True will export the geometry to a GPK file. 
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Exercise 5E – Proposed Jameson Road 
The alignment and profile for Jameson Road has been previously stored in a GPK file. In this example, we 
will import the alignment and profile for Jameson Road from the GPK file. 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_HORIZ_GEOMETRY 

  
 Open the design file that will be used for the Jameson Road alignment: 

..\Design\Geopak\Basemaps\12345_BK004.dgn 
 

 Attach the survey information as a reference file. 
..\Design\Survey\Basemaps\12345_BE001.dgn 

 
 Select the Import Geometry command from the General Geometry task group as shown below. 

 
 You are prompted to select the GPK file containing the data that you wish to import. Select the 

file jobbak.gpk. 
 
The Import Geometry dialog is opened as shown on the following page. 
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 Select the Alignment and associated Profile as shown below. Check on the Create Civil Rules 

option. Choose the Import command to initiate the process. 

 
The alignment and profile are imported into the active design file using the feature definition 
that is assigned in the GPK file. In the example above, No Feature was defined for the alignment. 
The data is imported without an assigned feature definition. 
 
 
 



March 30, 2017 GEOPAK OpenRoads Technology for Civil Design  

 

Page 118 Chapter 5 – Civil Geometry 

 

 Select the alignment and choose the Properties icon to review the Feature Name and Feature 
Definition as shown below. 

 
The alignment can be given a Feature Definition by choosing one of the Geometry and 
Stationing features from the list. Remember, when one of the Geometry and Stationing feature 
definitions is assigned the Auto Export and Auto Annotate functions will write the chain and 
profile to the selected GPK file and annotate the stations for the alignment. Be sure to choose 
the job185 GPK file to write the data back to the correct gpk file for the project. 
 

 Set the Feature Definition to Geometry & Stations > CL_P_Construction for the Jameson Road 
Alignment 
 

 When prompted to store the alignment in a GPK file, choose job185.gpk 
 
The alignment and stationing is redrawn using the selected feature definition 
 

 From the MicroStation menu, choose File > Save Settings when complete 
 
 
When a federated approach is used to create separate design files for each alignment, the graphics may 
not automatically display in the “000” basemap (see Using Multiple “Federated” Basemaps). 
 

 Open the file 12345_BK000.dgn 
 Verify that the file containing the Jameson Road centerline, 12345_BK003.dgn ,is attached as a 

reference 
 If the graphics for the Jameson Road centerline are not displayed, use MicroStation’s Level 

Display dialog to turn on/off the desired levels for each reference attachment 
 Save settings and close the 000 file when complete 
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6 Vertical Geometry 

The OpenRoads technology stores vertical alignments as a component of the horizontal alignment in the 
same design file as the horizontal geometry. This is true for both existing vertical alignments, which are 
extracted from an OpenRoads Terrain Model, and proposed vertical alignments. 
 
Although the vertical geometry is stored in the design file, the graphical display of the vertical alignment 
information is not plotted in the design file. Vertical alignments are displayed in a profile window for 
review and editing. To plot the vertical alignment information in a design file that can be used for plan 
and profile sheet clipping, the vertical alignments must be exported to a GPK file and drawn into 
MicroStation using the legacy GEOPAK Design and Computation Manager tool. 
 

6.1 Profile Settings 
The Design File settings contain parameters for formats as you work with vertical alignments. Select 
Settings > Design File and then click the Civil Formatting item from the list on the left of the dialog. The 
Profile Settings are set to the values shown below in the ODOT seed files. 
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6.2 Existing Ground Profiles 
Existing ground profiles are extracted along the selected element from the active terrain model. The 
active terrain model is set by selecting the terrain element and choosing the Set As Active Terrain 
Model icon as shown below. 

 
To extract the existing profile, select the alignment graphics and choose the Open Profile Model icon as 
shown below. 

 
You are prompted to select or open a view window to use for the profile display. Open a new view 
window and then left-click in the view window to display the profile. An example is shown on the 
following page. 
 
Note: The profile is displayed in the profile view for review and editing; however, the profile is not 
written to the design file. The selected view window is used as a temporary display of all the profiles 
associated with the selected alignment. The selected view window is not specifically associated with a 
particular alignment/profile and can be used to display the profiles from a different geometric alignment 
as needed. 
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Selecting a profile graphic reveals a pop-up menu with commonly used commands as shown below. 

 
The following commands are available. See the online help for more information 

 Properties 

 Set as Active profile 

 Rules 

 Create Best Fit Profile 

 Profile Report 

 Delete 
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The Profile view window contains command icons specific to profiles as shown below. 

 
The following commands are available. See the online help for more information. 

 Fit Plan Extents 

 Fit Profile Elements 

 Vertical Geometry Tools 
 
The Vertical Geometry Tools can be selected from the last icon, 
as shown at right, or selected from the Task list by selecting Tasks 
> Civil Tools > Vertical Geometry, as shown below. 

 
 
 
 
See the online help for information on the individual Vertical Geometry commands. 
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6.3 Profile Feature Definitions 
The symbology of vertical geometry is defined by Feature Definitions; however, the feature definition 
for profiles is not assigned by the user. Feature definitions for vertical alignments are defied as follows: 
 

 Existing vertical alignments inherit their display parameters from the feature definition that has 
been assigned to the terrain model that was used to extract the profile. 
 

 Proposed vertical alignments inherit their display parameters from the feature definition that 
has been assigned to the horizontal geometry that the vertical geometry is associated with.  

 

6.4 Exporting Existing Profiles to the GPK File 
Both existing and proposed profiles can be exported to the GEOPAK Coordinate Geometry database 
(GPK) as needed.  
 
Existing profiles must be exported manually using the General Geometry task group’s Export to Native 
command. Before exporting, it is necessary to define the Feature Name for the profile. 
 
Select the profile element and choose the Properties item from the pop-up menu. 
 
The Properties item can be used to review an edit various 
parameters for the selected profile as shown at right. 
 
The Feature Name item is used when the profile is 
exported to the GPK file and should be set according to 
the naming conventions defined in the ODOT CADD 
Engineering Standards Manual (ODOTcadd) Section 300. 
 
 After defining the Feature Name, use the Export To 
Native command to export the profile elements to the 
selected GPK file. 
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Exercise 6A –Existing Profiles 
For the purpose of plan sheet production using the legacy GEOPAK Plan and Profile Sheets commands, it 
is necessary to store both the existing and proposed alignments in the GEOPAK GPK file for the project. 
The profiles can then be plotted in the appropriate basemap design files by use of the GEOPAK Design 
and Computation Manager. See ODOT’s GEOPAK Road 1 training guide for more information. 
 
Using the ODOT Feature Definitions, the feature definition that is assigned to the horizontal geometry 
controls whether the proposed profile is automatically exported to the GPK file as described earlier in 
this chapter. Existing ground profiles are not automatically exported to the GPK file and must be 
manually exported. 
 
Exiting ground profiles are automatically generated from the Active Terrain when a profile window is 
opened for a particular horizontal alignment. In this exercise we will export the existing profiles for St 
Peter Road, SR 185, and Jameson Road to the GEOPAK GPK file for the project. 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_VERT_GEOMETRY 

  
 Open the design file containing the St. Peter Road horizontal alignment: 

\Design\Geopak\Basemaps\12345_BK003.dgn 
 

 Verify that the GEOPAK Working Directory is set correctly. Select GEOPAK > Road > User 
Preferences to access the User Preference dialog. Set the Working directory to the 
...\12345_VERT_GEOMETRY\Design\GEOPAK folder for the exercises in this chapter 
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 The survey information was attached as a reference in a previous exercise. Select the referenced 

terrain model and ensure that it is set as the Active Terrain from the pop-up menu. 
 

 Use the Element Selection tool to select the centerline alignment for St. Peter Road. From the 
OpenRoads pop-up menu, select the Open Profile Model command. 

 
 Open view window 2 and issue a data point (left mouse click) to select the view. The existing 

profile for St. Peter Road is displayed in the view. 
 

 Next we’ll assign a name to the profile. Use the Element Selection tool to select the existing 
ground profile. From the OpenRoads pop-up menu, select the Properties option. Assign the 
Feature Name as X_CLP_STPETER. 

 
 Lastly, we’ll export the profile to the GEOPAK GPK file. Before exporting the profile, make sure 

the GEOPAK Working Directory is defined for the project to the folder containing the GPK file. 
 

  To export the profile, choose the Tasks > Civil Tools > General Geometry > Export to Native 
command.  
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 Select the existing ground profile line. Right-Click to end the selection process 
 

 The Job Number dialog is opened. Select the job185.gpk file and choose the OK button. The 
selected profile is exported to the GPK file. 
 

Export the existing ground profile for S.R. 185 
 

 Open the following design file containing the S.R. 185 horizontal Alignment: 
..\Design\Geopak\Basemaps\12345_BK002.dgn 
 

 Set the referenced survey terrain model as the active terrain. 
 

 Open a profile view for the S.R. 185 vertical alignment. 
 

 Select the existing ground line. Choose the Properties option from the pop-up menu. 
 

 Assign the existing ground profile the Feature Name X_CLP_S185 
 

 From the Tasks menu, select the Tasks > Civil Tools > General Geometry > Export to Native 
command 
 

 Select the existing ground profile line. Right-Click to end the selection process 
 

 The Job Number dialog is opened. Select the job185.gpk file and choose the OK button. The 
selected profile is exported to the GPK file. 

 
Export the existing ground profile for Jameson Road 
 

 Open the following design file containing the S.R. 185 horizontal Alignment: 
..\Design\Geopak\Basemaps\12345_BK004.dgn 
 

 Set the referenced survey terrain model as the active terrain 
 

 Open a profile view for the Jameson Road vertical alignment. 
 

 Select the existing ground line. Choose the Properties option from the pop-up menu. 
 

 Assign the existing ground profile the Feature Name X_CLP_JAMESON 
 

 From the Tasks menu, select the Tasks > Civil Tools > General Geometry > Export to Native 
command 
 

 Select the existing ground profile line. Right-Click to end the selection process 
 

 The Job Number dialog is opened. Select the job185.gpk file and choose the OK button. The 
selected profile is exported to the GPK file. 
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6.5 Proposed Vertical Alignments 
Proposed vertical alignments can be defined by placing disjointed line and curve elements, which are 
later joined as a complex element, or by use of the Profile Complex by VPI command. A Best Fit Profile 
command is also available. 
 
Profile creation commands are available directly in the profile view window, as shown below, or from 
the task list by selecting Tasks > Civil Tools > Vertical Geometry.  
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Using CivilAccudraw in Profile Mode 

Civil Accudraw can be used to facilitate the profile creation process. When a profile window is active, the 
Civil Accudraw menu appears similar to the example below: 

 
Z 
This ordinate is used to issue a Station and Elevation to the active Vertical Geometry command. 

 
 
dZ 
This ordinate is used to issue a delta Z value from a reference point. 
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ProfileOffset 
This ordinate is used to issue profile points at a defined station and offset. The station is defined 
by the horizontal alignment. The offset is defined from the selected profile. Note, that the 
reference profile that is used for the offset value must be selected using the Civil Accudraw 
shortcut “o”. 
 
To select the reference profile, with Civil Accudraw active use 
the Tab key to shift focus to the Profile Offset field. Enter the 
“o” shortcut to define the reference profile. Select the profile 
when prompted as shown at right. 
 
Once the profile has been defined, the station and offset can 
be entered when working with the vertical geometry commands. 
The example below shows placing a profile line using the vertical geometry command Profile 
Line Between Points. 

 
Slope 
The slope ordinate is used to enter a station and slope value. 
 
In the example below, a starting point has been issued for the Profile Line Between Points 
command. The endpoint of the line can be defined at a specific station and slope from the start 
point using the Slope ordinate. 
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Exporting Proposed Profiles to the GPK File 

Similar to proposed alignments, proposed profiles are exported to the GPK file using the value of the 
Auto Export function, which is defined by the feature definition assigned to the parent horizontal 
alignment. 
 
When graphics are drawn for a proposed vertical alignment, these graphics inherit the feature definition 
that has been defined for the associated horizontal alignment. With the ODOTcadd Standards, the Auto 
Export value is set to True for vertical alignments. However, the vertical alignment is not exported to the 
GPK file until it is completed and has been assigned a Feature Name. 
 
In the example below, two profile lines were drawn using the Profile Line Between Points command. A 
vertical curve was added using the Profile Curve Between Elements command. The Profile Complex by 
Elements command is used to join the elements together as a single profile. When this command is 
processed a Feature Name is assigned to the profile and the profile is stored in the GPK file containing 
the parent horizontal alignment. 

 
Note: 
If the proposed profile is edited or deleted these changes are automatically exported to the GPK file.  
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Exercise 6B – St. Peter Road Proposed Profile 
In this exercise, we’ll define the proposed profile for St. Peter Road using individual profile elements that 
will be chained together to define the vertical geometry. 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_VERT_GEOMETRY 

 
 Open the following design file containing the St Peter Road alignmet: 

..\Design\Geopak\Basemaps\12345_BK003.dgn 
 

 Open a profile view for the St. Peter Road vertical alignment 
 

 Use the Profile Line Between Points command with Civil Accudraw to enter the tangent lines 
for the profile using the values in the table below. 
 

Station Elevation Civil Accudraw Ordinate 

17+00 Meet Existing ProfileOffset 

18+25 997.8800 Z 

19+70 995.6026 Z 

20+00 996.0826 Z 

 
Tips: 
To use the Civil Accudraw Profile Offset ordinate, use the tab key to shift keyboard focus to the 
Offset field as shown below. 

 
With focus in the Offset field, key in the “o” shortcut to 
select the profile element that will be used as the origin 
for the Station and Profile Offset values. You are 
prompted to Select a reference element. Select the 
exiting ground line for St. Peter Road. 
 

 
 

 After the vertical tangent lines have been defined, use the Profile Curve Between Elements 
command to place vertical curves with the following values: 
 

Station Curve Length 

18+25 200’ 

19+70 10’ 

 
Use the Trim/Extent Both option when defining the curves as shown on the following page. 
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 Create a complex element from the profile components using the Profile Complex By Elements 
command. Define the Feature Name for the profile as P_CLP_STPETER. Be sure to start the 
profile by selecting the first tangent line as shown below. 

 
The profile is automatically exported to the GPK. 

 
 Set the proposed profile as the active profile by selecting the profile and choosing the Set Active 

Profile icon from the pop-up menu. 
 

 Both the existing and proposed profiles should be available in the GPK file. Open the GEOPAK 
Coordinate Geometry dialog and use the COGO Navigator to verify that both profiles for St. 
Peter Road are included in the GPK file. 
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Exercise 6C – S.R. 185 Proposed Profile 
In this exercise, we’ll define the proposed profile for State Route 185. The proposed profile will be 
defined using the Profile Complex By VPI command. 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_VERT_GEOMETRY 

 
 Open the following design file containing the S.R. 185 horizontal alignment: 

..\Design\Geopak\Basemaps\12345_BK002.dgn 
 

 To enter the first VPI, select the Profile Complex by VPI command 
 

 In the Tool Settings dialog, key in the Feature Name 
P_CLP_S185 as shown at right.  

 
Store the proposed profile for S.R. 185 using the values 
shown in the table below. 

 
Note: The Curve Length values shown in the table above 
are used to define the curve at the VPI previous to the VPI 
point being entered. For example, the 700’ vertical curve 
is applied to the VPI at station 392+00 as the VPI at station 
398+00 is being defined.  

 

VPI Station Civil Accudraw Ordinate Offset/Elevation Curve Length 

1 386+25 ProfileOffset Offset = 0 0 

2 387+00 ProfileOffset Offset = 0.25 0 

3 392+00 Z Elevation = 1014.07 0 

4 398+00 Z Elevation = 998.65 700 

5 403+00 Z Elevation = 993.65 300 

6 410+00 Z Elevation = 982.17 300 

7 422+50 Z Elevation = 966.61 300 

8 426+00 Z Elevation = 964.45 400 

9 428+27.30 ProfileOffset Offset = 0 150 

 
Use Civil Accudraw with the appropriate ordinate to facilitate entering the profile points.  
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 Activate Civil Accudraw and choose the ProfileOffset ordinate 

 
 The Civil Accudraw Station and Profile Offset fields are now floating on the cursor. Use the Tab 

key to set the keyboard focus to the Profile Offset field. Key-in an “o”. The “o” shortcut is used 
to define the origin element for Civil Accudraw. 
 

 When prompted to Select a reference element or Reset to return to command, select the 
existing ground line. The existing ground line is now the reference element for entering the first 
station and offset value. 
 

 Enter the first station and offset values from the table on the previous page, as shown below 

 
 When entered, the values are locked in the dialog. Enter a data point (left mouse click) to accept 

the values. The first VPI has been defined. 
 

 Define the second VPI by entering the station and offset values shown in the table 
 

 Change the Civil Accudraw ordinate to Z (elevation) to enter the station, elevation, and curve 
length values for VPIs 3-8 

 
 Change the Civil Accudraw ordinate to ProfileOffset to define the last VPI and vertical curve. 
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 Issue a Reset (right-mouse click) when you have completed the profile definition. 
 

 The profile is automatically exported to the GPK file based on the feature definition that has 
been assigned to the horizontal alignment. 
 

 Open the GEOPAK GPK file to verify all of the profiles are contained in the GPK as shown below. 

 
 Set the proposed profile as the active profile by selecting the profile and choosing the Set Active 

Profile icon from the pop-up menu. 
 

 Save settings and exit MicroStation when complete. 
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7 Corridor Modeling 

The OpenRoads technology provides several corridor modeling and site design tools to facilitate 
generating the 3D model. Designers work primarily in 2D files to define the planametrics for the project. 
The OpenRoads technology tools automatically generate the 3D model. 
 

7.1 Corridor Modeling Commands 
The corridor modeling commands can be accessed from the MicroStation task list by selecting Tasks > 
Civil Tools > Corridor Modeling. 

 
The most commonly used commands are detailed in this training guide. See the online help for 
additional information. 
 

7.2 Corridor Modeling Design Files 
The 3D model is generated in a “KM” basemap design file. For smaller projects with only one alignment, 
it is acceptable to generate the entire model in one KM design file. For projects with more than one 
alignment, it is recommended that users take a federated approach to store each corridor model in its 
own KM design file. 
 
The ODOT_Files.mvba application is used to create design files for the project as shown in the example 
on the following page. 
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The Comments field is used to define the alignment name that is used for each corridor model design 
file. 
 
For projects with multiple corridor files, choose the Federate Basemaps option. With this option 
selected, the program will create a file named “#####_KM000.dgn” if one has not been previously 
created (see Using Multiple “Federated” Basemaps). 
 
Note: The 2D seed file is used for corridor model design files. 
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Exercise 7A – Corridor Design Files 
In this exercise we will create separate design files for the 3D model of each alignment in the project. 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_CORRIDOR_MODEL 

 
 Open the following design file for the training project: 

..\Design\Geopak\Basemaps\12345_BK002.dgn 
 

 Use the ODOT_Files.mvba application by selecting ODOT > File Management> Create Design 
Files to create the following design files for the corridor modeling process. Be sure to toggle on 
the Federate Basemaps option. 

 

File Name Comments 

12345_KM001.dgn S.R. 185 Corridor Model 

12345_KM002.dgn St. Peter Road Corridor Model 

12345_KM003.dgn Jameson Road Corridor Model 
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7.3 Templates 
In simple terms, the template is a “smart” typical section that you “push” along an alignment in order to 
create the proposed 3D model.  An example of a template for a 2-Lane undivided highway, with cut and 
fill slope options, is shown below. 

 
Templates are stored in a template library (*.itl). 
 
Templates are defined by inserting Points, Components, and End Conditions. A component is a set of 
points that define an open or closed shape. There is no limit to the number of points or components in a 
template. 
 
When the template is processed, the template points are connected between template “drop” locations 
to form the longitudinal break lines that are used to create the proposed surface.  An example of the 
longitudinal break lines plotted from a 3-dimensional design surface is shown below. 

 
Only the top template points are used to create the proposed surface mesh. Points below the surface are 
excluded from the proposed design surface. 
 
The sub-surfaces can be included in the proposed cross sections as “components” or alternate surfaces. 
These components can be used for volume calculations. 
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ODOT Template Library 

ODOT provides a sample template library in the following folder: 
..\ODOTcadd\Standards\Geopak\Road\templates\ODOTcadd_Templates.itl 

 
The templates contained in the ODOT library can be used as a starting point to define templates for 
specific projects. Many of the templates represent individual components that can be combined to 
generate the full template for a specific typical section design. For example, a template representing a 
lane of pavement can be combined with another template representing curb and gutter. 
 
The templates for each project are stored in their own project specific template library. When a new 
project is created using the ODOTcadd_CreateNewProject.exe application, the ODOT template library is 
copied into the \Design\Geopak folder for the project and renamed as follows: 
 

######_Templates.itl 
Where ###### = the 5 or 6 digit PID number for the project. 

 
The template library can be specified by a MicroStation configuration variable in the PCF file for the 
project. When a new project is created using the ODOT_CreateNewProject.exe application, the variable 
is defined in the PCF file similar to the example below: 
 

CIVIL_ROADWAY_TEMPLATE_LIBRARY = $(_USTN_PROJECTDATA)Geopak/12345_Templates.itl 
 
Template creation is a key component to the Corridor Modeling process. The designer must have a 
thorough understanding of how to create and modify template components in order to make necessary 
design-specific modifications. 
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The Create Template Dialog 

To open a template library, select the Tasks> Civil Tools > Corridor Modeling > Create Template icon. 
The Create Template dialog is opened. 

 
The dialog is split into several areas. Each area is briefly described on the following pages. See the online 
help for information not presented here. 
 

Menu Commands 
The File menu contains familiar commands for creating new Templates and new folders within 
the template library, as well as commands to save and open template libraries, 
 
The Edit menu contains commands used when editing templates such as Undo, Redo, Cut, 
Copy, Paste, etc… 
 
The Add menu contains commands to add points and components to the active template. 
 
The Tools menu contains various tools for template creation. The Options and Dynamic Settings 
menu items are described on the following page. 
 
 
 
 
Options 
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Selecting Tools > Options… displays the Template Options dialog which allows you to specify 
naming and step options for the current template. Use the Dynamic Settings dialog, detailed on 
the following page, to toggle these settings on/off as you design the template.  
 

 
 

Naming Options 
Component Seed Name 

From Feature Definition indicates, when selected, the component name 
is derived from the style specified when the component is created. 
 
Specify indicates, when selected, the component name is specified in the 
field. 
 

Point Seed Name allows you to specify the seed name for point in the current 
template. Since point names must be unique, the seed name is appended with a 
different number each time a point is created. 

 
Apply Affixes 

Indicates, when on, that affixes are applied. 
 
Left Prefix/Suffix specifies which prefix/suffix should be added to a point 
or component when the value is on the left of 0.0 (absolute). 
 
Right Prefix/Suffix specifies which prefix/suffix should be added to a 
point or component when the value is on the right of 0.0 (absolute). 

 
Step Options 
These options are used to specify precision step input for components and points. These 
values can also be accessed from the Dynamic Settings dialog. 
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X Step specifies the step increment for the X distance from the dynamic origin. If 
this value is non-zero, then the cursor moves to the horizontal increments of the 
specified value as measured from the dynamic origin. 
 
Y Step specifies the step increment for the Y distance from the dynamic origin. If 
this value is non-zero, then the cursor moves in vertical increments of the 
specified value as measured from the dynamic origin. 
 
Slope specifies the step increment for slope from the dynamic origin. If this 
value is not 0, then the cursor moves in slope increments of the dynamic origin. 
Slope is applicable only when the dynamic settings are in horizontal/slope 
mode. 

 
 
Dynamic Settings 
Select Tools > Dynamic Settings to display the Dynamic Settings dialog, which is used for precision 
input of template components and to assign point names and styles when defining components. 
The dialog can also be accessed by selecting the icon located at the bottom of the Current 
Template window as shown below. 

 
The Dynamic Settings dialog, shown below, is opened. 

 
 
X:Y/X:Slope toggles between X,Y step lock and X/Slope step lock. 
 
X Value displays the current X distance from the dynamic origin. 
 
X Step specifies the step increment.  If this value is non-zero, then the cursor moves in 
horizontal increments of the specified value as measured from the dynamic origin. 
 
Y value displays the current Y distance from the dynamic origin. 



 GEOPAK OpenRoads Technology for Civil Design March 30, 2017 

 

Chapter 7 – Corridor Modeling Page 145 

 

Y Step specifies the step increment.  If this value is non-zero, then the cursor moves in 
vertical increments of the specified value as measured from the dynamic origin. 
 
Point Name specifies the name of the point to be placed. 
 
Point Style allows you to set the style of the point. The style is used to draw feature lines 
in the plan view. For ODOT projects, the style CM_P_Feature_Line should be used as the 
default style for most template points unless you want to assign a specific style that can 
be plotted in the display view 3D model.  
 
Apply Affixes specifies, when selected, that point name affixes (prefix or suffix) are to be 
applied to the point name when placing points. The Affixes are defined on the Template 
Options dialog. 
 
The Key-in pull down is used to specify the type of key in to be performed. 
 

 XY= key in absolute coordinates 
 DL= key in delta coordinates from last point placed (defaults to the dynamic origin 

if it is the first point of a component. 
 HS= key in horizontal delta distance and slope from last point placed. 
 VS= key in vertical delta distance and slope from last point placed. 
 OL= key in delta coordinates from dynamic origin. 
 OS= key in horizontal delta distance and slope from dynamic origin. 

 
Set Dynamic Origin sets the location of the dynamic origin 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Template Library 



March 30, 2017 GEOPAK OpenRoads Technology for Civil Design  

 

Page 146 Chapter 7 – Corridor Modeling 

 

On the left side of the Create Template dialog is the Template Library area which contains a 
Windows-like folder structure. This area is used to manage the content of the current template 
library. Two tabs are supported for the Template Library area as described below. 
 

Library 
When the Library tab is selected, the Template Library 
displays the contents of the current template library in a 
familiar Windows folder structure as shown at right. The 
Template Library area also supports common Windows 
functions like drag, drop, cut, paste, etc. 
 
If you double-click a template name, it becomes the 
active template. 
 
When a template is selected from the list, the Preview 
window is used to display a preview of the template. 
 
Double-click the template name to set it as the active 
template. 
 
The ODOT category contains various components and 
end conditions that can be used to build templates for 
your project. 
 
The Project Templates category is used to create new 
templates for the active project. 
 
 
Active Template 
When this tab is selected, the Template Library area 
displays the contents of the active template as shown at 
right. 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
Current Template 
The right side of the Create Template dialog is used to display and edit the current template. 
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Name 
Shows the name of the current template 
 
Description 
Allows you to review/edit the current template description 
 
 
Display 

Components/Constraints 
This option is used to set the display mode of the template. If Components is selected, 
then the template components are displayed. If Constraints is selected, then the point 
constraints for the template are displayed. Template points are always displayed. 
 
Display Point Names 
Toggle this option on to display the template point names. 
 
Display All Components 
When this option is checked on, any components that are “hidden” are displayed with 
dashed lines. 

 
 
Current Template Window 
The Current Template Window is used to display and edit the current template. The window 
uses its own graphics engine and is not a MicroStation view.  
 
A magenta colored box is used to designate the origin of the template. 
 
At the bottom of the Current Template Window are view commands similar to the MicroStation 
view commands. 
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The two buttons that look like MicroStation View Previous and View Next commands are 
actually undo and redo commands used on template operations. The CTRL-Z keyboard shortcut 
can also be used to undo the last template operation. 
 
Within the Current Template Window you can right-click to access commonly used template 
functions. You can also double click template components for editing purposes. 
 

 

7.4 Template Points 
When the template is processed using the corridor modeling command, the points of a template are 
connected to form breakline features. Each point will be connected longitudinally to the next template 
drop location to form 3-D longitudinal breakline surface features. The breaklines are drawn using the 
symbology defined with the Feature Definition that is assigned to each point. 
 
Since the template points are connected to generate the completed surface, establishing a standard name 
for template features that are used on each template is very important to the quality of the proposed 
design surface. For example, if a pavement point is named ACSC_T_CL on the first template, and it is 
named PAVT_SURFACE on the next, the software will not automatically connect these points to generate 
the breakline feature. Following a point naming convention is important in order to obtain the best 
results with Corridor Modeling. 
 
It is equally important to ensure that the feature definition assigned to points is consistent from template 
to template. 
 
Each template point name must be unique to the template. The software automatically appends a 
number to the point name if the same name is used during template creation. 
 
There is no limit to the number of points in a template. 
 
The ODOT template library uses standards point names and feature definitions that are documented in 
the following Microsoft Excel spreadsheet: 
 

\ODOTcadd\Standards\Geopak\Road\templates\ODOTcadd_RoadwayTemplateDefinitions.xlxs 
 

 
 

7.5 Template Components 
A component is a set of points that define an open or closed shape. Each component, whether open or 
closed, can represent a different material or area of interest. Components are named and have an 
assigned feature style. There are 6 types of components as described below: 
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Simple 
A simple component typically represents a section of pavement. It’s a closed parallelogram (4 
constrained points) that is defined by the slope and thickness. 

 
Constrained 
A constrained component consists of points that are all restricted to the movement of the first 
point. A constrained point is typically used to manage the behavior of other points in the 
template. When a point (parent) is moved, any constrained point (child) also moves. This 
restriction only affects the offset and elevation (x,y) of the restrained point and the relationship 
is unidirectional (movement of child point does not move the parent point).  Fully constrained 
points are displayed with a red + symbol. 

 
Unconstrained 
An unconstrained component is open or closed-shaped with no movement restrictions. Moving 
one point has no impact on the other points that make up the component. 
 
Null Point 
A null point is a template point that is purposely not related to any particular component. It’s 
most often used as a reference for controlling other points. 
End Condition 
An end condition is a special open-shaped component that targets a surface, an elevation, or an 
alignment. End conditions are typically used to define cut and fill slope solutions. 
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Overlay/Stripping 
A specialized component type that is used for defining pavement planning and overlay 
materials. 

 

7.6 Creating Template Components 
ODOT provides an example template library that contains several commonly used components. These 
components can be used to build templates. It may also be necessary to make specialized components 
to meet specific project requirements. 
 
Components are added to the current 
template by selecting the component 
that you wish to add from the Add pull-
down menu, or by right-clicking in the 
Current Template window to access 
the Add New Component menu shown 
at right. 
 
 
 
As new components are created, the Current Component portion of the Create Templates dialog is used 
to define the Name, Style, and any other relevant parameters for the component type being created. 
 
In the example below, a simple component is created representing a single lane of pavement. 
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Before placing the component in the template, various options are available to control how the 
template is placed by right-clicking in the template window to reveal the menu shown below. 

 
Change placement Point can be used to change which component point is used as the point 
placed at the point you specify. Each time this command is selected, the placement point will 
move in a clockwise direction to the next point in the component. 
 
Mirror will create the original component as well as a mirrored component reflected 
horizontally about the template origin. 
 
Reflect will create a single component reflected about the template origin. 
 
The Mirror and Reflect options are toggles that are turned on or off and remain active. The 
on/off status of the Mirror and Reflect options is displayed at the bottom right corner of the 
Create Templates dialog. 

 
Select Set Dynamic Origin to set the location of the dynamic origin. The dynamic origin is 
indicated by the purple box in the template display window. 
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7.7 Point Names and Affixes 
When components are added to a template, the points that make up the component are named 
according to the Point Name and the Pont Style defined in the Dynamic Settings dialog (Tools > 
Dynamic Settings). The Point Name is automatically appended with the number 1, and the appended 
number is automatically incremented for each point in the component as shown in the example below. 

 
The Point Name can be keyed in or selected from the drop-down menu. When selected from 
the menu, the Point Style is automatically assigned for the point according to ODOT standards. 
 
The Apply Affixes option is used to add a user defined prefix or suffix to the point name. In the 
example below a simple component was added with the Mirror option toggled on. The prefix of 
“L-“ is applied to the points on the left side of the template. The prefix of “R-“ is applied to the 
points on the right side of the template. 

 
The affixes are defined in the Template Options dialog. 
 
Tip: As a general rule, affixes should not be applied to templates that contain individual 
components that will be used as “building blocks” for complete roadway templates. This is 
because the component may be used on either the left or right side of the template. Affixes 
should always be applied when creating completed templates for use with Roadway Designer. 
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Note that all the points of the component are named using the currently defined Point Name. In 
the example on the previous page, the points were placed using the ACSC_T_CL (Asphalt 
Concrete Surface Course Top Center Line) point name. After the component is placed, it is 
necessary to rename the points and assigned feature definitions to ensure that the points and 
3D line strings are drawn using the appropriate standards. This can be done by double-clicking 
on each point to access the Point Properties dialog shown on the following page. 
 
The Name can be typed in, or selected from the drop-down list. If the Name is selected from the 
list, the associated Feature Definition is automatically defined. The Point Properties dialog is 
covered later in this document. 
 

 
 
The points have been renamed appropriately in the example shown below. 

 

7.8 Reviewing and Editing Point and Component Names 
Point and component names can easily be reviewed and edited using the Active Template tab as shown 
below. 
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Right-click on a point or component name to reveal the 
menu shown at left. Choose Rename to rename the 
selected element. 
 
The Item and Value list, shown below the elements, is 
used to review various parameters but cannot be used 
for editing. 
 
Choose the Edit option for more editing operations. 
 
Points and components can also be edited by double-
clicking on a point or component in the template 
window. The Point Properties and Component Properties 
dialogs are covered later in this document. 
 
Note: The Feature Definition cannot be edited using the 
Active Template editing options.  
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Exercise 7B – Basic Template Creation 
In this exercise we will create a simple template consisting of only the pavement and shoulders. 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_CORRIDOR_MODEL 

 
 Open the following design file for the training project: 

..\Design\Geopak\Basemaps\12345_KM001.dgn 
 

 Select Tasks > Civil Tools > Corridor Modeling > Create Template to open the Create Templates 
dialog. 
 

 In the Template Library list, right-click on the Project Templates folder and choose the New > 
Template option. Name the new template 
Exercise7B. 
 

 Select Tools > Options to open the Template 
Options dialog. Set the parameters for the 
dialog as shown at right. 
 
 
 
 
 
 
 
 
 
 
 
 

 Select Tools > Dynamic Settings to open the Dynamic Settings 
dialog. Set the parameters as shown at right. 
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 Right-Click in the template window and choose Add New Component > Simple. A simple 
component is floating on the cursor using the default settings for the Slope, Thickness, and 
Width. 
 

 Set the parameters for the new component that will be created as follows: 
Name:  ACSC 
Feature: MD_P_Asphalt_Concrete_Surface_Course 
Slope:  -1.60% 
Thickness: 1.25”  
Width:  12 

 
 Right-Click in the template window and choose the Mirror option (Ctrl-M). The simple 

component is now mirrored and appears on both the left and right sides. The component is 
mirrored about the Dynamic Origin location.  
 

 Identify the template origin by issuing a data point at the (0,0) coordinate location in the 
template window. The component constrained to the nearest point in the grid by the Step 
values defined in the Dynamic Settings dialog. The mirrored components are shown below. 

 
Tip: You can use the XY= option in the Dynamic Settings dialog to enter the (0,0) coordinate. 

 
Take note of the point names for the components. Each point is named according to the Point 
Name parameter in the Dynamic Settings dialog. Points to the left and right of the origin are 
prefixed according to the affixes defined in the Template Options dialog shown on the previous 
page. The Point Style (feature definition) is the same for each point. It is necessary to review 
and edit the points to assign the appropriate point name and style. 
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The Point Properties dialog (documented in section 7.15 of this training guide) is used to edit 
points. 
 

 Double-click on point L-ACSC_T_CL to review and edit the properties of the point. Take the 
following steps in the Point Properties dialog: 
 

 Change the point name to ACSC_T_EP by selecting the name from the list. 

 
 When the point name is selected from the list, the corresponding Feature Definition is 

automatically assigned for the point. Verify that the Feature Definition is now set to 
MD_P_ACSC_T_EP 
 

 The point name still needs to have a prefix assigned. Add the prefix L- to the point 
name. The point name and feature definition should be set as shown below. 

 
 Select the Apply button to save the changes. 

 
 Review the remaining points to set the appropriate point Name and Feature Definition for the 

top and bottom of the pavement layer. Remember, the feature definition that is assigned to 
each point will control the level symbology for the 3D line strings that are drawn in the corridor 
model. 
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 Add a simple component for the shoulder surface to the template using the Mirror option with 
the following settings: 

Name:  ACSC-OS 
Feature: MD_P_Asphalt_Concrete_Surface_Course 
Slope:  -4.00% 
Thickness: 1.25” 
Width:  4 

 
 Edit the point names for the shoulders by double-clicking on each point to open the Point 

Properties dialog. Be sure the pick the point names from the drop-down menu list so that the 
corresponding feature definitions are assigned. When completed, the points should be named 
as shown below. 

 
 

 When complete, save your template by choosing File > Save from the Crete Template dialog 
pull-down menu. 
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7.9 Drag and Drop Component Operations 
A previously created template component can be included in the active template by use of drag and 
drop operations. Select a previously drawn component from the active template library and drag the 
component into the Current Template window. The component dynamically floats on the cursor. 
Release the mouse button to drop the component at the desired location. 
 
While dragging the component in the Current Template window, right-click anywhere in the Current 
Template window to access the placement options discussed previously (Mirror, Reflect, etc…) 
  
When connecting two components by dragging a component into the active template, the connecting 
point will change to a white colored plus sign prior to placing the component to indicate that the points 
are coincident. The point name from the previously placed component will be retained. Point names can 
be edited at any time during the template creation process. 
 
In the example below, a previously defined curb and gutter component is placed at the edge of 
pavement in the active template (New Template1) by dragging the Curb – Type 2 component and 
dropping it on the right edge of pavement point. The Mirror option is turned on, with Apply Affixes also 
toggled on, to place the curb and gutter on both sides of the pavement. 
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7.10 Component Editing 
Components are edited by double-clicking on a component to open the Component Properties dialog 
shown below, or by issuing a right mouse click on a previously drawn component. 

 
The right-click menu shown below is shown below. 

 
See the online help for details on each of these 
functions. 
 
 
 
 
 
 
 
 
 
 
 
 

 

7.11 Mouse Wheel Functions While Creating Templates 
The mouse wheel has the following functions when creating templates: 
 

 Scroll the wheel to zoom in or out in the template window. 
 

 Hold down the Shift key while scrolling the mouse wheel to zoom in or out in the vertical direction 
only. 
 

 Hold down the Ctrl key while scrolling the mouse wheel to zoom in or out in the horizontal 
direction only. 
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7.12 The ODOT template Library 
ODOT provides a template library with many template components defined that can be used as the 
starting point for creating and editing templates for your project. The template library is available in the 
following folder: 

\ODOTcadd\Standards\GEOPAK\Road\Templates\ODOTcadd_Templates.itl 
 
This template library is copied to the project when the ODOTcadd_CreateNewProjects.exe application is 
used to create the project folder structure. 
 
ODOTcadd_Templates.itl has two main folders containing the template and components as show below.  

 
Each folder is summarized below: 
 

ODOT 
This folder contains various Components and End Conditions that can be used to create 
completed templates. 

 
Backbones 
The “backbone” is defined as the pavement and shoulder portion of the template. The 
Backbones folder contains several common pavement and shoulder configurations for 
divided and undivided roadways. A variety of configurations are available for 
superelevated and non-superelevated roadways. 
 
Components 
The Components folder contains individual design components that can be used as the 
“building blocks” for a complete template. A Type 2 Curb and Gutter is an example of a 
component.  
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End Conditions 
Several end conditions are defined for cut and fill conditions according to ODOT design 
standards. 

 
Project Templates 
This is an empty folder to be used by the designer to create templates for the project. 
 

 

7.13 Basic Template Creation Workflow 
While the process to create templates will have many variables, the basic procedure to create templates 
is summarized below: 
 

 Open the template library 
 

 Create a new template or copy a template. Templates can be copied from one library to another 
by selecting Tools > Template Library Organizer from the Create Templates dialog. 
 

 Drag and drop template backbones or individual components into the active template 
 

 Create/edit the components as necessary 
 

 Merge components as desired 
 

 Review the point names and point name overrides 
 

 Review the component names and component name overrides 
 

 Test the template behavior 
 

 Save the template library 
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Exercise 7C – Create Templates from Components 
In this exercise we will assemble the template for St. Peter Road by dragging and dropping components 
from the ODOT template library. 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_CORRIDOR_MODEL 

 
 Open the following design file for the St. Peter Road corridor model: 

..\Design\Geopak\Basemaps\12345_KM002.dgn 
 

 Attach the Survey base map with a Nest Depth value of 0. 
..\Design\Survey\Basemaps\12345_BE001.dgn 

 
 Select the terrain model boundary and choose the Set As Active Terrain Model option 

 
 Attach the All Geometry base map with a Nest Depth value of 1. 

..\Design\Geopak\Basemaps\12345_BK000.dgn 
 
Next we will create a folder in the template library to contain the St. Peter Road templates. 
 

 From the Tasks menu, select Tasks > Civil Tools > Corridor Modeling > Create Templates to 
open the Create Template dialog. 

 
 Create a folder named St. Peter Road to store all the templates for St. Peter Road. Right-click on 

the Project Templates folder and choose the New > Folder option. 
 
Take the following steps to create the template for St. Peter Road: 

 
 Right-click on the St. Peter Road folder and choose New > Template to create the first template 

for St. Peter Road. Name the template “St. Peter Road”. 
 

 Open the Dynamic Settings dialog (Tools > Dynamic Settings) to define the Step increment 
values as 0.5 and 0.1. This is helpful to ensure that the initial pavement placement is constrained 
on the “grid” 

 In the Dynamic Settings dialog, turn off the Affixes option. We will drag in a pavement backbone 
that already has the left and right sides defined.  

 
 Drag the following pavement Backbone into the template at the 0,0 origin: 

 
ODOT > Backbones > Undivided Roadways > Pavement and Shoulder 301-8E Uncurbed > 2-Lane 
without Superelevation Point > Asphalt Concrete without Stabilization 
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St. Peter Road will use a pavement width of 10’. Take the following steps to define the pavement width: 
 

 Edit point L-ACSC_T_EP to define the Horizontal constraint with a value of  -10 
 

 Edit point R-ACSC_T_EP to define the Horizontal constraint with a value of  10 
 

Next we will add the end conditions to the template. 
 

 In the Dynamic Settings dialog, turn on the Affixes option 
 

 Drag the following component onto the edge of shoulder point. Right-click and use the Mirror 
option to place it on both sides simultaneously. 

 
ODOT >  End Conditions > 307-4E Common and Barrier Grading > 307-4E Cut 3:1 

 
The completed template should appear as shown below. 

 
 When complete, save your template by choosing File > Save from the Crete Template dialog 

pull-down menu. 
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7.14 Corridor Modeling Basics 
A corridor model is created by applying a template to selected horizontal and vertical geometry. The 
Create Corridor tool can be selected from the task list, Tasks > Civil Tools > Corridor Modeling > Create 
Corridor, or by the pop-up menu when a horizontal alignment is selected. 

 
When the command is selected, the software will step you through a series of prompts. These prompts 
appear on the cursor and can also be defined using the Tool Settings dialog. 

 
You are prompted to define the following parameters: 
 

Locate Profile – Reset For Active Profile 
Select the profile name from the drop down list, or issue a reset button to accept the Active 
Profile that is defined for the Horizontal Alignment. ODOT recommends using the Active Profile 
option rather than specifically choosing a profile name. 
 
Corridor Name 
Define the name for the corridor. It is recommended that you use same name as the horizontal 
alignment. 
 
Design Stage 
Design stages are used to define a variety of parameters to control the template drop interval as 
well as which elements are drawn in the 3D model (3D line strings, 3D components, surface 
meshes, etc). The design stages are defined in ODOT_DesignProjectsettings.dgnlib which is 
attached by a configuration variable. 
 
The design stages can be reviewed in the Civil Standards tab of the Project Explorer dialog as 
shown on the following page. 
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The design stage can be changed at any time throughout the corridor modeling process. 
 
Each design stage is defined to provide more detailed information as you work from conceptual 
design for the final design. The settings for each design stage are defined in the ODOT standards 
and vary for each design stage as shown below: 
 

Template Drop Interval Multiplier 
When templates are applied to the horizontal and vertical geometry, the user is 
prompted to enter a template drop interval. ODOT recommends an interval of 5. The 
Template Drop Interval Multiplier parameter is used to specify a multiplier, which is 
applied to the initial template drop interval, to determine the actual interval of each 
template drop location according to the selected design stage. This is useful to speed up 
processing for early design stages where less detailed information is required. The ODOT 
design stages have been defined with the multiplier values shown in the table below. 
 
Output Settings 
The Output Settings contain on/off toggles for the graphics that are drawn in the 3D 
model. Less information is drawn in the 3D model for the early design stages. The table 
below details the graphics drawn for each design stage. 
 

Design Stage Template 
Drop 
Interval 
Multiplier 

Create 
Top 
Mesh 

Create 
Bottom 
Mesh 

Create 
Linear 
Features 

Create 
Component 
Meshes 

Include 
Null Point 
Linear 
Features 

Planning 10 False False True True False 

Preliminary 5 False False True True False 

Design 1 False False True True False 

Final w/Meshes 1 True True True True False 
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After defining the Profile, Corridor Name, and Design Stage, you are prompted to define the Template 
Drop information as shown below. 

 
The parameters can be defined in the 
Crete Template Drop window, as 
shown at left, or by dialogs floating on 
the cursor that will step you through 
the parameters. 
 
Each parameter is defined below: 
 
 
 
 
 

 
 

Lock to Start 
Toggle this option on to lock the start of the corridor to the start of the horizontal alignment. 
 
Start 
Define the Start station for the Corridor. 
 
Lock to End 
Toggle this option on to lock the end of the corridor to the end of the horizontal alignment. 
 
End 
Define the end station for the Corridor. 
 
Drop Interval 
This parameter is used to define the interval that the template will be applied to the corridor. 
We recommend a Drop Interval of 5 for ODOT projects. 
 
The selected Corridor Design Stage includes a parameter, Template Drop Interval Multiplier, 
which impacts the Drop Interval that is applied to create the corridor. For example, the 
Preliminary Corridor Design Stage has a Template Drop Interval Multiplier value of 5. When 
the Preliminary Corridor Design Stage is used, the Drop Interval is multiplied by 5 which results 
in a template drop ever 25’. 
 
Minimum Transition Before Drop / Minimum Transition After Drop 
If they are non-zero, then a transition drop is created at the beginning/end of the template drop 
with a length greater than or equal to the value entered. The actual length is determined by 
how far it is between the new drop and the drop before/after the new drop. If there isn't 
enough space to meet the minimum, then the previous/next drop is shortened to accommodate 
the transition. If there is no previous/next drop, then no transition drop is created. 
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After defining the Create Template Drop parameters, the template is applied to the selected horizontal 
and vertical alignments to create the corridor. 
 

 A 3-Dimensional model named Design-3D is automatically created in the active design file and 
referenced to the active model. The referenced graphics are not always desirable and can be 
turned off using the MicroStation Reference Attachment tools. 
 
The 3D model can be opened and viewed as necessary. 3D Mesh elements are created for each 
component in the template. An example of the components for the shoulder and graded 
shoulder is shown below. 

 
 2-Dimensional graphics are drawn in the active model as defined by the features assigned to the 

individual points in the template. The ODOT feature definitions that are assigned to points on 
the Surface of the template are the only template features that draw these 2D plan graphics. 
 

 Graphics representing the length of the corridor model are created in the active model. This 
graphics is placed on the level CM_Corridor_Graphics and include several “handles” that can be 
easily selected to identify the Corridor Model as shown below. 
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 Graphics representing the template drop range are drawn on the level 
CM_Template_Range_Graphics as shown below. This graphic can be selected to edit or modify 
the template drop parameters. 

 
 The corridor is added to the Civil Model, which can be reviewed by selecting the Civil Model tab 

in the Project Explorer dialog. 
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 The Feature Definitions are copied from the DGN Library to the active file. The feature 
definitions can be reviewed and modified in the Civil Standards tab on the Project Explorer 
dialog. 

 
 Element Templates, which are assigned to the various feature definitions, are also copied from 

the DGN Library to the active design file. The Element Templates can be reviewed by selecting 
Element > Element Templates from the MicroStation pull-down menu. 

 
The Feature Definitions and Element Templates are copied to the file to facilitate sending the 
file to other users who may not have the ODOT workspace configured. All of the information will 
still display with the correct symbology since the Features, Levels, Element Templates, Line 
Styles, etc… are all imbedded in the file. 
 
If a Feature Definition or Element Template definition is changed in the standards, it is 
necessary to delete any Feature Definitions and Element Template definitions that have been 
copied to the design file in order for the file to read the updated standards. 
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Exercise 7D – St. Peter Road Corridor 
In this exercise we will apply a template to define a corridor for St. Peter Road. We will model the 
intersection for St. Peter Road and S.R. 185 in a later exercise. 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_CORRIDOR_MODEL 

  
 Open the following design file for the St. Peter Road corridor: 

\Design\Geopak\Basemaps\12345_KM002.dgn 

 
 Select the horizontal alignment for St. Peter Road and choose the Create Corridor command 

from the pop-up menu. Define the corridor with the following settings: 
 

Profile:   P_CLP_STPETER 
Corridor Name:  CLP_STPETER 
Design Stage:  2 - Preliminary 

 
 Use the following settings on the Create Template Drop dialog: 

Start:     17+00 
End:     19+50 
Drop Interval:    5 
Minimum Transition Before Drop: 0 
Minimum Transition After Drop: 0 
Template:    Project Templates\St. Peter Road 

 
The corridor is created as well as the 3D-Model for the corridor graphics. 
 

 Use the References dialog to turn off the display of the 3D model. This is optional, but is usually 
helpful to make it easier while working with the corridor model for subsequent operations. 
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 Change the ending station of the corridor to 19+25. This is easily accomplished by selecting the 
Template Drop graphic as shown below. The template drop Start and End locations can be 
edited by selecting the Manipulator Text and keying in a new value, or by dragging the 
manipulator arrow. The corridor is automatically updated when the new value is entered. 

 
 

 Use the MicroStation Models dialog to open the Design-3D Model. Set the view rotation to the 
Isometric view. 
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 In the 3D model, open the Level Display dialog. Sort 
the levels using the Used column to review the 
levels that are used to place the corridor graphics. 
Toggle off all the levels and then turn them back on 
one at a time to see which graphics are drawn on 
each level. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Change the view display mode to Illustration to view the rendered graphics for the corridor. 
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 Use the Rotate View command to rotate the view to review the 3D graphics. 

 
 Using the Models dialog, open the Design model. 

 
 Save Settings before exiting the design file. 
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7.15 Advanced Template Design 
The corridor modeling tools provide a lot of options that can be used to create very complex templates 
that handle a variety of design scenarios. However, care should be taken not to create overly complex 
“Franken-Templates” that can be hard to edit and even harder to diagnose when things don’t work as 
expected. It’s better to define a few simpler templates for specific station ranges than it is to define one 
overly complex template. 
 
In this section, we will take a deeper look at the available template parameters. 
 

Point Constraints 

Point constraints are used to manage the behavior of points in a template.  They are used so that if a 
point is moved in a template, either by the user editing the template or by the application of a 
horizontal or vertical control during design processing, all the points related to the point being moved 
behave in a rational and predictable manner. 
 
For example, when a Simple component is inserted into the active template, it is comprised of four 
points which are connected together to define the component as shown in the example below. 

 
Three of the four points are constrained with relation to the insertion point. If the original insertion 
point is moved, the other three points move in relation to the first point. 
 
A point can have, at most, 2 constraints on it. If two constraints are defined, the point is said to be “fully 
constrained”.  A point that is fully constrained is represented by a red plus sign. In the example above, 
points R-ACSC_T_EP, R-ACSC_B_EP, and ACSC_B_CL are fully constrained. 
 
A point that is partially constrained, meaning that it has only one constraint on it, is shown as a yellow 
plus sign. 
 
An unconstrained point is shown as a green plus sign. In the example above, point ACSC_T_CL is 
unconstrained. 
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Point constraints are two-dimensional and one-way. Two-dimensional means that the constraints can 
only affect the points offset and elevation (x and y coordinates in the cross section view). One-way 
means there is a child-parent relationship between points. In other words, if point B is constrained by 
point A, point A is said to be the parent of point B and moving point A will affect point B, but you cannot 
move point B to affect point A. The example below shows a sample of this where the blue arrow 
indicates a parent/child relationship from point A to point B: 

 
Constraints can also be labeled so that during processing, the value(s) of labeled constraint(s) may be 
changed. For example, the template may have a constraint label called ACSC Thickness that controls the 
thickness of the first pavement layer. This value can then be changed over one or more station ranges 
during the corridor modeling process. 
 
The constraints for all the points in a template can be displayed by choosing the Display Constraints option 
on the Create Template dialog. 

 
 
 
 
 
 

 
 

Constraints are displayed as blue lines between the parent and the child point. At the midpoint of the 
constraint line, there is a short white line designating the constraint type as follows: 
 

 Horizontal line = Horizontal Constraint 

 Vertical line = Vertical Constraint 

 Sloped line = Slope Constraint 
 
Multiple lines will be shown for points with two constraints. 
 
Floating the cursor over a point will temporarily display an arrow designating the direction of the 
constraint (the arrow points to the child point) and a pop-up menu displaying information about the 
point. 
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The Point Properties Dialog 

The Point Properties dialog is used to review and edit various properties associated with the template 
points, including the definition of the point constraints. To access the Point Properties dialog, in the Create 
Template dialog double-click on the point in the Current Template window. The Point Properties dialog, 
shown below, is opened. 

 
The dialog contains the following options: 
 

Name displays the point name. The point name can be keyed-in or selected from the drop-down list. 
If the point name is selected from the list, the corresponding Feature Definition is automatically 
assigned. Point names must be unique to the template. 

 
Use Feature Name Override displays the name of the feature that will be created in the surface to 
correspond to the point. This field is optional. If it is blank, then the point name will be used as the 
feature name. 

 

 The option is intended primarily for end condition components to create connectivity from one 
station to the next when the template end conditions change. For example, if you want all surface 
tie-in points to belong to one feature, then set the feature name of all the ending end condition 
points on each side of the template to the same name (i.e. all Cut and Fill end points on the right 
would be given the feature name R-Tie and all the ones on the left would be given the feature 
name L-Tie). 
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 If the point has a Feature Name Override defined, the point name is displayed in red in the 
Template window. 

 
The Superelevation Flag is used to identify the point as a candidate to be used for assigning 
superelevation control lines. This option should only be toggled on for pavement points on the 
surface of the pavement. 

 
Feature Definition is used to define the feature definition of the point. If no style is specified, then it 
comes from the first component of which the point is a member. 
 
Alternate Surface allows you to specify the name of an alternate surface for a point. You may choose 
multiple alternate surface names. Select from the list of available surfaces in the active template. 
 
Member Of indicates in which components the point is included. 

 
Constraints 
The Constraints portion of the Point Properties dialog allows you to review/edit the constraints on a 
point. 
 

Type specifies the constraint type: None, Horizontal, Vertical, Slope, Vector-Offset, Project to 
Surface, Project to Design, Horizontal Maximum, Horizontal Minimum, Vertical Maximum, 
Vertical Minimum, Angle Distance. The constraints are described in more detail on the following 
page. 
 
Setting up the appropriate constraint types is critical to achieve the desired results when 
pavement layers, superelevation, and transitioning are introduced to the design. 

 
Label displays the optional label for the constraint. Constraints that are labeled can have their 
value changed during design processing. The same label name can be assigned to more than one 
constraint and more than one point. See Section 10.4 for details. 

 
Horizontal Feature Constraint is used to allow a point to target elements in the design file that 
are defined with the specified Feature Definition within a specific Range. Use of this option is 
not recommended. 
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Point Constraint Types 

Horizontal 
The child point remains at the given horizontal distance from the parent point.  

 
In the example above, point B has been constrained to point A with one constraint as shown below. 

 
If point A is moved horizontally, 
point B will maintain its relative 
distance from point A. 
 
If point A is moved vertically, point B 
is unaffected. 
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Vertical 
The child point remains at the given vertical distance from the parent point. 

 
In the example above, point B has been constrained to point A with one constraint as shown below. 

 
 

If point A is moved horizontally, 
point B is unaffected. 
 
If point A is moved vertically, point 
B will maintain its vertical 
relationship to point A. 
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Slope 
The child point will maintain the given slope from the parent point. 

 
In the example above, point C has been defined with a Horizontal and a Slope constraint as shown 
below: 

 
Slope constraints are absolute. Slopes going from lower-left to upper-right are positive regardless of 
whether the child point is to the left or right of the parent. 

 
 

Slope constraints can also have Rollover Values 
assigned to them. Rollover values are used to set the 
slope constraint based on a High Side slope difference 
and a Low Side slope difference. A Reference Point is 
specified which defines the controlling slope to the 
parent point. 
 
Note that the Rollover Values can be used for ODOT 
projects only in cases where a shoulder break is not 
required for the high side of superelevation. 
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Horizontal Maximum  
The child point has two parent points and remains at the given horizontal distance from the parent point 
that is farthest to the right (has the maximum horizontal or X value). 
 
Horizontal Minimum 
The child point has two parent points and remains at the given horizontal distance from the parent point 
that is farthest to the left (has the minimum horizontal or X value). 
 
Vertical Maximum 
The child point has two parent points and remains at the given vertical distance from the parent point 
that is highest (has the maximum vertical or Y value). 
 
Vertical Minimum 
The child point has two parent points and remains at the given vertical distance from the parent point 
that is lowest (has the minimum vertical or Y value). 
 
Vector Offset 
The child point has two parent points and will be projected onto the vector defined by the two parents. If 
the offset is not zero, then the child point will maintain a perpendicular offset from the parent vector at 
the specified offset value. Negative values indicate an offset to the left of the vector defined by the parent 
points. Positive values indicate an offset to the right. 
 
Project to Surface 
This constraint must be used in conjunction with one of the previously define constraints. The other 
constraint will define the projection direction. The child point will then be projected to the surface with 
the name or parametric label given when the design is processed. If the surface does not exist, or no 
solution is found, then the point will remain where it is placed in the template. 
 
Project to Design 
This constraint is similar to the Project to Surface, except that the point is projected to the design surface 
of the template. A projection value is given to indicate whether the projection is to be to the left or to the 
right. The point must also be constrained by one of the previous constraints, excluding the Project to 
Surface, so that a direction for the projection may be determined. A negative value limits the projection 
to the left of 0; a positive value limits the projection to the right. A value of 0 will seek to the left and to 
the right of 0 to project the point.  If no solution is found, then the point will remain where it is placed in 
the template. 
 
Angle Distance 
This constraint takes two parent points, a distance, and an angle. The selected point is then fully 
constrained to the location defined by the first parent, and the angle from the first parent relative to the 
vector defined by the two parent points. This constraint creates a rigid-body rotation. When selected, no 
other constraints types are available. 
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Constraint Labels 

Constraint Labels can be assigned for points in your template that may have a variable value in your 
design, or a different value from one project to another. The value for the Label can be modified in the 
corridor modeling process. Assigning labels will allow your templates to be more flexible and therefore 
make them useful for more than one project. 
 
In the example below, a simple component has been created representing the Asphalt Concrete Surface 
Course for one lane of pavement. 

 
The depth of the pavement at points ACSC_B_CL and R-ACSC_B_EP has been defined as -0.1042’ as 
shown below. 

 
The thickness of the pavement can be changed by editing the template points, or by adding a Label. In 
the example above, the Label  “ACSC Thickness” has been assigned for point ACSC_B_CL and also for 
point R-ACSC_B_EP. 
 
The Label name is user definable. The same label name is used for each point in the template that will 
use the value of the label. Once a label name has been assigned, it is available to be selected from the 
drop down label list as other points are defined. 
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The value of the label can be changed in the Create Template dialog, or 
during the corridor modeling process. 
 
To change the value in the Create Template dialog, select Parametric 
Constraints in the Active Template option. The points that have been 
assigned the label are listed as shown at right. 
 
Double-click the name of the Parametric Constraint that you wish to edit. 
The Edit Default Parametric Value dialog show below is opened which 
allows you to edit the value. 

 
The template graphics are automatically update to reflect the new value. 
 
 

Editing Points with the Right-Click Menu 

In addition to the Point Properties dialog, points can be edited from a pop-up menu that is accessed by 
right-clicking on a point in the Active Template window. The menu is shown below. 

 
Some of these commands are covered later in this training guide. See the online help for documentation 
of commands not covered in this document. 
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Adding Components to the Template 

A component is a set of points that define an open or closed shape. 
 
When defining new components using precision input, the sign of the distance is dependent on the 
parent-child relationship of the points. The parent is always the first point placed when creating 
template components. The following rules apply: 
 

 A child placed to the right of the Parent point is at a positive distance 
 A child placed to the left of the Parent point is at a negative distance 
 A child placed above the Parent point is at a positive distance 
 A child placed below the Parent point is at a negative distance 
 The Slope is the algebraic slope 

 
There are six types of components: 
 

 Simple 
 Constrained 
 Unconstrained 
 Null Point 
 End Condition 
 Overlay/Stripping 

 
Each component type is described in further detail on the following pages. 
 
As you add components to your template, the area under the active template window is used to display 
various parameters for the component. This is called the Current Component area. 
 
Right-click in the current template window at any time during the component creation process to access 
the menu shown below: 

 
Select Finish when you have completed creation of the component. 
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Creating Simple Components 

A simple component consists of four points defined by Slope, Thickness, and Width.  The top points are 
constrained by Horizontal and Slope constraints. The lower points are constrained to the points directly 
above them by a Horizontal and Vertical constraint. 
 
To create a simple component, right-click in the active template window and select Add New 
Component > Simple, or select Add > Simple from the pull down menu of the Create Template dialog to 
initiate the command. 
 
Define the Name, Slope, Thickness, Width, and Feature of the component before placing the 
component in the template. 
 
The Feature is used to set the symbology for the graphics drawn to represent the component in the 3D 
model. 

 
The Dynamic Settings dialog is used to facilitate component placement. The point names are derived 
from the Point Name selected in the Dynamic Settings dialog. Each point is appended with a number 
that is incremented. The points are assigned the Point Style feature that is active in the Dynamic 
Settings dialog. 
 
Point names and the feature that is assigned to each point should be reviewed and edited after the 
component is placed. 
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Creating Constrained and Unconstrained Components 

Constrained or Unconstrained components can be used to create any open or closed shapes in the 
template such as curb and gutter, median barriers, retaining walls, or complex pavement situations such 
as the shoulder break on the high side of superelevation. 
 

Constrained Components 
To create a constrained component, right-click in the current template window and select Add 
New Component > Constrained, or select Add > Constrained from the pull down menu of the 
Create Template dialog to initiate the command. 
 
When constrained components are created, both horizontal and vertical constraints are applied 
to each point. 
 
Unconstrained Components 
To create an unconstrained component, right-click in the current template window and select Add 
New Component > Unconstrained, or select Add > Unconstrained from the pull down menu of 
the Create Template dialog to initiate the command. 
 
When unconstrained components are created, no constraints are applied. This option is useful 
when you wish to define constraints other than Horizontal and Vertical constraints. 

 
The Dynamic Settings dialog can be for precision input when creating the component. In the example 
below, point ACSC_T_EP will be created at a defined horizontal distance and slope from point 
ACSC_T_CL using a horizontal distance of 12 and a slope of -1.6% by using the hs=12 option with a value 
of 12,-1.6%. Use the Enter key to execute the command. 
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Right-click in the current template window at any time during the component creation process to access 
the menu shown below: 

 
 Select Finish when you have completed creation of the component. 

 

 Components can be created as open or closed shapes. To toggle on/off the option to placed 
closed shapes, select Closed Shape. 

 

 Select Mirror to create two components at the same time. The second component is a mirror 
image of the one you are defining. The component is mirrored about a vertical line passing 
through the Dynamic Origin location. 

 

 Select Undo Last to undo the last point that was added to the component. 
 

 Select Cancel to terminate the component creation process. 
 

 Select Set Dynamic Origin to specify the location of the dynamic origin. 
 
 

Null Points 

A null point is a template point that is purposely not related to any particular component. It’s most often 
used as a reference for controlling other points. 
 
To create a null point, right-click in the current template window and select Add New Component > Null 
Point, or select Add > Null Point from the pull down menu of the Create Template dialog to initiate the 
command. 
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Testing Point Controls 

The behavior of fully constrained points can be tested by right-clicking on the point and selecting Test 
Point Controls as shown below. 

 
Select the desired option to test the behavior of a template as the point is moved either horizontally, 
vertically, or both at the same time.  
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ODOT Standard Point and Component Names and Features 

As you create templates, each point and component in the template is assigned a Name and a Feature 
Definition. It is important to ensure that the points and components are named and assigned features 
consistently in each template. 
 
Feature definitions for template points and components are defined in ODOT_Features_Design.dgnlib, 
which is attached by a configuration variable. These features can be reviewed in the Project Explorer 
dialog by selecting the Civil Standards tab as shown below. 

 
Template points are used to create 3D linear features in the corridor model. The 3D Linear Features 
category contains the feature definitions that are applied to template points. 
 
Template components are used to create 3D surfaces in the corridor model. The 3D Surface Features 
category contains the feature definitions that are applied to template components. 
 
The features are also detailed in an Excel Document in the ODOTcadd Standards. See the following 
document: 
 

\ODOTcadd\Standards\Geopak\Road\templates\ODOTcadd_RoadwayTemplateDefinitions.xlsx 
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Point Names and Features 
As the template is applied to the corridor, 3D line strings are drawn in the design file by connecting the 
points from template drop to template drop by their Name. The symbology of these line strings is 
controlled by the Point Style (aka Feature Definition) that is assigned to each point. 
 
The ODOT workspace for OpenRoads includes several Feature Definitions that can be used for template 
points. 
 
Features can be reviewed and assigned in a variety of ways. 
 

 We have already discussed the Point Properties dialog which is accessed by double-clicking the 
point in the Current Template window. The Name and Feature Definition can easily be edited 
using this dialog. 

 
 The Dynamic Settings dialog can be used to define the Point 

Name that will be assigned to points as they are created. 
The Point Name field can be used to key-in a name for the 
point or to select a name from a predefined list as shown at 
right. It is recommended that you use the point names from 
this list when designing your templates. 

 
When a point name is selected from the list, the Point Style, 
which is the Feature Definition, is automatically set to the 
appropriate value. The Point Style list contains a list of all 
the Feature Definitions available in the ODOTcadd 
workspace. 

 
 Features can also be assigned to one or more points by selecting Tools > Apply Feature 

Definition to Points from the Create Template dialog as shown below. 
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Component Names and Features 
Component Names and Features are defined as each component is created. The available features 
within the ODOTcadd workspace can be reviewed in the Civil Standards tab of the Project Explorer 
dialog as shown at right. 
 
Component Names and Features can be 
reviewed and edited in a variety of ways: 
 

 Double-click on a component to open 
the Component Properties dialog. 
 

 Select Tools > Apply Feature Definition 
to Components… to apply a selected 
Feature Definition to one of more 
components in the template. 
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7.16 End Conditions 
An end condition is a special open-shaped component that targets a surface, a feature of a surface, an 
elevation, or an alignment.  End Conditions are commonly used for cut and fill definitions. End 
Conditions are added to the end of simple, constrained, or unconstrained components. 
 
To create an end condition, right-click in the template window and select Add New Component > End 
Condition, or select Add > End Condition from the Create Template dialog’s pull down menu. 
 
When adding an end condition to the current template, the Current Component portion of the Create 
Template dialog displays the following options: 

 
The Name field is used to specify the user defined name for the component. 
 
The Feature is used to set the feature definition for the component. 
 
Target Type specifies the type of target the End Condition is seeking. Targets include: 

 Terrain Model – Seeks an OpenRoads Terrain Model 
 Elevation – Seeks a particular elevation 
 Linear Horizontal/Vertical/Both – Seeks the intersection with a particular linear element 

selected from a list. 
 Feature Definition Horizontal/Vertical/Both – Seeks the intersection with a particular feature 

type. 
 
Horizontal Offset specifies a horizontal offset from the target. This option only applies if the target is a 
horizontal target, or has a horizontal aspect. 
 
Vertical Offset specifies a vertical offset from the target. Applies only if the target is a vertical target or 
has a vertical aspect. For an elevation target, specify the elevation here. 
 
Priority specifies the order in which end conditions are attempted in seeking a solution. Where more 
than one End Condition starts at the same point, this value determines the order in which End 
Conditions are attempted to find a solution. Lower numbers, which have a higher priority, are 
attempted first. 
 
Benching Checkbox indicates, when on, the set of segments of the End Condition are repeated until a 
solution is found. 
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Benching Count indicates the maximum number of times that benching should occur. If this 
value is 0, then the repeat count is unlimited, and the benching End Condition must find its 
target for it to be valid. If any other number is entered, then if the benching is repeated for the 
specified count and if the target is not reached, the benching End Condition will still be 
considered successful if an End Condition attached to the end of the benching End Condition is 
successful. 
 
From Datum indicates, when on, the benching will use a datum elevation and step elevation to 
set the benching rather than using the End Condition segments as they are defined. 

 
Datum Elevation specifies the elevation that represents the basis for the step elevation. Datum 
+ Current bench elevation = n * Step Elevation. 
 
Step Elevation specifies the increment for benching when a datum is being used. Each bench 
elevation is always located at the end of the first segment (or the second point) of the benching 
End Condition. 

 
Rounding Length specifies the length used to round the end condition. When this value is something 
other than 0.0, 4 additional points are added to the end of the end condition using a parabolic formula 
to smooth out the transition of the intersection of the end condition with the surface. This rounding 
effect is only applied when the target is a terrain model or an elevation. Any other end conditions 
attached to the end of this one is attached to the end of the rounded section. 
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End Condition Point Properties 

As you are defining points for an end condition, the Dynamic Settings dialog includes additional options 
for the point definition as shown below. 
 

 

Check for Interception specifies the preceding segment will 
be checked for interception of the target when the end-
conditions are solved. If it is turned off, then the segment 
will be ignored when checking for interceptions. 
 
Place Point at Interception specifies that when an 
interception is found along the preceding line segment, the 
line segment will be drawn to the interception. Otherwise, if 
the interception is found, the line segment will be drawn to 
its maximum width. 
 
End Condition is Infinite specifies the last segment will be 
considered to be of infinite length when attempting to 
intercept the target. This option is applicable only to the last 
point on the end condition. 
 
Do Not Construct specifies the point will be solved like all 
other points in the end-condition, but the point will be 
skipped when drawing the component segments. 

 
These end condition point properties can be edited in the Point Properties dialog. Double click on an end 
condition point to review or edit the properties. 
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End Condition Priority 

The end condition priority value is used when more than one end condition is defined starting at the 
same point. A simple end condition consisting of two fill lines is shown in the example below. 

 
When the end condition is processed in corridor modeling, each end condition will be tested in the 
order specified by the user. The order is determined by the Priority value entered by the user during the 
end condition creation. The most desirable solution, and the first condition to be tested, is given a 
priority value of 1. 
 
Double-clicking on a component will open the Component Properties dialog shown below. If the 
component is an end condition, the End Condition Properties are displayed. The Priority is set as shown 
below. 
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The properties for point R-EC_FSLP were 
defined as shown at right. Check for 
Interception is toggled on and End Condition 
is Infinite is toggled off. The point is defined 
with a -33.33% Slope for a vertical distance 
of 16.0’ from the graded shoulder point R-
EC_GSH1.  
 
The properties for the point R-EC_FSLP1 
were defined to specify a 2:1 slope with the 
End Condition is Infinite option toggled on. 
The priority for the end condition component 
R-FILL_2 is set to a value of 2. 
 
With these settings, the end condition R-
FILL_3 will be tested first (Priority=1) for an 
interception with the surface within the 
vertical distance of 16.0’. If an interception is 
found within the vertical distance, the end 
condition is used for the cross section and a 
point will be placed at the interception. 
 
If no interception is found within 16.0’ vertically 
from point R-EC_GSH1, the condition fails and the software will test the next end condition, R-FILL_2, 
which has a Priority value of 2. 
 
Since End Condition is Infinite is toggled on for point R-EC_FSLP1, the solution will solve for an 
interception with the surface regardless of the vertical constraint definition. 
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Testing End Conditions 

End conditions can be tested in the Create Template dialog before processing the template with corridor 
modeling. Testing simulates how the end condition will behave when the corridor is processed. 
 
This is extremely useful for complex end condition definitions with multiple solutions. To test the end 
condition, select the Test command, located below the Current Template window. The Test End 
Conditions dialog is opened. 

 
The software will check for conflicts in the priorities defined in the template before opening the Test End 
Condition dialog. If conflicts exist, a warning is issued. 
 
The dialog displays the current template. Non-solved end conditions, and their child components, are 
displayed in dashed lines. Normal components and solved end conditions are displayed as solid lines. 
 
To test the end condition, select one of the available targets and then select the Draw button. Move 
your cursor over to the testing window. The end conditions will change from a dotted line to a solid line 
indicating the solution for the target interception. 
 

Failure Report activates the Results dialog. When you fail to get a solution on one or both sides, 
the results show which components failed and which end condition start points were not solved. 
 
Check Priorities tests the template for priority conflicts. When conflicts exist, a message is 
displayed indicating there are end conditions that start from the same point and have the same 
priorities. The End Condition Priority Conflicts dialog is displayed. If no conflicts exist, a message 
box indicating no conflicts is displayed. 
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Available Targets lists all of the targets applicable to the current template. You can select the 
desired target and draw it in the display. 

 
Use Surface Slope specifies the slope of the surface that is being placed. This is useful in certain 
instances where an end condition intersects a surface more than once, such as a ditch profile. 

 
Draw draws the selected target. Surfaces and elevations are drawn as horizontal lines. Features 
and alignments are drawn as a “+” mark. As you draw a target, the display dynamically updates 
to show the solution(s). 
 
Reset clears all the drawn targets. 

 
Display Rules list the display rules for the current template. Left-click the Value to toggle 
between True and False. Press the Reset button to restore the original Display Rules values. 
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7.17 Component Properties 
The properties of the component can be edited by double-clicking on the component. The Component 
Properties dialog is opened. 

 
Name 
Specifies the name of the current component. Select a different component using the locate 
button. 
 
Use Name Override 
The name override is used to specify the name used by the software to connect components 
from one template drop location to the next. 
 
The option is intended to create connectivity from one station to the next when the template 
components change. For example, a template may contain more than one solution for a fill 
condition as shown below.

 
Two end conditions are defined for the fill slopes named R-FILL2 and R-FILL3. When the 
templates are processed, the software will evaluate each template drop location to determine 
whether the R-FILL2 or the R-FILL3 component is used. 3D Mesh elements are created by 
connect all the components by the name of the component. All of the components named R-
FILL2 will be connected to create 3D Mesh element, and all of the components named R-FILL3 
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will be connected to create another mesh element.  This leaves a gap in components at the 
locations where the fill slope transitions from 3:1 to 2:1 since the components named R-FILL3 
will not be connected to the components named R-FILL2. The solution is to assign the same 
Override Name for each component. 
 
Description 
Specifies an optional description of the component. 
 
Feature Definition 
Specifies the feature style of the component. This option is used for display and also to define 
the component’s material. ODOT has defined a specific group of styles to be used for 
components prefixed with the word “Component”. When the components are plotted in 
MicroStation, either as a 3D model, or as cross sections, the symbology defined by the selected 
Style is used.  Care should be taken to select the appropriate style for each template 
component. 
 
Parent Component 
Specifies the parent component. If a component has a parent component, then it is only 
displayed if the parent component is displayed. The parent component can be either a non-end 
condition component, or an end condition component. Specify the component or identify it 
using the locate button. 
 
The Active Template listing can also be used to display 
and edit the parent child relationship between points 
and components. In the example at right, the 
Components category is open to show the parent/child 
relationship between the components in the tree. Drag 
and drop operations can be used to move one 
component under another. 

 
Note:  The component names are listed alphabetically, 
not from top to bottom as drawn in the template. 
 
Exclude from Top/Bottom Mesh 
Specifies that the component will be excluded from the top and bottom mesh elements that are 
created in the corridor modeling process. 
 
Close Shape 
This option is only available for non-End Condition components. Only closed shapes can be used 
to compute component quantities. 
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Exercise 7E - Creating and Testing End Conditions 
In this exercise, you will create a simple cut end condition with a 3:1 foreslope and a 2’ ditch. The 
backslope will contain two end conditions, a 3:1 slope and a 2:1 slope as shown below. 

  
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_CORRIDOR_MODEL 

 
 Open the following design file for the training project: 

..\Design\Roadway\Basemaps\12345_KM002.dgn 
 

 From the Tasks menu, select Tasks > Civil Tools > Corridor Modeling > Create Templates 
 

 Create a new template named Normal Ditch in the Project Templates folder. 
 

 Open the Dynamic Settings dialog and select the Point Name to “EC_HINGE” from the list. The 
Point Style is automatically set. Set the Step values as desired. Uncheck Apply Affixes. 
 

 Add an End Condition for the graded shoulder 

 Right-click in the template window and choose Add New Component > End Condition. 

 Start the End Condition at coordinate 0, 0 (xy=0, 0). 

 Name the component “GSH1” 

 Use the Feature “MD_P_Graded_Shoulder” for the component 

 Be sure to check off Check for Interception in the Dynamic Settings dialog after placing 
the first point. 

 Change the Point Name in the Dynamic Settings dialog to “EC_GSH1” After placing the 
first point but before placing the second point. By choosing the name from the list, the 
Feature Definition is automatically assigned. 

 Place the second point 6’ horizontally from the first point at a slope of -8% (hs=6, -8%) 

 Right click and select Finish. 
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 Add an End Condition for the ditch foreslope. 

 In the Dynamic Settings dialog, select the Point Name EC_FSLP. 

 Right-click in the template window and choose Add New Component > End Condition. 

 Name the component “3:1 Foreslope” 

 Use the Feature “MD_P_Foreslope” for the component 

 Create the component with a vertical constraint of -1.5 at a 3:1 slope (vs=-1.5,-1:3) from 
the point EC_GSH1. Be sure to check off Check for Interception in the Dynamic Settings 
dialog after placing the first point. 

 Right click and select Finish. 

 Double click on the 3:1 Foreslope End Condition and set the Parent component to GSH1. 
Hit Apply. 
 

 Add an End Condition for the 2’ ditch bottom. 

 In the Dynamic Settings dialog, select the Point Name EC_DITCH. 

 Right-click in the template window and choose Add New Component > End Condition. 

 Name the component “DITCH” 

 Use the Feature “MD_P_Ditch” for the component 

 Create the component with a horizontal constraint of 2.0 and a vertical constraint of 0 
(dl=2,0) from the point EC_FSLP. Be sure to check off Check for Interception in the 
Dynamic Settings dialog after placing the first point. 

 Right click and select Finish. 

 Double click on the DITCH End Condition and set the Parent component to 3:1 
Foreslope. Hit Apply. 

 
Next we’ll define two end conditions for the backslope. 

 In the Dynamic Settings dialog, select the Point Name EC_BKSLP 
 Right-click in the template window and choose the Add New Component > End Condition 

option. 
 Name the end condition “3:1 Backslope” 
 Set the Feature for the end condition to “MD_P_Backslope” 
 Create the component with a vertical constraint of 5’ at a 3:1 slope (vs=5,1:3) from the point 

EC_DITCH. Be sure to check on Check for Interception in the Dynamic Settings dialog after 
placing the first point. 

 Right click and select Finish. 
 Double click on the 3:1 Backslope End Condition and set the Parent component to DITCH. Hit 

Apply. 
 

Add a second End Condition for the 2:1 backslope using the settings detailed below. 
 In the Dynamic Settings dialog, select the Point Name EC_BKSLP 
 Right-click in the template window and choose Add New Component > End Condition. 
 Name the end condition “2:1 Backslope” 
 Set the Feature for the end condition to “MD_P_Backslope” 
 Set the component Priority to 2 
 In the Dynamic Settings dialog, toggle on the Check for Interception and End Condition is 

Infinite options (options not available until the first point of the end condition is placed).  
 Create the component with a vertical constraint of 5’ at a 2:1 slope (vs=5,1:2) from the point 

EC_DITCH 
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 Right click and select Finish. 
 Double click on the 2:1 Backslope End Condition and set the Parent component to DITCH. Hit 

Apply. 
 
Next we’ll review the point names and feature styles, as well as the Override names for the points and 
components. 

 Double-Click on the point EC_BKSLP to make the following change: 
 Toggle on the Use Feature Name Override option and enter an override name of 

“BKSLP” and change the name to “EC_BKSLP3” then hit Apply. 
 Double-Click on the point EC_BKSLP1 to make the following changes: 

 Toggle on the Use Feature Name Override option and enter an override name of 
“BKSLP” and change the name to “EC_BKSLP2” then hit Apply. 

 
Review the component properties for the backslope components to set the override name. 
 

 Double-click the 2:1 Backslope component. Toggle on the Use Name Override option and set 
the override name to “Backslope” 
 

 Double-click the 3:1 Backslope component. Toggle on the Use Name Override option and set 
the override name to “Backslope” 

 
The completed template should appear as shown below. 

 
 Use the Test option to ensure that the backslope components behave as intended. The 3:1 

backslope should solve first for backfills up to 5’ high. The 2:1 solution should solve for 
backslopes greater than 5’. 
 

 When complete, choose File > Save from the Create Template dialog to save the changes to the 
template library. 
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7.18 Corridor Editing Tools 
Select one of the corridor handles, as shown below, to access a menu of common corridor commands. 

 
The commands in the menu are grouped as follows: 
 

 Properties 

 Corridor Views 

 Reports 

 Corridor References 

 Corridor Creation Tools 

 Lock – Deactivate Rule 

 Delete 
 

These commands are also available in the MicroStation task list by selecting Tasks > Civil Tools > 
Corridor Modeling. 
 
Commonly used commands are detained in this training guide. For additional information, see the 
online help. 
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Corridor Properties 

Select Properties from the corridor pop-up menu to access the dialog shown below. 

 
With the exception of the Horizontal Name, the corridor parameters shown above can be edited in the 
properties dialog. This dialog is most commonly accessed to change the profile used for the corridor or 
the Design Stage. 
 

Corridor Views 

The Corridor Views icon has one command, Open Cross Section Model. This command is used to create 
a dynamic cross section view to review the model by scrolling through cross sections. 
 
When selected, you are prompted to Open or Select View for the cross section display. In the example 
below, View 2 was selected to display the dynamic cross sections. 

 
This dynamic view is a temporary display of the cross sections. The sections are not written to the design 
file using this command. 
 
 
 



 GEOPAK OpenRoads Technology for Civil Design March 30, 2017 

 

Chapter 7 – Corridor Modeling Page 207 

 

Reports 

The Reports icon provides access to the following four reports: 
 

 Corridor Component Quantities 

 Design Input Report 

 Results Report 

 Milling Report 
 
These reports are detailed in the online help. 
 
The Corridor Component Quantities report is used to generate a quick cost estimate for the selected 
corridor by assigning a Unit Cost for each component in the corridor templates. 

 

Corridor References 

The following four Corridor References commands are available: 
 

Add Corridor Reference 
This tool is used to add graphical elements to the corridor processing. This must be done when a 
Feature is targeted in the template definition. This enables the software to process only the 
identified elements which speeds up processing. For example, if the template targets a right-of-
way line, the right-of-way lines must be included as a Corridor Reference in order for the 
template to find the lines. 
 
Remove Corridor Reference 
This tool is used to remove graphical elements from the corridor processing. 
 
Add Clipping Reference 
This command is used to remove areas of overlap when working with multiple corridors. For 
example, in a corridor intersected by a crossing roadway, clipping is used to remove overlapping 
features within the intersection. 
 
Remove Clipping Reference 
This tool is used to remove any clipping references defied for a corridor. 
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Process Corridor 

Select this icon to reprocess the corridor. 
 

Lock – Deactivate Rule 

This command can be used to temporarily deactivate processing rules on the corridor. This is useful 
when making edits so that the corridor does not automatically update as the edits are made. Once the 
edits have been completed, the rules can be turned back on and the corridor reprocessed. 
 

Delete 

Select this command to delete the corridor. 
 

Corridor Creation Tools 

The Corridor Creation Tools menu contains commonly used corridor commands. The tools are listed 
below. These tools are detailed on the following pages. 

 
 

Corridor Objects 
 
Create Template Drop 
 
Create Transition 
 
Create Secondary Alignment 
 
Define Target Aliasing 
 
Create Parametric Constraint 
 
Create End Condition Exception 
 
Create Point Control 
 
Create Curve Widening 
 
Key Station 
 
Assign Superelevation to Corridor 
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Corridor Objects 

This option is a one-stop shop to view, create, and edit corridor objects. Most of the options contained 
in the Corridor Creation Tools can be accessed from this dialog as shown below. 

 

Create Template Drop 

This tool is used to create a new te mplate drop location on the corridor. 

Create Transition 
A transition is created between templates of different names, as templates generally don't instantaneously 
change from one template to another. This tool creates the transition by selecting the two templates drops 
which are adjacent to it. Once the transition location is created, it is up the user to define how the transition 
is applied. 
 
See the online help for more information. 

Create Secondary Alignment 
Secondary alignments are used to modify the direction of cross section processing. By default, at any given 
station, the cross section is created orthogonal to the main alignment. If a secondary alignment exists, then 
that portion of the cross section which lies outside the secondary alignment will be orthogonal to the 
secondary alignment instead of the main alignment. 
 
See the online help for more information. 

Define Target Aliasing 
Target aliasing allows you to target other corridor surfaces or features or to set up a prioritized target list for 
end condition solutions on surfaces, features and alignments. 
 
See the online help for more information. 
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Create Parametric Constraint 

Parametric constraints can be used to change one or more labeled constraint values of a template while 
the template is being processed in the corridor modeler. 

 
In the example at left, the Constraint Label “ACSC 
Thickness” is assigned in the template for the Vertical 
constraint of the Asphalt Concrete Surface Course point. 
The Parametric Constraint can be used to define a new 
value for a specified station range. 
 
 
 
 
 
 

 

Create End Condition Exception 

End Condition Exceptions are used to modify the behavior of an end condition solution without 
requiring the use of additional template drops. When an end condition exception is added, it must be 
edited to change its behavior. End condition exceptions come in two classes: 
 

 Overrides allow you to replace or override the template drop end conditions on the left or right 
of the backbone. When you choose this option, you must edit the override to set up the new 
end condition. When the override exception is edited, the Create Template dialog is displayed 
allowing you to edit the end-condition. 
 

 End condition Transitions are used where the end condition may change suddenly due to 
changes in the existing surface or other reasons, and you want the transition to be smooth over 
a specified station range rather than a sudden change over a short length. 
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Create Point Control 
Point controls are used to override the normal locations of one or more points and or components in a cross 
section. Examples of this include lane widening, staying within the right-of-way, or maintaining a particular 
slope for a ditch. 
 

 
 

Create Curve Widening 

Curve widening is used to automatically create and apply horizontal controls to widen lane and/or edge 
of pavement lines around curves, moving them further away from the centerline at each curve of the 
controlling alignment. The tool is used in conjunction with an ASCII file (*.wid) which contains 
parameters to define the widening. 
 
Curve widening is defined in the Location and Design Manual, Volume 1 Roadway Design, Section 
301.1.3 Travelled Way Widening on Highway Curves. 
 
ODOT does not provide curve widening tables at this time. Use Point Controls to manually assign the 
station ranges and offsets for curve widening. 
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Key Station 
This command is used to add stations that are not coincident to the template interval to the corridor 
processing. For example, a key station can be added at a drive or culvert location to ensure the template is 
processed at that station. 
 

 

Assign Superelevation to Corridor 

Superelevation is covered in the next chapter. 
 

Processing Order for Point Overrides 

As you can see, there are several ways in the corridor processing to override the template definition for 
various constraints using Parametric Constraints, Point Controls, and Horizontal Feature Constraints. 
 
This is generally the order in which OpenRoads solves the location of points and components at each 
template drop: 
 

1. Template is dropped, and points are placed according to the point constraints stored in the 
template. 

2. Parametric constraints are applied as defined in the template, and in the corridor. 
3. Horizontal Feature constraints are applied to move points if the feature is found in the specified 

range. 
4. Point controls are applied to the assigned points, overriding the corresponding constraint, and 

all points that are constrained back to the point controlled point will be recalculated. 
5. Component display rules are solved based on the current position of all points. 
6. End conditions are solved by extending designated segments along the specified slope to seek 

their targets. 
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Exercise 7F – Point Controls: Horizontal 
In this exercise we will create a template and corridor for State Route 185. We will use Point Controls to 
taper the lane width at the beginning of the project and to define curve widening for the spiral-curve-
spiral in S.R. 185. 
 

Part 1: Creating the S.R. 185 Template 

In this exercise we will create the template for S.R. 185 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_CORRIDOR_MODEL 

 
 Open the design file for the S.R. 185 Corridor Model: 

..\Design\Geopak\Basemaps\12345_KM001.dgn 
 

 From the Tasks menu, select Tasks > Civil Tools > Corridor Modeling > Create Template 
 

 In the Project Templates folder, create a new folder named “S.R. 185” to house the State Route 
185 templates 
 

 In the S.R. 185 folder, create a new template named “S.R. 185” 
 

 Open the Dynamic Settings dialog to ensure the Step values are defined as desired. 
 

  Create the S.R. 185 template by dragging in the components listed below. Be sure to pay 
attention to the Apply Affixes setting and turn it on when dragging in the end conditions. 
 
ODOT > Backbones > Undivided Roadways > Pavement and Shoulder 301-8E Uncurbed > 2-Lane 
without Superelevation Pont > Asphalt Concrete without Stabilization 
 
ODOT > End Conditions > 307-4E Common and Barrier Grading > 307-4E 3:1 Cut, Fill Table 
 

 After dragging in the end conditions, we will remove some of the options. For this project, we 
only want to use fill slopes of 3:1 or 2:1. Remove the following components: 
 
There are two different Graded Shoulder components in the end condition on each side of the 
template. The components R-GSH1 and L-GSH1 are used when the 6:1 slope is used. Remove 
these two components by right-clicking on the component and choosing the Delete Component 
option. Since these two graded shoulder solutions overlap, you are prompted to select the 
component you wish to delete as shown on the following page. Remove the R-GSH1 and L-GSH1 
components. The 6:1 slope component is also removed since it has been defined as a “child” 
component of the graded shoulder 1 component. 
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 Delete the 4:1 fill slope component on each side of the template. The completed template 

should appear as shown below. 

 
 From the Create Template dialog, choose File > Save. Close the Create Template dialog. 
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Part 2: Create the S.R. 185 Corridor Model 

In this exercise we will create the corridor for State Route 185 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_CORRIDOR_MODEL 

 
 Open the design file for the S.R. 185 Corridor Model: 

..\Design\Geopak\Basemaps\12345_KM001.dgn 
 

 Attach the following design files as references: 
 

Geometry Basemap 
..\Design\Geopak\Basemaps\12345_BK000.dgn 
 
Be sure to set the Nest Depth parameter to a value of 1 when attaching the geometry 
basemap. 

 
Survey Basemap 
..\Design\Survey\Basemaps\12345_BE001.dgn 
 
Set the Nest Depth parameter to No Nesting when attaching the survey basemap. 

 
 Select the terrain model boundary and choose the Set As Active Terrain Model option 

 
 Select the State Route 185 alignment and choose the Create Corridor command from the pop-

up menu. Create a corridor named CLP_S185 using the Active Profile, and the Preliminary 
Design Stage. Use the parameters below and the S.R. 185 template created in the previous 
exercise. 
 

Start Station: 386+25 
End Station: 428+27.30 
Template Drop Interval: 5 

 
When a federated approach is used to create separate design files for each corridor model (see Using 
Multiple “Federated” Basemaps) users should add the corridor design file as a reference to the 
“KM_000” design file. 
 

 Open the file 12345_KM000.dgn 
 Verify that the corridor design file is pre-attached and displayed. If the file is not attached, 

manually attach the KM001 design file containing the State Route 185 corridor 
 Save settings and close the 000 file when complete 
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Part 3: Adjusting the Lane Width to meet Existing Pavement 

In this exercise we will use Point Controls to taper the lane widths at the beginning of the project to tie 
in to the existing pavement. 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_CORRIDOR_MODEL 

 
 Open the design file for the S.R. 185 Corridor Model: 

..\Design\Geopak\Basemaps\12345_KM001.dgn 
 

 From the Tasks menu, select Tasks > Civil Tools > Corridor Modeling > Create Point Control 
 

 When prompted, select the corridor for S.R. 185 
 
We will define the taper for the point R-ACSC_T_EP using the settings shown below. 

 
 The Control Description is a user definable name for the point control definition. 

 The Mode for this example is Horizontal as we are only adjusting the right lane’s 
horizontal offset and not the vertical offset. 

 The Control Type is used to define what will be used as the basis for the point control 
horizontal offsets. Select Linear Geometry to use an OpenRoads horizontal alignment as 
the basis for the lane width offsets. 
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 The Point parameter is used to define the point name in the template that the point 
control is assigned to. 

After identifying the Point, the software will prompt to select the Plan or Profile Element that will be 
used as the Linear Geometry in order to define the point control Horizontal Offsets. 

 
 Select the Horizontal Geometry for S.R. 185 

 
 Step through the remaining prompts using the values shown on the previous page 

 
Define the taper for the point L-ACSC_T_EP using the settings shown below. 

 
The proposed centerline of S.R. 185 does not meet the crown of the existing pavement. Next we’ll 
define a point control for point ACSC_T_CL to force the crown of the template to meet the crown of 
exiting pavement. The dialog settings to create the point control are shown on the following page. 
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When complete, the edge of pavement and ACSC_T_CL lines are tapered to meet the existing conditions 
as shown below. 
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After a point control has been defined, it can be reviewed and edited using the Corridor Objects 
command. 
 

 From the Tasks menu, select Tasks > Civil Tools > Corridor Modeling > Corridor Objects 
 

 When prompted, select the S.R. 185 corridor. The Corridor Objects dialog is opened as shown 
below 

Select the Point Control item from the list on the left of the dialog. The parameters of the selected 

corridor can be reviewed and edited using this dialog. 

Tip: As edits are made, the corridor is automatically updated since it is locked to the rules defined in this 
dialog. If you have to make multiple changes, you will have to wait for the corridor to update before 
making the next change. You can temporarily unlock the rules using the lock icon at the top of the 
dialog. After making the changes, turn the lock back on. The corridor is not automatically updated when 
the lock is turned on. Select the corridor and choose the Process Corridor command to update the 
corridor. 
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Part 4: Adjusting the Pavement Slope to meet Existing Pavement 

In this exercise we will use a Parametric Constraint to override the pavement slope defined in the 
template to tie into the existing pavement slope at the beginning of the project 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_CORRIDOR_MODEL 

 
 Open the design file for the S.R. 185 Corridor Model: 

..\Design\Geopak\Basemaps\12345_KM001.dgn 
 

To override the pavement slope using a Parametric Constraint, it is first necessary to define a Label for 
the point constraint that we wish to manipulate in the template definition. The label can be defined in 
the corridor by selecting the corridor graphic and choosing the Edit Template Drop command as shown 
below. 

 
Using this command edits the template definition as applied to the corridor, not the template as defined 
in the library. When the command is selected, the Editing Roadway Designer Template Drop dialog is 
opened. Note: Synchronizing the template with the library will override and changes that may have 
been made to the corridor’s template definition. 
 
Take the following steps to assign a Label to the points L-ACSC_T_EP and R-ACSC_T_EP: 
 

 Double-click on point L-ACSC_T_EP to open the Point Properties dialog. 
 

 Key in the name “L-PAVT_SLOPE” in the Label field for the Slope constraint as shown on the 
following page. 
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 Select the Apply button to accept the change. 

 
 Edit the point properties for the point R-ACSC_T_EP to assign the Label name “R-PAVT_SLOPE” 

to the Slope constraint. Select the Apply button to accept the change. 
 

We will use these two labels to override the pavement slope at the beginning of the project to meet 
the existing pavement slope. 
 

The next step is to analyze the existing pavement to get the elevations and lane widths in order to 
compute the existing pavement cross slopes at station 326+25. To do this, we will use the Analyze Point 
command. 

 
 From the Tasks menu, select Tasks > Civil Tools > Terrain Model > Analyze Point. This command 

can be used to analyze the terrain model as well as 3D linear features. When prompted to Select 
Element to Analyze Point, choose the existing edge of pavement line on the east (left) side of 
the alignment. As you drag the cursor along the selected element, the Elevation, Slope, and 
Direction are reported as shown below. 

 
Civil Accudraw can be used to key in the station on the proposed centerline that you wish to 
analyze the selected feature. 
 

 With Civil Accudraw toggled on select the Station-Offset ordinate. 
 

 In the Civil Accudraw settings, use the Tab key to highlight the Offset field. 
 

 With focus set to the Offset field, key in the letter “o” to define the element that you 
wish to use for the station and offset ordinate. 
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 Once defined, you can now key in a Station value to get the elevation on the selected 
linear feature at the station location. The results are shown on below. 

 
Note: The Offset value is irrelevant as the command will project a perpendicular from 
the alignment to the selected linear feature in order to report the elevation on the 
linear feature. 

 
Using the Analyze Point command, get the elevations for the left and right edge of pavement 
and the center of the existing pavement at station 386+25. Note, the surveyed line for the 
center of pavement is on the level SV_X_Center_of_Pavement. Enter the elevation values in the 
table below. 
 

Selected Linear Feature Elevation 

Left Edge of Pavement  

Center of Pavement  

Right Edge of Pavement  

 
Compute the existing pavement cross slope and enter the value in the table below. 
 

Side Width Cross Slope % 

Left 12.3870’  

Right 11.7944’  
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Now we are ready to define the Parametric Constraints to override the pavement slope at the 
beginning of the project. 
 

 From the Tasks menu, select Tasks > Civil Tools > Corridor Modeling > Create Parametric 
Constraint.  

 
 Create parametric constraints for the L-PAVT_SLOPE and R-PAVT_SLOPE labels from station 

386+25 using the slopes computed above, to end at 1.60% at station 387+00. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
After the labels have been defined, the proposed pavement should meet the existing pavement in the 
3D model, within an acceptable tolerance, similar to the example shown below. 

 
Whether it is necessary to adjust the model to this level of detail is debatable as the construction 
contractor will ensure that the proposed pavement ties in to the existing pavement. However, this 
exercise illustrates the power of point controls and parametric constraints to override the initial 
template definition. 
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Exercise 7G – Ditch Profiles 
The template definition for S.R. 185 contained end conditions for both cut and fill conditions. When the 
template is applied, the priority of each end condition is used to determine the order in which the end 
conditions are processed. As each option is evaluated, the first option that is successful will be used for 
the template drop location. 
 
In many cases, it will be necessary to define a new profile for a ditch, or even override the template 
solution in order to force a ditch in areas where the solution that was used for a range of template drop 
locations did not include a ditch. This exercise will look at a few different ditch modification scenarios. 
 
The length of the example project contains too many ditches for us to define them all in this training 
course. We will take a look at a few specific areas in order to introduce you to the available tools to 
define ditch profiles. 
 

Part 1: Redefining a Ditch Profile with an Elevation and Grade Point Control 

Point controls can be used to defile a ditch profile by a starting elevation and a grade for a range of 
stations. 
 
The template used for S.R. 185 will draw a ditch in cut conditions. This ditch point R-EC_DITCH is set 
with a Vertical constraint value of -1.5’ from point R-EC_GSH2 as shown below. 

 
Point R-EC_Ditch1 is constrained 2’ horizontally and 0’ vertically from point R-EC_Ditch. Defining a point 
control for point R-EC_Ditch will also adjust the elevation for point R-EC_Ditch1 since it is constrained 
vertically to point R-EC_Ditch. 
 
In this example we will define a new profile for the ditch on the right side of the corridor from stations 
390+75 to 394+00. 
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 Open MicroStation using the shortcut provided for the training class. 

 
 Set the User and Project as follows: 

User:  ODOTcadd 
Project:  12345_CORRIDOR_MODEL 

 
 Open the design file for the S.R. 185 Corridor Model: 

..\Design\Geopak\Basemaps\12345_KM001.dgn 
 

 From the Tasks menu, select Tasks > Civil Tools > Corridor Modeling > Create Point Control. 
When prompted to Locate Corridor, select the S.R. 185 corridor model. 
 

 Create the vertical point control using the settings shown below. 
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When the point control is applied, the 3:1 slope from the graded shoulder to the ditch elevation 
is maintained. The ditch line moves out appropriately. 

 
 The results can be reviewed by opening a cross section view. From the Tasks menu, select Tasks 

> Civil Tools > Corridor Modeling > Open Cross Section View. When prompted, select the S.R. 
185 corridor and then data point inside view 2. The cross section for Station 391+50 is shown 
below. The point control is indicated by the purple box drawn around point R-EC_Ditch. 

 
 Review the 3D model to inspect the changes. Obviously this is not a legitimate design solution as 

the ditch does not have an outlet, but the example illustrates one way to manipulate a ditch 
profile. 
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Part 2: Defining a Special Ditch Profile 

When a corridor model is created, some of the Feature Definitions that have been assigned to the points 
in the template are configured to draw 2D plan view graphics into the corridor design file. These plan 
view graphics have a profile defined that can be reviewed in a profile window.  
 
The Feature Definition MD_P_EC_DITCH is configured to draw 2D plan graphics in the corridor design 
file. The ditch profiles can be displayed relative to the centerline stationing in the profile window. All 
profiles must be defined in the same design file that contains the centerline geometry, the geometry 
basemap “BK” design file. 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_CORRIDOR_MODEL 

 
 Open the design file for the S.R. 185 geometry: 

..\Design\Geopak\Basemaps\12345_BK002.dgn 
 

 Attach the Design model for the S.R. 185 corridor design file with a Nest Depth value of 0. 
..\Design\Geopak\Basemaps\12345_KM001.dgn 

 
It is not necessary to attach the corridor model to design a new ditch profile. This is only 
necessary if you wish to display the ditch profile that was generated by the corridor model onto 
the S.R. 185 profile. 
 
We will define a new ditch profile for the right side of the corridor from stations 405+00 to 
412+00. Notice that the template did not place a ditch for the full station range. 
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The profile of the ditch line as defined by the 
initial corridor model processing can be 
projected to the S.R. 185 profile by use of the 
Project Profile to Element command, or the 
Project Profile Range to Element command, 
contained in the Tasks > Civil Tools > Vertical 
Geometry group. 

 
 To define the new ditch profile, select the 

centerline of S.R. 185 and choose the Open 
Profile Model command from the pop-up menu. 
Open view 2 to display the profile. 
 

 To display the current ditch profile as defined in the corridor model, select the Project Profile to 
Element command. 
 

 When prompted to Select Element to Project, choose the inside ditch line on the right 
side of the corridor  

 
 When prompted to Select Element to Project Onto, choose the horizontal alignment for 

SR 185. The ditch profile is displayed in the profile view as shown below. 
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 In the Profile view window, choose the Profile Complex by VPI command. 
 

 Toggle on Civil Accudraw and select the Z ordinate option. 

 
 Place a profile without any vertical curves (Curve Length = 0) using the following station and 

elevation values. 
 

405+00  987.94 
409+00   979.00 
410+00  965.25 
410+15  965.25 
411+00  972.25 
412+00  977.00 
 

 After placing the profile, select the profile and choose the Properties icon from the pop-up 
menu. Define the Feature Name of the profile as R-Ditch. The ditch profile should appear similar 
to the example below. 
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 Open the design file for the S.R. 185 corridor model: 
..\Design\Geopak\Basemaps\12345_KM001.dgn 

 
First we will define an End Condition Override to define a ditch for the full station range from 
405+00 to 412+00. 
 

 From the Tasks menu, select Tasks > Civil Tools > Corridor Modeling > Create End Condition 
Exception. When promoted, select the S.R. 185 corridor. 

 
 Define the end condition exception with the values shown below. 

 
 The Right Override dialog is opened to display the right side template drop at station 405+00. 

Right-click in the template window and choose the Delete Components option to delete the 
graded shoulder and side slope lines. The deleted lines are still displayed as shown below. 

 
 

 Open the Dynamic Settings dialog (Tools > Dynamic Settings) and toggle on the Apply Affixes 
option 
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 Select the following end condition and drag it onto the edge of shoulder point: 
 

ODOT > End Conditions > 307-4E Common and Barrier Grading > 307-4E Cut 3:1 
 

 Delete the 3:1 backslope component. The end condition override should appear as shown 
below. 

 
When the dialog is closed, the corridor is reprocessed and the ditch is drawn for template drop 
locations where the template conditions are met. 
 
For this example, there will be stations where the end condition does not solve as shown below. 
We will remedy this by assigning the new ditch profile to the corridor. 
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 From the Tasks menu, select Tasks > Civil Tools > Corridor Modeling > Create Point Control. 
Select the S.R. 185 corridor when prompted. 
 

 Create the point control using the settings shown below. 

 
When the ditch profile is applied, some of the template drops will display the new ditch line as shown in 
the example below 

 
Normally a culvert would be designed for this location. Culvert design and grading around the culvert 
are beyond the scope of this training course. The purpose of this exercise is to illustrate the process to 
define and apply a special ditch profile in the corridor model. 
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8 Superelevation 

The Superelevation commands calculate how much banking to apply to curves in the horizontal 
alignment to help offset centrifugal force. These commands also compute how the road will make the 
transition from normal crown to a fully banked curve and back again. 
 
Pavement slopes are initially defined in the template.  Superelevation is created and applied after the 
corridor is defined and the template drops have been assigned. This chapter will detail how 
superelevation is computed with OpenRoads as well as how to accurately model the shoulder break for 
the high side of Superelevation as defined in the Location and Design Manual, Volume 1, Roadway 
Design, Figures 301-8E, 301-9E, and 301-10E using the Table Wizard with ODOT’s ASCII Superelevation 
Tables. 
 
For this example, we will reference the shoulder break for uncurbed roadways defined in Figure 301-8E 
shown below. 

 
The behavior for the low side of superelevation is easily facilitated by applying a Rollover Lock to the 
shoulder point in the template definition. 
 
The high side of superelevation presents some challenges. For pavement slopes greater than 3%, the 
shoulder slope maintains a 7% maximum break. This can also be facilitated with the Rollover Lock 
parameter in the template point properties. If the pavement slope exceeds 6%, a 2’ break is introduced. 
Modeling this behavior cannot be modeled using the rollover lock. This chapter will document the 
procedure to model the superelevation using the ODOT template library. 
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8.1 Superelevation Design Files 
Superelevation graphics for each alignment are normally be placed in a separate design files. The 
ODOT_Files.mvba application is used to create superelevation design files for the project as shown 
below.  

 
Notice that the file is created in the \geopak\basemaps folder for the project. 
 

8.2 Applying Superelevation to a Corridor 
The Superelevation tools are located in the Tasks > Civil tools > Corridor Modeling group as shown 
below. 

 
From left to right, the following tools are available: 

 Create Superelevation Sections 

 Create Superelevation Lanes 

 Calculate Superelevation/Import Superelevation 

 Assign Superelevation to Corridor 

 Insert Superelevation/Cross-Slope 

 Superelevation Editor 

 Superelevation Report 

 Display Superelevation in Plan 
 

 
See the online help for tools not covered in this training guide. 
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Create Superelevation Sections 

Superelevation graphics are drawn on the active MicroStation level. Activate the GK_Shapes level 
before processing the superelevation commands. 
 
When the Create Superelevation Section tool is accessed, you are prompted to enter a Name for the 
superelevation section and to select the alignment as shown below. 

 
After the alignment is selected, you are prompted to enter the Start and End Stations for the 
superelevation definition. In the example below, the entire length of the chain was used to define the 
start and end locations. Two superelevation sections were created, one for each curve set. 

 
In the example at left, there are two separate shapes 
defining the superelevation “sections”. Each curve 
set of the horizontal alignment is the basis of a 
superelevation section. 
 
The superelevation definition is drawn on the active 
level. 
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Next you are prompted to define the pavement lanes as shown below. Issue a Data button (left-click) to 
accept each value as you are prompted by the software. 

 
As each lane is defined, a shaded shape is displayed on the active level, for the lane. 

 
Note: Fill display is turned off in the default ODOT workspace. To turn it on, select the View Attributes 
command and toggle on the Fill option. 
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After defining the lanes, issue a Reset button (right-click) to move to the next step; selecting the 
standards file, as shown below. 

 
Two superelevation preference files are provided in the ODOTcadd standards as shown above. These are 
the same preference files used with the GEOPAK Road tools. 
 
After the preference file is selected, the dialog shown below is opened to allow selecting the 
appropriate parameters for the project. 
 

 
Toggle the Open Editor option on to access the dialog shown on the following page. 
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This dialog is used to review and edit the superelevation parameters. 
 
The superelevation values can also be reviewed and edited by selecting one of the pavement lanes as 
shown below. Each of the text items designating the station and cross slope can be edited by selecting 
the text. 

 
Superelevation values can also be reviewed and edited in the Project Explorer’s Civil Model group as 
shown on the following page. 
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Selecting a superelevation shape, as shown at left, allows 
you to access a menu with the following three commands: 
 

 Properties 

 Insert Superelevation Station/Cross Slope 

 Delete 
 

 
 

See the online help for more information on these commands. 
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Selecting the superelevation section graphic, as shown below, provides access to a pop-up menu 
containing the superelevation commands listed below. 

 
 Properties 

 Create Superelevation Lanes 

 Calculate Superelevation 

 Assign Superelevation to Corridor 

 Insert Superelevation Station/Cross Slope 

 Superelevation Editor Tools 

 Import Superelevation 

 Superelevation Report 

 Lock/Deactivate Rule 

 Delete 
 
See the online help for more information on these commands. 
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Assign Superelevation to Corridor 

After the superelevation values have been computed, the next step in the process it to assign the 
superelevation sections to a corridor. Before assigning the superelevation to the corridor, it is necessary 
to attach the reference file containing the superelevation definition. If a Federated basemap collector 
design file is used for the superelevation, the “KS000” design file is attached with a Nest Depth value of 
1. 
 
After the reference file containing the superelevation definition has been attached, it can now be 
assigned to the corridor. Choose the Assign Superelevation to Corridor command. Select each 
superelevation section that you wish to apply to the corridor similar to the example below. 

 
After the sections and the corridor have been identified, the Associate Superelevation dialog similar to 
the one shown below is opened. This dialog is used to associate specific points in the template to the 
superelevation lanes. 

 
In the example above, the Superelevation Objects L-Lane and R-Lane are shown for each of the two 
superelevation sections. The objects default to the points that have been identified with the 
Superelevation Flag toggled on in the template definition. 
 
After reviewing and making any corrections to the assigned points for each lane, select OK to apply the 
superelevation to the corridor. 
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The model is automatically updated with the superelevation values which override the cross slopes 
initially defined in the templates. 
 
Superelevation is applied to the pavement lanes, but not the shoulders. The Rollover Lock, described in 
the following pages, is used to define the behavior for the shoulders. Using ODOT’s design standards, 
this will facilitate superelevated roadways where no shoulder break is required on the high side of 
superelevation. We will review the Rollover Lock settings and discuss the procedure to insert templates 
for the superelevation and correct the shoulder slopes in the next section. 
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8.3 Templates for Superelevated Sections 
ODOT’s template library contains shoulder templates for superelevated sections. These templates are 
intended as the starting point for defining the superelevation and will require some modification to 
accurately reflect the superelevated roadway. 
 
The ODOT template library includes shoulder buildups for superelevation as shown below. 

 
The shoulders defined in the Buildups without Superelevation folder are used for normal crown 
roadways without superelevation and for superelevated roadways where the pavement slope is less 
than the value specified for a shoulder break condition. Shoulders greater than 6% include the shoulder 
break point in this example using Figure 301-8E. 
 
Shoulders defined in the Buildups with Superelevation Point folder are used for roadways with a 
shoulder break introduced. 
 
In either case, the user will have to make some modifications to the shoulder components when the 
template is created. Each case is explained below.  

Defining the Shoulder Rollover for the Low Side of Superelevation 

According to figure 301-8E, the shoulder slope will match the pavement slope for superelevated sections 
when the pavement slope is greater than 4%. This behavior can be modified using the Rollover Lock. 
The rollover lock cannot be defined in the shoulder templates since it requires a Reference Point (the 
inside edge of the adjoining pavement lane) and the Parent Pont (the edge of pavement point). After 
the pavement and shoulder have been defined in a template, the rollover lock can be applied. 
 
In the example shown on the following page, the template was constructed by dragging in the following 
two templates from the ODOT library: 
 

ODOT > Components > Pavement > Buildups > Asphalt Concrete without Stabilization 
ODOT > Components > Shoulder > Buildups without Superelevation > Asphalt Concrete 
without Stabilization 
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The shoulder rollover for the low side of superelevation is defined as follows: 
 

 Double-Click the outside edge of shoulder point R-ACSC_T_OS to open the Point Properties 
dialog 
 

 Toggle on the Rollover Values… option 

 
 Select Rollover Values… to define the rollover parameters shown on the following page 
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 The High Side Difference parameter is set to 7% to define the maximum slope break for the high 

side of superelevation 
 

 The Low Side Difference parameter is set to 0% to constrain the shoulder slope on the low side 
of superelevation to match the pavement slope 
 

 The Reference Point is set to the point on the inside edge of pavement adjacent to the shoulder 
 

After defining the rollover lock, you can test the behavior of the shoulder by editing the edge of 
pavement point to set various pavement slopes and examine the results. You can also test the behavior 
without editing the slope constraint value by right-clicking on the edge of pavement point and choosing 
Test Point controls > Test Vertical Point Control.  
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Defining the High Side of Superelevation 

The rollover lock defines the behavior for the high side of superelevation with the High Side Difference 
parameter which we have set to 7% in this example. Figure 301-8E dictates that a shoulder break is 
introduced when the pavement slope exceeds 6%. In the example below, the Slope constraint for point 
R-ACSC_T_EP has been set to 8% with the High Side Difference parameter of 7% applied. Note the 
shoulder slope. 

 
To correct this, we will insert the shoulder buildup template as shown below. 

 
With this template inserted, we can see that the slope for the inside portion of the shoulder matches 
the pavement slope, and the slope for the outside portion of the shoulder is defined as -1%. This 
template is correct for a superelevation rate of 6% but the Slope constraint for point R-ACSC_T_SB must 
be edited in order to accommodate other pavement slopes greater than 6%. The Point Properties dialog 
for point R-ACSC_T_SB is shown on the following page. 
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The default template is defined with a Slope constraint of 6% for the shoulder break point. In order to 
ensure that the slope for the shoulder break matches the pavement slope, use the Vector-Offset 
constraint instead of the Slope constraint. Define the vector using the points from the adjacent 
pavement lane with an offset value of 0 as shown in the example above. 
 
An example of a template defined for a superelevated section is shown below. 

 
Note that templates must be defined uniquely for horizontal curves with the high side on the left or the 
right. 
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Using ODOT’s Backbones 

Templates can also be constructed using one of the predefined pavement and shoulder configurations in 
the Backbones category of ODOTcadd_Templates.itl. 

 
The pavement and shoulder components defined in the Backbones category already have the proper 
constraints and Rollover Lock assigned for superelevated roadways. 
 
Backbones defined with and without a superelevation point in the shoulder are provided. Backbones 
defined without a superelevation point can be used for normal crown and superelevated sections up to 
the maximum pavement slope where no shoulder break is required on the high side of superelevation. 
 
Backbones with a superelevation break point in the shoulder are proved for cases where the high side of 
superelevation is on either the left or right side of the roadway. 
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Exercise 8A – Defining the Superelevation for the SR 185 Corridor 
In this exercise we will define the superelevation sections for the State Route 185 Corridor. 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_SUPERELEVATION 

 
 Open the design file containing the S.R. 185 Corridor Model: 

..\Design\Geopak\Basemaps\12345_KM001.dgn 
 

 Use the ODOT_Files.mvba application to create a design file for the S.R. 185 superelevation 
definition. Be sure to check on the Federate Basemaps option. 

 
With the Federate Basemaps option toggled on, two files are created: 12345_KS000.dgn and 
12345_KS001.dgn. 
 

 Open the 12345_KS001.dgn file to define the superelevation for proposed S.R. 185. 
 

 Set the active MicroStation level to GK_Shapes. 
 

 From the Tasks menu, select Tasks > Civil Tools > Corridor Modeling > Create Superelevation 
Sections 

 
 You are prompted to define the Name for the superelevation section. Use the same name as the 

horizontal alignment, CLP_S185. 
 

 Next you are prompted to select the alignment. Select the CLP_S185 alignment 
 

 Use the entire length of the chain for the start and ending stations by toggling on the Lock to 
Start and Lock to End options 
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Next, the software will step you through the process to define the pavement lanes. 
 

 Define two lanes for the superelevation as shown below 
 

 
 
 
 
 
 
 
 
 

 After defining both lanes, right click to terminate the lane creation process. The Calculate 
Superelevation dialog is opened. Choose the ODOT_Undivided.sep file by navigating to the 
following ODOTcadd standards location, …\ODOTcadd\Standards\Geopak\Road\super. The file 
browser will default the user to this directory via configuration variable. Use the settings shown 
below. 

 
 
 
 

 After accepting the dialog settings, the Superelevation Editor dialog is opened.  
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Review the superelevation parameters and close the dialog when completed. The maximum 
superelevation rate should be 8.0% for this alignment. 
 

The Assign Superelevation to Corridor command is used to associate the superelevation settings with 
the corridor model and the template points. This assignment is made in the corridor design file. 

 
 Open the 12345_KM002.dgn file containing the corridor for S.R. 185 

 
 Attach the superelevation definition design file, 12345_KS000.dgn, to the corridor design file, 

12345_KM002.dgn, with a Nest Depth value of 1. 
 

 Select the Assign Superelevation to Corridor command to associate the superelevation settings 
with the corridor model and the template points 

 
Choose the graphics that were drawn for the boundary of both superelevation sections, and 
then right-click (reset) to accept the sections  
 

 When prompted to Locate Corridor, select the white corridor graphic for the S.R. 185 corridor 
boundary. 
 

 The Associate Superelevation dialog is opened. The dialog should default to the correct settings 
but it is good practice to review the settings before accepting them. 
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 After associating the superelevation sections with the corridor, use the Open Cross Section 

View command to review the corridor. 
 

When prompted, sect the corridor and 
select a new view window to display the 
corridor. 
 
After reviewing the corridor cross sections, 
close the cross section view window. 
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Exercise 8B – Defining Superelevation Templates 
In this exercise we will define and insert a new template for the station range where the superelevation 
is greater than 6% 
 
The normal crown template that has already been configured for State Route 185 has a Rollover Lock 
defined for the shoulders. Start by reviewing the template for S.R. 185 to verify the rollover values. 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_SUPERELEVATION 

 
 Open the design file containing the S.R. 185 Corridor Model: 

..\Design\Geopak\Basemaps\12345_KM001.dgn 
 

 From the Tasks menu, select Tasks > Civil Tools > Corridor Modeling > Create Template 

 
 Open the previously created template for SR 185 in the Project Templates > SR 185 folder.  

 
 
Double-click the left edge of shoulder 
point L-ACSC_T_OS to review the 
properties. 
 
Select the Rollover Values button to 
access the dialog shown on the 
following page. 
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For ODOT projects using Figure 301-8E, the values show below should be entered. 
 

 
These values should also be entered for point 
R-ACSC_T_OS. 
 
Using these values, the rollover lock will ensure 
that the shoulder slopes are correctly 
transitioned for superelevation rates < 6.0%. 
This can be reviewed and verified in the Cross 
Section View. 
 
Close the Create Templates dialog after 
completing the review of the Rollover Lock 
values. 
 
 
 
 
 

 
 

 Use the Open Cross Section View command to review the corridor. 
 

 A temporary dimension line can be displayed in the cross section view window to review the 
width and slope between two selected template points. Hold down the right mouse button until 
the pop-up menu appears as shown below. Select the Place Temporary Dimension Line 
command. 
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 Define the Start Point, End Point, and Dimension Height for the temporary dimension line. Define 
dimension lines for the shoulder and pavement lanes as shown below. 

 
The cross section for station 411+00 reveals that the shoulder definition on the low side of 
superelevation is correctly following the pavement slope, but we need to define the shoulder 
break on the high side of superelevation since the pavement slope for the road exceeds 6.0%.  
 
For projects using Figure 308-1E where the pavement slope is <= to 6.0%, this template with the 
rollover lock defined is sufficient. However for projects where the pavement slope exceeds 6.0% 
a new template will need to be inserted to model the shoulder break on the high side of 
superelevation. 
 

The next step is to create a new template for station range where the superelevation is greater than 
6.0%. This can be accomplished by creating a new template in the template library, and then inserting a 
new template drop in the corridor. 
 

 Choose the Create Template command to open the template library for the project 
 

 The new template for the superelevation can be created from scratch or by copying the normal 
crown template for S.R. 185 and replacing the pavement and shoulders with new components. 
For this example, copy the S.R. 185 template and rename the copy as “S.R. 185 Superelevation” 
 

 Double-click the SR 185 Superelevation template to make it the active template. Make the 
following edits: 
 

o Delete the pavement and shoulder components for the entire template 
 

o Open the Dynamic Settings dialog and toggle off the Apply Affixes option 
 

o Drag the following pavement backbone into the template at the 0,0 location 
 

ODOT > Backbones > Undivided Roadways > Pavement and Shoulder 301-8E Uncurbed 
> 2-Lane with Superelevation High Side Right > Asphalt Concrete without Stabilization 
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The previously defined points R-ACSC_T_OS and L-ACSC_T_OS are still in the template 
since those are the points where the end conditions connect. The point for the new 
shoulder points are named R-ACSC_T_OS1 and L-ACSC_T_OS. 
 

o Right-click on point R-ACSC_T_OS and select the Move Point command. Move point R-
ACSC_T_OS to place it on top of point R-ACSC_T_OS1 
 

o Right-click on the moved point and choose the Merge Points command. Delete the old 
point R-ACSC_T_OS. We want to keep the new point since it already has the correct 
constraints assigned for the superelevation break. 

 
o Double-click point R-ACSC_T_OS1 and rename it to R-ACSC_T_OS. The right side of the 

shoulder should appear as shown below. 

 
o Repeat the steps above to move the left end condition to the left shoulder point, merge 

the points, and rename the point. 
 
The completed template should appear similar to the example shown on the following page. 
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Now that we have a new template defined with a shoulder break point for the right (high) side of 
superelevation, the next step is to compute the station ranges that we will use to apply the template. 
After the new template drop is defined, we’ll compute and apply values for the labels. 
 
First we need to compute the stations on the entrance and exit spirals where the pavement reaches the 
6.0% cross slope. 
 
The superelevation report is a good place to get started by reviewing the key points for the 
superelevation transition. From the Tasks menu, select Tasks > Civil Tools > Corridor Modeling > 
Superelevation Report. After identifying the superelevation section, a report similar to the example 
below is opened. 
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The transition values for the superelevation are shown above. Using the stations and cross slopes, 
compute the station where the pavement will equal 6.0% for the entrance and exit spiral: 
 

Location Cross Slope Station 

Entrance Spiral 6.0%  

Exit Spiral 6.0%  

 
Next we will insert a new template drop using the SR 185 Superelevation template with the stations 
computed above. 
 

 Choose the Create Template Drop option by selecting the corridor as shown below. The 
command can also be selected from the Tasks menu by selecting Tasks > Civil Tools > Corridor 
Modeling > Create Template Drop. 

 
 Use the values shown below to create the template drop 

 
The template drop is inserted into the corridor. You can review the model with the Open Cross 
Section View command to verify the results. 
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You can also review the 3D model to examine the results. The shoulder break for the entrance spiral is 
shown below. 

 
As we can see, the model produces an abrupt transition from one template drop to the next. We will use 
a Parametric Constraint to apply a transition for the shoulder break width on both the entrance and exit 
spirals. 
 
The length of the shoulder break transition is not defined in the Location and Design Manual. For the 
purpose of generating the model, you can choose to ignore this area, or define a short transition length. 
 
In the template definition, the point R-ACSC_T_SB has a Label defined that can be used to control the 
width of the shoulder break as shown below. 

 
Take the following steps to define values and station ranges for the parametric constraint. 
 

 Select Tasks > Civil Tools > Corridor Modeling > Create Parametric Constraint 
 

 When prompted, choose the corridor to add the parametric constraint 
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 Create the parametric constraint for the entrance spiral using the values shown below 

 
After the parametric constraint is created, the 3D model now includes a short transition for the 
shoulder break as shown below. 

 
 Create a second parametric constraint for the exit spiral using the values shown below. 

 
After defining the parametric constraint values, the definition of the superelevation transition for the 
shoulder on both the low and high sides of superelevation is complete. Review the results by examining 
the 3D model and by use of the Open Cross Section View command. 
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Exercise 8C: Curve Widening 
Curve widening is defined in the Location and Design Manual, Volume 1 Roadway Design, Section 
301.1.3 Travelled Way Widening on Highway Curves. 
 
The OpenRoads tools include a command to compute and apply curve widening as shown below. The 
curve widening values are read from a table in order to create point controls that are applied to the 
edge of pavement points in order to accommodate the lane widening. 

 
ODOT does not provide curve widening tables at 
this time. We will use Point Controls to manually 
assign the station ranges and offsets for curve 
widening. 
 
 
 

 
For a 55 MPH design with a 6 degree curve, Figure 301-5cE defines a curve widening value of 3.0’. The 
widening is applied to the edge of pavement in the inside of the curve, point L-ACSC_T_EP in this 
example. The widening is applied through the length of the horizontal curve. Point controls for the lane 
width transition from 12’ to 15’ will occur over the length of the entrance and exit spirals. 
 
To define the widening, three point controls must be defined for both transitions and for the curve. 
 

 From the Tasks menu, select Tasks > Civil 
Tools > Corridor Modeling > Create Point 
Control 
 

 When prompted, select the corridor for 
S.R. 185 
 
Create the first point control for the 
entrance widening taper using the values 
shown at right. 
 

 Create the second point control for the 
length of the curve. Name the point 
control CurveWidening2. Use a Start and 
Stop Offset value of -15. 
 

 Create the third point control for the 
length of the exit spiral. Name the point 
control CurveWidening3. Use a Start 
value of -15 and a Stop value of -12 
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When complete, the Open Cross Section View command can be used to review the cross sections. The 
Place Temporary Dimension Line command is used in review the left lane width the example below. 
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9 Intersection Modeling 

In this chapter we will step through the process to model the intersection of S.R. 185 and St. Peter Road 
using the OpenRoads tools. The completed intersection will appear similar to the example shown below. 

 
Depending on the scope of the project, it may be desirable to place each corridor in a separate design 
file. For very small projects with a single designer, it is acceptable to put all of the corridors in one design 
file. For larger projects, it is recommended that you place each corroder in a separate design file and use 
reference attachments to pull the data together. In this example, each corridor is stored in a separate 
design file. 
 

Process Overview 
The process to model the intersection will take several steps as summarized below: 
 

 Define the Horizontal and Vertical geometry for each road 
 Create Templates for each road 
 Model the mainline corridor 
 Model the side road corridor 
 Add radius returns to the side road and define the vertical profile for each of the radius returns 
 Modify the mainline corridor to remove any side slopes through the limits of the intersection 
 Adjust the side road corridor to end at the radius return 
 Create a surface terrain for the pavement surface of the side road in the intersection area. The 

surface terrain is defined by the radius returns, the edge of pavement for the mainline corridor, 
and the centerline and profile of the side road corridor. 

 Apply a “surface template” to the surface terrain of the intersection. This will establish the 
pavement buildup components beneath the pavement surface terrain. 

 Apply Linear Templates to the radius returns to model the shoulders and side slopes for the 
intersecting side road. 
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Exercise 9A – Modeling an Intersection 

Part 1: Corridor Design Files 

The St. Peter Road corridor model will be created in its own design file. The design files for the corridor 
models were created in Exercise 7B. Take the following steps to prepare the 12345_KM003.dgn file for 
the corridor modeling process. 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_INTERSECTION 

 
 Open the following design file for the St. Peter Road corridor model: 

..\Design\Geometry\Basemaps\12345_KM002.dgn 
 
The alignment, profile, and corridor for St. Peter Road as well as S.R. 185 were competed in 
previous exercises. In order to model the intersection, we’ll need to attach the S.R. 185 corridor. 
 

 Attach the corridor model for S.R. 185 with a Live Nesting value of 0 
..\Design\Geopak\Basemaps\12345_KM001.dgn 

 
 Zoom in on the intersection of S.R. 185 and St. Peter Road. Turn off any unnecessary levels in 

the survey basemap. 
 

 Open the References dialog and turn off the display of the 3D model for St. Peter Road. 

 
 Choose File > Save Settings from the MicroStation menu. 

 
We are now ready to begin the modeling process for the St. Peter Road intersection. The corridors 
should appear similar to the example shown on the following page. 
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When a federated approach is used to create separate design files for each corridor model (see Using 
Multiple “Federated” Basemaps) users should add the corridor design file as a reference to the 
“KM_000” design file. 
 

 Open the file 12345_KM000.dgn 
 Attach the design file containing the St. Peter Road corridor as a reference to the 000 file 
 Save settings and close the 000 file when complete 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



March 30, 2017 GEOPAK OpenRoads Technology for Civil Design  

 

Page 266 Chapter 9 – Intersection Modeling 

 

Part 2: St. Peter Road Intersection and Pavement Surface Terrain Model 

The corridor for St. Peter Road ends at station 19+25. To define a terrain model representing the 
pavement surface for the intersection, we will need to start by placing the edge of pavement lines and 
radius returns for the intersection. 
 
The edge of pavement lines and the radius returns must be created using Civil Geometry tools. Take the 
following steps to create the edge of pavement lines: 

 
 In the Features Definition Toggle Bar, set the active feature definition to Pavement > 

PV_P_Edge_of_Pavement 
 

 In the Features Definition Toggle Bar, toggle on the Use Active Feature Definition option 
 

 From the Tasks menu, choose the Single Offset Partial command as shown below. 

 
This command is used to place a civil geometry element at an offset from the selected 
alignment. When prompted to Locate Element, choose the St. Peter Road alignment. 
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 Enter a Name for the element a shown below, R-EOP St Peter Road. 
 

 Using an Offset of 10’, define the starting point of the offset element by snapping to the edge of 
pavement line at the end of the corridor as shown below. 

 
 Enter the End Distance by issuing a data point at the end of the corridor. 

 
 When prompted to Mirror the solution, choose Yes. 

 
 The mirrored line is named R-EOP St Peter Road1. Change the name to L-EOP St Peter Road by 

selecting the line element and choosing the Properties command from the pop-up menu. 
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Next, assign a profile to the newly created edge of pavement elements. 
 
 From the Tasks menu, choose the Profile By Slope From Element command as shown below. 

 
 When prompted to Locate First Element to Profile, choose one of the new edge of pavement 

elements. Continue by choosing the other element when prompted to Locate Next Element to 
Profile. After choosing both elements, right click (reset) to end the selection process. 
 

 Choose the centerline of St. Peter Road when prompted to Locate Reference Element. 
 

 Enter a Slope value of -1.6% 
 

 Choose the Point Selection mode All 
 

 Use a Profile Adjustment of None 
 

 Enter a Vertical Offset of 0 
 
 
Next, create the radius returns for the intersection. 

 
 From the Tasks menu, select the Tasks > Civil Tools > Horizontal Geometry > Simple Arc 

command. 
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 Create the first arc on the right side of St. Peter Road using a 50’ radius. Be sure to enter a Name 
of R-Radius St Peter Road for the radius return element. Choose the R-EOP St Peter Road line as 
the first element. When prompted to Trim/Extend, choose the Back option. 

 
 

 Create the second arc on the left side of St. Peter Road with a Radius of 50’, a Name of L-Radius 
St Peter Road, and use the Trim/Extend Back option. 
 

Next, assign a profile to the two radius return elements using the Quick Profile Transition 
command. 

 
 After selecting the command, you are prompted to choose the Quick Transition Method. Select 

the Parabolic option. 
 

 When prompted to Locate What to Define, select one of the radius return elements. A quick 
profile is created for the element. 
 

 Repeat the procedure for the second radius return 
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After the profiles are assigned, the edge of pavement and radius return lines should appear in the 
3D model similar to the example shown below. 

 
 

The profile for each radius return can be reviewed and edited by selecting one of the radius returns and 
selecting the Open Profile Model command. The profile for R-Radius St Peter Road is shown below. 
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In addition to the two radius returns, we will need a line that follows the edge of pavement for S.R. 185 
that extends from the ends of the radius returns. This is necessary to define the boundary of the 
intersection area that will be used to make the surface terrain model. We cannot use the edge of 
pavement line from the CLP_S185 corridor model as the line must be constrained to the limits of the 
radius returns. 
 
Since this new edge of pavement line will overlap the edge of pavement lines already drawn for the 
CLP_S185 corridor we will use a different feature definition. 
 

 In the Features Definition Toggle Bar, set the active feature definition to Modeling > 3D Linear 
Features > Misc > MD_P_DNC. The initials “DNC” stand for Do Not Construct. This feature 
definition can be used for linear elements used in the modeling process whose graphics will not 
be used for part of the plan production process. Graphics drawn with this feature are placed as 
construction elements on the level MD_P_DNC. 
 

 From the Tasks menu, choose the Tasks > Civil Tools > Horizontal Geometry > Single Offset 
Partial command. 

 
 Create an offset line 12’ to the left of the CLP_S185 alignment from the ends of the radius 

returns. 
 

 Because this new line is drawn on top of the edge of pavement line for S.R. 185, it is easier to 
temporarily turn off the reference file display of the S.R. 185 corridor model to ensure the line 
was drawn correctly. Open the References dialog and turn off the display of the 
12345_KM002.dgn file. 
 

 The completed graphic should appear similar to the example on the following page. 
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Next, assign a profile to this new edge of pavement line. 
 

 From the Tasks menu, choose the Civil Tools > Vertical Geometry > Profile By Slope From 
Element command. 

 
 Define the profile with a -1.6% slope from the centerline of S.R. 185 
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The edge of pavement and radius return lines will be used to define the boundary of a terrain model for 
the surface of the pavement in the intersection. 

 
 From the Tasks menu, choose the Create From Elements command as shown below. 

 
 Set the Feature Definition to P_Pavement 

Surface in the Create Terrain Model From 
Elements dialog as shown at right. Note: Since 
this is a terrain feature it cannot be selected from 
the Feature Definition tool bar. 
 

 Set the feature Name to St Peter Road 
 

 Choose the two edge of pavement and radius 
returns for St. Peter Road as well as the partial 
offset line for S.R. 185. Reset when the elements 
are selected. 
 

 Set the Feature Type to Boundary 
 

 Set the Edge Method to None 
 

The surface is created and contour lines 
are drawn as shown at right. 
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We need one more graphic to complete the pavement surface definition. The center line and profile 
of St. Peter Road will be added to define the crown of the pavement surface. This will be 
accomplished by creating one more partial offset element. 
 
 In the Features Definition Toggle Bar, set the active feature definition to Modeling > 3D Linear 

Features > Misc > MD_P_DNC. 
 

 From the Tasks menu, choose the Tasks > Civil Tools > Horizontal Geometry > Single Offset 
Partial command. 
 

 Choose the centerline of St. Peter Road when prompted to Locate Element. 
 

 Start the line at the end of the St. Peter Road corridor, Station 19+25 with an Offset value of 0. 
 

 Use the MicroStation Intersection Snap to end the line at the intersection of St. Peter Road with 
the S.R. 185 Edge of Pavement. 

 
 After placing the line, we will assign a profile to the line using the Profile By Slope From Element 

command. The Reference Element is the centerline of St. Peter Road. Since the new element 
overlaps the centerline of St. Peter Road, use a Slope value of 0.0%. 
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Add this new partial offset line to the surface terrain model as a break line. 

 From the Tasks menu, select the Terrain Model Add Features command as shown below. 

 
 Set the Feature Type to Break Line 

 
 Select the St Peter Road terrain model when prompted to Locate Terrain Model to Add 

Elements 
 

 Select the partial offset of the centerline of St Peter Road when prompted to Locate Element to 
Add.  
 
After the break line element is added, the St Peter Road terrain model should appear similar to 
the example below. 
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Part 3: St. Peter Road Intersection Templates 

Two templates are necessary in order to define the pavement, shoulders, and side slopes for the St. 
Peter Road intersection area. 
 

 One template will be used to define the pavement buildup without the shoulder or end 
condition components. This template will be applied to a surface terrain model to define the 
intersection pavement surface and pavement buildup. 
 

 A second template will be used to define the shoulder and side slopes. This template will be 
applied to the radius return and edge of pavement graphics for St. Peter Road. 

 
Take the following steps to create the pavement template: 
 

 Open the Template library by choosing the Create Template command. 
 

 Copy the St. Peter Road Template. 
 

 Rename the copied template to St. Peter Road Pavement 
 

 Double-click the St. Peter Road Pavement template to make it active 
 

 Right-click in the Current Template window and choose the Delete Component command. 
Delete the shoulders and the side slopes on both sides of the template. 

 
The completed St. Peter Road Pavement template contains only the pavement as shown below. 

 
Note: The actual slopes of the components as defined in the template is irrelevant. The template will be 
applied to the slope of the surface terrain. 
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Take the following steps to create the radius return template: 
 

 Copy the St. Peter Road Template 
 

 Rename the copied template to St. Peter Road Shoulder 
 

 Double-click the St. Peter Road Shoulder template to make it active 
 

 Right-click in the Current Template window and choose the Delete Component command. 
Delete the Pavement, the left shoulder, and end conditions on the left side. Leave the right 
shoulder and the right end conditions in place. 
 

 Open the Dynamic Settings dialog to ensure the Step values are defined. 
 

 Right-click on point R-ACSC_T_EP and choose the Move Point command. Move the point to the 
(0,0) position. 
 

 Double-click point R-ACSC_T_OS to access the Point Properties dialog. Add a Slope constraint to 
the point with a -4.00% slope from point R-ACSC_T_EP. 

 
The completed template for the radius returns should appear as shown below 

 
 

 Save and close the Template library. 
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Next we will assign the pavement template to the St Peter Road terrain model. 
 From the Tasks menu, select the Tasks > Civil Tools > 3D Geometry > Apply Surface Template 

command as show below 

 
 When prompted, select the St Peter Road terrain model 

 
 Select No for the Apply Clipping Boundary option 

 
 Choose the St. Peter Road Pavement template. 

 
 Data point to accept the selection. The template is applied to the terrain model. 

 
 
Take the following steps to apply the St. Peter Road Shoulder template to the edge of pavement tangent 
lines and the radius return elements: 
 

 Select the right radius return graphic and choose the Apply Linear Template command from the 
pop-up menu 

 
 Choose the St. Peter Road Shoulder template from the library 

 
 The template can be applied for a portion of the selected graphic, or the entire element. Define 

the Start Station and End Station to encompass the entire length of the element 
 

 When applying a linear template, the template can be placed on either the left or right side of 
the selected element. When prompted to Select Side – Reflect Option, issue a data point on the 
side of the element that you wish to apply the template 
 

 Use the default Exterior Corner Sweep Angle value of 5 degrees 
 
The template is applied to the radius return. Repeat the process for the remaining edge of 
pavement lines and radius return. 
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When complete, the intersection should appear similar to the example below. 

 
The next step is to remove the left shoulder and the end conditions for S.R. 185 through the intersection 
area. 
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Part 4: Adjusting the S.R. 185 Corridor in the Intersection 

The last step is to remove the left shoulder and end conditions on the S.R. 185 corridor through the 
intersection area. 
 

 Open the design file containing the corridor model for S.R. 185 
..\Design\Geopak\Basemaps\12345_KM001.dgn 

 
 Attach the St. Peter Road corridor with a Live Nesting value of 0 

..\Design\Geopak\Basemaps\12345_KM002.dgn 
 

 Copy the template drop for the S.R. 185 Corridor by selecting the Template Range Graphics and 
choosing the Copy Template Drop option 

 
 Define the Start and End station of the new template drop by snapping to the radius return 

graphics. The new template drop is created as shown below. 
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 Select the new template drop and choose the Edit Template Drop command. 

 
 Edit the template drop to remove the end conditions and the shoulder on the left side of the 

template. 

 
After the template drop has been edited, the corridor for S.R. 185 appears as shown below. 

 
The 3D view of the modeled intersection should appear similar to the example shown on the 
following page. 
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10 Civil Cells 

Civil cells can be created to define typical design components that can be repeatedly placed in the 
design. Civil cells can contain horizontal and vertical geometry, terrains, linear templates, area 
templates, and simple corridors. Think of a civil cell as a collection of civil elements that can be placed 
relative to the geometry in your specific design. 
 
When a civil cell is created, all of the rules associated with the various civil elements are retained. When 
a civil cell is placed in the design, the elements that make up the civil cell retain their original ruled 
relationships which are applied to the selected geometry in the design. 
 

10.1 ODOTcadd_CivilCells.dgnlib 
Civil cells are stored in a MicroStation DGN Library. ODOT provides an example civil cell library that 
contains a few civil cells for basic T-Intersections and residential driveways. Additional civil cells will be 
added in the future. 
 
The configuration variable CIVIL_CIVILCELLDINLIBLIST is used to define the dgnlib file(s) that contain the 
civil cells. The variable has been defined as follows in ODOT_Site.cfg: 
 

CIVIL_CIVILCELLDGNLIBLIST = $(ODOT_STD)Geopak/Road/civil_cells/*.dgnlib 
 

10.2 Civil Cells Toolset 
Four tools are provided in the Task menu for placing civil cells as shown below. 

 

Create Civil Cell 
This command steps you through a series of prompts to create a civil cell. Creating civil cells is 
not covered in this document. See the OpenRoads help for more information. 
 
Place Civil Cell 
Civil cells can be selected from configured libraries or from civil cells placed in the active file. 

 
Process Civil Cell 
Reprocesses all linear templates and templates for the selected civil cell. 
 
Drop Civil Cell 
Used to drop the civil cell into separate civil elements. 
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10.3 Placing Civil Cells 
The command to place a civil cell is activated from the Task menu by selecting Tasks > Civil Tools > Civil 
Cells > Place Civil Cell.   

 
Click the browse button to open the Pick Civil Cell dialog shown below. 

 
Selecting one of the Civil Cells in the library will display the civil cell on the right side of the dialog as 
shown in the example above. 
 
Depending on how the civil cell is constructed, each civil cell will have different required Reference 
Elements that the user must identify as the civil cell is placed in the design. The placement process will 
prompt the user to select the required civil elements. Prompts are displayed floating on the cursor 
similar to the example below. 
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The T-Intersection with Shoulder civil cell requires that you select two horizontal alignments as part of 
the placement process. Each of the selected alignments must have a vertical profile defined. The 
following two civil elements are required: 
 

 CL Intersecting Road 

 Through EOP 
 
Note: Corridor graphics drawn in the 2D model such as edge of pavement and shoulder lines can be 
selected as reference elements for Civil Cell placements since these corridor graphics have a profile 
defined. 
 
After the reference elements are selected, the civil cell is displayed in the design, but has not been 
placed in the file at this point. The direction of the selected elements may not match the direction of the 
reference elements that were used when the civil cell was originally created. In the example below, the 
civil cell is drawn on the wrong side of the intersection. 

 
You are prompted to Select Elements to View Alternatives (Reset to Skip) as shown above. As the 
cursor is floated over each element, the direction of the element is displayed with an arrow as shown 
above. Issue a data point to reverse the direction of the civil cell placement. 
 
When a data point is entered to reverse the direction of a reference element, the civil cell graphics are 
updated to show the current orientation of the civil cell. The example shown at the top of the following 
page shows the results after the direction of the CL Intersecting Road reference is reversed. 
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Issuing a data point over the reference element that was selected for the Through EOP reference results 
in the solution shown below. 

 
When the solution appears as desired, issue a Reset button to continue to the next step. 
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After issuing the reset, you are prompted to accept the civil cell placement as shown below. 

 
The civil cell is placed in the design file similar to the example shown below. Note: The reference file 
attachment for the 3D model is turned on in this example. 

 
Both 2D and 3D graphics are generated for the civil cell. The geometry, vertical profiles, and templates 
applied to the elements that make up the civil cell can all be edited as shown in the following sections. 
 
The civil cell can be edited using a variety of methods as described on the following pages. 
 
Note that the ODOT civil cells have not been configured to automatically clip the corridor of the 
intersecting alignment. 
 
Also note that the ODOT civil cells do not currently include any side slopes. These can be added as 
detailed in the next section. 
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10.4 Modifying Civil Cells after Placement 
Civil cells can be dropped using the Drop Civil Cell command from the Tasks menu, or by the 
MicroStation Drop Cell command. However, many edits to the civil cells can be performed without 
dropping the civil cell. 
 
After a civil cell is placed, it can be reviewed from the Project Explorer dialog in the Civil Model group as 
shown in the example below. 

 
Expanding the Dependent Elements item will reveal a list of dependent elements similar to the example 
shown below. 

 
Choosing one of the Dependent 
Elements from the list will highlight the 
element in the design file. 
 
Right-clicking on an item will reveal a 
menu of applicable commands. 
 
Various editing options are described on 
the following pages. 
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Editing the Pavement Surface Template 

The main pavement area for the ODOT T-Intersection and Driveway civil cells are defined as a Surface 
Template using the Asphalt Concrete without Subgrade Stabilization template. The assigned template 
can be edited as follows: 
 

 Right-Click on the surface terrain in the list of Dependent Elements for the civil cell 

 
 Select the Edit Applied Surface Template option 

 The Editing Roadway Designer Template Drop dialog is opened to allow changes to the applied 
template 

 After making the necessary changes, save and close the Editing Roadway Designer Template 
Drop dialog. Note, changes made are not stored in the template library for the project. These 
changes are saved for the template definition that is stored with the civil cell. 

 The changes are automatically applied to the civil cell and the 3D model. 
 

Editing the Shoulder Template 

Linear Templates are used to define the shoulders in the ODOT civil cells. Expanding the Linear 
Template item reveals the items shown in the example below. Right-click the Template Drop and 
choose the Edit Template Drop item to make changes to the template that has been applied for the 
selected item. 

 
Changes are automatically applied to the Civil Cell and the 3D model. 
 
Each Linear Template item for pavement edge lines and the radius returns must be edited uniquely. 
 
 
 
 
 
 
 



March 30, 2017 GEOPAK OpenRoads Technology for Civil Design  

 

Page 290 Chapter 10 – Civil Cells 

 

Making Graphical Edits 

Civil cells are placed with the same ruled geometry that was used in the initial civil cell definition.  
 
In the example below, the radius return is selected. The radius can be edited using the element 
manipulators as shown below. 

 
The width of a pavement lane can be edited similar to the example below. 

 
These edits are dynamically reflected in the civil cell graphics and the 3D model. 
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Civil cells are placed in the design file independent of the stationing assigned to the selected reference 
Element. The civil cell does not inherit the stationing of the selected alignment. 
 
When the civil cell is placed, the length of the civil cell defaults to the length that it was created. The 
length can be changed by editing the “DNC” (Do Not Construct) element that is placed along the 
centerline of the civil cell.  
 
In the example below, the element placed on the level MD_P_DNC is selected. This element is placed as 
part of the civil cell along the centerline of the selected reference element. When the element is 
selected, the manipulators for the end and the length can be edited. 
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Adding End Condition to Civil Cell components 

Individual elements in the civil cell can be used to apply a linear template. In the example below, the 
edge of shoulder graphic is selected to reveal the pop-up menu for the element. The Apply Linear 
Template option is used to add an end condition to the element. 

 
When the command is selected, the Apply Linear Template dialog is opened. This dialog is discussed in 
the Intersection Modeling chapter of this training guide. 

 
For this example, the applied template will contain the graded shoulder and side slope elements as 
shown on the following page. 
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In the example below, the end condition has been applied to the edge of pavement and radius return 
elements for the civil cell. 
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Exercise 10 – Jameson Road Intersection 
In this exercise we will model the intersection for Jameson Road using a Civil Cell. 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345_INTERSECTION 

 
 Open the following design file for the Jameson Road corridor model: 

..\Design\Geometry\Basemaps\12345_KM003.dgn 
 

 Attach the geometry basemap with a Nest Depth value of 1: 
..\Design\Geometry\Basemaps\12345_BK000.dgn 
 

 Attach the S.R. 185 corridor model with a Nest Depth value of 0: 
..\Design\Geometry\Basemaps\12345_KM001.dgn 

 
 Attach the survey information with a Nest Depth value of 0: 

..\Design\Survey\Basemaps\12345_BE001.dgn 
 

 Select the terrain model and make it the active terrain by selecting Set As Active Terrain Model 
rom the pop-up menu. 
 

 Select the Place Civil Cell command to place the civil cell T-Intersection with Shoulders on the 
centerline of Jameson Road. 

 
 When prompted to Locate Reference Element: CL Intersecting Road, choose the 

centerline of Jameson Road 
 

 When prompted to Locate Reference Element: Through EOP, choose the edge of 
pavement for S.R. 185 

 
 

 The Civil Cell may not orient properly. If it does not, when prompted to Select Elements 
to View Alternatives, issue a data point on the centerline and another on the edge of 
pavement elements to view the alternatives. When the cell is oriented properly, issue a 
reset to move to the next step. 
 

 Issue a data point to accept the civil cell placement. The cell is placed and should in the 
file and should appear similar to the example below. 
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 The civil cell does not include any end conditions for the side slopes. Create a new template 

named Jameson Road Side Slopes for the side slopes of Jameson Road as shown below. 

 
Take a look at the templates contained in the ODOT > End Conditions > 307-4E Common and 
Barrier Grading folder in the template library. The 307-4E Cut 3:1 template may be just what 
you are looking for.  
 
Drag this template into the new template that you created for the project. Be sure to open the 
Dynamic Settings dialog and turn on the affixes before dragging in the end condition.  
 

 Delete the 2:1 Backslope. 
 Double Click on the point “R-EC_BKSLP3” and check on End Condition is Infinite. 
 Save and close the Template Library. 
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 Use the Apply Linear Templates command to assign the Jameson Road side slope template to 
the edge of shoulder graphics in the civil cell. The command can also be selected from the pop-
up menu when one of the Jameson road edge of shoulder elements is selected. 

 
The side slopes for Jameson Road should appear similar to the example below. 

 
The proposed work for Jameson Road starts at station 17+00. The remainder of Jameson Road 
can be modeled by creating a new template and corridor. 
 

 
 
 
 
 
 
 
 
 
 
 



 GEOPAK OpenRoads Technology for Civil Design March 30, 2017 

 

Chapter 10 – Civil Cells Page 297 

 

Take the following steps to create a template for Jameson Road: 
 

 Select the Create Templates command and create a new template in the Project Templates > 
Jameson Road folder named Jameson Road. 
 

 Open the Dynamic Settings dialog and turn off the Apply Affixes option. 
 

 Drag the following ODOT Backbone into the Jameson Road template at the 0,0 coordinate: 
 
ODOT > Backbones > Undivided Roadways > Pavement and Shoulder 301-8E Uncurbed > 2-Lane 
without Superelevation Point > Asphalt Concrete without Stabilization 
 

 In the Dynamic Settings dialog, turn on the Apply Affixes option 
 

 Drag the following end condition onto the left and right sides of the template: 
 
ODOT > End Conditions > 307-4E Common and Barrier Grading > 307-4E 3:1 Cut, Fill Table 
 

 Remove the R-GSH1 and L-GSH1 components from the template 
 

 Save the and close the template library 
 

Take the following steps to create the corridor for Jameson Road: 
 
 Select the Jameson Road alignment and choose the Create Corridor command from the pop-up 

menu 
 

 When prompted to Locate Profile-Reset For Active Profile, issue a left-click (reset) to use the 
active profile 
 

 Name the Corridor CLP_JAMESON 
 

 Use the settings below to create the template drop for Jameson Road. Note, the end station 
shown here corresponds to the start of the civil cell. 
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The ditch on the right side is incomplete and can be designed by defining a ditch profile and using a 
point control to assign the ditch profile to the corridor, similar to the procedure used in Exercise 7G.  We 
will not specifically address the ditch profile in this exercise. 
 
The corridor for State Route 185 extends through the intersection. Take the following steps to edit the 
S.R. 185 corridor: 

 
 Open the following design file for the S.R. 185 corridor model: 

..\Design\Geometry\Basemaps\12345_KM001.dgn 
 

 Attach the Jameson Road corridor as a reference with a Nest Depth value of 0 
..\Design\Geometry\Basemaps\12345_KM003.dgn 

 
 Use the Copy Template Drop command to add a new template drop on the State Route 185 

Corridor at the end of the radius returns for Jameson Road. The command is accessed by 
selecting the template range graphics, and then choosing Copy Template Drop from the pop-up 
menu. Be sure to choose the template drop graphics for the superelevated template drop. 

 
The new template drop should be inserted at the beginning and end of the radius returns as 
shown below. 

 
 



 GEOPAK OpenRoads Technology for Civil Design March 30, 2017 

 

Chapter 10 – Civil Cells Page 299 

 

 Choose the template range graphics for the new template drop and select the Edit Template 
Drop command from the pop-up menu. 

 
 Remove the shoulders and the end conditions from the right side of the template as shown 

below. 

 
After the edit is applied, the 3D model for the intersection of S.R. 185 and Jameson Road should 
appear similar to the example below. 
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 The State Route 185 corridor is in full superelevation with a shoulder break on the high side of 
the superelevation. The shoulders in the civil cell used for Jameson Road are defined with a 
slope of -4.0%. How would you fix this problem? 

 
In the example below, the Parametric Constraint named Shoulder_Slope is assigned to point 
ACSC_T_OS in the linear template for the radius return. The value for the constraint was edited 
as shown below: 

 
This solution does not include a corresponding break in the shoulder for the radius return. 
 
This example also applies the transition from the 3.5% slope to the -4.0% slope across the entire 
length of the radius return. Ultimately it will be up to the construction personnel to determine 
how this break will be constructed as the Location and Design Manual does not provide any 
guidance for the shoulder break entrance and exit transition lengths. 
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When a federated approach is used to create separate design files for each corridor model (see Using 
Multiple “Federated” Basemaps) users should add the corridor design file as a reference to the 
“KM_000” design file. 
 

 Open the file 12345_KM000.dgn 
 Attach the design file containing the Jameson Road corridor as a reference to the 000 file 
 Save settings and close the 000 file when complete 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

THIS PAGE LEFT INTENTIONALLY BLANK 



March 30, 2017 GEOPAK OpenRoads Technology for Civil Design  

 

Page 302 Chapter 11 – Cross Sections 

 

11 Cross Sections 

OpenRoads tools provide options to cut cross sections directly into a cross section sheet, or as stand-
alone sections with a GEOPAK cross section control cell. Each option is covered in this training guide. 
 
The cross section commands are located in the Tasks > Civil Tools > Corridor Modeling menu as shown 
below. 
 

 
 
From left to right, the following commands are provided: 
 

 Open Cross Section View 

 Create Cross Sections 

 Annotate Cross Sections 

 End Area Volumes 

 Edit Station 

 Show Place Dimension 

 Remove Temporary Dimensions 

 Locate Station via Datapoint 

 Cross Section Viewer 
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11.1 Open Cross Section View 
 

The Open Cross Section view command is used to generate a temporary cross section view 
window to review the selected corridor in a cross section format. 

 
 
When the command is selected, you are prompted to Locate Corridor or Alignment. If you select an 
alignment, you are prompted to identify the Left and Right Offsets as well as the Station and Interval 
for the cross sections. 
 
After selecting the corridor or alignment, you are prompted to Select or Open View. Open a new view 
window and issue a data point within the newly opened view to display the cross sections. An example is 
shown below. 

 
The cross sections are not written to the file. 
 
The View Properties item provides the following options: 

 
These options are more or less self-explanatory. See the online 
help for details. 
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You can scroll through the stations or enter a specific station using the options shown below. 

 
The following commands in the cross section group are used with the temporary cross section view: 
 

 Edit Station 

 Show Place Dimension 

 Remove Temporary Dimensions 

 Locate Station via Datapoint 
 
These commands can also be selected from a pop-up menu by holding down the right-mouse button in 
the temporary cross section view as shown below. 

 

Edit Station 

The Edit Station command allows you to edit the current station. When the command is selected, the 
Edit Template at Station dialog is opened as shown below. This dialog is used to make any necessary 
edits to the selected template drop location and is not applied to any other stations. 
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Place Temporary Dimension Line, Remove All Temporary Dimensions 

The Place Temporary Dimension Line command is used to review the length and slope of selected 
components in the cross section view window. 
 
When the command is selected, you are prompted to enter the Start Point, End Point, and Dimension 
Height. The temporary dimension line for one of the pavement lanes is shown below. As you scroll 
through the cross sections, the dimension line is updated for each cross section. 

 
The Remove All Temporary Dimensions command is used to remove the display of the dimension lines. 
 

Locate Station via Datapoint 

This command is used to display a temporary cross section at the station location identified by issuing a 
data point in the plan view. 
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11.2 Create Cross Sections 
 

The Create Cross Sections command is used to create a new Drawing model within the 
active design file containing the cross sections. It can also be launched by selecting an 

alignment and clicking the Create Cross Sections button from the pop-up menu. 
 
Cross sections can be created is a sheet format or in a free-floating format with a GEOPAK cross section 
cell. The choice whether to cut the cross sections directly a cross section sheet, or as stand-alone cross 
sections with a GEOPAK cell depends on the intended use of the cross section information. 
 

 If you intend to use any legacy GEOPAK cross section commands, such as seeding quantities or 
processing criteria, use the GEOPAK format option. 
 

 If you do not intend to use any legacy GEOPAK functions and all you need are simple cut and fill 
quantities, use the Sheet format option. 

 
Each option is discussed on the following pages. 
 

Cross Section Graphics 

Cross sections are cut directly from the 3D model. Whatever is drawn/displayed in the 3D model will be 
drawn on the cross sections. 
 
The components included in the template are drawn on the cross sections. Each pavement layer 
component will be displayed in the cross section model. Traditionally, ODOT has not displayed the 
individual pavement layers on the cross sections. The subgrade line, drawn at the bottom of the 
pavement layers, is typically displayed on the final cross sections. The subgrade line must be included as 
a separate component in the template if you wish to display the subgrade line in the cross sections. 
 
To add a subgrade component to a template, in the Create Template dialog, right-click in the Current 
Template window and choose Add New Component > Unconstrained from the pop-up menu. Name the 
component Subgrade and use the MD_T_Subgrade feature. Trace the pavement layers to define the 
subgrade component. Be sure that this element is not placed as a closed component. An example of the 
component is shown below. 
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Creating Cross Sections in Sheet Format 

Cross Section design files are created using the ODOT_Files.mvba Application. To launch this application 
from the MicroStation pull-down menu, select ODOT > File Management > Create Design Files. 
 
Select the Roadway Sheets category to create a cross section sheet design file. 

 
The “XS” file type is used for cross section sheets. This file is stored in the \Roadway\Sheets folder for 
the project. 
 
Tips: 

 When the Cross Section design file is created, use a Scale value of 1 
 The OpenRoads tools will be used to create the cross section sheets and set the annotation scale 

for the cross section sheet model. 
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Cross sections are extracted from referenced corridor models, 3D graphics, and terrain models. Before 
extracting the cross sections, attach the necessary references and turn on/off the desired graphics. 
 

 In the Cross Section design file, be sure to set the Design model as the active model before 
attaching references 

 
When the Create Cross Sections command is selected, you are prompted to Locate Alignment. After 
selecting the desired alignment, the Create Cross Sections dialog is opened. 

 
The dialog defaults to a 5-Scale sheet option. To change the format, select Preferences button. The 
ODOTcadd workspace included three options as shown below. 

 
Sheet: CROSS 10 Scale 
This preference will cut cross sections and place them 
on the ODOT sheet cell CROSS at a scale of 10. 
 
Sheet: CROSS 5 Scale 
This preference will cut cross sections and place them 
on the ODOT sheet cell CROSS at a scale of 5. 
 
Stacked: GEOPAK Format 
This preference will cut cross sections and place them 
with GEOPAK cells. This preference will allow the user 
to use the legacy GEOPAK tools. 
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There are several options in the Create Cross Section dialog. 
 

 The General tab is where most of the user edits will be made. The other tabs in this dialog have 
been set up by the loaded preference. The General tab is where the user can set the Start 
Station, Stop Station, Left and Right Offset and the Interval to cut cross sections. 

 

 Unlike with GEOPAK tools, pattern lines are not used to set locations to cut cross sections. If the 
GEOPAK format preference is loaded, then when the cross sections are generated pattern lines 
will be drawn.  

 

 Another option the user will set is the Display in View option. After the cross sections are cut 
they will be displayed in the selected view. 

 

 When cross sections are cut, a new drawing model is created. The Model Name can be specified 
in the General tab. 

 
To cut cross sections select the Apply button in the Create Cross Section dialog. 
 
With this release of the software, the cross sections generated using this tool are static and do not 
dynamically update as changes are made to the corridor model. 
 
Cross sections are extracted at the specified Interval on the General tab. 
 
If cross sections are required at specific locations not covered by the Interval, the Custom tab is used to 
define the cross section locations. 
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If any custom cross sections are defined in the list view on the Custom tab, the settings for interval and 
offsets on the General tab are ignored. However, the toggles for critical sections (Controls > Critical 
Stations) are honored. 
 

 Station Range allows you to extract multiple cross sections spanning a range of stations. 

 Perpendicular allows you to extract a single cross section that is perpendicular to the alignment 
or graphics.  

 Skewed allows you to extract a cross section that is skewed to the alignment or graphics.  

 Linestring allows you to extract a cross section that is along the path of a linestring. 
 
The cross section sheets are written to a Drawing Model. By default, the Drawing model has a gray 
background. Since the ODOT pavement components are drawn with gray scale values, it may be 
desirable to change the background color for the Drawing Model in your User Preferences (Workspace > 
Preferences > View Options). 

 
 
The cross sections are placed in column format as shown above. The sheets can be split into separate 
models, or separate files, using the ODOT Split Sheet Cells application which is detailed later in this 
chapter. 
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Creating Cross Sections in GEOPAK Format 

If you intend to use any legacy GEOPAK functions, it is necessary to process the cross sections into a 
format that is compatible with the legacy tools. The legacy tools, such as Earthworks Quantities, Seeding 
Quantities, or criteria processing, require the following information for processing: 
 

 Horizontal alignments stored as chains in the GPK 
 Vertical alignments stored as chains in the GPK 
 GEOPAK Pattern Lines 
 Cross Sections with GEOPAK Cells 

 
GEOPAK functions will not allow both the pattern lines and the cross sections to reside in the same 
design file. When the cross sections are extracted from the 3D model, the pattern lines are draw in the 
Design Model and the cross sections are placed in a Drawing model within the active design file. The 
pattern lines and the cross sections must be split into separate design files in order for GEOPAK to 
recognize these graphics when processing the legacy tools. 
 
According to ODOT CADD Standards, pattern lines are drawn in the “KL” dgn file. The cross sections and 
GEOPAK cells are drawn in the “XC” dgn file. The ODOT_Files.mvba application is used to create the 
files. 
 
From the MicroStation menu, select ODOT > File Management > Create Design Files to open the dialog 
shown below. Toggle the Category option to GEOPAK Specific Basemap Files to create the KL file and 
the XC file for the pattern lines and cross sections. 
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Take the following steps to extract the cross sections in GEOPAK format: 
 

 Open the XC file and attach all of the 3D corridor design files, survey, and any other 3D 
information that you wish to use to extract the cross sections. Remember, cross sections ae a 
byproduct of the 3D model. Anything that you wish to show up on the cross sections must be 
drawn in the model. 
 

 Select the Create Cross Sections command and then choose the desired alignment as prompted. 

 
 From the Create Cross Sections dialog, choose the Preferences button. Select the Stacked: 

GEOPAK Format option and choose the Load button as shown below. 

 



 GEOPAK OpenRoads Technology for Civil Design March 30, 2017 

 

Chapter 11 – Cross Sections Page 313 

 

 From the Create Cross Sections dialog, set the Start Station, Stop Station, Left Offset, Right 
Offset, and Interval settings as desired. The Custom item can be used to set a custom station 
range as well as specifying additional stations for cross section locations as detailed previously in 
this document. 
 

 The Pattern Line symbology is defined by the Controls > Plan Display > Planimetric item. 
Double-click on the item to edit the settings as shown below. 

 
 Select the Apply button to initiate the process. The cross sections are written to a new Drawing 

Model within the active XC dgn file. The new drawing model is named according to the Model 
Name specified in the General settings of the Create Cross Sections dialog. 
 

 From the MicroStation pull-down menu, select File > Save Settings to save the cross section 
model as the active model. 

 
The pattern lines must be contained in their own design file is order for the legacy GEOPAK 
commands to locate the pattern lines. The easiest way to put the pattern lines in the KL design file is 
through the use of references. Take the following steps to copy the pattern lines to the KP design 
file: 
 
  Open the KL file and attach the design model from the XC design file as a reference attachment. 

Turn off Live Nesting when making the attachment. 
 

 Once attachment is made, you can merge the referenced elements into the active file. Right-
Click on the XC reference attachment and choose the Merge Into Master command as shown on 
the next page. 
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 When the command is issued, you are prompted to select the view to merge the reference. 

Select the active view. Select OK from the Alert dialog when it appears. 

 
 The reference content is merged into the active file. The reference attachment is automatically 

removed. From the MicroStation pull-down menu, select File > Save Settings to save the design 
file settings. 

 
Remember: 
The cross sections contained in the XC file are not dynamically linked to the model. Changes to the 
model will necessitate manually recreating the cross sections and pattern lines. 
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11.3 Annotate Cross Sections 
 
Cross sections extracted from the model are not annotated. This is true whether the cross sections are 
extracted into sheets or in GEOPAK format. The Annotate Cross Section tool is used to annotate cross 
section elevations and slopes.  

 
 

The tool can be found in the Civil Tools task in the Corridor Modeling group. The Annotate 
Cross Section dialog in shown below. 

 

 
ODOT has two preferences configured to help annotate cross sections. To load a preference, select the 
Preferences… button. In the Preferences dialog shown below select the desired preference and select 
load. 

 
 

PGL Station/Elevation: 
This preference will set up the Annotate Cross Section 
dialog with the correct settings for placing the proposed 
grade line station and elevation. 
 
Slope:  
This preference will set up the Annotate Cross Section 
dialog with the correct settings for placing slope values 
above a given line. 
 
There is currently a limitation in using this tool to place 
the Existing elevation. 
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The Annotate Cross Section Dialog has several sections. First the user should select the Cross Section 
Model to annotate. Then the user should select the Surface to annotate. 
 
When using either of the two ODOT preferences the user to should select the corridor as the surface. In 
the General tab there is also an option to set a station range to apply the annotation to. 
 
There are four folders shown in the dialog, Points, Features, Segments, and Frame. The user only needs 
to edit the Features and Segments Folder. 
 

PGL Station/Elevation Labeling 

To place station and proposed grade line elevations the user needs to first load the PGL 
Station/Elevation preference as described above. When this preference is loaded the Features > 
General folder will appear as shown below. 

 
The Image shows the Include Features checkbox is checked and that Elevation and Station are check on 
in the list. In order to place the station and elevation data on the cross sections the user needs to select 
the Crossing Feature name from the list of points that are defined in the cross sections. To do this the 
user should click in the Annotate tab in the Features folder and click the locate element button as 
shown below. 
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When that button is selected the dialog will temporally disappear and in MicroStation the cursor will be 
a selection cursor to identify an element. The user should navigate to any cross section in the desired 
cross section model and zoom in on the part of the cross section where the proposed center of 
pavement is. When the template was made for the corridor there were features assigned to certain 
locations, the features are set to display an X on the cross sections. The X’s are placed at an extremely 
small scale and are construction levels and therefor will not be plotted. See the section on templates for 
more information. The image below shows a zoomed in view of the center line feature at the proposed 
center line location in a cross section. 

 
The Annotate Cross Section dialog will reappear 
after a selection is made and the selected feature 
will be highlighted in the Crossing Features list as 
shown below. 

 
Note: The points that are selected in the Crossing 
Features list will be annotated using the current 
settings of the Annotate Cross Sections dialog. Use 
the All button to select all the points. Use the None 
button to clear the selected points. 
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When the Apply button is selected, all the cross sections in the selected cross section model and within 
the specified station range if set are annotated with the respective station and PGL elevation as shown 
in the example below. 

 
Note: The vertical location of the text is determined by an offset value in the preference settings. The 
offset is measured relative to the selected point, not relative to the cross section grid. The location of 
the station and elevation text will not be centered vertically within the cross section grid lines as seen in 
the example above. 
 

Slope Labels 

A similar process can be used to annotate slopes. To do this the user should first load the Slopes 
preference in the Annotate Cross Section dialog described above. Now navigate to the Segments folders. 
The dialog should look as imaged below. 

 
Notice the Include Segments checkbox is check on as well as Slope and Alternate Slope are checked in 
the list. 
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The loaded preference has set default values to annotate slopes, these settings can be edited as desired 

from the list by selecting the  button in the last column of the list. 
 
The Alternate Slope annotation settings are used if the slope exceeds 20% as defined by the Use 
Alternate Slope if Slope Exceeds parameter. 
 
Note that the number of decimal places is user definable by changing the Precision parameter. 
 
Again the user needs to select the features to annotate. To do this the user should select the Annotate 
tab in the Segments folder and click the locate element button to select the points that will be used to 
annotate a slope. When that button is selected the dialog will temporally disappear and in MicroStation 
the cursor will be a selection cursor to identify an element. The user should navigate to any cross section 
in the desired cross section model and zoom in on the part of the cross section where the desired slope 
starts and issue a data point (left click). 
 
When the template was made for the corridor there were features assigned to certain locations, the 
features are set to display an X on the cross sections. The X’s are placed at an extremely small scale and 
are construction levels and therefor will not be plotted. These features were placed in the template at 
the start and end locations of the slopes in the end conditions. 
 
After the user clicks on the desired feature for the start of a slope the Annotate Cross Section dialog will 
appear again with the selected feature highlighted in the list. The user should repeat this process to 
select the feature at the end of the slope. The Annotate Cross Section dialog should look similar to 
what’s shown below. There should be two features selected representing the beginning and end of a 
given slope. Now the user should select the Apply button. This will go through all the cross sections in 
the selected cross section model and within the specified station range if set and annotate the 
respective slope, an example is shown below. 

 
Tip: The software will annotate the slope between all the selected points. Selecting more than two 
points will lead to unwanted annotations. Annotate each segment by selecting one pair of points at a 
time. 
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Labeling Ditch Elevations 

Although an ODOT preference has not been configured specifically to annotate ditch elevations, 
annotation for ditch elevations can be easily labeled using the Annotate Cross Sections dialog. 
 
Select the Features tab and check on the Include Features item. Toggle on the Elevation item as shown 
below. 

 
The format for the text is set by choosing the   button at the end of the item list. Set the Text 
Symbology parameters as shown below to label ditch elevations. 

 
 
The Horizontal offset is used to offset the text 
horizontally from the point that is selected for 
annotation. We will select the inside ditch point 
for ditches on the left side of the cross section, 
and the outside ditch point for ditches on the 
right side of the cross section. 
 
The Horizontal offset value is multiplied by the 
annotation scale to determine the text location. 
In this example the value of -0.2 will be 
multiplied by the annotation scale value of 5 for 
an offset of -1.0 from the selected point.  
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The Features > Annotate tab is used to select the points to be annotated. Select the point names from 
the Crossing Features list, or use the Locate button to graphically select the small “X” that is placed on 
the cross section points. 
 
An example of the annotated ditch elevations is shown below. 
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11.4 Cross Section Viewer 
 

This tool can be found in the Civil Tools task in the Corridor Modeling group. The Cross 
Section Viewer dialog is shown below. 

 
 
Using this dialog, the user can navigate to the desired cross section within the selected Cross Section 
Model. 

 
The dialog will list all the stations where a cross section was cut. The user can click on a desired station 
and the cross section at that station will be centered in the view. The user can use the arrow keys to 
move to the next cross section. A Zoom Factor can also be set as well as a movie mode can be run 
where the view will move through the cross sections at a specified time interval. 
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11.5 Displaying Right-Of-Way Labels on Cross Sections 
Right-of-Way labels can be displayed on the cross sections with the OpenRoads tools as shown in the 
example below. 
 
In order to display the Right-of-Way on the cross sections, the right of way lines must be defined as 3D 
elements and referenced to the 3D model. The recommended procedure to generate 3D right-of-way 
lines is to reference the survey model into the right-of-way design file and activate the terrain as the 
active profile for each right-of-way line. 
 
According to the ODOT CADD Standards, right-of-way lines are normally drawn in a separate right-of-
way basemap, using the “BR” file code, in the following location: 

\Design\rw\basemaps\nnnnnn_BR###.dgn 

 
Right-of-way lines drawn in 2D in the Design model can be used to generate the 3D right-of-way lines by 
taking the following steps: 
 

 Attach the Survey basemap with the existing ground terrain as reference attachment 
 

 Set the Survey terrain as the active terrain model 
 

 Open a Profile View for the right-of-way lines, one at a time 
 

 Set the existing ground line as the active profile to the selected right-of-way line 
 

 When the profile is assigned, a 3D line string is generated in the 3D model for the right-of-way 
lines. 

 
To display the right-of-way lines on the cross sections, reference the BR file with a Nest Depth value of 1 
to the cross section design file. 
 
The example below shows how the labels appear when using the Open Cross Section View command. 
The size of the label in the dynamic cross section view is not user controllable. 
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When the cross sections are processed using the Create Cross Sections command, the size of the right-
of-way label is controlled by the model Annotation Scale setting. 
 
The example below shows a cross section that was processed with the Create Cross Sections command. 
The Stacked: GEOPAK Format preference was used for this example. 
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11.6 End Area Volumes 
 

The End-Area Volumes dialog can be found in the Civil Tools tasks, in the Corridor 
Modeling group. When launched a dialog will appear as the image below shows 

 

 
This tool currently has some limitations. ODOT pays for concrete removal as a separate pay item. 
Asphalt pavement is sometimes removed with excavation, but may be a separate removal item 
depending on the project. This tools is used for simple cut and fill quantities and cannot be used for 
more complex situations with separate concrete removal areas. 
 
If your project requires more than simple cut and fill quantities, you must cut cross sections using the 
GEOPAK format with cross section control cells and then use the legacy GEOPAK tools to generate the 
cross section quantities. See ODOT’s GEOPAK Road 2 training guide for information on the legacy 
GEOPAK earthwork quantity tools. 
 
ODOT has a preference that can be loaded for this dialog. This preference can be loaded by selecting the 

Preferences… button. Then selecting ODOT Basic Cut Fill preference and hit load. 
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The End-Area Volumes dialog has several options. The General tab imaged above will list the surfaces 
found for the selected alignment. This will typically be existing survey and a proposed corridor. Each 
surface has a type. The type is set by the feature definition. There are 4 types of surface, Existing, 
Design, Substrata, and Subgrade. Existing survey surface will be set to existing and a corridor should be 
set to a design type. 
 
The General tab has options for calculation method, station range limits, area size to ignore, units, and 
reports. The Create XML Report checkbox is useful to review and see quantities. ODOT recommends 
checking this checkbox on. XML reports are described below. 
 
The Unsuitable Materials by Station tab can be used for top soil striping, ODOT does not currently do 
top soil striping. 
 
The Classifications tab will list the surface and components of the corridor. The image below shows an 
example of what the classifications tab looks like. The calculations will produce volumes for these 
components. Fill Factors can be set for a given component.     

 
The Compaction/Expansion tab can be used to set cut and fill factors for given station ranges. 
 
The Volume Exceptions tab can be used to set station ranges to be excluded from volume calculations. 
This would typically be used to exclude bridge locations. 
 
The Annotation Tab sets what will be drawn on the cross sections for end-area calculations. When 
ODOT Basic Cut Fill Preference is loaded this tab will look as shown below. 
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A Cut Shape and Fill Shape will be plotted on the cross sections as well as the Cut Area, Fill Area, Cut 
Volume, and Fill Volume text will be placed in the appropriate column on the ODOT sheet cell. 
 
When the Apply button is selected the annotation will be plotted to the cross sections, the image below 
shows an example for where the cut and fill areas and volumes are placed in the model. 

 
In order to view the cut and fill shapes the Fill view attribute must be toggled on, as pictured below. The 
shapes are placed on the level XS_P_Earthwork_Shapes. 
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If Create XML Report checkbox was checked a report viewer will appear as imaged below. There are 
many reports to choose from. The user can double click on different reports, the Volumes.xsl report is a 
good report for viewing the calculations. The report will list each station a cross section was drawn at 
and give quantities for cut and fill areas as well as volumns for the components. The bottom of the 
report will list totals. The report can be printed to a pdf to be saved. Select File > Print in the report 
veiwer to print the report to PDF. 
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11.7 Setting up cross section sheets for printing 
When cross sections are cut from the OpenRoads tools they are placed in a drawing model. ODOT has 
not previously made use of the drawing model. In order for the cross sections sheets to work with other 
applications and print organizer and to comply with ODOT standards the sheets need to be separated to 
one sheet per model for that file or separate the sheets to one sheet per file. 
 
ODOT has written an application to assist in this process. The application can be launched from the 
MicroStation menu by selecting ODOT > Sheet Management > Split Sheet Cells. This will open the dialog 
imaged below. 

 
 
Select the desired settings and select Process Sheets to 
initiate the process. 
 
For more information click the Help icon to open up 
PDF documentation for the application. 
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Exercise 11 - Cross Sections 
Use this chapter as a guide to extract cross sections for S.R. 185 in cross section sheet format. 
 
Before creating the new design file for the cross sections, take the following steps to create 3D Right-of-
Way lines: 
 

 Open MicroStation using the shortcut provided for the training class. 
 

 Set the User and Project as follows: 
User:  ODOTcadd 
Project:  12345-CROSS_SECTIONS 

 
 Open the Right-of-Way basemap design file: 

..\Design\RW\Basemaps\12345_BR001.dgn 
 

 The existing right-of-way lines are already drawn in the file. The survey basemap has been 
attached as a reference. Select the terrain model and choose the Set As Active Terrain icon from 
the pop-up menu. 
 

 Each right-of-way line must have a profile defined in order to create a 3D line sting for the right-
of-way lines. The elevation of the profile will be used when the right-of-way markers are placed 
on the cross sections. Select each right-of-way line and choose the Open Profile Window 
command and follow the prompts to display the existing ground profile in a new window. 
 

 Set the existing ground profile as the active profile for each right-of-way line. 

 
 Open the 3D model in the right-of-way file to verify that the 3D line strings have been created 

for each right-of-way line. 
 

 After verifying the 3D line strings have been created, return to the Design Model and save 
settings. 
 
This procedure is not limited to existing right-of-way lines. Proposed right-of-way lines can also 
be displayed on the cross sections is a similar manner. 
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Take the following steps to create a design file for the S.R. 185 Cross Sections: 
 

 Use the ODOT_Files.mvba application (ODOT > File Management > Create Design Files) to 
create the new design file for the cross section sheets as shown below. Make sure the scale is 
set to 1. 

 
 Note the location of the new sheet file. Open the new file after it has been created. 

 
 The Sheet model is the active model. Open the Design model. 

 
 Attach the Design model from the following references with the next depth value shown below: 

 

 File Name Nest Depth 

All Geometry ..\Design\Geopak\Basemaps\12345_BK000.dgn 1 

S.R. 185 Corridor ..\Design\Geopak\Basemaps\12345_KM001.dgn 0 

St. Peter Road Corridor ..\Design\Geopak\Basemaps\12345_KM002.dgn 0 

Jameson Road Corridor ..\Design\Geopak\Basemaps\12345_KM003.dgn 0 

Existing Right-Of-Way ..\Design\RW\Basemaps\12345_BR001.dgn 0 

Existing Ground Survey ..\Design\Survey\Basemaps\12345_BE001.dgn 0 
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 Set the terrain model active by selecting the terrain boundary and choosing the Set As Active 
Terrain Model command from the pop-up menu 

 Use the Create Cross Sections tool to extract the cross sections for S.R. 185. 
 

 Select the Preferences button. Use the Sheet: CROSS 5 Scale preference to extract the 
cross sections. 

 Set the Start Station value to 386+00 

 Set the End Station value to 428+00 

 Set the Scale to Engr: 1:5 

 
The cross sections are extracted to a Drawing Model in the active design file. The first sheet is 
shown on the following page. 
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 Use the Annotate Cross Sections command to annotate the PGL Station and Elevation, the side 
slopes, and the ditch elevations. See section 11.3 of this chapter. 
 

 Use the End Area Volumes command to extract cut and fill quantities from the cross sections. 
See section 11.6. 
 

 Run the ODOT Spit Sheets application to spit the cross section sheets into separate models. See 
section 11.7. 
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12 Subsurface Utilities 

Plan view graphics representing various underground utilities can be extracted to create 3-dimensional 
objects using the Subsurface Utilities commands. This section will discuss the process to generate 3D 
graphics for underground utilities using the Extract Graphics command. This section is not intended 
cover the Bentley subsurface utilities commands in detail. 
 
Additional information on existing utilities is presented in the ODOT_OpenRoadsSurvey training guide. 
 

12.1 Subsurface Utility Tools 
GEOPAK V8i (SELECTseries 3) and subsequent releases include Bentley’s new Subsurface Utilities tools. 
These tools are included and installed as part of PowerGEOPAK and the GEOPAK Suite. 
 
These tools are used to extract 2D or 3D utility graphics to generate a 3-dimensional representation of 
the utilities. The Subsurface Utilities commands are located in the MicroStation Tasks menu as shown 
below. 

 
The Extract Graphics command, shown below, is used to generate 3D models for the subsurface utility 
information. 
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The first time the command is selected, the software prompts the user as shown below. Select Yes to 
create the utility model. 

 
When the utility model is created, the software takes the following action: 
 

 If the current MicroStation model is a 2D model, the software will automatically create a new 3D 
model named Design-3D. This is the typical workflow for ODOT projects. 

 
 If a current MicroStation model is a 3D model, the utility graphics will be extracted in the 

current 3D model. This is not the typical workflow for ODOT projects. 
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12.2 Utility Design Files 
Three dimensional graphics for the subsurface utilities are normally extracted in a separate utility 
basemap. Do not use the survey basemap, “BE” file, for extracting subsurface utility information. It is 
recommended that all 3D utility information is extracted to the following files:  
 

 The 3D model for storm sewer information is extracted in the “BD” drainage basemap 
 

 The 3D model for all other underground utilities is extracted in the “BU” utility basemap 
 
The ODOT_Files.mvba application is used to crate these design files as shown below. The application is 
accessed by selecting ODOT > File Management > Create Design Files from the MicroStation pull-down 
menu. 

 
Be sure to select the 2D seed file for the new design files as shown above. The typical workflow for 
ODOT projects is to allow the Extract Graphics process to create a separate 3D model for the 3-
dimensional graphics. 
 
Check on the Federate Basemaps option to create a “000” file if you will have more than one basemap 
design file for each file type. 
 
After these files are created, the normal workflow is to attach the survey basemap as a reference to the 
2D design model. 
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12.3 Extract Graphics 
The Extract Graphics command, shown below, is used to generate 3D models for the subsurface utility 
information. 

 
The command provides two methods to extract utility information: Selection, or Utility Filter, as shown 
below. 

 
 The Utility Filter option is used to scan the current file and attached references for plan view 

cells representing catch basins, inlets, and manholes. 
 

 The Selection option is used to manually select individual utility lines, or storm sewer pipes, in 
order to generate 3D graphics for these items. 

 
In either case, the elevation for the elements can be defined by the original graphics (if these graphics 
have been drawn in a 3D model at their actual elevation) or relative to the active terrain by specifying a 
Vertical Offset value. 
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Using Filters to Extract 3D Catch Basins, Manholes, and Inlets 

ODOT provides several Utility Filters to extract the various catch basin, inlet, and manhole types. 
 
In the example below, the Select Filter option is set to use the All Catch Basins filter. 

 
After selecting the Method and Filter, be sure to toggle on the Use 3D Element Elevations option if the 
original survey data is drawn at the correct elevations in a 3D model (this is the normal process for 
ODOT survey processing). 
 
The software will step the user through the filter extraction process by prompts on the cursor. 
 
Left-click to accept the following options to extract 3D utility information: 
 

 Method: Utility Filter 
 Select Filter 

 
The software scans the active file and any attached references to find ODOT cells matching the selected 
utility filter parameters. As each item is processed, 3D graphics for each object are drawn in the Design-
3D model as shown on the following page. 
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In the example above, View 1 displays the 2D Design model with the survey information attached as a 
reference. View 2 displays the Design-3D model for the CB-7 catch basin that was extracted using the All 
Catch Basins utility filter. 
 
Note: With the ODOT configuration, select Alt-F2 to open view 2 to display the Design 3D model. 

Modifying Storm Sewer Nodes 

Individual catch basins, inlets, and manholes are referred to as a “Node” in the subsurface utility 
software. As each storm sewer catch basin, inlet, and manhole is processed, the software places a plan 
view graphic for each node in active model. This graphic can be used to manipulate the 3D graphic for 
the node. An example of the node graphic placed for a CB-2-5 is shown below. 

 
When the node is selected, a pop-up 
menu appears with the following 
commands: 
 

 Properties 

 Graph 

 Utility Properties 

 Delete 
 
Additionally, two fields appear for 
the Node Top Elevation and Node 
Rotation. Left-click one of these text 
fields to edit the value. Changes are 
automatically applied to the 3D 
model. 
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When the Properties item is selected from the pop-up menu, the options below are available. Changes 
to the properties of a node are automatically applied to the 3D model. 

 

Extracting 3D Storm Sewer Lines 

3D storm sewer lines are extracted using the Selection method as shown below. 
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In the example above, the survey information is referenced from a 3D survey basemap. The lines 
representing storm sewer conduit are drawn as a 3D line between the survey points. These lines are 
drawn at the proper elevation defined by the endpoints, however, these are flat lines, not 3D pipes. 
 
When the command is selected, the application will prompt the user to select the elements to extract as 
shown above. One or more graphics can be selected for extraction, however; it is important to note that 
the selected items are all extracted using the current parameters. Be sure to select only elements of the 
same Feature Type and size for extraction. 
 
As the selected storm sewer line(s) is extracted, the following parameters are defined: 
 

Use 3D Elevations? 
Toggle this option on to use the elevation of the selected elements. Note, this option cannot be 
selected until after at least one graphic element has been selected 
 
Vertical Offset 
Storm sewer pipes are normally drawn at their invert elevation in the ODOT workflow. A 
Vertical Offset value of 0 is typically used for ODOT projects. 
 
Create Trench 
The Create Trench option is used to apply a linear template to the selected utility line. This 
template is defined by the selected Feature Definition. The ODOT Feature Definitions for storm 
sewer lines do not have a template defined. 
 
Feature Definition 
Various feature definitions are defined for storm sewer conduit as shown below. 
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Name Prefix 
As each storm sewer conduit line is extracted, a unique name is given to each element created. 
When extracting a single element, the name can be manually assigned as shown in the example 
above. If multiple elements are selected, the Name Prefix value is incremented for each 
element. 
 
Description 
The Description item is used to define the size of the conduit. 

 
The software prompts the users for information before extracting the selected element(s). Left-click to 
accept each option as prompted. 
 
An example of an extracted storm sewer conduit is shown below. 

 
Each individual storm sewer line is referred to as a “Link” by the subsurface utility software. A link must 
have a node at each end. When the Extract Graphics command is used to generate a link, the software 
automatically places a node at each end of the link, even if a node already exists in the file. The node is 
placed on the active level in the 2D model, but on level Default in the 3D model. It is recommended to 
set the active level to Default in the 2D model before processing so that these elements are on the same 
level on both models. The Default level should be turned off in the 3D model, as shown on the following 
page. 
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The 3D model of the storm sewer information can be generated by the surveyor, or the designer. 
Responsibility to generate a 3D model for the storm sewer information will vary from District to District. 
 

Modifying 3D Storm Sewer Links 

In addition to the 3D graphics, a line is drawn in the active 2D model for the extracted link as shown 
below. 

 
Selecting the link reveals a pop-up menu of commands, as well as two editable fields designating the 
direction and length of the length. The following commands are available from the pop-up menu: 
 

 Properties 

 Profile 

 Graph 

 Split Link 

 Utility Properties 

 Delete 
 
The Properties dialog is used to review and edit the properties of the selected link. See the online 
documentation for information on the other commands. 
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Extracting Utilities by Depth of Cover 

The Extract Graphics command is also used to extract underground utility lines defined by a depth 
below the active terrain surface. 
 
The example below shows the settings to extract an existing telecommunications line at a depth of 3’ 
below the terrain model surface, using the Selection Method. 

 
The Vertical Offset parameter is used to define the depth below the surface for the utility extraction. 
 
The software automatically places a node at the end of the utility line. The default nodes are defined by 
the software and in some cases may not be entirely appropriate for ODOT purposes. Unfortunately the 
default nodes cannot be deleted. In the example above, an end cap node is placed at the beginning and 
end of the telecommunications line. 
 
The ODOTcadd Standards provide feature definitions for various underground utilities as shown below. 

 
The Selection method is used to manually select individual elements representing a specific utility line. 
This method is advantageous as it allows the user to set the Vertical Offset and Description (size) 
parameters uniquely for each utility as it is extracted. 
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The Utility Filter option is advantageous to extract multiple utilities simultaneously. Filters are available 
in the ODOTcadd Standards to extract All Utilities, or utilities of a specific type.  

 
The disadvantage when using the Utility Filter 
method is that all of the utilities will be extracted 
using default values for the depth and size. The 
table below list the default values for the ODOT 
filters. 
 
 

Utility Type Default Depth Default Size 

Communications -2’ 2” 

Electrical -2.5’ 2” 

Gas -3’ 6” 

Water -3.5’ 6” 

Petroleum -5’ 6” 

Waste Water -8’ 6” 

 
 
Individual filters can be copied from 
the Drainage and Utilities dgn library 
to the active file to edit the default 
values on a per-dgn file basis, as 
shown at right. 
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Copied Filters are edited using the Utility Filter Manager command, shown below. For additional details, 
see the OpenRoads online help. 

 

 
Regardless of the extraction method used, the Properties command can be used to review and edit an 
individual utility line as shown below. Note that the utility depth cannot be edited in the properties; the 
depth is set at the time the utility is extracted. 
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12.4 Underground Utilities and Cross Sections 
In order for the underground utilities to display on the cross sections, the Design-3D model for the 
drainage and utility basemap design files must be attached as a reference to the Design-3D model in the 
cross section design file. Once attached, the utilities will be displayed on the cross sections similar to the 
example below. 

 
Notes: 

 The Feature Definitions for the various utility conduit items include both the internal diameter 
and the wall thickness values. The outside diameter is necessary for clash detection reports 
(clash detection is available when using a full Subsurface Utility license, not from a GEOPAK or 
PowerGEOPAK license). As a result, both the internal and external diameter will be displayed on 
the cross sections as shown in the example above. 
 

 The utilities are not labeled in the cross sections and must be labeled manually on the cross 
section sheets. 
 
 
 
 

 Storm Sewer structures (catch basins, inlets, and manholes), that fall between cross sections 
cannot be projected to the nearest cross section. In order to show a particular storm sewer 
node, you must extract a cross section at the specific station that will intersect each node. The 
graphics representing a specific node are based on the graphics drawn in the Design-3D model. 
 
Also note that nodes displayed in the cross section are not labeled by the software. An example 
is shown below. 
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12.5 Proposed Utilities 
The ODOT feature definition libraries provide various features for proposed underground utilities as 
shown below. 
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Similar to existing utilities, proposed 
utilities, including storm sewers, are 
placed using the Subsurface Utilities 
tools. 
 
As of this release of the ODOTcadd 
Standards, the subsurface utility tools 
have not been configured for design and 
analysis of the storm sewer network.  
 
 

 
This section of the training guide will document the process to place storm sewer nodes and links. 
 

Proposed Utility Design Files 

Proposed utilities are typically be placed in their own design files and not in the same file with the 
existing utility and storm sewer information. 
 
For smaller projects, it is permissible to place the existing and proposed utilities and storm sewer 
information in the same design file. It is up to the project designer to use their judgement as to whether 
this information is best placed in the same or multiple files. 
 
Proposed utilities are normally placed in a 2D design model. The Subsurface Utility software creates the 
3D model as the 2D nodes and links are defined. 
 
The ODOT_Files.mvba application is used to create these design files as shown below. The application is 
accessed by selecting ODOT > File Management > Create Design Files from the MicroStation pull-down 
menu. 
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Be sure to use the 2D seed file when creating the Drainage and Utility basemap file types. 
 
Toggle on the Federate Basemaps option to create a “000” file if you will have more than one basemap 
design file for each file type. 
 
The survey, geometry, corridor, and existing utilities may be attached as references, as needed. 
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Placing Proposed Storm Sewer Nodes 

Proposed storm water utilities are normally placed in a 2D model in the drainage (BD) basemap design 
file. The Subsurface Utility software will generate the 3D model for the proposed utility. 
 
Catch basins, inlets, manholes, and headwalls are placed as a Node using the Place Node tool shown 
below. 

When the command is selected, the dialog shown at right, above, is displayed. 
 
The user is prompted to select a reference element for the node elevation as shown below.  

 
Nodes can be placed at a specific elevation, or relative to 
the selected surface or a corridor model. Select the surface 
or issue a Reset to type an elevation. 
 

 
 

After the elevation reference is selected, the user is prompted to set the Placement Type. 
 

The By Minimum Depth option is used to set the 
initial depth using a default value. The invert 
elevation can be edited after placement if 
necessary. 

 
 

Next the user is prompted to set the location of the node. Civil Accudraw can be used to set the location 
of the node by a station and offset value relative to a specific alignment as shown in the example below. 
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Finally, the user is prompted to enter the rotation for the node. The rotation angle can be keyed in, or 
specified by a data point. 
 
The node is drawn in the 2D model, and the 3D model as shown below. 

 
The 3D model is automatically referenced to the 2D model, as shown at left, above. Turning off the 
reference display of the 3D model reveals the 2D graphic as shown below. 
 
This graphic differs from the plan view cells that have 
been traditionally used for ODOT plans. The Subsurface 
Utility software forces all of the sub-elements of the cell 
to the same symbology and does not allow for filled 
elements. 
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Placing Proposed Storm Sewer Links 

Proposed storm water utilities are normally placed in a 2D model in the drainage (BD) basemap design 
file. The Subsurface Utility software will generate the 3D model for the proposed utility. 
 
Storm sewer conduit is placed as a “Link” by the Subsurface Utility software. Links are placed between 
nodes and require a node at each end, even for culverts and outlet pipes. 
 
The ODOTcadd Standards provide a generic node that is used for each end of a culvert, or at an outlet 
location. This generic symbol is defined as a headwall in the ODOTcadd Standards but it does not draw a 
headwall shape. A simple triangle is drawn at the headwall node location. 
 
Headwalls will not be added to the ODOTcadd Standards for the SELECTseries versions of GEOPAK and 
PowerGEOPAK. ODOT plans to add headwalls to the ODOTcadd Standrds after new functionality is 
introduced with the forthcoming release of OpenRoads Designer Connect Edition in 2017. 
 
The example below shows the location of the headwall feature definition in the ODOTcadd Standards. 

 
The generic headwall node is placed using 
a triangle symbol on the level SC_Scratch1 
as shown below. The direction of the 
triangle is irrelevant to the flow direction 
of any links connected to the node. 
 

 
 
 
 

 
To place a link, select the Connect Conduit 
Between Nodes command as shown at right. 
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Select each node to place the conduit, similar to the example below. 

 
Notes: 

 A single line is drawn in the 2D plan view regardless of the pipe size. 
 

 The pipe is drawn as a 3D element in the Design-3D model as shown below 
 

 The Design-3D model is referenced to the 2D model, as shown at left below. The inner and outer 
dimensions of the conduit are displayed as shown below. 

 
 Nodes for drainage structures have specific connection areas. When connecting a link to a node, 

be sure to zoom in to ensure that you are connecting the link the for correct side of the desired 
node. 
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Proposed Box Culverts 

Proposed storm water utilities are normally placed in a 2D model in the drainage (BD) basemap design 
file. The Subsurface Utility software will generate the 3D model for the proposed utility. 
 
Feature definitions for existing and proposed box culverts are provided in the ODOT standards. The 
available features for proposed box culverts are shown below. Available culvert sizes are based on the 
Figure 1008-14 of the ODOT Location and Design Manual – Volume 2, Drainage Design. 

 
Box culverts are placed as a link by the Subsurface Utility software by use of the Connect Conduit 
Between Nodes command. A node must first be placed at each end of the proposed box culvert in the 
design file by use of the Place Node command. The generic headwall feature definition is used to define 
the location of each end of the box culvert.  
 
Select the Place Node command from the task list as shown below.  
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Place a node at each end of the proposed box culvert using the Generic Headwall-P feature definition as 
shown above. The Place Node command has been previously document in this chapter. 
 
The Connect Conduit Between Nodes is used to place the proposed box culvert.  

 
 
 
Each box culvert feature definition contains a drop-down list of available sizes as defined in Figure 1008-
14 of the ODOT Location and Design Manual – Volume 2, Drainage Design. 
 
The Connect Conduit Between Nodes command has been documented previously in this chapter. 
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When the box culvert is placed, two sets of graphics are drawn for the proposed box culvert as shown 
below: 
 
The appropriate custom line style is used to draw the box culvert in the 2D model on the level 
DR_P_Culvert as shown below. By default, the software automatically references the 3D model to the 
2D model. The display of the referenced 3D model has been turned off in the example below. 

 
The box culvert is drawn in the Design-3D model on the level DR_P_Culvert, similar to the example 
shown below. 
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